Creare criteri di avviso basati su soglie di metriche

Le policy di avviso basate su soglie delle metriche in Cloud Monitoring inviano notifiche quando i valori delle metriche superano una soglia definita per una finestra di nuovo test specificata. Ad esempio, puoi configurare una criterio di avviso per creare un avviso quando l'utilizzo della CPU supera l'80% per almeno cinque minuti.

Questi contenuti non si applicano ai criteri di avviso basati su log. Per informazioni sulle policy di avviso basate su log, che ti informano quando un determinato messaggio viene visualizzato nei log, consulta Monitoraggio dei log.

Per ricevere notifiche quando i dati smettono di arrivare o quando si prevede che una metrica violi una soglia, consulta Crea policy di avviso per l'assenza di metriche e Crea policy di avviso per il valore delle metriche previste. Per creare policy di avviso in modo programmatico utilizzando l'API Cloud Monitoring, consulta Crea policy di avviso utilizzando l'API. Per creare policy di avviso che utilizzano query Monitoring Query Language (MQL) con soglie statiche o dinamiche, consulta Policy di avviso con MQL e Crea livelli di severità dinamici utilizzando MQL.

Questa funzionalità è supportata solo per i progetti Google Cloud . Per le configurazioni di App Hub, seleziona il progetto host di App Hub o il progetto di gestione.

Prima di iniziare

  1. Per ottenere le autorizzazioni necessarie per creare e modificare le policy di avviso utilizzando la console Google Cloud , chiedi all'amministratore di concederti il ruolo IAM Editor Monitoring (roles/monitoring.editor) sul progetto. Per saperne di più sulla concessione dei ruoli, consulta Gestisci l'accesso a progetti, cartelle e organizzazioni.

    Potresti anche riuscire a ottenere le autorizzazioni richieste tramite i ruoli personalizzati o altri ruoli predefiniti.

    Per saperne di più sui ruoli di Cloud Monitoring, consulta Controlla l'accesso con Identity and Access Management.

  2. Assicurati di avere familiarità con i concetti generali delle policy di avviso. Per informazioni su questi argomenti, consulta Panoramica degli avvisi.

  3. Configura i canali di notifica che vuoi utilizzare per ricevere le notifiche. Per garantire la ridondanza, ti consigliamo di creare più tipi di canali di notifica. Per saperne di più, consulta la pagina Crea e gestisci canali di notifica.

Crea policy di avviso

Per creare una criterio di avviso che confronti il valore della metrica con una soglia statica, segui questi passaggi:

  1. Nella Google Cloud console, vai alla pagina  Avvisi:

    Vai ad Avvisi

    Se utilizzi la barra di ricerca per trovare questa pagina, seleziona il risultato con il sottotitolo Monitoring.

  2. Nella barra degli strumenti della console Google Cloud , seleziona il tuo progetto Google Cloud . Per le configurazioni di App Hub, seleziona il progetto host o il progetto di gestione di App Hub.
  3. Seleziona Crea policy.
  4. Seleziona le serie temporali da monitorare:

    1. Fai clic su Seleziona una metrica, scorri i menu per selezionare un tipo di risorsa e un tipo di metrica, quindi fai clic su Applica.

      Il menu Seleziona una metrica contiene funzionalità che ti aiutano a trovare i tipi di metrica disponibili:

      • Per trovare un tipo di metrica specifico, utilizza la barra dei filtri. Ad esempio, se inserisci util, il menu mostrerà solo le voci che includono util. Le voci vengono visualizzate quando superano un test "contiene" senza distinzione tra maiuscole e minuscole.
      • Per visualizzare tutti i tipi di metriche, anche quelle senza dati, fai clic su Attive. Per impostazione predefinita, i menu mostrano solo i tipi di metriche con dati. Per saperne di più, consulta Metrica non elencata nel menu.

      Puoi monitorare qualsiasi metrica integrata o qualsiasi metrica definita dall'utente.

    2. (Facoltativo) Per monitorare un sottoinsieme delle serie temporali che corrispondono ai tipi di metrica e risorsa selezionati nel passaggio precedente, fai clic su Aggiungi filtro. Nella finestra di dialogo del filtro, seleziona l'etichetta in base alla quale filtrare, un comparatore e poi il valore del filtro. Ad esempio, il filtro zone =~ ^us.*.a$ utilizza un'espressione regolare per trovare corrispondenze in tutti i dati delle serie temporali il cui nome della zona inizia con us e termina con a. Per saperne di più, vedi Filtrare la serie temporale selezionata.

    3. (Facoltativo) Per modificare l'allineamento dei punti in una serie temporale, imposta i campi Finestra mobile e Funzione finestra mobile nella sezione Trasforma i dati.

      Se stai monitorando una metrica basata su log, ti consigliamo di impostare il menu Finestra temporale mobile su almeno 10 minuti.

      Questi campi specificano come vengono combinati i punti registrati in una finestra. Ad esempio, supponiamo che la finestra sia di 15 minuti e che la funzione finestra sia max. Il punto allineato è il valore massimo di tutti i punti negli ultimi 15 minuti. Per saperne di più, consulta Allineamento: regolarizzazione all'interno delle serie.

      Puoi anche monitorare la velocità con cui cambia il valore di una metrica utilizzando il campo Funzione finestra mobile per variazione percentuale. Per saperne di più, consulta Monitora un tasso di variazione.

    4. (Facoltativo) Combina le serie temporali quando vuoi ridurre il numero di serie temporali monitorate da una policy o quando vuoi monitorare solo una raccolta di serie temporali. Ad esempio, anziché monitorare l'utilizzo della CPU di ogni istanza VM, potresti voler calcolare la media dell'utilizzo della CPU per tutte le VM in una zona e poi monitorare questa media. Per impostazione predefinita, le serie temporali non vengono combinate. Per informazioni generali, consulta Riduzione: combinazione di serie temporali.

      Per combinare tutte le serie temporali:

      1. Nella sezione Tra serie temporali, fai clic su Espandi.
      2. Imposta il campo Aggregazione delle serie temporali su un valore diverso da none. Ad esempio, per visualizzare il valore medio della serie temporale, seleziona mean.
      3. Assicurati che il campo Raggruppa per serie temporale sia vuoto.

      Per combinare o raggruppare le serie temporali in base ai valori delle etichette, segui questi passaggi:

      1. Nella sezione Tra serie temporali, fai clic su Espandi.
      2. Imposta il campo Aggregazione di serie temporali su un valore diverso da none.
      3. Nel campo Raggruppa per serie temporale, seleziona le etichette in base alle quali raggruppare.

      Ad esempio, se raggruppi in base all'etichetta zone e poi imposti il campo di aggregazione su un valore di mean, il grafico mostra una serie temporale per ogni zona per cui esistono dati. La serie temporale mostrata per una zona specifica è la media di tutte le serie temporali con quella zona.

    5. Fai clic su Avanti.

  5. Configura l'attivatore della condizione:

    1. Lascia il campo Tipo di condizione con il valore predefinito Soglia.

    2. (Facoltativo) Aggiorna il menu Trigger di avviso, che contiene i seguenti valori:

      • Una serie temporale è in violazione: impostazione predefinita. Qualsiasi serie temporale che viola la soglia per l'intera finestra di ritest fa sì che la condizione venga soddisfatta.

      • Percentuale di serie temporali in violazione: una percentuale di serie temporali deve violare la soglia per l'intera finestra di ritest prima che la condizione venga soddisfatta. Ad esempio, potresti ricevere una notifica quando il 50% delle serie temporali monitorate viola la soglia per l'intera finestra di nuovo test.

      • Numero di serie temporali in violazione: un numero specifico di serie temporali deve violare la soglia per l'intera finestra di nuovo test prima che la condizione venga soddisfatta. Ad esempio, potresti ricevere una notifica quando 32 delle serie temporali monitorate violano la soglia per l'intera finestra di nuovo test.

      • Tutte le serie temporali sono in violazione: tutte le serie temporali devono violare la soglia per l'intera finestra di nuovo test prima che la condizione venga soddisfatta.

      Per informazioni sugli intervalli utilizzati da Monitoring per allineare e misurare i dati delle serie temporali, vedi Periodi di allineamento e finestre di ripetizione del test.

    3. Inserisci quando il valore di una metrica viola la soglia utilizzando i campi Posizione soglia e Valore soglia. Ad esempio, se imposti questi valori su Sopra la soglia e 0.3, qualsiasi misurazione superiore a 0.3 viola la soglia.

    4. (Facoltativo) Per selezionare per quanto tempo le misurazioni devono violare la soglia prima che Monitoring invii una notifica, espandi Opzioni avanzate e poi utilizza il menu Finestra di ritest.

      Il valore predefinito è Nessun nuovo test. Con questa impostazione, una singola misurazione può generare una notifica. Per ulteriori informazioni e un esempio, vedi Impostazioni di periodo e durata dell'allineamento.

    5. (Facoltativo) Per specificare in che modo Monitoring valuta la condizione quando i dati non arrivano più, espandi Opzioni avanzate, quindi utilizza il menu Valutazione dei dati mancanti.

      Il menu Dati mancanti nella valutazione è disabilitato quando il valore della Finestra di ripetizione del test è Nessuna ripetizione del test.

      Campo "Valutazione dei dati mancanti" della consoleGoogle Cloud
      Riepilogo Dettagli
      Dati mancanti vuoti Gli avvisi aperti rimangono aperti.
      I nuovi avvisi non vengono aperti.

      Le condizioni soddisfatte continuano a essere soddisfatte quando i dati smettono di arrivare. Se è aperto un avviso per questa condizione, l'avviso rimane aperto. Quando un avviso è aperto e non arrivano dati, il timer di chiusura automatica si avvia dopo un ritardo di almeno 15 minuti. Se il timer scade, l'avviso viene chiuso.

      Per le condizioni che non vengono soddisfatte, la condizione continua a non essere soddisfatta quando i dati smettono di arrivare.

      Punti dati mancanti considerati come valori che violano la condizione della policy Gli avvisi aperti rimangono aperti.
      È possibile aprire nuovi avvisi.

      Le condizioni soddisfatte continuano a essere soddisfatte quando i dati smettono di arrivare. Se è aperto un avviso per questa condizione, l'avviso rimane aperto. Quando un avviso è aperto e non arrivano dati per la durata della chiusura automatica più 24 ore, l'avviso viene chiuso.

      Per le condizioni non soddisfatte, questa impostazione fa sì che la condizione di soglia della metrica si comporti come un metric-absence condition. Se i dati non arrivano entro il periodo di tempo specificato dalla finestra di nuovo test, la condizione viene valutata come soddisfatta. Per una criterio di avviso con una condizione, il soddisfacimento della condizione comporta l'apertura di un avviso.

      Punti dati mancanti considerati come valori che non violano la condizione della policy Gli avvisi aperti vengono chiusi.
      I nuovi avvisi non vengono aperti.

      Le condizioni soddisfatte non vengono più soddisfatte quando i dati smettono di arrivare. Se è aperto un avviso per questa condizione, l'avviso viene chiuso.

      Le condizioni non soddisfatte continuano a non essere soddisfatte quando i dati smettono di arrivare.

    6. Fai clic su Avanti.

  6. (Facoltativo) Crea una criterio di avviso con più condizioni.

    La maggior parte delle policy monitora un singolo tipo di metrica, ad esempio una policy potrebbe monitorare il numero di byte scritti in un'istanza VM. Quando vuoi monitorare più tipi di metriche, crea una policy con più condizioni. Ogni condizione monitora un tipo di metrica. Dopo aver creato le condizioni, specifica come vengono combinate. Per informazioni, consulta Policy con più condizioni.

    Per creare una criterio di avviso con più condizioni, segui questi passaggi:

    1. Per ogni condizione aggiuntiva, fai clic su Aggiungi condizione di avviso e poi configura la condizione.
    2. Fai clic su Avanti e configura la modalità di combinazione delle condizioni.
    3. Fai clic su Avanti per passare alla configurazione delle notifiche e della documentazione.
  7. Configura la notifica e aggiungi le etichette utente:

    1. Espandi il menu Notifiche e nome e seleziona i canali di notifica. Per motivi di ridondanza, ti consigliamo di aggiungere a una criterio di avviso più tipi di canali di notifica. Per saperne di più, consulta Gestisci i canali di notifica.

    2. (Facoltativo) Per utilizzare un oggetto personalizzato nella notifica anziché quello predefinito, aggiorna il campo Oggetto della notifica.

    3. (Facoltativo) Per ricevere una notifica quando un avviso viene chiuso, seleziona Notifica alla chiusura dell'avviso. Per impostazione predefinita, quando crei una criterio di avviso con la console Google Cloud , viene inviata una notifica solo quando viene creato un avviso.

    4. (Facoltativo) Per modificare il tempo di attesa di Monitoring prima di chiudere un avviso dopo l'interruzione dell'invio dei dati, seleziona un'opzione dal menu Durata chiusura automatica avviso. Per impostazione predefinita, quando i dati smettono di arrivare, Monitoring attende sette giorni prima di chiudere un avviso aperto.

    5. (Facoltativo) Per associare la criterio di avviso a un'applicazione App Hub, seleziona un'applicazione e un servizio o un workload nella sezione Etichette applicazione. Avvisi e notifiche mostrano queste etichette.

    6. (Facoltativo) Seleziona un'opzione dal menu Livello di gravità della policy. Gli avvisi e le notifiche mostrano il livello di gravità.

    7. (Facoltativo) Per aggiungere etichette personalizzate alla criterio di avviso, nella sezione Etichette utente policy, segui questi passaggi:

      1. Fai clic su Aggiungi etichetta e nel campo Chiave inserisci un nome per l'etichetta. I nomi delle etichette devono iniziare con una lettera minuscola e possono contenere lettere minuscole, numeri, trattini bassi e trattini. Ad esempio, inserisci severity.
      2. Fai clic su Valore e inserisci un valore per l'etichetta. I valori delle etichette possono contenere lettere minuscole, numeri, trattini bassi e trattini. Ad esempio, inserisci critical.

      Per informazioni su come utilizzare le etichette delle policy per gestire le notifiche, consulta Annota gli avvisi con le etichette.

  8. (Facoltativo) Nella sezione Documentazione, inserisci i contenuti che vuoi includere nella notifica.

    Per formattare la documentazione, puoi utilizzare testo normale, Markdown e variabili. Puoi anche includere link per aiutare gli utenti a eseguire il debug dell'avviso, ad esempio link a playbook interni, dashboard Google Cloud e pagine esterne. Ad esempio, il seguente modello di documentazione descrive un avviso di utilizzo della CPU per una risorsa gce_instance e include diverse variabili per fare riferimento alle risorse REST della condizione e della criterio di avviso. Il modello di documentazione indirizza poi i lettori a pagine esterne per aiutarli con il debug.

    Quando vengono create le notifiche, Monitoring sostituisce le variabili della documentazione con i relativi valori. I valori sostituiscono le variabili solo nelle notifiche. Il riquadro di anteprima e altri punti della console Google Cloud mostrano solo la formattazione Markdown.

    Anteprima

    ## CPU utilization exceeded
    
    ### Summary
    
    The ${metric.display_name} of the ${resource.type}
    ${resource.label.instance_id} in the project ${resource.project} has
    exceeded 90% for over 15 minutes.
    
    ### Additional resource information
    
    Condition resource name: ${condition.name}  
    Alerting policy resource name: ${policy.name}  
    
    ### Troubleshooting and Debug References
    
    Repository with debug scripts: example.com  
    Internal troubleshooting guide: example.com  
    ${resource.type} dashboard: example.com
    

    Formato nella notifica

    Esempio di come viene visualizzata la documentazione in una notifica.

    Per saperne di più, vedi Annotare le notifiche con la documentazione definita dall'utente e Utilizzare i controlli dei canali.

  9. Fai clic su Nome avviso e inserisci un nome per la policy di avviso.

  10. Fai clic su Crea policy.

Filtra la serie temporale selezionata

I filtri assicurano che vengano monitorate solo le serie temporali che soddisfano un insieme di criteri. Quando applichi i filtri, potresti ridurre il numero di righe nel grafico, il che può migliorare le prestazioni del grafico. Puoi anche ridurre la quantità di dati monitorati applicando l'aggregazione. I filtri assicurano che vengano utilizzate solo le serie temporali che soddisfano un determinato insieme di criteri. Quando applichi i filtri, ci sono meno serie temporali da valutare, il che può migliorare le prestazioni dell'avviso.

Un filtro è composto da un'etichetta, un comparatore e un valore. Ad esempio, per trovare tutte le serie temporali la cui etichetta zone inizia con "us-central1", puoi utilizzare il filtro zone=~"us-central1.*", che utilizza un'espressione regolare per eseguire il confronto.

Quando filtri per ID progetto o per contenitore di risorse, devi utilizzare l'operatore di uguaglianza, (=). Quando filtri in base ad altre etichette, puoi utilizzare qualsiasi comparatore supportato. In genere, puoi filtrare le etichette delle metriche e delle risorse, nonché per gruppo di risorse.

Quando fornisci più criteri di filtro, vengono monitorate solo le serie temporali che soddisfano tutti i criteri.

Per aggiungere un filtro, fai clic su Aggiungi filtro, completa la finestra di dialogo e poi fai clic su Fine. Nella finestra di dialogo, utilizza il campo Filtro per selezionare il criterio in base al quale filtrare, seleziona l'operatore di confronto e poi seleziona o inserisci il valore. Il menu a discesa elenca solo i valori visualizzati nell'ultima settimana, ma puoi inserire qualsiasi valore. Ogni riga della tabella seguente elenca un operatore di confronto, il suo significato e un esempio:

OperatoreSignificatoEsempio
= Uguaglianza resource.labels.zone = "us-central1-a"
!= Disuguaglianza resource.labels.zone != "us-central1-a"
=~ Uguaglianza di espressione regolare2 monitoring.regex.full_match("^us.*")
!=~ Disuguaglianza espressione regolare 2 monitoring.regex.full_match("^us.*")
starts_with Il valore inizia con resource.labels.zone = starts_with("us")
ends_with Il valore termina con resource.labels.zone = ends_with("b")
has_substring Il valore contiene resource.labels.zone = has_substring("east")
one_of Una tra resource.labels.zone = one_of("asia-east1-b", "europe-north1-a")
!starts_with Il valore non inizia con resource.labels.zone != starts_with("us")
!ends_with Il valore non termina con resource.labels.zone != ends_with("b")
!has_substring Il valore non contiene resource.labels.zone != has_substring("east")
!one_of Il valore non è uno dei seguenti resource.labels.zone != one_of("asia-east1-b", "europe-north1-a")

Risoluzione dei problemi

Questa sezione contiene suggerimenti per la risoluzione dei problemi.

Metrica non elencata nel menu delle metriche disponibili

Per monitorare una metrica non elencata nel menu Seleziona una metrica, esegui una delle seguenti operazioni:

  • Per creare un criterio di avviso che monitora una metrica Google Cloud , espandi il menu Seleziona una metrica e poi fai clic su Attivo. Se l'opzione è disattivata, il menu elenca tutte le metriche per i serviziGoogle Cloud e tutte le metriche con dati.

  • Per configurare una condizione per un tipo di metrica personalizzata prima che questo tipo di metrica generi dati, devi specificare il tipo di metrica utilizzando un filtro di monitoraggio:

    1. Seleziona ? nell'intestazione della sezione Seleziona metrica, quindi seleziona Modalità filtro diretto nel tooltip.
    2. Inserisci un filtro di monitoraggio o un selettore di serie temporali. Per informazioni sulla sintassi, consulta i seguenti documenti:

Monitora un tasso di variazione

Per monitorare il tasso di variazione di un valore della metrica, imposta il campo Funzione finestra mobile su Variazione percentuale. Quando la condizione viene valutata, Monitoring calcola il tasso di variazione della metrica come percentuale e poi confronta questa percentuale con la soglia della condizione. Questo processo di confronto prevede due passaggi:

  1. Se la serie temporale ha un tipo di metrica DELTA o CUMULATIVE, viene convertita in una serie temporale con un tipo di metrica GAUGE. Per informazioni sulla conversione, consulta Kind, tipi e conversioni.
  2. Monitoring calcola la variazione percentuale confrontando il valore medio nella finestra temporale scorrevole di 10 minuti più recente con il valore medio della finestra temporale scorrevole di 10 minuti prima dell'inizio del periodo di allineamento.

Non puoi modificare la finestra temporale mobile di 10 minuti utilizzata per i confronti in una criterio di avviso relativa alla frequenza di variazione. Tuttavia, devi specificare il periodo di allineamento quando crei la condizione.

Passaggi successivi