Cloud Workstations enthält einen Standard-Basiseditor, mit dem Sie Anwendungen schreiben, erstellen, testen, debuggen und ausführen können. Der Basis-Editor basiert auf dem Open-Source-Projekt Code-OSS, unterstützt IDE-Erweiterungen, die mit der Open VSX Registry bereitgestellt werden, und enthält die vorinstallierte IDE-Erweiterung Cloud Code.
So verwenden Sie den Cloud Workstations-Basiseditor:
- Folgen Sie der Kurzanleitung, um eine Workstationkonfiguration zu erstellen. Wenn Sie aufgefordert werden, Umgebungsanpassung auszuwählen, wählen Sie Code OSS (Standard) als Code-Editor aus.
Folgen Sie der Kurzanleitung, um mit der soeben erstellten Konfiguration eine Workstation zu erstellen.
Rufen Sie in der Google Cloud Console die Seite Cloud Workstations auf, um Ihre Workstation über den Browser zu starten.
Aktivitätsleiste
Die Aktivitätsleiste wird an der Seite angezeigt und Sie können auf die im Cloud Workstations-Basiseditor verfügbaren Ansichten zugreifen. Diese Ansichten der Aktivitätsleiste sind:
Explorer: Ordner und Dateien im aktuellen Arbeitsbereich ansehen
Suchen: Dateien nach einem String oder regulären Ausdruck durchsuchen
Quellcodeverwaltung: Anwendungsdateien mit der Git-Unterstützung des Cloud Workstations-Basiseditors verwalten
Fehlerbehebung: Beheben Sie Fehler in Ihrer Anwendung, indem Sie Haltepunkte festlegen und Variablen prüfen.
Erweiterungen: Durchsuchen Sie einen Katalog von Erweiterungen, die Ihrer IDE zusätzliche Funktionen hinzufügen.
Cloud Code: Google Cloud -Anwendungen direkt über die IDE erstellen und bereitstellen
Einstellungen: Passen Sie den Cloud Workstations-Basiseditor an Ihren Workflow an.
Dateien ansehen und bearbeiten
Der integrierte Code-Editor, mit dem Sie Dateiverzeichnisse durchsuchen und Dateien in Ihrer Workstation ansehen und bearbeiten können.
So arbeiten Sie mit dem Basis-Editor:
Verwenden Sie die Aktivitätsleiste, um zwischen den Ansichten zu wechseln.
Verwenden Sie den Editor, um Ihre Dateien anzusehen und zu bearbeiten.
In der Explorer-Ansicht können Sie die Dateiverzeichnisse durchsuchen, Dateien hoch- und herunterladen, Webanwendungen auf einer Cloud Workstations-VM-Instanz als Vorschau ansehen und Nutzungsstatistiken aufrufen.
Abbildung 1. Cloud Workstations-Basiseditor
Dateien und Verzeichnisse hoch- und herunterladen
Verwenden Sie eine der folgenden Methoden, um Dateien und Verzeichnisse in der Code-OSS-Explorer-Ansicht hoch- oder herunterzuladen:
Ziehen Sie Dateien in die Explorer-Ansicht, um sie dem Arbeitsbereich hinzuzufügen.
Rufen Sie die Dateien und Verzeichnisse auf, die Sie verwenden möchten, klicken Sie mit der rechten Maustaste darauf und wählen Sie dann Hochladen oder Herunterladen aus.
Abbildung 2. In der Explorer-Ansicht rechtsklicken, um Dateien hoch- und herunterzuladen
Sprachunterstützung
Der Basis-Editor von Cloud Workstations unterstützt Sprachen wie Go, Python, Java, .NET Core und Node.js über Erweiterungen und bietet Sprachfunktionen wie:
- Intelligente Hervorhebung, Codevorschläge und kontextbasierte Vervollständigungen
- Lint und Fehlerbeschreibung
- Codenavigation (zu Definitionen, Deklarationen, Referenzen und Implementierungen wechseln)
- Intuitive Fehlerbehebung für Debugging
Cloud Code-Integration
Cloud Code bietet IDE-Unterstützung für den gesamten Entwicklungszyklus von Kubernetes- und Cloud Run-Anwendungen, vom Erstellen und Anpassen einer neuen Anwendung aus Beispielanwendungen bis hin zur Ausführung Ihrer fertigen Anwendung. Cloud Code unterstützt Sie außerdem mit ausführungsbereiten Beispielen, Konfigurations-Snippets und einer maßgeschneiderten Debugging-Umgebung.
Cloud Code ist in Gemini eingebunden, einen KI-basierten Assistenten, der die Entwicklung vereinfacht. Mit Gemini Aufgaben effektiver und effizienter erledigen.
Cloud Code unterstützt die Entwicklung von Anwendungen in Node.js, Python, Java, Go und .NET Core.
Zusätzlich zum Cloud Code-Menü, das in der Statusleiste von Cloud Workstations verfügbar ist, können Sie auch über die Befehlspalette auf Cloud Code-Befehle zugreifen. Drücken Sie zum Öffnen der Befehlspalette Strg + Umschalttaste + P (oder Befehlstaste + Umschalttaste + P unter macOS) oder klicken Sie auf Ansicht > Befehlspalette.
Integration des Data Agent Kit
Wenn Sie Ihre Data-Science- und Data-Engineering-Arbeitslasten direkt im Basis-Editor verwalten möchten, können Sie das Google Cloud Data Agent Kit verwenden, das in Cloud Code integriert ist. Wenn Sie das Data Agent Kit verwenden möchten, klicken Sie in der Aktivitätsleiste des Basis-Editors auf das Symbol Google Cloud Data Agent Kit. Weitere Informationen finden Sie unter Data Agent Kit – Übersicht.
Unterstützung für Versionsverwaltung
Der Cloud Workstations-Basiseditor enthält eine vorkonfigurierte Versionsverwaltung. Sie können Repositories initialisieren, Unterschiede zwischen Dateistatus anzeigen, Änderungen bereitstellen, die Bereitstellung aufheben und Änderungen committen. Sie können auch öffentliche, private oder sogar selbst gehostete Repositories verwenden, sofern diese von der Workstation aus zugänglich sind.
Arbeitsbereich verwalten
Mit Cloud Workstations können Sie Ihre Projekte als Arbeitsbereiche verwalten und konfigurieren. Arbeitsbereiche stellen in der Regel Ihren Stammprojektordner dar. Mit dem Basis-Editor von Cloud Workstations können Sie Arbeitsbereiche erstellen, öffnen und speichern sowie mit projektspezifischen Einstellungen anpassen.
Wenn Sie einen Ordner als Arbeitsbereich öffnen möchten, verwenden Sie das Menü oben in der Aktivitätsleiste und wählen Sie Datei > Ordner öffnen aus. Alternativ können Sie die Optionen Datei öffnen oder Letzter Arbeitsbereich auf der Willkommensseite des Basis-Editors verwenden oder den URL-Parameter folder verwenden, um den Pfad des Ordners anzugeben, den Sie öffnen möchten, z. B. &folder=/home/user/foo.
Anwendungen zur Fehlerbehebung
Mit Cloud Workstations können Sie Ihre Anwendung debuggen. Go-, Node.js-, Python- und Java-Anwendungen werden unterstützt. Sie können Startkonfigurationen erstellen, Haltepunkte festlegen und Variablen prüfen – alles in Cloud Workstations.
Außerdem können Sie Fehler in Kubernetes-Anwendungen in einem lokalen Cluster wie minikube oder Docker Desktop, einem Remote-Cluster in GKE oder einem anderen Cloud-Anbieter beheben.
Integriertes Terminal
Über das integrierte Terminal können Sie mit der zugrunde liegenden Entwicklungsumgebung interagieren. Verwenden Sie eine der folgenden Methoden, um die Terminalansicht ein- und auszuschalten:
- Drücke
Control+. - Drücken Sie Strg + Umschalttaste + P (oder Befehlstaste + Umschalttaste + P unter macOS) oder klicken Sie auf Ansicht > Befehlspalette und geben Sie dann
View: Toggle Terminalein. - Wählen Sie Terminal > Neues Terminal aus.
- Wählen Sie Ansicht > Terminal aus.
- Klicken Sie in der Liste der Terminal-Tabs auf HinzufügenHinzufügen.
Wenn Sie mehrere Terminalfenster öffnen möchten, klicken Sie auf Teilen oder drücken Sie Strg + Umschalttaste + 5.
Terminal-Tabs verwalten und anpassen
Wenn Sie mehrere Terminals öffnen, wird neben der Terminalansicht eine Liste mit Terminal-Tabs angezeigt. Diese Liste enthält die Namen offener Terminals.
Wenn Sie einen Terminalnamen in der Liste auswählen, werden die Symbole
Teilen und
Löschen angezeigt. Klicken Sie auf das entsprechende Symbol, um ein Terminalfenster zu teilen oder zu löschen.
Wenn Sie weitere Terminaloptionen wie Terminal in Editorbereich verschieben, Umbenennen, Farbe ändern, Symbol ändern und mehr sehen möchten, rechtsklicken Sie auf einen Terminalnamen.
Abbildung 5. Terminal anpassen
Auf dem Display scrollen
Zusätzlich zur Verwendung der Maus, während der Browserfokus auf einem Sitzungstab liegt, können Sie unter Windows und Linux mit Strg + Umschalttaste + BildAuf und Strg + Umschalttaste + BildAb (oder unter macOS mit Fn + Umschalttaste + Nach-oben und Fn + Umschalttaste + Nach-unten) scrollen.
Einstellungen anpassen
Zum Anpassen des Editors, der Benutzeroberfläche und des funktionalen Verhaltens bietet der Cloud Workstations-Basiseditor die folgenden Bereiche zum Definieren von Einstellungen:
Maschineneinstellungen: Einstellungen, die global gelten, wenn Sie eine Verbindung zu einer virtuellen Cloud Workstations-Instanz herstellen, und die auf Ihrer Workstation in der Datei
$HOME/.codeoss-cloudworkstations/data/Machine/settings.jsonangezeigt werden.Nutzereinstellungen: Einstellungen, die global gelten, wenn Sie eine Verbindung zu einer virtuellen Cloud Workstations-Instanz herstellen, und die im Browserspeicher für jede Workstation-Instanz beibehalten werden.
Arbeitsbereichseinstellungen: Einstellungen, die in einem Arbeitsbereich gespeichert sind und nur beim Öffnen dieses Arbeitsbereichs gelten. Diese Einstellungen werden zusammen mit Ihren Arbeitsbereichsdateien in der Datei
$WORKSPACE_ROOT/.vscode/settings.jsonangezeigt.
Der Editor wertet jeden Einstellungsbereich einzeln aus.
Tastenkombinationen
Da der Standard-Basiseditor im Browser ausgeführt wird, sind einige Tastenkombinationen möglicherweise vom Browser reserviert und werden nicht vom Editor erfasst.
Zur Unterstützung aller Tastenkombinationen enthält der Standard-Basis-Editor eine Progressive Web App (PWA), mit der der Editor diese Tastenkombinationen erfassen kann.
So verwenden Sie die PWA:
- Öffnen Sie die Workstation in Ihrem Browser.
- Klicken Sie in der Adressleiste des Browsers auf das Installationssymbol.
Die PWA sollte dann installiert werden und die Workstation wird in der PWA neu geöffnet. Beim nachfolgenden Laden Ihrer Workstation bietet der Browser in der Adressleiste die Option, die Workstation in der PWA wieder zu öffnen.