ב-Cloud Workstations יש עורך בסיסי שמוגדר כברירת מחדל, שמאפשר לכם לכתוב, ליצור, לבדוק, לנפות באגים ולהריץ את האפליקציות שלכם. העורך הבסיסי מבוסס על פרויקט הקוד הפתוח Code-OSS, תומך בתוספי IDE שסופקו עם Open VSX Registry, ומגיע עם תוסף ה-IDE של Cloud Code מותקן מראש.
כדי להתחיל להשתמש בעורך הבסיסי של Cloud Workstations:
- פועלים לפי ההוראות במדריך למתחילים כדי ליצור הגדרה של תחנת עבודה. כשמוצגת הבקשה לבחור Environment customization, בוחרים באפשרות Code OSS (default) כעורך הקוד.
פועלים לפי ההוראות במדריך למתחילים כדי ליצור תחנת עבודה באמצעות ההגדרות שיצרתם.
במסוף Google Cloud , נכנסים לדף Cloud Workstations כדי להפעיל את תחנת העבודה מהדפדפן.
סרגל הפעילות
סרגל הפעילות מופיע בצד, ואפשר לגשת לתצוגות שזמינות בעורך הבסיסי של Cloud Workstations. אלה התצוגות של סרגל הפעילות:
סייר: הצגת התיקיות והקבצים בסביבת העבודה הנוכחית
חיפוש: חיפוש מחרוזת או ביטוי רגולרי בקבצים
בקרת מקור: ניהול קובצי אפליקציות באמצעות תמיכת Git של עורך הבסיס של Cloud Workstations
ניפוי באגים: ניפוי באגים באפליקציה על ידי הגדרת נקודות עצירה (breakpoints) ובדיקת משתנים
תוספים: חיפוש בקטלוג של תוספים שמוסיפים תכונות ל-IDE
Cloud Code: יצירה ופריסה של אפליקציות Google Cloud ישירות מסביבת הפיתוח המשולבת (IDE)
הגדרות: התאמה אישית של עורך הבסיס של Cloud Workstations כך שיתאים לתהליך העבודה שלכם
הצגה ועריכה של קבצים
עורך הקוד המובנה שמאפשר לכם לעיין בספריות של קבצים, ולראות ולערוך קבצים בתוך תחנת העבודה.
כדי לעבוד עם עורך הבסיס, פועלים לפי השלבים הבאים:
משתמשים בסרגל הפעילות כדי לעבור בין התצוגות.
משתמשים בעורך כדי להציג ולערוך את הקבצים.
בתצוגת Explorer אפשר לעיין בספריות הקבצים, להעלות ולהוריד קבצים, לראות תצוגה מקדימה של אפליקציות אינטרנט במכונה וירטואלית של Cloud Workstations ולראות נתוני שימוש.
איור 1. עורך בסיסי של Cloud Workstations
העלאה והורדה של קבצים וספריות
כדי להעלות או להוריד קבצים וספריות בתצוגת Code-OSS Explorer, אפשר להשתמש בכל אחת מהשיטות הבאות:
גוררים קבצים מעל התצוגה של Explorer כדי להוסיף אותם לסביבת העבודה.
עוברים לקבצים ולספריות שרוצים להשתמש בהם, לוחצים לחיצה ימנית ובוחרים באפשרות Upload או Download.
איור 2. לוחצים לחיצה ימנית בתצוגת Explorer כדי להעלות ולהוריד קבצים
שפות
עורך הבסיס של Cloud Workstations תומך בשפות כמו Go, Python, Java, .NET Core ו-Node.js באמצעות תוספים, ומספק תכונות שפה כמו:
- הדגשה חכמה, הצעות לקוד והשלמות על סמך הקשר
- ניתוח קוד סטטי (linting) ומתן שגיאות תיאוריות
- ניווט בקוד (מעבר להגדרות, להצהרות, להפניות ולהטמעות)
- תמיכה אינטואיטיבית בניפוי באגים
שילוב של Cloud Code
Cloud Code מספק תמיכה בסביבת פיתוח משולבת (IDE) למחזור הפיתוח המלא של אפליקציות Kubernetes ו-Cloud Run, החל מיצירה והתאמה אישית של אפליקציה חדשה מאפליקציות לדוגמה ועד להרצת האפליקציה המוגמרת. בנוסף, Cloud Code תומך בכם לאורך כל הדרך באמצעות דוגמאות שמוכנות להרצה, קטעי קוד להגדרה וחוויית ניפוי באגים מותאמת אישית.
כדי לפשט את הפיתוח, Cloud Code משתלב עם Gemini, עוזר דיגיטלי מבוסס-AI. להשתמש ב-Gemini כדי לבצע משימות בצורה יעילה ומועילה יותר.
ב-Cloud Code אפשר לפתח אפליקציות ב-Node.js, ב-Python, ב-Java, ב-Go וב- .NET Core.
בנוסף לתפריט של Cloud Code שזמין בשורת הסטטוס של Cloud Workstations, אפשר לגשת לפקודות של Cloud Code גם דרך לוח הפקודות. כדי לפתוח את לוח הפקודות, מקישים על Control+Shift+P (או על Command+Shift+P ב-macOS), או לוחצים על View > Command Palette.
שילוב של Data Agent Kit
כדי לנהל את עומסי העבודה של מדע הנתונים ומהנדסי מערכות מידע ישירות בעורך הבסיסי, אתם יכולים להשתמש ב-Google Cloud Data Agent Kit שמשולב ב-Cloud Code. כדי להשתמש ב-Data Agent Kit, לוחצים על הסמל של Google Cloud Data Agent Kit בסרגל הפעילות של עורך הבסיס. מידע נוסף זמין במאמר סקירה כללית על Data Agent Kit.
תמיכה בניהול גרסאות
עורך הבסיס של Cloud Workstations כולל ניהול גרסאות מוגדר מראש. אתם יכולים להפעיל מאגרים, להשוות בין מצבי קבצים, להעביר קבצים לאזור ה-staging, להסיר קבצים מאזור ה-staging ולבצע שינויים. אתם יכולים גם להשתמש במאגרים ציבוריים, פרטיים או אפילו במאגרים באירוח עצמי, כל עוד המאגרים נגישים מתחנת העבודה.
ניהול סביבות עבודה
בעזרת Cloud Workstations אתם יכולים לנהל ולהגדיר את הפרויקטים שלכם כסביבות עבודה. סביבות עבודה בדרך כלל מייצגות את תיקיית הפרויקט ברמה הבסיסית (root). בעורך הבסיסי של Cloud Workstations אפשר ליצור, לפתוח ולשמור סביבות עבודה, וגם להתאים אותן אישית באמצעות הגדרות ספציפיות לפרויקט.
כדי לפתוח תיקייה כסביבת עבודה, משתמשים בתפריט שבחלק העליון של סרגל הפעילות ובוחרים באפשרות File > Open Folder. אפשר גם להשתמש באפשרויות Open File או Recent Workspace בדף קבלת הפנים של עורך הבסיס, או להשתמש בפרמטר של כתובת ה-URL folder כדי לציין את הנתיב של התיקייה שרוצים לפתוח – לדוגמה, &folder=/home/user/foo.
ניפוי באגים באפליקציות
ב-Cloud Workstations אפשר לנפות באגים באפליקציות, עם תמיכה באפליקציות ב-Go, ב-Node.js, ב-Python וב-Java. אתם יכולים ליצור הגדרות אישיות להפעלה, להגדיר נקודות עצירה ולבדוק משתנים, והכול בתוך Cloud Workstations.
בנוסף, אתם יכולים לנפות באגים באפליקציות של Kubernetes באשכול מקומי כמו minikube או Docker Desktop, באשכול מרוחק ב-GKE או בכל ספק שירותי ענן אחר.
טרמינל משולב
אתם יכולים לבצע פעולות בסביבת הפיתוח הבסיסית באמצעות הטרמינל המשולב. כדי להפעיל או להשבית את תצוגת הטרמינל, אפשר להשתמש בכל אחת מהשיטות הבאות:
- לוחצים על
Control+. - מקישים על Control+Shift+P (או על Command+Shift+P ב-macOS), או לוחצים על View > Command Palette, ואז מזינים
View: Toggle Terminal. - בוחרים באפשרות Terminal > New Terminal.
- לוחצים על View > Terminal.
- לוחצים על הוספההוספה ברשימת הכרטיסיות של הטרמינל.
כדי לפתוח כמה חלונות טרמינל, לוחצים על Split או על Control+Shift+5.
ניהול והתאמה אישית של כרטיסיות הטרמינל
אם פותחים כמה טרמינלים, רשימת כרטיסיות הטרמינל מופיעה בצד של תצוגת הטרמינל. הרשימה הזו מכילה שמות של טרמינלים פתוחים.
כשבוחרים שם של טרמינל ברשימה, מופיעים הסמלים
פיצול ו-
מחיקה. לוחצים על הסמל המתאים כדי לפצל או למחוק את חלון הטרמינל.
כדי לראות אפשרויות נוספות של הטרמינל, כמו Move Terminal into Editor Area, Rename, Change Color, Change Icon ועוד, לוחצים לחיצה ימנית על שם הטרמינל.
איור 5. התאמה אישית של הטרמינל
גלילה במסך
בנוסף לשימוש בעכבר כשהמיקוד של הדפדפן נמצא בכרטיסיית סשן, אפשר לגלול באמצעות לחיצה על Control+Shift+PageUp ועל Control+Shift+PageDn ב-Windows וב-Linux (או על Fn+Shift+Up ועל Fn+Shift+Down ב-macOS).
התאמה אישית של ההגדרות
כדי להתאים אישית את העורך, את ממשק המשתמש ואת ההתנהגות הפונקציונלית, העורך הבסיסי של Cloud Workstations מספק את ההיקפים הבאים להגדרת ההגדרות:
הגדרות המכונה: הגדרות שחלות באופן גלובלי כשמתחברים למופע של מכונה וירטואלית של Cloud Workstations, ומופיעות בתחנת העבודה בקובץ
$HOME/.codeoss-cloudworkstations/data/Machine/settings.json.הגדרות משתמש: הגדרות שחלות באופן גלובלי כשמתחברים למופע של מכונה וירטואלית של Cloud Workstations, ונשמרות באחסון של הדפדפן לכל מופע של תחנת עבודה.
Workspace Settings: הגדרות שמאוחסנות בסביבת עבודה ורלוונטיות רק כשפותחים את סביבת העבודה הזו. ההגדרות האלה מופיעות עם קובצי סביבת העבודה בקובץ
$WORKSPACE_ROOT/.vscode/settings.json.
העורך מעריך כל היקף הגדרות בהתאמה.
מקשי קיצור
כלי העריכה הבסיסי שמוגדר כברירת מחדל פועל בדפדפן, ולכן יכול להיות שחלק ממקשי הקיצור שמורים לדפדפן ולא נקלטים בכלי העריכה.
כדי לתמוך בכל מקשי הקיצור, עורך הבסיס שמוגדר כברירת מחדל כולל אפליקציית Progressive Web App (PWA) שמאפשרת לעורך לתעד את מקשי הקיצור האלה.
כדי להשתמש ב-PWA:
- פותחים את סביבת העבודה בדפדפן.
- לוחצים על סמל ההתקנה שמופיע בסרגל הכתובות של הדפדפן.
אפליקציית ה-PWA תותקן ו-Workstation ייפתח מחדש באפליקציית ה-PWA. בטעינות הבאות של תחנת העבודה, הדפדפן מציג בסרגל הכתובות אפשרות לפתוח מחדש את תחנת העבודה ב-PWA.