Cloud Workstations include un editor di base predefinito che ti consente di scrivere, creare, testare, eseguire il debug ed eseguire le tue applicazioni. L'editor di base si basa sul progetto open source Code-OSS, supporta le estensioni IDE fornite con Open VSX Registry e include l'estensione IDE Cloud Code preinstallata.
Per iniziare a utilizzare l'editor di base di Cloud Workstations:
- Segui le istruzioni della guida rapida per creare una configurazione della workstation. Quando ti viene chiesto di selezionare Personalizzazione dell'ambiente, seleziona Code OSS (predefinito) come editor di codice.
Segui le istruzioni della guida rapida per creare una workstation utilizzando la configurazione appena creata.
Nella console Google Cloud , vai alla pagina Cloud Workstations per avviare la workstation dal browser.
Barra delle attività
La barra delle attività viene visualizzata lateralmente e puoi accedere alle visualizzazioni disponibili nell'editor di base di Cloud Workstations. Le visualizzazioni della barra delle attività sono le seguenti:
Explorer: visualizza le cartelle e i file nell'area di lavoro corrente
Cerca: cerca nei file una stringa o un'espressione regolare
Controllo del codice sorgente: gestisci i file dell'applicazione con il supporto Git dell'editor di base di Cloud Workstations
Debug: esegui il debug dell'applicazione impostando i punti di interruzione e ispezionando le variabili
Estensioni: cerca in un catalogo di estensioni che aggiungono funzionalità aggiuntive al tuo IDE
Cloud Code: crea ed esegui il deployment di applicazioni Google Cloud direttamente dall'IDE
Impostazioni: personalizza l'editor di base di Cloud Workstations in base al tuo flusso di lavoro
Visualizza e modifica i file
L'editor di codice integrato che ti consente di sfogliare le directory dei file e di visualizzare e modificare i file all'interno della tua workstation.
Per utilizzare l'editor di base, segui questi passaggi:
Utilizza la barra delle attività per passare da una visualizzazione all'altra.
Utilizza l'Editor per visualizzare e modificare i file.
Utilizza la visualizzazione Explorer per sfogliare le directory dei file, caricare e scaricare file, visualizzare l'anteprima delle applicazioni web su un'istanza di macchina virtuale Cloud Workstations e visualizzare le statistiche sull'utilizzo.
Figura 1. Editor di base di Cloud Workstations
Carica e scarica file e directory
Per caricare o scaricare file e directory nella visualizzazione Explorer di Code-OSS, utilizza uno dei seguenti metodi:
Trascina i file sulla visualizzazione Explorer per aggiungerli al workspace.
Vai ai file e alle directory che vuoi utilizzare, fai clic con il tasto destro del mouse, quindi scegli Carica o Scarica.
Figura 2. Fai clic con il tasto destro del mouse nella visualizzazione Explorer per caricare e scaricare i file
Supporto dei linguaggi
L'editor di base di Cloud Workstations supporta linguaggi come Go, Python, Java, .NET Core e Node.js tramite estensioni, fornendo funzionalità dei linguaggi come:
- Evidenziazione smart, suggerimenti di codice e completamenti basati sul contesto
- Linting e generazione di errori descrittivi
- Navigazione nel codice (vai a definizioni, dichiarazioni, riferimenti e implementazioni)
- Supporto intuitivo per il debug
Integrazione di Cloud Code
Cloud Code fornisce il supporto IDE per l'intero ciclo di sviluppo delle applicazioni Kubernetes e Cloud Run, dalla creazione e personalizzazione di una nuova applicazione a partire da applicazioni di esempio fino all'esecuzione dell'applicazione completata. Cloud Code ti supporta anche lungo il percorso con esempi pronti per l'esecuzione, snippet di configurazione e un'esperienza di debug personalizzata.
Cloud Code si integra con Gemini, un collaboratore basato sull'AI, per semplificare lo sviluppo. Utilizza Gemini per svolgere le attività in modo più efficace ed efficiente.
Cloud Code supporta lo sviluppo di applicazioni in Node.js, Python, Java, Go e .NET Core.
Oltre al menu Cloud Code disponibile nella barra di stato di Cloud Workstations, puoi accedere ai comandi di Cloud Code anche tramite la tavolozza dei comandi. Per aprire la tavolozza dei comandi, premi Ctrl+Shift+P (oppure Comando+Shift+P su macOS) oppure fai clic su Visualizza > Tavolozza comandi.
Integrazione di Data Agent Kit
Per gestire i workload di data science e data engineering direttamente nell'editor di base, puoi utilizzare Google Cloud Data Agent Kit, che è integrato con Cloud Code. Per utilizzare Data Agent Kit, fai clic sull'icona Google Cloud Data Agent Kit nella barra delle attività dell'editor di base. Per saperne di più, consulta la panoramica di Data Agent Kit.
Supporto del controllo della versione
L'editor di base di Cloud Workstations è dotato di un controllo della versione preconfigurato. Puoi inizializzare i repository, confrontare gli stati dei file, eseguire lo stage, l'unstage e il commit delle modifiche. Puoi anche utilizzare repository pubblici, privati o persino self-hosted, purché siano accessibili dalla workstation.
Gestione delle aree di lavoro
Con Cloud Workstations, puoi gestire e configurare i tuoi progetti come workspace. Le aree di lavoro di solito rappresentano la cartella principale del progetto e con l'editor di base di Cloud Workstations puoi creare, aprire e salvare le aree di lavoro, nonché personalizzarle con impostazioni specifiche del progetto.
Per aprire una cartella come area di lavoro, utilizza il menu nella parte superiore della barra delle attività e seleziona File > Apri cartella. In alternativa, puoi utilizzare le opzioni Apri file o Area di lavoro recente nella pagina di benvenuto dell'editor di base oppure utilizzare il parametro URL folder per specificare il percorso della cartella che vuoi aprire, ad esempio &folder=/home/user/foo.
Applicazioni di debug
Cloud Workstations ti consente di eseguire il debug della tua applicazione, con supporto per applicazioni Go, Node.js, Python e Java. Puoi creare configurazioni di lancio, impostare punti di interruzione e ispezionare le variabili, tutto all'interno di Cloud Workstations.
Inoltre, puoi eseguire il debug delle applicazioni Kubernetes su un cluster locale come minikube o Docker Desktop, su un cluster remoto su GKE o su qualsiasi altro provider cloud.
Terminale integrato
Puoi interagire con l'ambiente di sviluppo sottostante tramite il terminale integrato. Utilizza uno dei seguenti metodi per attivare e disattivare la visualizzazione del terminale:
- Premi
Control+. - Premi Ctrl+Shift+P (o Comando+Shift+P su macOS) oppure fai clic su Visualizza > Riquadro dei comandi, quindi inserisci
View: Toggle Terminal. - Seleziona Terminale > Nuovo terminale.
- Seleziona Visualizza > Terminale.
- Fai clic su addAggiungi nell'elenco delle schede del terminale.
Per aprire più finestre del terminale, fai clic su Dividi o premi Ctrl+Shift+5.
Gestisci e personalizza le schede del terminale
Se apri più terminali, sul lato della visualizzazione del terminale viene visualizzato un elenco di schede del terminale. Questo elenco contiene i nomi dei terminali aperti.
Quando selezioni un nome di terminale nell'elenco, vengono visualizzate le icone
Dividi e
Elimina. Fai clic sulla rispettiva icona per dividere o eliminare una finestra del terminale.
Per visualizzare altre opzioni del terminale, ad esempio Sposta il terminale nell'area dell'editor, Rinomina, Cambia colore, Cambia icona e altre ancora, fai clic con il tasto destro del mouse sul nome di un terminale.
Figura 5. Personalizza il tuo terminale
Scorri il display
Oltre a utilizzare il mouse mentre lo stato attivo del browser è su una scheda della sessione, puoi scorrere premendo Ctrl+Shift+PagSu e Ctrl+Shift+PagGiù su Windows e Linux (o Fn+Shift+Su e Fn+Shift+Giù su macOS).
Personalizza impostazioni
Per personalizzare l'editor, l'interfaccia utente e il comportamento funzionale, l'editor di base di Cloud Workstations fornisce i seguenti ambiti per la definizione delle impostazioni:
Impostazioni macchina: impostazioni che si applicano a livello globale quando ti connetti a un'istanza virtuale di Cloud Workstations e che vengono visualizzate sulla tua workstation nel file
$HOME/.codeoss-cloudworkstations/data/Machine/settings.json.Impostazioni utente: impostazioni che si applicano a livello globale quando ti connetti a un'istanza virtuale di Cloud Workstations e che vengono mantenute nell'archiviazione del browser per ogni istanza di workstation.
Impostazioni dell'area di lavoro: impostazioni memorizzate all'interno di un'area di lavoro che si applicano solo quando si apre l'area di lavoro in questione. Queste impostazioni vengono visualizzate con i file dell'area di lavoro nel file
$WORKSPACE_ROOT/.vscode/settings.json.
L'editor valuta ogni ambito delle impostazioni rispettivamente.
Scorciatoie da tastiera
Poiché l'editor di base predefinito viene eseguito nel browser, alcune scorciatoie da tastiera potrebbero essere riservate dal browser e non acquisite dall'editor.
Per supportare tutte le scorciatoie da tastiera, l'editor di base predefinito include un'app web progressiva (PWA) che consente all'editor di acquisire queste scorciatoie.
Per utilizzare la PWA:
- Apri la workstation nel browser.
- Fai clic sull'icona di installazione visualizzata nella barra degli indirizzi del browser.
La PWA dovrebbe quindi essere installata e la workstation si riapre nella PWA. Nei caricamenti successivi della workstation, il browser presenta un'opzione per riaprire la workstation nella PWA nella barra degli indirizzi.