本页面简要介绍了记录并列出了 Cloud DNS 支持的 DNS 记录类型,包括 Cloud DNS 自定义记录类型 ALIAS。
记录是 DNS 资源和域名之间的映射。每个单独的 DNS 记录都有一个类型(名称和编号)、一个到期时间(存留时间)和类型特定的数据。
如需创建和管理资源记录集,请参阅添加、更新和删除记录。
支持的 DNS 记录类型
Cloud DNS 支持以下类型的记录。
| 适用的记录类型 | Enter |
|---|---|
A |
主机的数字 IP 地址,采用 IPv4 点分十进制格式。 |
AAAA |
主机的数字 IP 地址,采用 IPv6 十六进制数字格式。 |
ALIAS(预览版) |
别名记录(预览版),用于将别名域名映射到区域顶层的规范名称。别名记录也称为 ANAME 记录或 CNAME 展平。 您可以使用 gcloud CLI 或 Cloud DNS API 配置别名记录。您无法使用 Google Cloud 控制台配置别名记录。 别名记录也称为 ANAME 记录或 CNAME 展平。 |
CAA |
有权为此网域颁发证书的证书授权机构,例如
创建 |
CNAME |
您还可以使用
有时,域名服务器会使用 如果您在创建 CNAME 记录时遇到问题,请参阅 在专用区域中定义的 CNAME 记录不起作用 。 |
DNSKEY |
DNSSEC 公钥,解析器使用该公钥通过 ZSK 和 KSK 密钥验证记录的真实性。 例如
在此示例中,
您只能在处于 |
DS |
安全委派区域的 DNSSEC 密钥指纹。
例如 您只能在公开区域中添加此记录类型。除非您为委派区域启用(和激活)DNSSEC,否则此记录集类型不会为该区域激活 DNSSEC。默认情况下,区域不会启用 DNSSEC。 |
HTTPS |
HTTPS 服务绑定记录,允许来源指示多个备用端点,每个端点都具有关联的参数。此记录还会将 HTTP 重定向到 HTTPS。
例如, HTTPS 记录类型基于更通用的 SVCB 记录类型,并使用相同的值格式。 |
IPSECKEY |
支持 IPsec 的客户端的 IPsec 隧道网关数据和公钥,用于实现随机加密。
例如, 如需了解详情,请参阅 RFC 4025。 |
MX |
代表您的网域接收电子邮件的邮件交换服务器的优先级编号和 DNS 名称。
例如: SMTP 服务器首选具有较低偏好设置编号的服务器,其中 您输入的 MX 记录必须以英文句点 ( 您可以创建多个具有不同优先级的记录来配置备份邮件服务器,或者使用相同的优先级将负载分配到多个邮件服务器上。
例如,如需将邮件定向到您的 Google Workspace 账号,请输入以下内容: |
NS |
为您的网域或子网域提供 DNS 服务的权威域名服务器的 DNS 名称。您的 |
SOA |
起始授权机构记录,用于指定有关 DNS 地区的权威信息。当您创建代管式区域时,系统会为您创建
例如, 如需了解详情,请参阅 RFC 1035。 |
SPF |
|
SRV |
用于指定特定服务的服务器位置(主机名和端口号)的数据。
例如, 如需了解详情,请参阅 RFC 2782。 |
SSHFP |
SSH 客户端的 SSH 指纹,用于验证 SSH 服务器的公钥。
例如, |
SVCB |
服务绑定记录,允许逻辑服务指明多个备用端点,每个端点都有关联的参数。
例如, 对于 HTTPS 来源,请参阅 HTTPS 记录类型。 |
TLSA |
基于 DNS 的命名实体认证 (DANE) TLSA 证书关联信息。 TLSA 记录包含用于验证 X.509 证书(例如 HTTPS 使用的证书)的信息,而无需依赖于一组预配置的证书授权机构 (CA) 对这些证书的签名。
例如 仅当您已为区域启用 DNSSEC 时,才使用此记录类型。 |
TXT |
文本记录,可包含任意文本,也可用于定义机器可读数据,例如安全或滥用行为防范信息。 TXT 记录可以包含一个或多个文本字符串;每个字符串的最大长度为 255 个字符。如果记录数据超过 255 字节,请将记录划分为 255 字节的字符串,并将每个字符串用引号引起来 - 例如 邮件代理和其他软件代理会将多个字符串连接在一起。 请用引号括起每个字符串,例如 每条 TXT 记录的字符数限制为 1,000 个。如果您需要提高此限额,请与 Google Cloud 支持团队联系。 |
后续步骤
如需开始使用 Cloud DNS,请参阅快速入门:使用 Cloud DNS 为域名设置 DNS 记录。
如需注册并设置网域,请参阅教程:使用 Cloud DNS 设置网域。
如需了解 API 客户端库,请参阅示例和库。
如需了解您在使用 Cloud DNS 时可能会遇到的常见问题的解决方案,请参阅问题排查。