Benutzerdefinierte Felder hinzufügen

Wenn Sie Daten in Looker untersuchen, benötigen Sie möglicherweise Felder, die nicht in Ihrem Datenmodell definiert sind, z. B. um einen Messwert spontan zu berechnen, Werte in benutzerdefinierte Gruppen zu kategorisieren oder eine Aggregation für ein bestimmtes Szenario zu filtern. Anstatt darauf zu warten, dass ein LookML-Entwickler das Modell aktualisiert, können Sie benutzerdefinierte Felder direkt in Ihrem Explore erstellen, um Ihre Analyse anzupassen.

Mit benutzerdefinierten Feldern können Sie Ad-hoc-Dimensionen und -Messwerte erstellen, die SQL generieren und direkt für Ihre Datenbank ausgeführt werden, genau wie in LookML definierte Felder.

Zum Erstellen und Verwenden von benutzerdefinierten Feldern benötigen Sie die Berechtigung create_custom_fields.

Je nach Ihren Analysezielen können Sie verschiedene Arten von benutzerdefinierten Feldern erstellen:

Benutzerdefinierte Felder unterscheiden sich von in LookML definierten Feldern und Tabellenkalkulationen

Wenn Sie die Unterschiede zwischen benutzerdefinierten Feldern, in LookML definierten Feldern und Tabellenkalkulationen kennen, können Sie den richtigen Ansatz für Ihre Analyse wählen.

Benutzerdefinierte Felder und in LookML definierte Felder unterscheiden sich unter anderem in folgenden Punkten:

  • Sie können in einem Explore spontan benutzerdefinierte Felder erstellen, ohne LookML schreiben zu müssen oder Entwicklerberechtigungen zu benötigen.
  • Benutzerdefinierte Felder unterstützen kein Aufschlüsseln.
  • Benutzerdefinierte Felder bleiben im Bereich Benutzerdefinierte Felder des Bereichs Konfigurieren (oder in der Feldauswahl in klassischen Explores) nur für Nutzer mit der Berechtigung zum Erstellen dieser Felder erhalten.

Benutzerdefinierte Felder und Tabellenkalkulationen unterscheiden sich unter anderem in folgenden Punkten:

  • Bei benutzerdefinierten Feldern wird ähnlich wie bei in LookML definierten Feldern SQL-Code generiert, der für Ihre Datenbank ausgeführt wird. Tabellenkalkulationen werden für die Abfrageergebnisse ausgeführt, nachdem die Daten aus Ihrer Datenbank abgerufen wurden.
  • Benutzerdefinierte Felder sind nicht von den in der Datentabelle angezeigten Daten abhängig. Sie können benutzerdefinierte Felder verwenden, um Abfrageergebnisse zu filtern oder zu pivotieren.

Benutzerdefinierte Felder ansehen und verwenden

Die Möglichkeit, benutzerdefinierte Felder zu sehen und mit ihnen zu interagieren, hängt davon ab, ob Sie berechtigt sind, sie zu erstellen.

Benutzerdefinierte Felder ansehen

Wenn Sie die Berechtigung create_custom_fields haben, können Sie alle benutzerdefinierten Felder sehen und bearbeiten, die in der Ansicht Benutzerdefinierte Felder im Bereich Konfigurieren (oder im Abschnitt Benutzerdefinierte Felder der Feldauswahl in klassischen Explores) angezeigt werden.

Wenn Sie nicht die Berechtigung create_custom_fields haben, wird der Bereich oder die Ansicht Benutzerdefinierte Felder nicht angezeigt.

Wenn Sie jedoch ein benutzerdefiniertes Feld in ein Explore, einen Look oder eine Dashboard-Tile einfügen, können alle Nutzer, für die Sie diese Inhalte freigeben, das benutzerdefinierte Feld sehen, unabhängig davon, ob sie benutzerdefinierte Felder erstellen können. Wenn Sie diese Inhalte durch Freigabe der URL eines Explore freigeben, muss die URL den Parameter qid enthalten (z. B. instance_name.looker.com/explore/ec/order_items?qid=lEPPueGN7cHkozOEZVDQbO). Nutzer, die keine benutzerdefinierten Felder erstellen dürfen, sehen nur den Titel des Felds, nicht aber die Beschreibung. Daher ist es wichtig, Felder genau zu benennen, wenn Sie sie in Abfragen verwenden, die für diese Nutzer freigegeben sind.

Benutzerdefinierte Felder verwenden

Wenn Sie die Berechtigung create_custom_fields haben, können Sie alle Felder bearbeiten und verwenden, die in der Ansicht Benutzerdefinierte Felder im Bereich Konfigurieren (oder im Abschnitt Benutzerdefinierte Felder der Feldauswahl in klassischen Explores) angezeigt werden. Sie können mit ihnen fast genauso interagieren wie mit allen anderen Messwerten oder Dimensionen. Sie können sie beispielsweise filtern, zu Visualisierungen hinzufügen und (bei benutzerdefinierten Dimensionen) zum Pivotieren von Ergebnissen verwenden. Eine Ausnahme ist, dass Sie keine benutzerdefinierten Felder zum Erstellen von Dashboard-Filtern verwenden können.

Nur Nutzer, die benutzerdefinierte Felder erstellen dürfen, können sie Abfragen in Explores, Looks oder Dashboard-Tiles hinzufügen. Wenn ein Nutzer jedoch Von hier aus explorativ Daten analysieren für einen freigegebenen Look oder eine Dashboard-Tile mit einem benutzerdefinierten Feld auswählt, kann er eine neue Abfrage mit diesem Feld erstellen, unabhängig davon, ob er benutzerdefinierte Felder erstellen kann oder nicht.

Benutzerdefinierte Feldtypen

Je nach Typ des zugrunde liegenden LookML-Felds können Sie verschiedene Arten von benutzerdefinierten Feldern erstellen und anpassen. In den folgenden Tabellen sind die Arten von benutzerdefinierten Feldern aufgeführt, die je nach LookML-Feldtyp erstellt werden können:

Benutzerdefinierte Feldtypen für Dimensionen

In der Feldauswahl eines Explores können Sie aus Dimensionen verschiedene benutzerdefinierte Feldtypen erstellen, je nach dem oder den zugrunde liegenden LookML-Feldtypen. In der folgenden Tabelle sind die Arten von benutzerdefinierten Feldern aufgeführt, die für die einzelnen Dimensionstypen unterstützt werden.

S = Funktioniert mit dem Datentyp string

N = Funktioniert mit dem Datentyp number und numerischen Measures

T = Funktioniert mit dem Datentyp tier

ZC = Funktioniert mit dem Datentyp zipcode

YN = Funktioniert mit dem Datentyp yesno

DI = Funktioniert mit dem Datentyp distance

DU = Funktioniert mit dem Datentyp duration

TS = Funktioniert mit den meisten Zeitstempel-Datentypen *

ID = Funktioniert mit den meisten Datentypen für ganzzahlige Datumsangaben *

SD = Funktioniert mit den meisten String-Datentypen für Datumsangaben *

L = Funktioniert mit dem Datentyp location

Jeder benutzerdefinierte Feldtyp, den Sie aus einer Dimension erstellen können, fällt in eine der folgenden Kategorien:

  • Aggregiert: Aggregierte Felder sind Messwerttypen, mit denen Aggregationen wie Summe und Durchschnitt durchgeführt werden. Aggregierte Measures können nur Dimensionen referenzieren, keine anderen Measures.
  • Nicht aggregiert: Nicht aggregierte Felder sind Dimensionen, nach denen in einer Explore-Abfrage gruppiert werden kann.
Name des benutzerdefinierten Feldes Kategorie Beschreibung Kompatibilität von LookML-Feldtypen
Anzahl der unterschiedlichen Werte Aggregieren Erstellt einen count_distinct-Messwert, der die Anzahl der eindeutigen Werte für eine ausgewählte Dimension berechnet. S N T ZC YN DI DU TS ID SD L
Summe Aggregieren Erstellt einen sum-Messwert, der die Werte einer ausgewählten Dimension addiert. N DI DU ID
Durchschnitt Aggregieren Erstellt einen average-Messwert, der den Durchschnitt der Werte einer ausgewählten Dimension berechnet. N DI DU ID
Min. Aggregieren Erstellt einen min-Messwert, der den kleinsten Wert einer ausgewählten Dimension ermittelt. N DI DU ID
Max. Aggregieren Erstellt einen max-Messwert, der den größten Wert einer ausgewählten Dimension ermittelt. N DI DU ID
Medianwert Aggregieren Erstellt einen median-Messwert, der den Mittelwert für die Werte einer ausgewählten Dimension ermittelt. N DI DU ID
Liste der eindeutigen Werte Aggregieren Erstellt einen list-Messwert, der eine Liste der eindeutigen Werte einer ausgewählten Dimension erstellt. S T ZC YN SD L
Klasse Nicht aggregiert Erstellt Klassen oder Ebenen, mit denen die Werte einer ausgewählten numerischen Dimension in einen benutzerdefinierten Satz von Zahlenbereichen unterteilt werden. N DI DU ID
Gruppe Nicht aggregiert Erstellt eine Gruppe, mit der Sie die Ergebnisse einer ausgewählten Dimension unter benutzerdefinierten Labels zusammenfassen können. S N T ZC YN DI DU TS ID SD L
*Hinweis zu Datums- und Uhrzeitdaten: Looker interpretiert einige Zeiträume und zeitbasierte Typen als unterschiedliche Datentypen, wenn Sie benutzerdefinierte Felder erstellen. Dies kann sich auf die benutzerdefinierten Feldtypen auswirken, die für diese Zeiträume und zeitbasierten Felder verfügbar sind. Looker interpretiert beispielsweise den Zeitraum hour_of_day als Datentyp number und bietet daher benutzerdefinierte Feldoptionen, die für andere type: number-Felder verfügbar sind. Weitere Informationen finden Sie im Abschnitt Interpretation von Datums- und Uhrzeitdatentypen in benutzerdefinierten Feldern auf dieser Seite.

Benutzerdefinierte Feldtypen für Messwerte

Je nach zugrunde liegendem LookML-Messwerttyp können Sie aus Messwerten in der Feldauswahl eines Explores nur einen benutzerdefinierten Feldtyp erstellen, nämlich einen gefilterten Messwert. In der folgenden Tabelle sind die LookML-Felder aufgeführt, zu deren Messwerttypen Sie einen Filter hinzufügen können.

LI = Funktioniert mit dem Messungstyp list

DT = Funktioniert mit dem Messungstyp date

YN = Funktioniert mit dem yesno-Messungstyp

N = Funktioniert mit numerischen Messungstypen *

Name des benutzerdefinierten Feldes Beschreibung Kompatibilität von LookML-Feldtypen
Measure filtern Fügt einem Measure eine Filterbedingung hinzu, um die in der Aggregation des Measures enthaltenen Werte einzuschränken. LI DT YN N
* Weitere Informationen zu den Arten von Measures, die Looker bei der Verwendung benutzerdefinierter Felder als numerisch interpretiert, finden Sie im Abschnitt Interpretation numerischer Measures durch benutzerdefinierte Felder auf dieser Seite.

Wie Datums- und Uhrzeitdatentypen in benutzerdefinierten Feldern interpretiert werden

Looker interpretiert einige Zeiträume und zeitbasierte Typen als unterschiedliche Datentypen, wenn Sie benutzerdefinierte Felder erstellen. Dies wirkt sich auf den Typ der benutzerdefinierten Felder aus, die Sie für ein bestimmtes Datums- oder Zeitfeld erstellen können. In benutzerdefinierten Feldern werden Datums- und Zeitfelder so kategorisiert:

Diese Kategorien sind mit verschiedenen Arten von benutzerdefinierten Feldern kompatibel, wie in der Tabelle Benutzerdefinierte Feldtypen für Dimensionen angegeben.

Zeitstempel- und Datumsdatentypen

In benutzerdefinierten Feldern werden die folgenden LookML-Zeitdatentypen als Zeitstempeldatentypen behandelt:

Ganzzahlige Datumsdatentypen

In benutzerdefinierten Feldern werden die folgenden LookML-Datums- und -Uhrzeitdatentypen als Ganzzahl-Datumstypen behandelt:

Datumsdatentypen vom Typ „String“

In benutzerdefinierten Feldern werden die folgenden LookML-Datentypen für Datum und Uhrzeit als String-Datentypen behandelt:

Interpretation numerischer Messwerte durch benutzerdefinierte Felder

In benutzerdefinierten Feldern werden die folgenden Messwerttypen als numerische Typen behandelt:

Diese Messwerttypen sind mit dem benutzerdefinierten Feldtyp „Gefilterter Messwert“ kompatibel, wie in der Tabelle Benutzerdefinierte Feldtypen für Messwerte angegeben.

Benutzerdefinierten Messwert aus einer Dimension erstellen

Die Methoden zum Erstellen einer benutzerdefinierten Messung aus einer Dimension unterscheiden sich je nachdem, ob Sie die Standard-Explore-Oberfläche oder die klassische Explore-Oberfläche verwenden.

Benutzerdefinierten Messwert in der Standard-Explore-Oberfläche erstellen

In Explores können Nutzer mit der Berechtigung create_custom_fields auf eine der folgenden Arten eine benutzerdefinierte Messung erstellen:

  • Sie können den Bereich „Konfigurieren“ verwenden:

    1. Bewegen Sie den Mauszeiger im Bereich Konfigurieren auf dem Tab Alle Felder oder Verwendete Felder auf die Dimension, die Sie zum Erstellen der benutzerdefinierten Messung verwenden möchten.
    2. Wählen Sie das Dreipunkt-Menü  Mehr der Dimension aus.
    3. Wählen Sie eine Aggregatfunktion aus (z. B. Anzahl unterschiedlicher Werte, Summe, Durchschnitt, Min. oder Max.).
  • Sie können die Datentabelle im Bereich „Daten“ verwenden: Wählen Sie in der Datentabelle die Datenspalte der Dimension aus, klicken Sie auf das Dreipunkt-Menü  Mehr und wählen Sie eine Aggregatfunktion aus.

  • Über die Schaltfläche „+ Hinzufügen“ können Sie Folgendes tun:

    1. Wählen Sie im Bereich Konfigurieren im Abschnitt Benutzerdefinierte Felder die Option + Hinzufügen und dann Benutzerdefinierter Messwert aus.
    2. Wählen Sie im Dialogfeld Benutzerdefinierte Messung erstellen ein Feld für die Messung und einen Messungstyp aus und definieren Sie eine benutzerdefinierte Messung mit benutzerdefinierten Filtern, Formaten und Beschreibungen.

Mit der dritten Methode über den Button + Hinzufügen können Sie das benutzerdefinierte Feld während seiner Erstellung anpassen. Zu den Anpassungen zählen das Umbenennen, das Hinzufügen einer optionalen Beschreibung oder die Auswahl eines anderen Formats als des Standardformats.

Die neue benutzerdefinierte Messung wird automatisch in der Datentabelle und in der Ansicht Benutzerdefinierte Felder im Bereich Konfigurieren angezeigt. Wie bei anderen Feldern auch können Sie den Namen eines benutzerdefinierten Felds auswählen, um es einer Abfrage hinzuzufügen oder daraus zu entfernen. Sie können auch die Schaltfläche Filter auswählen, um das Feld als Filter in einer Abfrage zu verwenden.

Benutzerdefinierten Messwert in klassischen Explores erstellen

In klassischen Explores können Sie auf eine der folgenden Arten einen benutzerdefinierten Messwert aus einer Dimension erstellen:

Mit der zweiten Methode können Sie das benutzerdefinierte Feld während seiner Erstellung anpassen. Zu den Anpassungen zählen das Umbenennen, das Hinzufügen einer optionalen Beschreibung oder die Auswahl eines anderen Formats als des Standardformats.

Über das Dreipunkt-Menü Mehr für die Dimension

In vielen Fällen können Sie diese Tastenkombination verwenden:

  1. Maximieren Sie die Feldauswahlansicht, die die Dimension enthält, die Sie messen möchten.
  2. Wählen Sie das Dreipunkt-Menü Mehr für die Dimension aus.
  3. Wählen Sie Aggregieren aus, um Optionen zum Erstellen einer benutzerdefinierten Messung aufzurufen. Die vorgeschlagenen Funktionen variieren je nach ausgewähltem Dimensionstyp (z. B. Zahl, String oder Datum). Wählen Sie eine Funktion aus.

Maximieren Sie den Bereich Benutzerdefinierte Felder in der Feldauswahl, um das neue Feld zu sehen.

Wie bei anderen Feldern auch können Sie den Namen eines benutzerdefinierten Felds auswählen, um es einer Abfrage hinzuzufügen oder daraus zu entfernen. Sie können auch den Mauszeiger auf das Feld bewegen, um weitere Optionen für dieses Feld aufzurufen. Dazu gehört das Symbol Filter, mit dem Sie das Feld als Filter in einer Abfrage verwenden können. Sie können das Feld auch bearbeiten.

Bereich Benutzerdefinierte Felder der Feldauswahl verwenden

Wenn Sie beim Erstellen eines benutzerdefinierten Messwerts ein Format oder einen Filter dafür definieren möchten, beginnen Sie im Bereich Benutzerdefinierte Felder mit dem Button Hinzufügen:

  1. Wählen Sie im Bereich Benutzerdefinierte Felder der Feldauswahl die Option Hinzufügen aus.
  2. Wählen Sie den Feldtyp aus, den Sie erstellen möchten. In diesem Beispiel wird Benutzerdefinierte Messung verwendet.
  3. Wählen Sie im Drop-down-Menü Zu messendes Feld ein Feld aus, wählen Sie im Drop-down-Menü Messwerttyp den Messwerttyp aus und geben Sie dann im Feld Name einen Namen an. Der Name wird in der Feldauswahl und in der Datentabelle angezeigt.
  4. Wenn Sie eine Filterbedingung hinzufügen möchten, wählen Sie auf dem Tab Filter im Drop-down-Menü Filtername ein Feld aus. Sie können Filterbedingungen mit den Plus- und Minus-Buttons Filterwert hinzufügen oder entfernen.
  5. Auf dem Tab Felddetails können Sie im Bereich Format ein Format angeben und im Feld Beschreibung eine optionale Beschreibung mit bis zu 255 Zeichen hinzufügen, um anderen Nutzern weitere Informationen zum benutzerdefinierten Feld zu geben, einschließlich der vorgesehenen Verwendung.
  6. Klicken Sie auf Speichern.

Die neue benutzerdefinierte Messung wird in der Feldauswahl im Bereich Benutzerdefinierte Felder angezeigt.

Wie bei anderen Feldern auch können Sie den Namen eines benutzerdefinierten Felds auswählen, um es in einer Abfrage anzuzeigen. Sie können auch die Schaltfläche Filter auswählen, um das Feld als Filter in einer Abfrage zu verwenden.

Benutzerdefinierte Gruppierung

Mit dem benutzerdefinierten Feldtyp Gruppe können Sie benutzerdefinierte Ad-hoc-Gruppen für Dimensionen erstellen, ohne logische Funktionen in Looker-Ausdrücken verwenden oder CASE WHEN-Logik in sql-Parametern oder type: case-Feldern entwickeln zu müssen.

Das ist besonders praktisch, wenn Sie Werten, die bestimmte Bedingungen erfüllen, feste Labels oder Kategorienamen zuweisen möchten, indem Sie beispielsweise bestimmte Bundesstaaten oder Länder in Regionen oder Kosten in Kategorien gruppieren.

So erstellen Sie eine Gruppe:

  1. Maximieren Sie die Ansicht, die die Dimension enthält, für die Sie benutzerdefinierte Gruppen erstellen möchten.
  2. Sie haben mehrere Möglichkeiten, das Menü Gruppieren nach zu öffnen:

    • Wählen Sie in der Standardoberfläche von „Explore“ im Bereich Konfigurieren das Dreipunkt-Menü  der Dimension aus (oder im Bereich Daten das Dreipunkt-Menü  der Datenspalte) und dann Gruppieren .
    • Wählen Sie in klassischen Explores das Dreipunkt-Menü Weitere Optionen der Dimension in der Feldauswahl (oder das Zahnradmenü der Dimension in der Datentabelle) und dann Gruppieren aus.

    Das Menü „Gruppieren nach“ für die Dimension „Bundesstaat“.

  3. Geben Sie im Feld Gruppenname ein Label für die erste Gruppe von Werten an. In diesem Beispiel wird gezeigt, wie Sie mit der Dimension Bundesstaat eine Gruppe von Bundesstaaten für die Region „Pazifischer Nordwesten“ der USA erstellen. Dies wird durch den Gruppennamen „Pazifischer Nordwesten“ dargestellt.

  4. Wählen Sie im Bereich Gruppenwert die vorhandene Bedingung aus, die standardmäßig ist ein beliebiger Wert lautet, um die Bedingungen anzupassen, die Sie für die Gruppe anwenden möchten.

  5. Wählen Sie die Bedingung aus und geben Sie einen oder mehrere Werte ein oder wählen Sie sie aus. In diesem Fall ist eine der angewendeten Bedingungen State is Oregon. Mit den Plus- und Minus-Buttons Hinzufügen und Entfernen können Sie Bedingungen hinzufügen oder entfernen. Klicken Sie zum Speichern außerhalb der Filterbedingung oder drücken Sie die Esc-Taste.

    • Wenn verfügbar, werden Vorschläge für Werte in einer Drop-down-Liste angezeigt, die durch einen nach unten zeigenden Pfeil im Werteingabefeld gekennzeichnet ist. Nutzer können diese auswählen oder danach suchen. Vorschläge sind am häufigsten für Felder vom Typ type: string verfügbar.
    • Looker wendet automatisch SQL-Bedingungen wie AND- oder OR-Logik an, wenn mehrere Bedingungen erstellt werden, basierend auf den von Ihnen angegebenen Feldtypen, Bedingungen und Werten.
    • Wenn Sie eine vorhandene benutzerdefinierte Gruppe bearbeiten, sollten Sie den Namen entsprechend den aktualisierten Bedingungen ändern.

    Ein Nutzer bewegt den Mauszeiger auf das Pluszeichen „Hinzufügen“ neben dem vorhandenen Gruppenwert. Das Kästchen „Verbleibende Werte gruppieren“ ist ausgewählt.

  6. Wenn Sie weitere Gruppen für diese Dimension hinzufügen möchten, bewegen Sie den Mauszeiger auf die vorhandene Gruppe und wählen Sie das Pluszeichen Hinzufügen aus. Wenn Sie Gruppen entfernen möchten, wählen Sie das Minuszeichen Entfernen aus. Sie können eine vorhandene Gruppe bearbeiten, indem Sie die Gruppenbedingung auswählen – in diesem Fall ist Oregon oder Idaho oder Washington. Looker wendet automatisch SQL-Bedingungen wie AND- oder OR-Logik an, wenn mehrere Bedingungen erstellt werden. Dies basiert auf den von Ihnen angegebenen Feldtypen, Bedingungen und Werten.

  7. Sie können auch das Kästchen Verbleibende Werte zu neuer Gruppe zusammenfassen anklicken, um eine Kategorie für die Gruppierung aller anderen Werte zu erstellen, die keine der Gruppenbedingungen erfüllen. In diesem Beispiel werden alle Bundesstaaten, die nicht Oregon, Idaho oder Washington sind, unter dem Label Sonstige zusammengefasst. Sonstiges ist der Standardname. Sie können ihn bei Bedarf im Feld Gruppenname anpassen.

    • Wenn Sie eine benutzerdefinierte Gruppe bearbeiten und die Gruppierung für alle anderen Werte entfernen möchten, deaktivieren Sie das Kästchen Verbleibende Werte zu neuer Gruppe zusammenfassen, um diese Gruppe zu entfernen.

    Der Text „State Groups“ wird in das Feld „Field name“ eingegeben und die Beschreibung „States by region“ in das Feld „Description“.

  8. Geben Sie in das Feld Feldname einen Namen ein. Der Name wird in der Feldauswahl und in der Datentabelle angezeigt.

  9. Wählen Sie + Beschreibung hinzufügen aus, um das Feld Beschreibung zu öffnen. Dort können Sie optional eine Beschreibung mit bis zu 255 Zeichen hinzufügen, um anderen Nutzern mehr Informationen zur benutzerdefinierten Gruppe zu geben.

    • Wenn Sie eine benutzerdefinierte Gruppe bearbeiten und bereits eine Beschreibung vorhanden ist, wird das Feld Beschreibung automatisch angezeigt.
  10. Wählen Sie Speichern und dann Ausführen aus, um das Explore noch einmal auszuführen.

Das neue Feld wird in der Datentabelle angezeigt und enthält Labels für alle Bundesstaaten: „Pacific Northwest“ für die Bundesstaaten Oregon, Washington und Idaho und „Other“ für alle anderen Bundesstaaten.

Sie können die neue Gruppe verwenden, um neue Erkenntnisse aus Ihren Daten zu gewinnen. Sie können beispielsweise vergleichen, wie viele Bestellungen von Nutzern im pazifischen Nordwesten im Vergleich zu Nutzern in anderen Regionen der USA aufgegeben wurden.

Das neue Feld wird im Bereich Benutzerdefinierte Felder der Feldauswahl angezeigt.

Wie bei anderen Feldern auch können Sie den Namen des Felds auswählen, um es einer Abfrage hinzuzufügen oder daraus zu entfernen. Sie können auch den Mauszeiger auf das Feld bewegen, um weitere Optionen für dieses Feld aufzurufen. Dazu gehört das Symbol Filter, mit dem Sie das Feld als Filter in einer Abfrage verwenden können. Sie können die benutzerdefinierte Gruppe auch bearbeiten.

Benutzerdefiniertes Binning

Mit dem benutzerdefinierten Feldtyp Klasse können Sie benutzerdefinierte Ad-hoc-Klassen oder ‑Ebenen für numerische Dimensionen und benutzerdefinierte Dimensionen erstellen, ohne logische Funktionen in Looker-Ausdrücken verwenden oder type: tier-LookML-Felder entwickeln zu müssen.

Mithilfe des berechneten Felds „Klasse“ lassen sich Werte schnell in bestimmte Ganzzahlbereiche gruppieren, um den Detaillierungsgrad Ihrer Daten anzupassen.

Benutzerdefinierte Klassenfelder werden im Notationsstil classic angezeigt.

So erstellen Sie einen Bin:

  1. Maximieren Sie die Ansicht, die die Dimension enthält, für die Sie benutzerdefinierte Bins erstellen möchten.
  2. Sie haben mehrere Möglichkeiten, das Menü Papierkorb zu öffnen:

    • Wählen Sie in der Standardoberfläche von „Explore“ im Bereich Konfigurieren das Dreipunkt-Menü  Mehr der Dimension aus (oder im Bereich Daten das Dreipunkt-Menü  Mehr der Datenspalte) und wählen Sie dann Bin aus.
    • Wählen Sie in klassischen Explores das Dreipunkt-Menü Weitere Optionen der Dimension in der Feldauswahl (oder das Zahnradmenü der Dimension in der Datentabelle) und dann Bin aus.

  3. Wählen Sie als optionalen Ausgangspunkt Feldinformationen abrufen aus, um mehr über die Werte für die Dimension zu erfahren, für die Sie benutzerdefinierte Klassen erstellen, einschließlich des Minimal- und Maximalwerts der Dimension sowie des Wertebereichs. Diese Informationen können bei der Festlegung der Art und Weise hilfreich sein, wie Sie Werteklassen angeben.

  4. Wählen Sie im Abschnitt Klassentyp einen Klassentyp aus.

    • Wählen Sie Gleiche Größe aus, um numerische Werte in gleich große ganzzahlige Bereiche zu unterteilen. Das sind beispielsweise Wertebereiche von 0–10, 10–20 und 20–30.
    • Wählen Sie Benutzerdefinierte Größe aus, um benutzerdefinierte Klassengrößen mit unterschiedlichen ganzzahligen Bereichen zu erstellen. Das sind beispielsweise Wertebereiche von 0–15, 15–75 und 75–100.
  5. Passen Sie die Klassengrößen und Bereiche an.

    • Wenn der ausgewählte Klassentyp Gleiche Größe ist, geben Sie die erforderlichen Werte in die Felder Klassengröße, Minimalwert und Maximalwert ein. Im vorherigen Beispiel werden Spezifikationen für Klassen mit einer Größe von 10 im Bereich von 0 bis 100 angezeigt. Klassen werden in den Daten automatisch für Werte erstellt, die außerhalb der angegebenen Bereiche liegen.
    • Wenn als Klassentyp die Größe Benutzerdefiniert ausgewählt ist, geben Sie die Ebenen-Haltepunkte in aufsteigender Reihenfolge im Feld Klassenhaltepunkte an. Trennen Sie sie entweder durch Kommas oder durch Zeilenumbrüche.
  6. Geben Sie in das Feld Feldname einen Namen ein. Der Name wird in der Feldauswahl und in der Datentabelle angezeigt.

  7. Wählen Sie + Beschreibung hinzufügen aus, um das Feld Beschreibung zu öffnen. Dort können Sie optional eine Beschreibung mit bis zu 255 Zeichen hinzufügen, um anderen Nutzern weitere Informationen zum benutzerdefinierten Bin zu geben.

    • Wenn Sie einen benutzerdefinierten Container mit einer vorhandenen Beschreibung bearbeiten, wird das Feld Beschreibung automatisch angezeigt.
  8. Wählen Sie Speichern und dann Ausführen aus, um das Explore noch einmal auszuführen.

Das neue Feld wird in der Datentabelle angezeigt und enthält die Stufen für Werte, je nachdem, in welche der angegebenen Gruppen sie passen.

Mit dem neuen Bin können Sie neue Erkenntnisse aus Ihren Daten gewinnen. Bei einem benutzerdefinierten Bin, der auf der Dimension Kosten basiert, können Sie beispielsweise die Anzahl der Bestellungen vergleichen, die Artikel in bestimmten Kostenbereichen enthalten.

Das neue Feld wird im Bereich Benutzerdefinierte Felder der Feldauswahl angezeigt.

Wie bei anderen Feldern auch können Sie den Namen des Felds auswählen, um es einer Abfrage hinzuzufügen oder daraus zu entfernen. Sie können auch den Mauszeiger auf das Feld bewegen, um weitere Optionen für dieses Feld aufzurufen. Sie können beispielsweise das Symbol Filter des Felds auswählen, um es als Filter in einer Abfrage zu verwenden. Sie können den benutzerdefinierten Container auch nach Bedarf bearbeiten.

Einem benutzerdefinierten Messwert einen Filter hinzufügen

Wenn Sie Filter auf benutzerdefinierte Messwerte anwenden, können Sie die Daten einschränken, z. B. nur Bestellungen aus bestimmten Regionen einbeziehen. Sie können einer benutzerdefinierten Messung einen benutzerdefinierten Filter hinzufügen, wenn Sie eine benutzerdefinierte Messung erstellen oder bearbeiten. So fügen Sie einem benutzerdefinierten Messwert einen Filter hinzu:

  1. Sie haben folgende Möglichkeiten, eine benutzerdefinierte Messung zu erstellen oder zu bearbeiten:
    • Wählen Sie im Bereich Konfigurieren (oder in der Feldauswahl in klassischen Explores) Hinzufügen und dann Benutzerdefinierte Messung aus, um eine neue benutzerdefinierte Messung zu erstellen.
    • Wählen Sie in der Standard-Explore-Oberfläche im Bereich Konfigurieren das Dreipunkt-Menü  Mehr der benutzerdefinierten Messung aus (oder im Bereich Daten das Dreipunkt-Menü  Mehr der Datenspalte) und wählen Sie dann Bearbeiten aus.
    • Wählen Sie in klassischen Explores das Dreipunkt-Menü Mehr der benutzerdefinierten Messung in der Feldauswahl (oder das Zahnradmenü der Dimension in der Datentabelle) und dann Bearbeiten aus.
  2. Wählen Sie im Bereich Filter im Drop-down-Menü Filtername das Feld aus, nach dem Sie filtern möchten.
  3. Wählen Sie unter Filterwert die Schaltfläche für die vorhandene Bedingung aus, die standardmäßig Beliebiger Wert ist, um die Filterbedingungen anzupassen, die Sie anwenden möchten.
  4. Wählen Sie die Bedingung aus und geben Sie einen Wert ein oder wählen Sie einen Wert aus. Klicken Sie neben dem Wert auf das Pluszeichen Hinzufügen, um mehrere Bedingungen für das ausgewählte Feld hinzuzufügen. Klicken Sie zum Speichern außerhalb der Filterbedingung oder drücken Sie die Esc-Taste.
    • Falls verfügbar, werden Wertvorschläge in einer Drop-down-Liste angezeigt, die durch einen nach unten zeigenden Pfeil im Werteingabefeld gekennzeichnet ist. Nutzer können dann einen Wert auswählen oder danach suchen. Vorschläge sind am häufigsten für Dimensionen von type: string verfügbar.
    • Wenn Sie eine vorhandene benutzerdefinierte Messung bearbeiten, sollten Sie den Namen der benutzerdefinierten Messung so ändern, dass er die Filterbedingung widerspiegelt. Der Feldname erscheint in der Feldauswahl und in der Datentabelle.
  5. Wenn Sie weitere Filter hinzufügen möchten, wählen Sie im Bereich Filterwert die Pluszeichen-Schaltfläche Hinzufügen aus. Wenn Sie Filter entfernen möchten, wählen Sie die Minuszeichen-Schaltfläche Entfernen aus.
    • Looker wendet automatisch SQL-Bedingungen wie AND- oder OR-Logik an, wenn Sie mehrere Filter erstellen, basierend auf den von Ihnen angegebenen Feldtypen, Bedingungen und Werten.
  6. Optional können Sie unten auf dem Tab Filter auf den Abwärtspfeil neben Benutzerdefinierter Filter klicken, um das Feld Ausdruck zu maximieren und einen benutzerdefinierten Filter anstelle eines UI-basierten Filters oder zusätzlich zu einem solchen hinzuzufügen. Geben Sie im Feld Benutzerdefinierter Filter einen Looker-Ausdruck ein. Verwenden Sie dazu Looker-Funktionen und -Operatoren, die in benutzerdefinierten Filtern verwendet werden können. Der Looker-Ausdruckseditor schlägt Feldnamen vor und zeigt Syntaxhilfe für alle verwendeten Funktionen an. Felder, die sowohl in einem Explore verwendet werden als auch für den von Ihnen erstellten Feldtyp geeignet sind, sind mit einem schwarzen Kreis gekennzeichnet.
  7. Auf dem Tab Felddetails können Sie im Bereich Format ein Format angeben und im Feld Beschreibung optional eine Beschreibung mit bis zu 255 Zeichen hinzufügen, um anderen Nutzern weitere Informationen zum benutzerdefinierten Feld zu geben, einschließlich der vorgesehenen Verwendung.
  8. Klicken Sie auf Speichern.

Gefilterte Messung aus einer anderen Messung erstellen

So erstellen Sie eine benutzerdefinierte Messung, die eine vorhandene Messung kopiert und einen Filter hinzufügt:

  1. Maximieren Sie die Ansicht, die den Messwert enthält, dem Sie einen benutzerdefinierten Filter hinzufügen möchten. Der Messwert darf kein benutzerdefinierter Messwert oder ein type: number-Messwert sein. Wenn Sie einer vorhandenen benutzerdefinierten Messung einen Filterausdruck hinzufügen möchten, müssen Sie die benutzerdefinierte Messung bearbeiten.
  2. Wählen Sie im Bereich Konfigurieren (oder in der Feldauswahl in klassischen Explores) das Dreipunkt-Menü Mehr für diesen Messwert aus. Sie können auch im Bereich Daten das Dreipunkt-Menü der Datenspalte oder bei klassischen Explores das Zahnrad-Menü auswählen.
  3. Wählen Sie Gefilterte Messung erstellen aus.
  4. Geben Sie bei Bedarf im Feld Name einen anderen Namen als den Standardnamen ein. Der Name wird in der Feldauswahl und in der Datentabelle angezeigt.
  5. Wählen Sie im Bereich Filter im Drop-down-Menü Filtername das Feld aus, nach dem Sie filtern möchten.
  6. Wählen Sie unter Filterwert die Schaltfläche für die vorhandene Bedingung aus, die standardmäßig Beliebiger Wert ist, um die Filterbedingungen anzupassen, die Sie anwenden möchten.
  7. Wählen Sie die Bedingung aus und geben Sie einen Wert ein oder wählen Sie einen Wert aus. Klicken Sie neben dem Wert auf das Pluszeichen Hinzufügen, um mehrere Bedingungen für das ausgewählte Feld hinzuzufügen. Klicken Sie zum Speichern außerhalb der Filterbedingung oder drücken Sie die Esc-Taste.
    • Wenn verfügbar, werden Vorschläge für Werte in einer Drop-down-Liste angezeigt, die durch einen nach unten zeigenden Pfeil im Werteingabefeld gekennzeichnet ist. Nutzer können diese auswählen oder danach suchen. Vorschläge sind am häufigsten für Dimensionen von type: string verfügbar.
    • Wenn Sie eine vorhandene benutzerdefinierte Messung bearbeiten, sollten Sie den Namen der benutzerdefinierten Messung so ändern, dass er die Filterbedingung widerspiegelt.
  8. Wenn Sie weitere Filter hinzufügen möchten, wählen Sie im Bereich Filterwert die Pluszeichen-Schaltfläche Hinzufügen aus. Wenn Sie Filter entfernen möchten, wählen Sie die Minuszeichen-Schaltfläche Entfernen aus.
    • Looker wendet automatisch SQL-Bedingungen wie AND- oder OR-Logik an, wenn Sie mehrere Filter erstellen, basierend auf den von Ihnen angegebenen Feldtypen, Bedingungen und Werten.
  9. Optional können Sie unten auf dem Tab Filter auf den Pfeil neben Benutzerdefinierter Filter klicken, um das Feld Ausdruck zu maximieren und einen benutzerdefinierten Filter anstelle eines UI-basierten Filters oder zusätzlich zu einem solchen hinzuzufügen. Geben Sie im Feld Benutzerdefinierter Filter einen Looker-Ausdruck ein. Verwenden Sie dazu beliebige Looker-Funktionen und -Operatoren, die in benutzerdefinierten Filtern verwendet werden können. Der Looker-Ausdruckseditor schlägt Feldnamen vor und zeigt Syntaxhilfe für alle verwendeten Funktionen an. Felder, die sowohl in einem Explore verwendet werden als auch für den von Ihnen erstellten Feldtyp geeignet sind, sind mit einem schwarzen Kreis gekennzeichnet.
  10. Auf dem Tab Felddetails können Sie im Bereich Format ein Format angeben und im Feld Beschreibung optional eine Beschreibung mit bis zu 255 Zeichen hinzufügen, um anderen Nutzern weitere Informationen zum benutzerdefinierten Feld zu geben, einschließlich der vorgesehenen Verwendung.
  11. Klicken Sie auf Speichern.

Die neue Messung wird in der Feldauswahl im Bereich Benutzerdefinierte Felder angezeigt.

Wie bei anderen Messwerten auch können Sie den Namen eines benutzerdefinierten Messwerts auswählen, um ihn einer Abfrage hinzuzufügen oder daraus zu entfernen. Sie können auch den Mauszeiger auf das Feld bewegen, um weitere Optionen für dieses Feld aufzurufen. Dazu gehört das Symbol Filter, mit dem Sie das Feld als Filter in einer Abfrage verwenden können. Sie können das Feld auch bearbeiten.

Benutzerdefinierte Dimension mit einem Looker-Ausdruck erstellen

Die Methoden zum Erstellen einer benutzerdefinierten Dimension hängen davon ab, ob Sie die standardmäßige Explore-Oberfläche oder die klassische Explore-Oberfläche verwenden.

Benutzerdefinierte Dimension in der Standardoberfläche von „Explore“ erstellen

So erstellen Sie eine benutzerdefinierte Dimension in der standardmäßigen Explore-Oberfläche mit einem Looker-Ausdruck und einer oder mehreren anderen Dimensionen:

  1. Wählen Sie im Bereich Konfigurieren die Option + Hinzufügen und dann Benutzerdefinierte Dimension aus.

  2. Geben Sie im Feld Ausdruck einen Looker-Ausdruck ein, mit dem der Wert für Ihre Dimension berechnet wird. Verwenden Sie dazu beliebige Looker-Funktionen und -Operatoren. Der Looker-Ausdruckseditor schlägt Feldnamen vor und zeigt Syntaxhilfe für alle verwendeten Funktionen an. Felder, die in einem Explore verwendet werden und mit dem von Ihnen erstellten Feld verwendet werden können, sind mit einem schwarzen Kreis gekennzeichnet.

  3. Wählen Sie im Drop-down-Menü Format bei Bedarf eine andere Formatierungsoption als die Standardoption aus.

  4. Geben Sie im Feld Name den Namen der benutzerdefinierten Dimension an. Der Name wird im Bereich Konfigurieren und in der Datentabelle angezeigt.

  5. Wählen Sie + Beschreibung hinzufügen aus, um im Feld Beschreibung optional eine Beschreibung mit bis zu 255 Zeichen hinzuzufügen, die anderen Nutzern mehr Kontext oder Informationen zur benutzerdefinierten Dimension gibt.

  6. Klicken Sie auf Speichern.

Die neue benutzerdefinierte Dimension wird automatisch in der Datentabelle und im Bereich Konfigurieren unter Benutzerdefinierte Felder angezeigt.

Wie bei anderen Feldern auch können Sie den Namen einer benutzerdefinierten Dimension auswählen, um sie einer Abfrage hinzuzufügen oder daraus zu entfernen. Sie können auch den Mauszeiger auf das Feld bewegen, um weitere Optionen für dieses Feld aufzurufen. Dazu gehört das Symbol Filter, mit dem Sie das Feld als Filter in einer Abfrage verwenden können. Sie können das Feld auch bearbeiten.

Benutzerdefinierte Dimension in klassischen Explores erstellen

So erstellen Sie eine benutzerdefinierte Dimension in klassischen Explores mit einem Looker-Ausdruck und einer oder mehreren anderen Dimensionen:

  1. Wählen Sie im Bereich Benutzerdefinierte Felder der Feldauswahl die Option Hinzufügen aus.
  2. Wählen Sie Benutzerdefinierte Dimension aus.
  3. Geben Sie im Feld Ausdruck einen Looker-Ausdruck ein, mit dem der Wert für Ihre Dimension berechnet wird. Verwenden Sie dazu beliebige Looker-Funktionen und -Operatoren. Der Looker-Ausdruckseditor schlägt Feldnamen vor und zeigt Syntaxhilfe für alle verwendeten Funktionen an. Felder, die in einem Explore verwendet werden und mit dem von Ihnen erstellten Feld verwendet werden können, sind mit einem schwarzen Kreis gekennzeichnet.
  4. Wählen Sie im Drop-down-Menü Format bei Bedarf eine andere Formatierungsoption als die Standardoption aus.
  5. Geben Sie im Feld Name den Namen der benutzerdefinierten Dimension an. Der Name wird in der Feldauswahl und in der Datentabelle angezeigt.
  6. Wählen Sie + Beschreibung hinzufügen aus, um im Feld Beschreibung optional eine Beschreibung mit bis zu 255 Zeichen hinzuzufügen, die anderen Nutzern mehr Kontext oder Informationen zur benutzerdefinierten Dimension gibt.
  7. Klicken Sie auf Speichern.

Die neue benutzerdefinierte Dimension wird in der Feldauswahl im Bereich Benutzerdefinierte Felder angezeigt.

Wie bei anderen Feldern auch können Sie den Namen einer benutzerdefinierten Dimension auswählen, um sie einer Abfrage hinzuzufügen oder daraus zu entfernen. Sie können auch den Mauszeiger auf das Feld bewegen, um weitere Optionen für dieses Feld aufzurufen. Dazu gehört das Symbol Filter, mit dem Sie das Feld als Filter in einer Abfrage verwenden können. Sie können das Feld auch bearbeiten.

Benutzerdefiniertes Feld duplizieren

Wenn Sie benutzerdefinierte Felder erstellen dürfen, können Sie auch vorhandene benutzerdefinierte Felder duplizieren, die Sie oder andere Nutzer erstellt haben. Das Duplizieren und anschließende Bearbeiten von benutzerdefinierten Feldern kann hilfreich sein, wenn Sie mehrere benutzerdefinierte Felder mit nur geringen Unterschieden erstellen möchten (z. B. Summen für 30 Tage, 60 Tage oder 90 Tage).

Die Methoden zum Duplizieren eines benutzerdefinierten Felds hängen davon ab, ob Sie die Standardoberfläche für „Explore“ oder die klassische Oberfläche für „Explore“ verwenden.

Benutzerdefinierte Felder in der Standard-Explore-Oberfläche duplizieren

Sie können benutzerdefinierte Felder in der Standard-Explore-Oberfläche auf eine der folgenden Arten duplizieren:

  • Maximieren Sie im Bereich Konfigurieren die Ansicht Benutzerdefinierte Felder, wählen Sie das Dreipunkt-Menü  Mehr des benutzerdefinierten Felds aus und klicken Sie auf Duplizieren.
  • Wählen Sie im Bereich Daten die Datenspalte des benutzerdefinierten Felds aus, klicken Sie auf das Dreipunkt-Menü  und wählen Sie Duplizieren aus.

Das duplizierte benutzerdefinierte Feld wird in der Ansicht Benutzerdefinierte Felder im Bereich Konfigurieren und in der Datentabelle angezeigt. Es hat den Namen des ursprünglichen Felds mit dem Zusatz „Kopie“ am Ende.

Als Nächstes können Sie das duplizierte benutzerdefinierte Feld bearbeiten.

Benutzerdefinierte Felder in klassischen Explores duplizieren

In klassischen Explores können Sie benutzerdefinierte Felder auf folgende Weise duplizieren:

  • Über das Dreipunkt-Menü Mehr im Bereich Benutzerdefinierte Felder der Feldauswahl
  • Zahnrad-Menü der Datentabelle eines benutzerdefinierten Feldes verwenden

So duplizieren Sie ein benutzerdefiniertes Feld in klassischen Explores:

  1. Maximieren Sie in der Feldauswahl den Bereich Benutzerdefinierte Felder.
  2. Wählen Sie das Dreipunkt-Menü Mehr für das benutzerdefinierte Feld aus, das Sie duplizieren möchten.
  3. Wählen Sie Duplizieren aus.

Alternativ können Sie im Zahnradmenü der Datentabelle des benutzerdefinierten Felds die Option Duplizieren auswählen.

Das duplizierte Feld wird unter dem Original im Bereich Benutzerdefinierte Felder der Feldauswahl angezeigt. Der Name des Originalfelds wird verwendet und am Ende wird „Kopie“ angehängt.

Als Nächstes können Sie das duplizierte benutzerdefinierte Feld bearbeiten.

Benutzerdefiniertes Feld bearbeiten

Wenn Sie benutzerdefinierte Felder erstellen dürfen, können Sie auch benutzerdefinierte Felder bearbeiten, die Sie oder andere Nutzer erstellt haben.

Die Methoden zum Bearbeiten eines benutzerdefinierten Felds hängen davon ab, ob Sie die Standard-Explore-Oberfläche oder die klassische Explore-Oberfläche verwenden.

Benutzerdefinierte Felder in der Standard-Explore-Oberfläche bearbeiten

Sie können benutzerdefinierte Felder in der Standard-Explore-Oberfläche auf eine der folgenden Arten bearbeiten:

  • Maximieren Sie im Bereich Konfigurieren die Ansicht Benutzerdefinierte Felder, wählen Sie das Dreipunkt-Menü  Mehr des benutzerdefinierten Felds aus und klicken Sie auf Bearbeiten.
  • Wählen Sie im Bereich Daten die Datenspalte des benutzerdefinierten Felds aus, klicken Sie auf das Dreipunkt-Menü  und wählen Sie Bearbeiten aus.

Bei beiden Optionen wird das Dialogfeld zum Bearbeiten des benutzerdefinierten Felds geöffnet.

Benutzerdefinierte Dimension bearbeiten

So bearbeiten Sie eine benutzerdefinierte Dimension:

  1. Ändern Sie die Definition der benutzerdefinierten Dimension im Feld Ausdruck nach Bedarf. Wenn verfügbar, können Sie sich von Gemini beim Erstellen eines Looker-Ausdrucks unterstützen lassen.
  2. Wählen Sie bei Bedarf im Drop-down-Menü Format ein neues Format aus.
  3. Geben Sie bei Bedarf einen neuen Namen in das Feld Name ein. Der Name wird im Bereich Konfigurieren und in der Datentabelle angezeigt. Wenn Sie die Definition eines benutzerdefinierten Felds geändert haben, sollten Sie den Namen entsprechend ändern.
  4. Fügen Sie im Feld Beschreibung optional eine Beschreibung mit bis zu 255 Zeichen hinzu oder bearbeiten Sie eine vorhandene, um anderen Nutzern mehr Kontext oder Informationen zur benutzerdefinierten Dimension zu geben.
    • Wenn bereits eine Beschreibung vorhanden ist, erscheint das Kästchen Beschreibung automatisch. Wenn keine Beschreibung vorhanden ist, wählen Sie + Beschreibung hinzufügen aus, um optional eine Beschreibung hinzuzufügen.
  5. Klicken Sie auf Speichern.

Benutzerdefinierte Messung bearbeiten

So bearbeiten Sie eine benutzerdefinierte Messung:

  1. Wenn Sie das Feld ändern möchten, das aggregiert werden soll, wählen Sie im Drop-down-Menü Zu messendes Feld ein neues Feld aus.
  2. Wenn Sie den Typ der Messfunktion ändern möchten, wählen Sie im Drop-down-Menü Messtyp einen neuen Messtyp aus.
  3. Geben Sie bei Bedarf einen neuen Namen in das Feld Name ein. Der Name wird im Bereich Konfigurieren und in der Datentabelle angezeigt. Wenn Sie einen Feld- oder Measure-Typ ändern, sollten Sie in der Regel auch den Namen des benutzerdefinierten Measures entsprechend ändern. Wenn Sie beispielsweise das Feld Verkaufspreis in Kosten ändern, sollten Sie auch den Namen des benutzerdefinierten Felds ändern, in diesem Fall von Summe der Spalte „Verkaufspreis“ in Summe der Spalte „Kosten“.
  4. Auf dem Tab Filter können Sie einen UI-basierten oder benutzerdefinierten Filter hinzufügen, ändern oder entfernen.
    • Wenn bereits ein benutzerdefinierter Filter vorhanden ist, wird das Feld Ausdruck für den benutzerdefinierten Filter automatisch angezeigt. Wenn kein benutzerdefinierter Filter vorhanden ist, wählen Sie den Abwärtspfeil neben Benutzerdefinierter Filter aus, um im Feld Ausdruck einen optionalen benutzerdefinierten Filter anstelle eines UI-basierten Filters oder zusätzlich zu einem solchen hinzuzufügen.
  5. Auf dem Tab Felddetails können Sie im Bereich Format Formatierungen hinzufügen, ändern oder entfernen. Optional können Sie im Feld Beschreibung eine Beschreibung mit bis zu 255 Zeichen hinzufügen, um anderen Nutzern zusätzliche Details zum benutzerdefinierten Feld zu geben, einschließlich der vorgesehenen Verwendung.
  6. Klicken Sie auf Speichern.

Benutzerdefinierte Gruppe oder benutzerdefinierte Klasse bearbeiten

Wenn Sie Gruppenbedingungen, Klassen-Grenzwerte, Feldnamen und Beschreibungen in einer benutzerdefinierten Gruppe oder Klasse bearbeiten möchten, öffnen Sie das Dialogfeld „Bearbeiten“ und folgen Sie der Anleitung in den Abschnitten Benutzerdefinierte Gruppierung und Benutzerdefinierte Klassifizierung.

Benutzerdefinierte Felder in klassischen Explores bearbeiten

In klassischen Explores können Sie benutzerdefinierte Felder auf folgende Weise bearbeiten:

  • Über das Dreipunkt-Menü Mehr im Bereich Benutzerdefinierte Felder der Feldauswahl
  • Zahnrad-Menü der Datentabelle eines benutzerdefinierten Feldes verwenden

Benutzerdefinierte Dimension bearbeiten

So bearbeiten Sie eine benutzerdefinierte Dimension in klassischen Explores:

  1. Ändern Sie die Definition der benutzerdefinierten Dimension im Feld Ausdruck nach Bedarf.
  2. Wählen Sie bei Bedarf im Drop-down-Menü Format ein neues Format aus.
  3. Geben Sie bei Bedarf einen neuen Namen in das Feld Name ein. Der Name wird in der Feldauswahl und in der Datentabelle angezeigt. Wenn Sie die Definition eines benutzerdefinierten Felds geändert haben, sollten Sie den Namen entsprechend ändern.
  4. Wählen Sie + Beschreibung hinzufügen aus, um im Feld Beschreibung optional eine Beschreibung mit bis zu 255 Zeichen hinzuzufügen, die anderen Nutzern mehr Kontext oder Informationen zur benutzerdefinierten Dimension gibt.
    • Wenn bereits eine Beschreibung vorhanden ist, erscheint das Kästchen Beschreibung automatisch.
  5. Klicken Sie auf Speichern.

Benutzerdefinierte Messung bearbeiten

So bearbeiten Sie eine benutzerdefinierte Messung in klassischen Explores:

  1. Wenn Sie das Feld ändern möchten, das aggregiert werden soll, wählen Sie im Drop-down-Menü Zu messendes Feld ein neues Feld aus.
  2. Wenn Sie den Typ der Messfunktion ändern möchten, wählen Sie im Drop-down-Menü Messtyp einen neuen Messtyp aus.
  3. Geben Sie bei Bedarf einen neuen Namen in das Feld Name ein. Der Name wird in der Feldauswahl und in der Datentabelle angezeigt. Wenn Sie einen Feld- oder Measure-Typ ändern, sollten Sie in der Regel auch den Namen des benutzerdefinierten Measures entsprechend ändern. Wenn Sie beispielsweise das Feld Verkaufspreis in Kosten ändern, sollten Sie auch den Namen des benutzerdefinierten Felds ändern, in diesem Fall von Summe der Spalte „Verkaufspreis“ in Summe der Spalte „Kosten“.
  4. Auf dem Tab Filter können Sie einen UI-basierten oder benutzerdefinierten Filter hinzufügen, ändern oder entfernen.
    • Wenn bereits ein benutzerdefinierter Filter vorhanden ist, wird das Feld Ausdruck für den benutzerdefinierten Filter automatisch angezeigt. Wenn kein benutzerdefinierter Filter vorhanden ist, wählen Sie den Abwärtspfeil neben Benutzerdefinierter Filter aus, um im Feld Ausdruck einen optionalen benutzerdefinierten Filter anstelle eines UI-basierten Filters oder zusätzlich zu einem solchen hinzuzufügen.
  5. Auf dem Tab Felddetails können Sie im Bereich Format Formatierungen hinzufügen, ändern oder entfernen. Optional können Sie im Feld Beschreibung eine Beschreibung mit bis zu 255 Zeichen hinzufügen, um anderen Nutzern zusätzliche Details zum benutzerdefinierten Feld zu geben, einschließlich der vorgesehenen Verwendung.
  6. Klicken Sie auf Speichern.

Benutzerdefinierte Gruppe oder benutzerdefinierte Klasse in klassischen Explores bearbeiten

Wenn Sie Gruppenbedingungen, Klassen-Breakpoints, Feldnamen und Beschreibungen in einer benutzerdefinierten Gruppe oder einer benutzerdefinierten Klasse in klassischen Explores bearbeiten möchten, öffnen Sie das Dialogfeld „Bearbeiten“ und folgen Sie der Anleitung in den Abschnitten Benutzerdefinierte Gruppierung und Benutzerdefinierte Klassifizierung.

Benutzerdefinierte Felder entfernen und löschen

Wenn Sie benutzerdefinierte Felder erstellen dürfen, können Sie benutzerdefinierte Felder aus einer Abfrage entfernen oder aus dem Explore löschen.

Wenn Sie ein benutzerdefiniertes Feld löschen, verschwindet dieses aus dem Explore, jedoch nicht aus Looks oder Dashboard-Tiles, die dieses Feld verwenden. Darüber hinaus verfügt jeder, der eine URL für ein Explore verwendet, welches das benutzerdefinierte Feld nutzt, weiterhin über das Feld.

Sie haben die Wahl zwischen Entfernen und Löschen:

  • Entfernen: Das benutzerdefinierte Feld wird aus der Explore-Abfrage und der Datentabelle entfernt. Die Definition des benutzerdefinierten Felds bleibt jedoch im Abschnitt Benutzerdefinierte Felder der Feldauswahl erhalten, sodass Sie es später wieder der Abfrage hinzufügen können.
  • Löschen: Das benutzerdefinierte Feld wird dauerhaft aus der Explore-Abfrage und dem Bereich Benutzerdefinierte Felder im Bereich Konfigurieren (oder der Feldauswahl in klassischen Explores) gelöscht.

Die Methoden zum Entfernen und Löschen eines benutzerdefinierten Felds hängen davon ab, ob Sie die Standard-Explore-Oberfläche oder die klassische Explore-Oberfläche verwenden.

Benutzerdefinierte Felder in der Standard-Explore-Oberfläche entfernen

In der Standardoberfläche von „Explore“ können Sie zwischen Entfernen und Löschen wählen:

  • Entfernen: Das benutzerdefinierte Feld wird aus der Explore-Abfrage und der Datentabelle entfernt. Die Definition des benutzerdefinierten Felds bleibt jedoch in der Ansicht Benutzerdefinierte Felder im Bereich Konfigurieren erhalten, sodass Sie es später wieder der Abfrage hinzufügen können.
  • Löschen: Das benutzerdefinierte Feld wird endgültig aus der Explore-Abfrage und der Ansicht Benutzerdefinierte Felder im Bereich Konfigurieren gelöscht.

Wenn Sie ein benutzerdefiniertes Feld aus der Abfrage entfernen, aber im Bereich Konfigurieren beibehalten möchten, verwenden Sie eine der folgenden Methoden:

  • Wählen Sie im Bereich Daten die Datenspalte des benutzerdefinierten Felds aus, klicken Sie auf das Dreipunkt-Menü  und wählen Sie Entfernen aus.
  • Wählen Sie im Bereich Konfigurieren den Tab Verwendete Felder aus und klicken Sie auf den Namen des benutzerdefinierten Felds, um die Auswahl aufzuheben.

Das benutzerdefinierte Feld wird nicht mehr in der Datentabelle oder den Abfrageergebnissen angezeigt, ist aber weiterhin in der Ansicht Benutzerdefinierte Felder im Bereich Konfigurieren verfügbar.

Benutzerdefinierte Felder in der Standard-Explore-Oberfläche löschen

Wenn Sie ein benutzerdefiniertes Feld endgültig aus einer Explore-Abfrage und dem Bereich Konfigurieren löschen möchten, haben Sie folgende Möglichkeiten:

  • Maximieren Sie im Bereich Konfigurieren die Ansicht Benutzerdefinierte Felder, wählen Sie das Dreipunkt-Menü des benutzerdefinierten Felds aus und klicken Sie auf Löschen.
  • Wählen Sie im Bereich Daten die Datenspalte des benutzerdefinierten Felds aus, klicken Sie auf das Dreipunkt-Menü  Mehr und wählen Sie Löschen aus.

Sie können auch die Tastenkombinationen Befehlstaste + K (Mac) oder Strg + K (Windows) verwenden, um benutzerdefinierte Felder zu löschen und Felder aus einer Explore-Abfrage zu entfernen.

Sie können ein gelöschtes benutzerdefiniertes Feld wiederherstellen, indem Sie in Ihrem Browser die Schaltfläche „Zurück“ wählen.

Benutzerdefinierte Felder in klassischen Explores entfernen

Sie haben folgende Möglichkeiten, benutzerdefinierte Felder in klassischen Explores zu entfernen:

  • Über das Dreipunkt-Menü Mehr im Bereich Benutzerdefinierte Felder der Feldauswahl
  • Zahnrad-Menü der Datentabelle eines benutzerdefinierten Feldes verwenden

So löschen Sie ein benutzerdefiniertes Feld in klassischen Explores:

  1. Maximieren Sie in der Feldauswahl den Bereich Benutzerdefinierte Felder.
  2. Wählen Sie das Dreipunkt-Menü Mehr für das benutzerdefinierte Feld aus, das Sie entfernen möchten.
  3. Klicken Sie auf Entfernen.

Alternativ können Sie im Zahnradmenü der Datentabelle des benutzerdefinierten Felds die Option Entfernen auswählen.

Benutzerdefinierte Felder in klassischen Explores löschen

Sie haben folgende Möglichkeiten, benutzerdefinierte Felder in klassischen Explores zu löschen:

  • Über das Dreipunkt-Menü Mehr im Bereich Benutzerdefinierte Felder der Feldauswahl
  • Zahnrad-Menü der Datentabelle eines benutzerdefinierten Feldes verwenden

So löschen Sie ein benutzerdefiniertes Feld in klassischen Explores:

  1. Maximieren Sie in der Feldauswahl den Bereich Benutzerdefinierte Felder.
  2. Wählen Sie das Dreipunkt-Menü Mehr für das benutzerdefinierte Feld aus, das Sie löschen möchten.
  3. Wählen Sie Löschen aus.

Alternativ können Sie im Zahnradmenü der Datentabelle des benutzerdefinierten Felds die Option Löschen auswählen.

Sie können auch die Tastenkombinationen Befehlstaste + K (Mac) oder Strg + K (Windows) verwenden, um benutzerdefinierte Felder zu löschen und Felder aus einer Explore-Abfrage zu entfernen.

Sie können ein gelöschtes benutzerdefiniertes Feld wiederherstellen, indem Sie in Ihrem Browser die Schaltfläche „Zurück“ wählen.

Nachdem Sie gelernt haben, wie Sie benutzerdefinierte Felder erstellen und bearbeiten, können Sie Folgendes tun: