Mit dem visuellen Modellierungs-Canvas in Looker können Sie eine Verbindung zu BigQuery-Datenquellen herstellen, um LookML-Datenmodelle mithilfe eines interaktiven Canvas mit Drag-and-drop-Funktion zu erstellen und zu bearbeiten. Mit dem visuellen Modellierungs-Canvas können Sie Tabellen visuell zusammenführen, Dimensionen und Messwerte definieren, eine Vorschau der Abfrageergebnisse in Echtzeit ansehen und Analysen veröffentlichen, ohne LookML-Code schreiben zu müssen.

Canvas-Komponenten
Der visuelle Modellierungs-Canvas umfasst die folgenden Arbeitsbereichskomponenten und Navigationstabs:
- Quellen database: Eine durchsuchbare Seitenleiste mit den verfügbaren Datenbank-Datasets, ‑Tabellen und ‑Ansichten für die aktive Verbindung
- Visueller Canvas graph_4: Der Hauptarbeitsbereich, in dem Sie Tabellen ziehen, Tabellenknoten anordnen und Join-Beziehungen definieren
- LookML-Code code: Ein Bereich mit dem generierten LookML-Code, der Ihrem visuellen Modell zugrunde liegt
- Datenvorschau table_chart: Ein minimierbarer unterer Bereich mit einer Echtzeit-Abfragevorschau (
LIMIT 100) des zusammengeführten Datasets - Feld-Editor edit_attributes: Ein Bereich zum Hinzufügen, Umbenennen und Anpassen von Dimensionen und Messwerten
Hinweis
Für die Verwendung des visuellen Modellierungs-Canvas benötigen Sie Folgendes:
- Eine Looker-Instanz mit Looker 26.14 oder höher, die von einem Looker-Administrator so konfiguriert wurde, dass Self-Service-Analysen aktiviert sind
- Eine BigQuery-Datenbankverbindung, die mit den folgenden Einstellungen konfiguriert ist:
- Konfiguriert mit dem Bereich Alle Projekte auf dem Tab Datenbanken der Seite Verbindungen
- Für die Authentifizierung mit OAuth konfiguriert
- Ein Looker-Nutzerkonto mit der
create_self_service_from_tableBerechtigung - Ein Google-Konto mit den folgenden IAM-Rollen für die Ziel-BigQuery-Tabellen:
Visuelles Modell erstellen
In den folgenden Abschnitten wird beschrieben, wie Sie mit dem visuellen Modellierungs-Canvas ein neues Datenmodell erstellen:
- Verbindung zur Datenbank herstellen
- Tabellen zum Canvas hinzufügen
- Beziehungen und Joins definieren
- Messwerte und Dimensionen hinzufügen und konfigurieren
- Echtzeit-Vorschau Ihrer Daten ansehen
- LookML für Ihr Modell ansehen
- Modell in einer Analyse veröffentlichen
Verbindung zur Datenbank herstellen
So stellen Sie eine Verbindung zu Ihrer Datenbank her:
- Klicken Sie in Looker in der Hauptnavigation auf die Schaltfläche Erstellen.
- Wählen Sie Datenquelle aus.
- Wählen Sie im Dialogfeld Datenquelle erstellen den Tab Mit Datenbank verbinden aus.
- Wählen Sie im Drop-down-Menü BigQuery-Verbindung eine Datenbankverbindung aus.
- Geben Sie Ihr Projekt an:
- Wählen Sie Aus Liste auswählen aus, um aus den verfügbaren Projekten für die Verbindung auszuwählen.
- Wählen Sie Manuell eingeben aus, um die Projekt-ID direkt einzugeben.
- Geben Sie an, ob alle Tabellen einbezogen oder bestimmte Tabellen ausgewählt werden sollen:
- Wählen Sie Alle Datasets und Tabellen in diesem ausgewählten Projekt einschließen aus, um mit einem leeren Canvas zu beginnen. Auf dem leeren Canvas können Sie Tabellen aus Ihrer Quellenliste hinzufügen.
- Wählen Sie Bestimmte Tabelle auswählen aus, um ein einzelnes Dataset und eine einzelne Tabelle anzugeben, die dem Canvas hinzugefügt werden sollen. Der visuelle Modellierungs-Canvas wird im Feld-Editor geöffnet und die Felder aus der ausgewählten Tabelle werden geladen. Sie können in der Navigationsleiste auf Visueller Canvas graph_4 klicken, um die Tabelle im Canvas zu sehen. Sie können weitere Tabellen aus Ihrer Quellenliste hinzufügen.
- Klicken Sie auf Weiter , um den visuellen Modellierungs-Canvas zu öffnen.
Tabellen zum Canvas hinzufügen
So fügen Sie dem Canvas Tabellen hinzu, um mit der Modellierung Ihrer Daten zu beginnen:
- Suchen Sie in der Seitenleiste Quellen database nach den Datasets, Tabellen oder Ansichten, die Sie modellieren möchten.
- Ziehen Sie jede Tabelle aus der Seitenleiste auf den Canvas.
- Positionieren Sie die Tabellenknoten auf dem Canvas neu, um das Layout Ihres Datenmodells zu organisieren.
Wenn Sie eine Tabelle auf den Canvas ziehen, wird sie im visuellen Modellierungs-Canvas als Tabellenknoten dargestellt. Auf dem Canvas werden der Tabellenname sowie die BigQuery-Projekt- und Dataset-ID angezeigt. Die erste Tabelle, die dem Canvas hinzugefügt wird, wird mit Basisansicht bezeichnet.
Beziehungen und Joins definieren
Wenn Sie dem Canvas mehr als eine Tabelle hinzufügen, sucht der visuelle Modellierungs-Canvas nach übereinstimmenden Spaltennamen (z. B. order_id in orders und order_items) und schlägt automatisch eine Join-Verbindungslinie zwischen den Tabellen vor.
So ändern oder erstellen Sie Beziehungen zwischen Tabellen in Ihrer Datenbank:
- Klicken Sie auf die Join-Verbindungslinie zwischen zwei Tabellenknoten, um den Bereich Join-Konfiguration zu öffnen. Konfigurieren Sie den Join im Bereich Join-Konfiguration :
- Join-Typ: Wählen Sie den Join-Typ aus (Left Outer, Inner oder Full Outer). Standardmäßig verwendet Looker einen Left Outer Join.
- Beziehung (Kardinalität): Wählen Sie den Beziehungstyp aus (1:1, 1:n, n:1 oder n:n).
- Join-Klausel: Überprüfen Sie die automatisch vorgeschlagenen Join-Schlüssel oder fügen Sie benutzerdefinierte Join-Bedingungen hinzu. Sie können mehrere Join-Bedingungen angeben, z. B.
orders.id = order_items.order_id AND orders.date = order_items.date.
- Join-Fehler beheben: Wenn ein Join einen ungültigen SQL-Pfad oder eine Zirkelreferenz erzeugt, wird die Verbindungslinie rot und ein erklärender Tooltip wird angezeigt. Passen Sie die Join-Schlüssel oder die Kardinalität der Beziehung an, um den Fehler zu beheben.
- Wenn Sie die Join-Einstellungen geändert haben, klicken Sie auf Anwenden , um die Änderungen auf den Join anzuwenden.
Messwerte und Dimensionen hinzufügen und konfigurieren
Der visuelle Modellierungs-Canvas richtet automatisch Dimensionen und Messwerte für Ihre Tabellen ein und ermöglicht es Ihnen, benutzerdefinierte Berechnungen hinzuzufügen. Standardmäßig erstellt der visuelle Modellierungs-Canvas einen Messwert vom Typ count oder sum für numerische Felder, während Felder mit Namen, die ID, Key oder Code enthalten, als numerische Dimensionen beibehalten werden. Wenn Sie eine 1:n -Beziehung definieren, wendet der visuelle Modellierungs-Canvas automatisch eine symmetrische Aggregationslogik an, um Fan-Out- und Fehler bei der Berechnung doppelter Werte zu vermeiden.
Sie können ein generiertes Feld nicht löschen, sondern nur ausblenden. Wählen Sie dazu entweder im Zahnradmenü des Felds im Feld-Editor die Option Ausblenden aus oder klicken Sie auf das Symbol Bearbeiten edit des Felds und aktivieren Sie das Kästchen Dieses Feld bei Analysen und Visualisierungen ausblenden.
Wenn Sie die Felder für eine Tabelle ansehen möchten, wählen Sie den Tabellenknoten auf dem Canvas aus und klicken Sie dann auf Felder bearbeiten.
Im Feld-Editor können Sie die folgenden Aufgaben ausführen:
- Dimension bearbeiten
- Messwert bearbeiten
- Benutzerdefinierte Dimension erstellen
- Benutzerdefinierten Messwert erstellen
Dimension bearbeiten
So bearbeiten Sie eine vorhandene Dimension:
- Wählen Sie im visuellen Modellierungs-Canvas einen Tabellenknoten aus und klicken Sie dann auf Felder bearbeiten, um den Feld-Editor zu öffnen.
- Klicken Sie im Feld-Editor auf den Tab Dimensionen.
- Suchen Sie die Dimension, die Sie bearbeiten möchten, und klicken Sie auf das Symbol Bearbeiten edit des Felds, um das Dialogfeld Dimension bearbeiten zu öffnen.
- Aktualisieren Sie die folgenden Felder nach Bedarf (das Feld Datentyp ist schreibgeschützt):
- Format: Wählen Sie im Drop-down-Menü eine Formatierungsoption aus.
- Name: Bearbeiten Sie den Namen, der zur Identifizierung der Dimension in LookML und Ausdrücken verwendet wird.
- Label: Bearbeiten Sie das Label, das in Analysen und Visualisierungen angezeigt wird.
- + Beschreibung hinzufügen: Klicken Sie auf diese Option, um eine optionale Beschreibung für die Dimension einzugeben oder zu bearbeiten.
- Dieses Feld bei Analysen und Visualisierungen ausblenden: Aktivieren oder deaktivieren Sie dieses Kästchen, um die Dimension auszublenden oder anzuzeigen.
- Klicken Sie auf Speichern.
Messwert bearbeiten
So bearbeiten Sie einen vorhandenen Messwert:
- Wählen Sie im visuellen Modellierungs-Canvas einen Tabellenknoten aus und klicken Sie dann auf Felder bearbeiten, um den Feld-Editor zu öffnen.
- Klicken Sie im Feld-Editor auf den Tab Messwerte.
- Suchen Sie den Messwert, den Sie bearbeiten möchten, und klicken Sie auf das Symbol Bearbeiten edit des Felds, um das Dialogfeld Messwert bearbeiten zu öffnen.
Aktualisieren Sie die folgenden Felder nach Bedarf:
- Zu messendes Feld: Wählen Sie im Drop-down-Menü das Feld aus, das Sie aggregieren möchten.
- Messwerttyp: Wählen Sie im Drop-down-Menü den Aggregationstyp aus, z. B. Summe, Anzahl, Durchschnitt, Min oder Max.
- Label: Bearbeiten Sie das Label, das in Analysen und Visualisierungen angezeigt wird.
- Tab „Filter“: Wählen Sie unter Ergebnisse eingrenzen im Drop-down-Menü Filtername ein Feld aus und geben Sie einen Filterwert an. Verwenden Sie die Schaltflächen + und - , um Filterbedingungen hinzuzufügen oder zu entfernen.
- Tab „Felddetails“: Wählen Sie im Drop-down-Menü Format eine Formatierungsoption aus und geben Sie optional eine Beschreibung ein (bis zu 255 Zeichen).
- Dieses Feld bei Analysen und Visualisierungen ausblenden: Aktivieren oder deaktivieren Sie dieses Kästchen, um den Messwert auszublenden oder anzuzeigen.
Klicken Sie auf Speichern.
Benutzerdefinierte Dimension erstellen
So erstellen Sie eine benutzerdefinierte Dimension mit einem Looker-Ausdruck:
- Wählen Sie im visuellen Modellierungs-Canvas einen Tabellenknoten aus und klicken Sie dann auf Felder bearbeiten, um den Feld-Editor zu öffnen.
- Klicken Sie im Feld-Editor des visuellen Modellierungs-Canvas auf Dimension hinzufügen, um das Dialogfeld Dimension erstellen zu öffnen.
- Geben Sie im Ausdruckseditor einen Looker-Ausdruck ein, der die Dimension definiert, oder klicken Sie auf Formuliere für mich einen Ausdruck mit Gemini , um einen Ausdruck zu generieren.
- Wählen Sie im Drop-down-Menü Format eine Formatierungsoption aus.
- Geben Sie einen Namen und ein Label für die Dimension ein.
- Optional: Klicken Sie auf + Beschreibung hinzufügen, um eine Beschreibung für die Dimension einzugeben oder zu bearbeiten.
- Optional: Aktivieren Sie das Kästchen Dieses Feld bei Analysen und Visualisierungen ausblenden, um die Dimension auszublenden.
- Klicken Sie auf Speichern.
Benutzerdefinierten Messwert erstellen
So erstellen Sie einen benutzerdefinierten Messwert:
- Wählen Sie im visuellen Modellierungs-Canvas einen Tabellenknoten aus und klicken Sie dann auf Felder bearbeiten, um den Feld-Editor zu öffnen.
- Klicken Sie im Feld-Editor auf den Tab Messwerte und dann auf Messwert hinzufügen, um das Dialogfeld Messwert erstellen zu öffnen.
- Wählen Sie im Drop-down-Menü Zu messendes Feld das Feld aus, das Sie aggregieren möchten.
- Wählen Sie im Drop-down-Menü Messwerttyp den Aggregationstyp aus, der auf das Feld Zu messendes Feld angewendet werden soll.
- Geben Sie ein Label für den Messwert ein.
- Konfigurieren Sie optionale Filterbedingungen oder Formatierungsdetails:
- Tab „Filter“: Wählen Sie unter Ergebnisse eingrenzen im Drop-down-Menü Filtername ein Feld aus und geben Sie einen Filterwert an. Verwenden Sie die Schaltflächen + und - , um Filterbedingungen hinzuzufügen oder zu entfernen.
- Tab „Felddetails“: Wählen Sie im Drop-down-Menü Format eine Formatierungsoption aus und geben Sie optional eine Beschreibung ein (bis zu 255 Zeichen).
- Optional: Aktivieren Sie das Kästchen Dieses Feld bei Analysen und Visualisierungen ausblenden, um den Messwert auszublenden.
- Klicken Sie auf Speichern.
Echtzeit-Vorschau Ihrer Daten ansehen
So überprüfen Sie die Datenausgabe Ihres Modells:
- Klicken Sie im visuellen Modellierungs-Canvas in der Navigationsleiste auf den Tab Datenvorschau table_chart.
- Klicken Sie auf eine Tabelle im Canvas, um Felder aus dieser Tabelle auszuwählen.
- Klicken Sie im Bereich „Datenvorschau“ auf das Drop-down-Menü Spalten in der Vorschau.
Wählen Sie im Drop-down-Menü die Felder aus der Tabelle aus, die Sie abfragen möchten, und klicken Sie dann auf Vorschau.
Der visuelle Modellierungs-Canvas fragt Ihre Datenbank ab und zeigt die Abfrageergebnisse in einer Tabelle im Bereich „Datenvorschau“ an.
Prüfen Sie die Daten, um sicherzustellen, dass es keine unbeabsichtigten Fan-Outs von Zeilen oder gelöschten Datensätze gibt.
Aktualisieren Sie die Joins oder Felder nach Bedarf und klicken Sie dann im Bereich „Datenvorschau“ auf Schema aktualisieren, um die Tabelle zu aktualisieren.
LookML ansehen
Klicken Sie auf den Tab LookML-Code code, um den generierten LookML-Code für Ihr Modell zu prüfen. Der LookML-Code für visuelle Modelle ist schreibgeschützt. Wenn Sie Felder und Joins bearbeiten möchten, verwenden Sie den visuellen Modellierungs-Canvas.
Modell in einer Analyse veröffentlichen
Klicken Sie im visuellen Modellierungs-Canvas auf die Schaltfläche Daten analysieren, um Ihr Modell zu speichern.
Looker generiert die zugrunde liegenden LookML-Modelldateien und speichert die Koordinaten des Canvas-Layouts. Ihr Modell wurde jetzt veröffentlicht und kann abgefragt werden.
Auf visuelle Modelle zugreifen
Veröffentlichte visuelle Modelle werden in der Looker-Navigation unter Analysen im Bereich Self-Service-Analysen angezeigt.
So fragen Sie ein visuelles Modell ab:
- Klicken Sie in Looker in der Hauptnavigation auf Analysen.
- Wählen Sie unter Self-Service-Analysen den Namen der Analyse Ihres Modells aus.
- Wählen Sie in der Feldauswahl Dimensionen und Messwerte aus, fügen Sie Filter hinzu und führen Sie Abfragen aus, um Visualisierungen und Dashboard-Kacheln zu erstellen.
Vorhandenes visuelles Modell bearbeiten
So ändern Sie ein vorhandenes Modell, das mit dem visuellen Modellierungs-Canvas erstellt wurde:
- Klicken Sie in Looker im Hauptnavigationsmenü auf Analysen.
- Öffnen Sie unter Self-Service-Analysen die Analyse für das Modell, das Sie bearbeiten möchten.
- Wählen Sie im Feldauswahl der Analyse die Option Modell bearbeiten aus, um den visuellen Modellierungs-Canvas zu öffnen. Wenn Sie die klassische Analyse verwenden, wählen Sie im Zahnradmenü der Analyse die Option Modell bearbeiten aus.
- Nehmen Sie die gewünschten Änderungen im visuellen Modellierungs-Canvas vor, z. B. Tabellen hinzufügen, Join-Klauseln aktualisieren oder neue Messwerte erstellen.
- Klicken Sie auf Daten analysieren , um das Modell zu aktualisieren.
Visuelles Modell löschen
So löschen Sie ein visuelles Modell:
- Klicken Sie in Looker im Hauptnavigationsmenü auf Analysen.
- Öffnen Sie unter Self-Service-Analysen die Analyse für das Modell, das Sie bearbeiten möchten.
- Wählen Sie im Feldauswahl der Analyse die Option Modell bearbeiten aus, um den visuellen Modellierungs-Canvas zu öffnen. Wenn Sie die klassische Analyse verwenden, wählen Sie im Zahnradmenü der Analyse die Option Modell bearbeiten aus.
- Wählen Sie im visuellen Modellierungs-Canvas im Dreipunkt-Menü die Option Löschen aus.