Looker のビジュアル モデリング キャンバスを使用すると、BigQuery データソースに接続して、インタラクティブなドラッグ&ドロップ キャンバスを使用して LookML データモデルを構築および編集できます。ビジュアル モデリング キャンバスを使用すると、LookML コードを記述せずに、テーブルを視覚的に結合したり、ディメンションとメジャーを定義したり、クエリ結果をリアルタイムでプレビューしたり、Explore を公開したりできます。

キャンバス コンポーネント
ビジュアル モデリング キャンバスには、次のワークスペース コンポーネントとナビゲーション タブが含まれています。
- ソース データベース: アクティブな接続で使用可能なデータベースのデータセット、テーブル、ビューを表示する検索可能なサイドバー
- ビジュアル キャンバス graph_4: テーブルをドラッグし、テーブルノードを配置して、結合関係を定義するメイン ワークスペース
- LookML コード コード: 視覚モデルの背後にある生成された LookML コードを表示するパネル
- データ プレビュー table_chart: 結合されたデータセットのリアルタイム クエリ プレビュー(
LIMIT 100)を表示する、折りたたみ可能な下部パネル - フィールド エディタ edit_attributes: ディメンションとメジャーの追加、名前変更、カスタマイズを行うためのパネル
始める前に
ビジュアル モデリング キャンバスを使用するには、次のものが必要です。
- Looker 26.14 以降を実行し、Looker 管理者が セルフサービス Explore を有効にするように構成した Looker インスタンス
- 次の設定で構成された BigQuery データベース接続。
- [接続] ページの [データベース] タブで [すべてのプロジェクト] スコープを使用して構成されている
- OAuth による認証用に構成されている
create_self_service_from_table権限を持つ Looker ユーザー アカウント- ターゲットの BigQuery テーブルに対する次の IAM ロールを持つ Google アカウント。
ビジュアル モデルの作成
以降のセクションでは、ビジュアル モデリング キャンバスを使用して新しいデータモデルを作成する手順について説明します。
- データベースに接続します
- キャンバスにテーブルを追加する
- リレーションシップと結合を定義する
- 指標とディメンションを追加して構成する
- データをリアルタイムでプレビューする
- モデルの LookML を表示する
- モデルを Explore に公開する
データベースに接続します
データベースに接続する手順は次のとおりです。
- Looker で、メイン ナビゲーションの [作成] ボタンをクリックします。
- [データソース] を選択します。
- [データソースの作成] ダイアログで、[データベースに接続] タブを選択します。
- [BigQuery 接続] プルダウン メニューからデータベース接続を選択します。
- プロジェクトを指定します。
- [リストから選択] を選択して、接続で使用可能なプロジェクトから選択します。
- [手動で入力] を選択して、プロジェクト ID を直接入力します。
- すべてのテーブルを含めるか、特定のテーブルを選択するかを指定します。
- [選択したプロジェクト内のすべてのデータセットとテーブルを含める] を選択して、空のキャンバスから開始します。空のキャンバスから、ソースリストの表を追加できます。
- [特定のテーブルを選択] を選択して、キャンバスに追加する単一のデータセットとテーブルを指定します。ビジュアル モデリング キャンバスが開き、フィールド エディタに選択したテーブルのフィールドが読み込まれます。ナビゲーション バーの [ビジュアル キャンバス] graph_4 をクリックすると、キャンバスにテーブルが表示されます。ソースリストから他のテーブルを追加できます。
- [続行] をクリックして、ビジュアル モデリング キャンバスを開きます。
キャンバスにテーブルを追加する
キャンバスにテーブルを追加してデータ モデリングを開始する手順は次のとおりです。
- [ソース] データベース サイドバーで、モデル化するデータセット、テーブル、ビューを参照または検索します。
- サイドバーからキャンバスに各テーブルをドラッグします。
- キャンバス上のテーブルノードを再配置して、データモデルのレイアウトを整理します。
テーブルをキャンバスにドラッグすると、ビジュアル モデリング キャンバスにテーブルノードとして表示されます。キャンバスにテーブル名と BigQuery プロジェクト ID、データセット ID が表示されます。キャンバスに追加された最初のテーブルには、[ベースビュー] というラベルが付けられます。
リレーションと結合を定義する
キャンバスに複数のテーブルを追加すると、ビジュアル モデリング キャンバスで一致する列名(orders と order_items の order_id など)がスキャンされ、テーブル間の結合接続線が自動的に提案されます。
データベース内のテーブル間のリレーションシップを変更または作成する手順は次のとおりです。
- 2 つのテーブルノード間の結合接続線をクリックして、[結合の構成] パネルを開きます。[結合の構成] パネルで結合を構成します。
- 結合タイプ: 結合タイプ(左外部、内部、完全外部)を選択します。デフォルトでは、Looker は左外部結合を使用します。
- 関係(カーディナリティ): 関係のタイプ(1 対 1、1 対多、多対 1、多対多)を選択します。
- 結合句: 自動的に提案された結合キーを確認するか、カスタム結合条件を追加します。複数の結合条件(
orders.id = order_items.order_id AND orders.date = order_items.dateなど)を指定できます。
- 結合エラーを解決する: 結合によって無効な SQL パスまたは循環参照が作成された場合、接続線が赤に変わり、説明のツールチップが表示されます。エラーを解決するには、結合キーまたはリレーションシップのカーディナリティを調整します。
- 結合設定を変更した場合は、[適用] をクリックして、変更を結合に適用します。
メジャーとディメンションを追加して構成する
ビジュアル モデリング キャンバスでは、テーブルのディメンションとメジャーが自動的に設定され、カスタム計算を追加できます。デフォルトでは、ビジュアル モデリング キャンバスは数値フィールドに対して count 型または sum 型のメジャーを作成し、ID、Key、Code を含む名前のフィールドは数値ディメンションとして保持します。一対多の関係を定義すると、ビジュアル モデリング キャンバスで対称集計ロジックが自動的に適用され、ファンアウトと重複値の計算エラーが防止されます。
生成されたフィールドは削除できません。非表示にすることのみ可能です。非表示にするには、フィールド エディタでフィールドの歯車メニューから [非表示] を選択するか、フィールドの [編集] 編集アイコンをクリックして [このフィールドを Explore とビジュアリゼーションで非表示にする] チェックボックスをオンにします。
テーブルのフィールドを表示するには、キャンバスでテーブルノードを選択し、[フィールドを編集] をクリックします。
フィールド エディタでは、次のタスクを実行できます。
ディメンションを編集する
既存のディメンションを編集する手順は次のとおりです。
- ビジュアル モデリング キャンバスで、キャンバス内のテーブルノードを選択し、[フィールドを編集] をクリックしてフィールド エディタを開きます。
- フィールド エディタで、[ディメンション] タブをクリックします。
- 編集するディメンションを見つけ、フィールドの [編集] 編集アイコンをクリックして [ディメンションを編集] ダイアログを開きます。
- 次のフィールドを更新します([データ型] フィールドは読み取り専用です)。
- 形式: プルダウン メニューから形式オプションを選択します。
- 名前: LookML と式でディメンションの識別に使用される名前を編集します。
- ラベル: Explore とビジュアリゼーションに表示されるラベルを編集します。
- + 説明を追加: このオプションをクリックして、ディメンションの説明を入力または編集します(省略可)。
- このフィールドを Explore とビジュアリゼーションで非表示にする: このチェックボックスをオンまたはオフにして、ディメンションを非表示または表示にします。
- [保存] をクリックします。
メジャーを編集する
既存の指標を編集する手順は次のとおりです。
- ビジュアル モデリング キャンバスで、キャンバス内のテーブルノードを選択し、[フィールドを編集] をクリックしてフィールド エディタを開きます。
- フィールド エディタで、[指標] タブをクリックします。
- 編集する指標を見つけて、フィールドの [編集] 編集アイコンをクリックして [指標を編集] ダイアログを開きます。
次のいずれかのフィールドを更新します。
- 測定するフィールド: プルダウン メニューから、集計するフィールドを選択します。
- メジャータイプ: プルダウン メニューから集計タイプ(合計、カウント、平均、最小、最大など)を選択します。
- ラベル: Explore とビジュアリゼーションに表示されるラベルを編集します。
- [フィルタ] タブ: [結果を絞り込む] で、[フィルタ名] プルダウン メニューからフィールドを選択し、フィルタ値を指定します。[+] ボタンと [-] ボタンを使用して、フィルタ条件を追加または削除します。
- [フィールドの詳細] タブ: [形式] プルダウン メニューから形式オプションを選択し、必要に応じて [説明](255 文字以内)を入力します。
- このフィールドを Explore とビジュアリゼーションで非表示にする: このチェックボックスをオンまたはオフにして、メジャーを非表示または表示にします。
[保存] をクリックします。
カスタム ディメンションを作成する
Looker 式を使用してカスタム ディメンションを作成する手順は次のとおりです。
- ビジュアル モデリング キャンバスで、キャンバス内のテーブルノードを選択し、[フィールドを編集] をクリックしてフィールド エディタを開きます。
- ビジュアル モデリング キャンバスのフィールド エディタで、[ディメンションを追加] をクリックして [ディメンションを作成] ダイアログを開きます。
- 式エディタ ボックスに、ディメンションを定義する Looker 式を入力するか、[Gemini で文書作成サポート] をクリックして式を生成します。
- [形式] プルダウン メニューから形式オプションを選択します。
- ディメンションの名前とラベルを入力します。
- 必要に応じて、[+ 説明を追加] をクリックして、ディメンションの説明を入力または編集します。
- 必要に応じて、[このフィールドを Explore とビジュアリゼーションで非表示にする] チェックボックスをオンにして、ディメンションを非表示にします。
- [保存] をクリックします。
カスタム メジャーを作成する
カスタム指標を作成する手順は次のとおりです。
- ビジュアル モデリング キャンバスで、キャンバス内のテーブルノードを選択し、[フィールドを編集] をクリックしてフィールド エディタを開きます。
- フィールド エディタで [Measure] タブをクリックし、[Measure を追加] をクリックして [Measure を作成] ダイアログを開きます。
- [測定するフィールド] プルダウン メニューから、集計するフィールドを選択します。
- [メジャー タイプ] プルダウンで、[測定フィールド] フィールドに対して実行する集計のタイプを選択します。
- 指標のラベルを入力します。
- フィルタ条件または書式設定の詳細(省略可)を構成します。
- [フィルタ] タブ: [結果を絞り込む] で、[フィルタ名] プルダウン メニューからフィールドを選択し、フィルタ値を指定します。[+] ボタンと [-] ボタンを使用して、フィルタ条件を追加または削除します。
- [フィールドの詳細] タブ: [形式] プルダウン メニューから形式オプションを選択し、必要に応じて [説明](255 文字以内)を入力します。
- 必要に応じて、[このフィールドを Explore とビジュアリゼーションで非表示にする] チェックボックスをオンにして、メジャーを非表示にします。
- [保存] をクリックします。
データをリアルタイムでプレビューする
モデルのデータ出力を確認する手順は次のとおりです。
- ビジュアル モデリング キャンバスで、ナビゲーション バーの [データ プレビュー] タブ table_chart をクリックします。
- キャンバスでテーブルをクリックして、そのテーブルからフィールドを選択します。
- データ プレビュー ペインで、[列をプレビュー] プルダウン メニューをクリックします。
プルダウン メニューから、クエリするテーブルのフィールドを選択し、[プレビュー] をクリックします。
ビジュアル モデリング キャンバスでデータベースがクエリされ、クエリ結果がデータ プレビュー ペインのテーブルに表示されます。
データを検査して、意図しない行のファンアウトやレコードのドロップが発生していないことを確認します。
必要に応じて結合またはフィールドを更新し、データ プレビュー ペインで [スキーマを更新] をクリックしてテーブルを更新します。
LookML を表示する
[LookML コード] タブ コードをクリックして、モデル用に生成された LookML を確認します。ビジュアル モデルの LookML は読み取り専用です。フィールドと結合を編集する場合は、ビジュアル モデリング キャンバスを使用します。
モデルを Explore に公開する
モデルを保存するには、ビジュアル モデリング キャンバスの [データを探索] ボタンをクリックします。
Looker は、基盤となる LookML モデルファイルを生成し、キャンバス レイアウトの座標を保存します。モデルが公開され、クエリを実行できるようになりました。
ビジュアル モデルへのアクセス
公開されたビジュアル モデルは、Looker のナビゲーションの [Explore] の [セルフサービス Explore] セクションに表示されます。
ビジュアル モデルをクエリする手順は次のとおりです。
- Looker のメイン ナビゲーションで [Explore] をクリックします。
- [セルフサービス Explore] で、モデルの Explore 名を選択します。
- フィールド ピッカーからディメンションとメジャーを選択し、フィルタを追加してクエリを実行し、ビジュアリゼーションとダッシュボード タイルを作成します。
既存のビジュアル モデルを編集する
ビジュアル モデリング キャンバスで作成された既存のモデルを変更する手順は次のとおりです。
- Looker のメイン ナビゲーション メニューで [Explore] をクリックします。
- [セルフサービス Explore] で、編集するモデルの Explore を開きます。
- [Explore] のフィールド ピッカーから [モデルを編集] を選択して、ビジュアル モデリング キャンバスを開きます。以前のバージョンの Explore を使用している場合は、Explore の歯車メニューから [モデルを編集] を選択します。
- ビジュアル モデリング キャンバスで変更を行います(テーブルの追加、結合句の更新、新しいメジャーの作成など)。
- [データを探索] をクリックしてモデルを更新します。
ビジュアル モデルの削除
ビジュアル モデルを削除する手順は次のとおりです。
- Looker のメイン ナビゲーション メニューで [Explore] をクリックします。
- [セルフサービス Explore] で、編集するモデルの Explore を開きます。
- [Explore] のフィールド ピッカーから [モデルを編集] を選択して、ビジュアル モデリング キャンバスを開きます。以前のバージョンの Explore を使用している場合は、Explore の歯車メニューから [モデルを編集] を選択します。
- ビジュアル モデリング キャンバスで、その他メニューから [削除] を選択します。