Modifica le dashboard definite dall'utente di Looker per perfezionare le visualizzazioni dei dati e fornire informazioni chiare e pertinenti per i tuoi flussi di lavoro operativi. Puoi personalizzare i contenuti, il layout e le impostazioni di visualizzazione per ottimizzare il modo in cui i dati vengono presentati e utilizzati.
Per modificare una dashboard, devi soddisfare i seguenti prerequisiti:
- Il livello di accesso Manage Access, Edit (Gestione accesso, modifica) per la cartella in cui si trova la dashboard
- Le autorizzazioni di Looker appropriate per modificare la dashboard
Inoltre, per modificare un determinato riquadro della dashboard, devi disporre dell'accesso al modello su cui si basa il riquadro.
Se non hai accesso a tutti i modelli su cui si basano i riquadri di una determinata dashboard, puoi comunque modificare altre parti della dashboard, come il titolo della dashboard, le impostazioni della dashboard, i filtri della dashboard (anche se non vedrai i suggerimenti per i filtri basati sui campi di un modello a cui non hai accesso) e i riquadri per i quali hai accesso al modello.
Quando modifichi una dashboard, tieni presente le best practice per la creazione delle dashboard. Trova informazioni e consigli sulla creazione di dashboard ad alte prestazioni nella pagina delle best practice Considerazioni per la creazione di dashboard di Looker ad alte prestazioni.
Attivazione della modalità di modifica nelle dashboard
Per accedere alla modalità di modifica, seleziona Modifica dashboard dal menu con tre puntini Azioni dashboard.
In modalità di modifica, puoi aggiungere, ridimensionare e riposizionare, modificare o eliminare i riquadri, i gruppi di riquadri, i filtri o le schede della dashboard. Puoi anche modificare il titolo della dashboard.
Quando sei in modalità di modifica, Looker visualizza una barra degli strumenti blu nella parte superiore della dashboard che contiene le seguenti opzioni:
- Aggiungi
- Filtri
- Impostazioni
- Layout rapido
- Stile (disponibile solo se l'amministratore di Looker ha attivato la funzionalità in anteprima Temi delle dashboard interne).
- Annulla
- Salva

Dopo aver apportato almeno una modifica, il pulsante Salva diventa disponibile. Fai clic su Salva per salvare le modifiche ed uscire dalla modalità di modifica.
Per ignorare le modifiche, fai clic su Annulla. Nella finestra di dialogo Vuoi ignorare le modifiche?, fai clic su Ignora per confermare che vuoi annullare l'operazione e uscire dalla modalità di modifica. La finestra di dialogo Vuoi ignorare le modifiche? viene visualizzata anche se provi a uscire dalla dashboard facendo clic sul percorso di navigazione o sulle frecce avanti o indietro del browser.
Per saperne di più sullo spostamento di un filtro della dashboard, consulta la pagina della documentazione Aggiunta e modifica dei filtri delle dashboard definite dall'utente.
Per informazioni sull'aggiunta e sulla configurazione dei filtri direttamente sui singoli riquadri di visualizzazione, consulta la documentazione relativa ai filtri sui riquadri di visualizzazione.
Riorganizzare e ridimensionare i riquadri
In modalità di modifica, puoi spostare e ridimensionare i riquadri di una dashboard.
Per spostare un riquadro, trascina l'icona con sei puntini in alto a sinistra. Quando trascini un riquadro in una nuova posizione sulla dashboard, vengono visualizzate linee di griglia blu per aiutarti a posizionarlo. Looker mostra la larghezza e l'altezza di ogni riquadro, nonché la percentuale della larghezza totale della dashboard occupata dal riquadro.
Puoi anche utilizzare l'opzione Sposta riquadro nel menu di modifica del riquadro per spostarlo nella parte superiore o inferiore della dashboard. Se la dashboard ha delle schede, puoi anche utilizzare l'opzione Sposta nella scheda nel menu di modifica del riquadro per spostarlo in un'altra scheda.
Per ridimensionare un riquadro, trascina l'angolo in basso a destra del riquadro o utilizza l'opzione Ridimensiona riquadro nel menu con tre puntini Azioni riquadro in alto a destra di ogni riquadro. Le dimensioni preselezionate disponibili sono le seguenti:
- Molto piccolo: ogni riquadro occupa un sesto della riga della dashboard.
- Piccolo: ogni riquadro occupa un quarto della riga della dashboard.
- Medio: ogni riquadro occupa un terzo della riga della dashboard.
- Grande: ogni riquadro occupa metà della riga della dashboard.
- Extra Large: ogni riquadro occupa l'intera larghezza della riga della dashboard.
Viene ridimensionato solo il riquadro selezionato. Le dimensioni dei riquadri sono adattabili alle dimensioni della dashboard.
Se vuoi ridimensionare un riquadro in modo che sia molto corto, nascondere il titolo del riquadro può aiutarti a renderlo il più corto possibile.
Dimensioni dei riquadri e layout della griglia
Quando aggiungi una visualizzazione utilizzando il layout a griglia a una dashboard, la disposizione della griglia può diventare adattabile alle dimensioni del riquadro della dashboard.
Ad esempio, hai un riquadro della dashboard con una visualizzazione che utilizza un layout a griglia di quattro piccoli grafici. Se ridimensioni il riquadro in modo che sia basso e largo, i grafici piccoli vengono visualizzati come una riga di quattro. Se ridimensioni il riquadro come un quadrato, i piccoli grafici vengono riposizionati in due righe da due. Se ridimensioni il riquadro in modo che sia stretto ma alto, i grafici vengono riposizionati in quattro righe da uno.
Per assicurarti che la disposizione della griglia sia adattabile, non inserire un numero nell'impostazione Numero di grafici per riga della visualizzazione. Se inserisci un valore in Numero di grafici per riga, il riquadro della dashboard rispetta questa impostazione indipendentemente dalle dimensioni o dalla forma del riquadro della dashboard.
Aggiunta di riquadri
In modalità di modifica, puoi aggiungere riquadri, gruppi di riquadri, schede o testo alla dashboard. Per informazioni su come aggiungere testo e riquadri, consulta la pagina della documentazione Creazione di dashboard definite dall'utente. Per informazioni su come aggiungere schede alle dashboard, consulta la pagina della documentazione Aggiunta di schede alle dashboard.
Modifica dei riquadri
In modalità di modifica, il menu con tre puntini Azioni riquadro in alto a destra di ogni riquadro mostra le opzioni di modifica disponibili.
Queste opzioni variano leggermente a seconda che tu stia visualizzando un riquadro di query o un riquadro collegato a un Look.
- In entrambi i casi, Looker visualizza le opzioni Modifica, Nascondi titolo, Aggiungi nota, Aggiungi descrizione di accessibilità e Sposta riquadro. Se la dashboard contiene schede, viene visualizzata l'opzione Sposta nella scheda. Se il riquadro si trova all'interno di un gruppo di riquadri, viene visualizzata anche l'opzione Separa riquadro.
- Per i riquadri delle query, Looker mostra anche le opzioni Duplica riquadro, Elimina e Visualizza.
- Per i riquadri collegati a un Look, Looker mostra anche l'opzione Rimuovi Look.
Il menu con tre puntini Azioni riquadro include anche l'opzione Mostra filtri, che ti consente di visualizzare i filtri applicati al riquadro.
Modifica del titolo di un riquadro della query
In modalità di modifica, puoi modificare il titolo di un riquadro di query facendo clic sul titolo e apportando le modifiche. Fai clic su Salva in alto a destra nella dashboard per salvare le modifiche.

Puoi anche modificare i titoli dei riquadri sia per i riquadri di query sia per i riquadri collegati a un Look quando modifichi la query o il Look sottostante di un riquadro.
Modifica della query o del Look di un riquadro
In modalità di modifica, puoi modificare la query o il Look sottostante di un riquadro, inclusi il titolo del riquadro e la visualizzazione, direttamente nella dashboard.
Fai clic su Modifica (o Modifica query unita per un riquadro di query unita) nel menu con tre puntini Azioni riquadro del riquadro.
Se stai modificando un Look, la barra degli strumenti Modifica Look mostra le dashboard contenenti i riquadri collegati a quel Look. Queste dashboard saranno interessate dalle modifiche. Se stai modificando un riquadro di query, non vedrai un elenco delle dashboard interessate nel riquadro di modifica, perché le modifiche interessano solo il riquadro e la dashboard in cui ti trovi.

Aggiunta e modifica di filtri in un riquadro di visualizzazione
Quando la funzionalità in anteprima Filtri sui riquadri di visualizzazione è attiva, puoi aggiungere e configurare i filtri direttamente su un singolo riquadro di visualizzazione anziché solo nella barra dei filtri della dashboard.
In modalità di modifica, puoi eseguire le seguenti attività:
- Aggiungi un filtro a un riquadro: seleziona l'icona Aggiungi filtro vis nell'intestazione del riquadro, quindi seleziona Aggiungi filtro nella finestra di dialogo visualizzata per configurare il campo e le impostazioni del filtro. Per istruzioni passo passo, consulta Aggiunta di un filtro a un riquadro di visualizzazione.
- Riordina i filtri: fai clic e tieni premuta l'icona Tieni premuto e trascina per riordinare nella barra dei filtri del riquadro, quindi trascina il filtro in una nuova posizione nella barra dei filtri del riquadro.
- Modifica o elimina un filtro: seleziona l'icona del menu Filtro con tre puntini accanto a un filtro nella barra dei filtri del riquadro, quindi seleziona Modifica o Elimina.
Al termine della modifica della dashboard, seleziona Salva nella barra degli strumenti di modifica della dashboard per salvare le modifiche e uscire dalla modalità di modifica.
Per saperne di più sul comportamento, sulla precedenza e sulle limitazioni dei filtri a livello di riquadro, consulta la documentazione relativa ai filtri sui riquadri di visualizzazione.
Nascondere o mostrare il titolo di un riquadro
In modalità di modifica, puoi nascondere o mostrare il titolo di un riquadro. Per impostazione predefinita, vengono visualizzati i titoli dei riquadri. Puoi nascondere un titolo facendo clic su Nascondi titolo nel menu con tre puntini Azioni riquadro del riquadro.
Se il titolo è nascosto, Looker visualizza l'opzione Mostra titolo nel menu con tre puntini Azioni riquadro del riquadro.
L'opzione per nascondere o mostrare non viene visualizzata nel menu Azioni con tre puntini Azioni riquadro dei riquadri di testo o dei riquadri che utilizzano visualizzazioni KPI (valore singolo) o visualizzazioni valore singolo (legacy). Per nascondere o mostrare il titolo di una visualizzazione di un singolo valore, fai clic su Modifica nel menu con tre puntini Azioni del riquadro, attiva o disattiva l'opzione Mostra titolo nel menu Stile e salva. Per nascondere o mostrare il titolo di un riquadro di testo, fai clic su Modifica nel menu con tre puntini Azioni riquadro del riquadro, rimuovi o ripristina il titolo del riquadro e salva.
Aggiunta di una nota a un riquadro
In modalità di modifica, fai clic sul pulsante Aggiungi nota nel menu con tre puntini Azioni riquadro del riquadro.
Inserisci il testo della nota e configura le seguenti opzioni di visualizzazione:
- Nel campo Testo della nota, inserisci il testo della nota da visualizzare nel riquadro. Puoi scegliere fra testo normale e HTML.
- Nel campo Posizione di visualizzazione, seleziona la posizione della nota. Puoi scegliere di collocarla sopra o sotto la visualizzazione, oppure di mostrarla solo quando l'utente passa il puntatore sopra l'icona i nel cerchio, visualizzata a destra del titolo del riquadro. Per i riquadri che contengono visualizzazioni KPI (valore singolo) con un'altezza non superiore ai 150 pixel, le note del titolo vengono visualizzate come testo quando tieni il puntatore del mouse sul campo Posizione di visualizzazione.
- Seleziona la casella Comprimi nota per comprimere la nota per impostazione predefinita. Quando una nota è compressa, viene visualizzata solo la prima riga, che termina con i puntini di sospensione. Se deselezioni questa casella, per impostazione predefinita viene visualizzato tutto il testo della nota. Se selezioni On icon hover (Al passaggio del mouse sull'icona) sotto Display Location (Posizione visualizzazione), questa opzione non viene visualizzata.
- Fai clic su Aggiungi o Annulla per aggiungere la nota al riquadro o annullarla.
La nota viene visualizzata nel riquadro, con la freccia di compressione o espansione sulla sinistra. Se fai clic sulla freccia, o su un punto qualsiasi all'interno della nota, passi dalla visualizzazione compressa a quella espansa e viceversa.

Dopo l'aggiunta di una nota a un riquadro, il comando nel relativo menu con tre puntini Azioni riquadro cambia da Aggiungi nota a Modifica nota. Per modificare o eliminare la nota, fai clic su Edit note (Modifica nota).
Aggiunta o modifica di una descrizione per l'accessibilità
Puoi aggiungere una descrizione di testo alternativo a un riquadro di visualizzazione per gli screen reader. L'aggiunta di una descrizione di accessibilità rende i dati e i risultati rappresentati nel grafico accessibili agli utenti di screen reader senza alterare l'aspetto visivo della dashboard.
Per aggiungere o modificare una descrizione dell'accessibilità:
- In modalità di modifica, seleziona il menu con tre puntini Azioni del riquadro del riquadro e seleziona Aggiungi descrizione di accessibilità (o Modifica descrizione di accessibilità se esiste già una descrizione).
- Nel campo Testo della descrizione di accessibilità, inserisci il testo che gli screen reader devono annunciare quando gli utenti accedono al riquadro.
- Seleziona Aggiungi (o Salva).
Quando un utente che utilizza uno screen reader accede al riquadro, lo screen reader legge ad alta voce la descrizione dell'accessibilità dopo aver letto il titolo del riquadro.
Per eliminare una descrizione di accessibilità, seleziona Modifica descrizione di accessibilità dal menu con tre puntini Azioni riquadro del riquadro, seleziona Elimina e poi conferma l'eliminazione.
Duplicazione di un riquadro di query
In modalità di modifica, puoi duplicare i riquadri delle query facendo clic sull'opzione Duplica riquadro dal menu con tre puntini Azioni riquadro del riquadro.
Looker crea una copia del riquadro con le stesse impostazioni di query e visualizzazione e aggiunge il nuovo riquadro in fondo alla dashboard. Da qui, puoi spostare o ridimensionare il riquadro, modificare il titolo del riquadro o modificare il nuovo riquadro per regolare la visualizzazione o la query sottostante.
Non puoi duplicare un riquadro collegato a un Look e non vedrai l'opzione Duplica riquadro nel menu con tre puntini Azioni riquadro dei riquadri collegati a un Look.
Modifica del testo
Esistono due tipi di riquadri di testo, ognuno dei quali offre un'esperienza di modifica diversa, ma genera lo stesso tipo di riquadro:
- Testo: un riquadro di testo della dashboard che offre un'esperienza di modifica visiva.
- Markdown: un riquadro di testo della dashboard che può essere modificato utilizzando alcuni tag HTML e un sottoinsieme del linguaggio di markup Markdown per formattare il riquadro.
Per modificare un riquadro Testo, attiva la modalità di modifica e fai clic all'interno del riquadro per apportare le modifiche.
Per modificare un riquadro Markdown, accedi alla modalità di modifica e seleziona Modifica dal menu con tre puntini Azioni riquadro del riquadro.
Opzioni di spostamento dei riquadri
In modalità di modifica, puoi spostare un riquadro nella parte superiore, inferiore, sinistra o destra della dashboard. Fai clic sul menu con tre puntini Azioni dashboard, seleziona Sposta riquadro e poi una delle seguenti opzioni:
- Sposta in cima
- Sposta in fondo
- Sposta a sinistra
- Sposta a destra
Il riquadro rimarrà nella colonna o nella riga in cui si trova. Se il riquadro si trova già in alto, in basso a sinistra o sul lato destro della colonna, l'opzione per spostarlo in quella posizione è disattivata.
Eliminazione di un riquadro
In modalità di modifica, puoi eliminare un riquadro da una dashboard. Seleziona Elimina (per un riquadro di query) o Rimuovi Look (per un riquadro collegato a un Look) dal menu con tre puntini Azioni riquadro del riquadro. L'eliminazione non può essere annullata.
L'eliminazione di un riquadro collegato a un Look da una dashboard non influisce sul Look sottostante.
Organizzazione dei riquadri in gruppi
Se l'amministratore di Looker ha abilitato la funzionalità in anteprima Gruppi di riquadri della dashboard, puoi organizzare più riquadri in contenitori di gruppi comprimibili nelle dashboard che utilizzano il layout di griglia predefinito. Il raggruppamento dei riquadri ti consente di organizzare visivamente i contenuti correlati e di spostare, duplicare o eliminare più riquadri come un'unica unità.

Creazione di un gruppo di riquadri
Per creare un gruppo di riquadri in una dashboard:
- Attiva la modalità di modifica.
- Fai clic sul pulsante Aggiungi nella barra degli strumenti nella parte superiore della dashboard (o al centro del riquadro della dashboard se è vuota), quindi seleziona Gruppo. Looker aggiunge un nuovo contenitore di gruppi a larghezza intera al canvas della dashboard con un titolo predefinito (ad esempio I miei gruppi 1), una freccia di espansione o compressione e i controlli dell'intestazione del gruppo.
- Per rinominare il gruppo, fai clic sul titolo del gruppo nell'intestazione del gruppo e inserisci un nuovo titolo.
- Fai clic su Salva nella barra degli strumenti per salvare le modifiche.
Aggiunta di riquadri a un gruppo
In modalità di modifica, puoi aggiungere nuovi riquadri direttamente a un gruppo o spostare i riquadri esistenti non raggruppati dal canvas della dashboard a un gruppo:
- Aggiungi un nuovo riquadro a un gruppo: nell'intestazione del gruppo, fai clic sull'icona Aggiungi riquadro al gruppo e seleziona il tipo di riquadro che vuoi creare (Visualizzazione, Testo, Markdown, Pulsante o Estensione). Puoi anche salvare una scheda direttamente in un gruppo da Esplora. Per impostazione predefinita, i nuovi riquadri all'interno di un gruppo hanno una dimensione pari a un terzo della larghezza del gruppo e vengono posizionati da sinistra a destra man mano che vengono aggiunti.
- Aggiungi un riquadro esistente a un gruppo: nell'intestazione del gruppo, fai clic sull'icona Aggiungi riquadro esistente al gruppo, quindi fai clic sul riquadro non raggruppato nel canvas della dashboard che vuoi spostare nel gruppo.
Non puoi spostare un riquadro direttamente da un gruppo di riquadri a un altro. Per spostare un riquadro in un altro gruppo, prima separa il riquadro per riportarlo al canvas della dashboard principale, quindi fai clic su Aggiungi riquadro esistente al gruppo nell'intestazione del gruppo di destinazione.
Riorganizzare, ridimensionare e gestire i gruppi di riquadri
In modalità di modifica, puoi riorganizzare e ridimensionare sia i singoli riquadri all'interno di un gruppo sia il contenitore del gruppo stesso:
- Espandere e comprimere un gruppo: fai clic sulla freccia accanto al titolo del gruppo per comprimere o espandere il contenitore del gruppo. Se comprimi un gruppo, i riquadri al suo interno vengono nascosti e il container viene ridotto alla sua intestazione.
- Riorganizza e ridimensiona i riquadri all'interno di un gruppo: trascina e ridimensiona i singoli riquadri all'interno di un contenitore di gruppi, proprio come faresti nel canvas della dashboard principale. Se lo spostamento o il ridimensionamento di un riquadro all'interno di un gruppo spinge i riquadri in una nuova riga, il contenitore del gruppo si espande automaticamente in altezza.
- Spostare un contenitore di gruppi: trascina l'icona Tieni premuto e trascina per riordinare nell'intestazione del gruppo per riposizionare il gruppo nel canvas della dashboard. Puoi anche fare clic sul menu Azioni di gruppo nell'intestazione del gruppo, selezionare Sposta gruppo e poi In alto o In basso. Se la dashboard ha delle schede, puoi spostare l'intero gruppo e i relativi riquadri in un'altra scheda facendo clic sul menu Azioni gruppo, selezionando Sposta in scheda e scegliendo la scheda di destinazione.
- Ridimensiona un container di gruppo: per impostazione predefinita, i gruppi di riquadri occupano l'intera larghezza della dashboard. Trascina l'handle di ridimensionamento sul bordo del contenitore del gruppo per regolarne la larghezza e l'altezza. Non puoi ridimensionare un contenitore di gruppi in modo che sia più piccolo dell'area occupata dai riquadri che contiene.
- Duplica un gruppo: fai clic sul menu Azioni gruppo nell'intestazione del gruppo, quindi seleziona Duplica gruppo per creare una copia del contenitore del gruppo e di tutti i riquadri al suo interno.
Separazione dei riquadri ed eliminazione dei gruppi di riquadri
Puoi rimuovere singoli riquadri da un gruppo ed eliminare un intero gruppo e i relativi riquadri:
- Separa un riquadro: la separazione viene eseguita sui singoli riquadri anziché sul contenitore del gruppo. Per rimuovere un riquadro da un gruppo senza eliminarlo, fai clic sul menu Azioni riquadro sul singolo riquadro all'interno del gruppo e seleziona Separa riquadro. Looker rimuove il riquadro dal gruppo e lo posiziona nel canvas della dashboard principale. Il trascinamento di un riquadro fuori da un gruppo non è supportato.
- Elimina un gruppo di riquadri: per eliminare un contenitore di gruppo e tutti i riquadri al suo interno, fai clic sul menu Azioni di gruppo nell'intestazione del gruppo, seleziona Elimina e conferma l'eliminazione nella finestra di dialogo.
Modifica delle impostazioni della dashboard
In modalità di modifica, fai clic su Settings (Impostazioni) in alto a sinistra nella barra degli strumenti blu per modificare le impostazioni della dashboard.

Nella pagina delle impostazioni della dashboard, seleziona una delle seguenti schede:
Impostazioni della dashboard: Generali
Nella scheda Generali, puoi aggiornare le seguenti impostazioni della dashboard:
- Fuso orario
- Esegui al caricamento
- Consenti la modalità a schermo intero per le visualizzazioni
- Preserva il layout del desktop
- Aggiorna automaticamente la dashboard
Fuso orario
Questa opzione è disponibile solo se l'amministratore di Looker ha attivato l'impostazione Fuso orario specifico dell'utente.
Seleziona il fuso orario in cui verrà eseguita la dashboard. I visualizzatori della dashboard potranno modificare temporaneamente l'impostazione del fuso orario durante la visualizzazione della dashboard.
Puoi scegliere una delle seguenti opzioni:
- Fuso orario di ogni riquadro per eseguire tutti i riquadri nel fuso orario in cui sono stati salvati
- Fuso orario del visualizzatore per eseguire tutti i riquadri nel fuso orario di ogni visualizzatore
- Seleziona un fuso orario specifico dall'elenco nel menu a discesa per eseguire tutti i riquadri in quel fuso orario
Esegui al caricamento
Se l'opzione Run on load (Esegui al caricamento) è abilitata, i dati della dashboard vengono caricati automaticamente al primo caricamento della dashboard.
Se l'opzione Run on load (Esegui al caricamento) è disabilitata, la dashboard non mostra alcun dato finché non fai clic sull'icona Reload data (Ricarica dati).
Consenti la modalità a schermo intero per le visualizzazioni
Se l'amministratore di Looker ha attivato l'impostazione Visualizzazioni a schermo intero, nelle impostazioni della dashboard viene visualizzata l'opzione Consenti la modalità a schermo intero per le visualizzazioni. Questa opzione è attiva per impostazione predefinita.
Se disattivi questa opzione su una dashboard, gli utenti che la visualizzano non vedranno l'opzione Visualizza nel menu con tre puntini Azioni della dashboard di ogni riquadro della dashboard e non potranno visualizzare i riquadri della dashboard in formato espanso o a schermo intero.
Mantieni il layout desktop
Quando questa opzione è attiva, il layout desktop completo di una dashboard viene conservato quando gli utenti visualizzano la dashboard in un browser più piccolo o sullo schermo di un dispositivo mobile. Gli utenti possono navigare nella dashboard con un cursore di zoom che ingrandisce i riquadri.
Gli utenti possono passare dalla visualizzazione desktop a quella mobile e viceversa facendo clic sul pulsante Passa alla visualizzazione mobile per tornare a visualizzare i riquadri della dashboard in un'unica colonna e facendo clic sul pulsante Passa alla visualizzazione desktop per visualizzare la dashboard nel layout desktop.
Aggiornamento automatico
È consigliabile effettuare regolarmente l'aggiornamento automatico dei dati per avere la certezza di utilizzare quelli più recenti. Puoi impostare le frequenze di aggiornamento automatico per un'intera dashboard o per i singoli riquadri. L'aggiornamento automatico non carica mai i risultati dalla cache di Looker, ma li carica sempre dal database.
Per impostare l'aggiornamento automatico per una dashboard e tutti i suoi riquadri:
- Abilita l'opzione Aggiorna automaticamente la dashboard.
- Seleziona una frequenza di aggiornamento per aggiornare automaticamente la dashboard e tutti i suoi riquadri.
- Per modificare la frequenza per un singolo riquadro accedi alla sezione Tile (Riquadri), in cui sono elencati tutti i riquadri della dashboard. Fai clic sull'elenco a discesa per tale riquadro nella colonna Refresh frequency (Frequenza aggiornamento), seleziona Refresh every (Aggiorna ogni), quindi imposta la frequenza desiderata.
- Fai clic su Salva per salvare le modifiche.
Per impostare l'aggiornamento automatico per alcuni riquadri ma non per la dashboard, segui questi passaggi:
- Disabilita l'opzione Automatically refresh dashboard (Aggiorna automaticamente dashboard), se era stata abilitata in precedenza.
- Nella colonna Refresh frequency (Frequenza aggiornamento) della sezione Tile (Riquadri), fai clic sull'elenco a discesa di un riquadro per aggiornarlo automaticamente.
- Seleziona Aggiorna ogni.
- Imposta la frequenza desiderata.
- Mantieni l'impostazione Does not refresh (Non aggiornare) per tutti i riquadri che non vuoi aggiornare automaticamente.
- Fai clic su Salva per salvare le modifiche.
Le impostazioni di frequenza accettano solo numeri interi.
Gli intervalli di aggiornamento automatico iniziano all'ora del giorno in cui attivi la funzione e la dashboard viene aggiornata con la frequenza specificata, purché rimanga aperta in una scheda del browser e non sia in modalità di modifica. Se all'ora pianificata per l'aggiornamento la dashboard è chiusa o in modalità di modifica, non viene aggiornata. Se la dashboard viene chiusa o passa alla modalità di modifica, che questo avvenga o meno all'ora pianificata per l'aggiornamento, l'intervallo di aggiornamento viene reimpostato sull'ora in cui la dashboard viene riaperta o esce dalla modalità di modifica.
Ad esempio, se sono le 08:33 quando imposti un aggiornamento giornaliero, la dashboard verrà aggiornata il giorno successivo alle 08:33 e poi di nuovo ogni giorno successivo alle 08:33. Se, tuttavia, un giorno entri in modalità di modifica alle 09:02 ed esci dalla modalità di modifica alle 09:45, da quel momento in poi l'aggiornamento giornaliero avverrà alle 09:45, a partire dal giorno successivo.
Le opzioni Clear cache and refresh (Cancella cache e aggiorna) e Reload data (Ricarica dati) sono indipendenti dall'intervallo di aggiornamento automatico, che pertanto non viene reimpostato in seguito a un aggiornamento manuale della dashboard. Se ad esempio l'intervallo di aggiornamento automatico di una dashboard è di 1 ora e utilizzi l'opzione Clear cache and refresh (Cancella cache e aggiorna) 40 minuti dopo un aggiornamento automatico, la dashboard viene comunque aggiornata automaticamente 20 minuti dopo (1 ora dopo l'ultimo aggiornamento automatico).
Analogamente, l'aggiornamento automatico viene eseguito indipendentemente dal fatto che l'opzione Run on load (Esegui al caricamento) sia abilitata o disabilitata. Se l'opzione Run on Load (Esegui al caricamento) è disabilitata e apri una dashboard per cui è impostato l'aggiornamento automatico, l'intervallo di aggiornamento inizia al momento dell'apertura anche se non fai clic sull'icona Reload data (Ricarica dati) per eseguire il caricamento iniziale dei dati.
Aggiornamento automatico e prestazioni
Gli aggiornamenti frequenti delle dashboard, soprattutto se sono di grandi dimensioni, possono sovraccaricare notevolmente alcuni sistemi di database. È consigliabile discutere questo aspetto con l'amministratore di Looker. Come minimo, evita di impostare un intervallo di aggiornamento più breve dell'intervallo di aggiornamento del database, perché in tal caso non ci sarebbero nuovi dati da aggiornare e le query verrebbero attivate inutilmente.
Analogamente, quando più utenti accedono a una dashboard con aggiornamento automatico, le prestazioni potrebbero risentirne. Per visualizzare la dashboard su uno schermo condiviso mentre più utenti vi accedono contemporaneamente, puoi creare due dashboard identiche e configurare per l'aggiornamento automatico solo quella sullo schermo condiviso.
Per ulteriori informazioni e consigli sulla creazione di dashboard ad alte prestazioni, consulta la pagina delle best practice Considerazioni per la creazione di dashboard di Looker ad alte prestazioni.
Impostazioni della dashboard: Filtri
Nella scheda Filtri, puoi aggiornare le seguenti impostazioni della dashboard:
Visualizzazione filtri predefinita
Nella scheda Filtri della finestra Impostazioni, puoi impostare l'opzione Visualizzazione filtrata predefinita su una delle seguenti opzioni:
- Espansa: la barra dei filtri viene visualizzata al caricamento pagina e i filtri vengono mostrati per impostazione predefinita.
- Compresso: la barra dei filtri non viene visualizzata al caricamento della pagina e i filtri sono nascosti per impostazione predefinita.
Fai clic su Salva per salvare la modifica.
L'opzione Visualizzazione filtri predefinita è impostata su Espansa per impostazione predefinita. Se modifichi l'impostazione in Compresso, devi uscire dalla modalità di modifica e aggiornare la dashboard per visualizzare la modifica.
I visualizzatori della dashboard possono passare temporaneamente dalla barra dei filtri compressa a quella espansa e viceversa facendo clic sull'icona dei filtri. Tuttavia, solo l'impostazione Visualizzazione filtrata predefinita modifica in modo permanente lo stato predefinito della barra dei filtri.
Posizione filtri
Nella scheda Filtri della finestra Impostazioni, puoi impostare l'opzione Posizione dei filtri su una delle seguenti opzioni:
- In alto: la barra dei filtri viene visualizzata nella parte superiore della dashboard.
- A destra: la barra dei filtri viene visualizzata a destra della dashboard.
Fai clic su Salva per salvare la modifica.
L'opzione Posizione filtro è impostata su In alto per impostazione predefinita.
Visualizza i filtri applicati sui riquadri
Quando la funzionalità in anteprima Filtri sui riquadri di visualizzazione o Filtri come riquadri e contesto dei filtri a livello di riquadro è abilitata, la scheda Filtri della finestra Impostazioni include l'impostazione Informazioni sui filtri dei riquadri per configurare se e come i filtri vengono visualizzati sui riquadri di visualizzazione.
Puoi impostare l'opzione Informazioni sui filtri del riquadro su una delle seguenti opzioni:
- Mostra tutto: visualizza i filtri a livello di dashboard, i filtri a livello di query (configurati nell'esplorazione sottostante) e i filtri a livello di visualizzazione (se la funzionalità in anteprima Filtri sui riquadri di visualizzazione è abilitata).
- Nascondi i filtri delle query (impostazione predefinita): visualizza solo i filtri a livello di dashboard e i filtri a livello di visualizzazione (se la funzionalità in anteprima Filtri sui riquadri di visualizzazione è abilitata).
- Non mostrare: impedisce la visualizzazione dell'opzione e dell'icona Mostra filtri nei riquadri di visualizzazione.
Fai clic su Salva per salvare la modifica.
Per scoprire di più su come i visualizzatori interagiscono con i filtri applicati a un riquadro, consulta Visualizzazione dei filtri applicati a un riquadro di visualizzazione.
Impostazioni della dashboard: Download
Nella scheda Download, puoi aggiornare le seguenti impostazioni della dashboard:
Queste impostazioni diventano le opzioni predefinite quando gli utenti scaricano i dati dai riquadri della dashboard. Gli utenti con un ruolo che contiene le autorizzazioni per scaricare i dati possono modificare queste opzioni in base alle esigenze. Per ulteriori informazioni sul download delle dashboard, consulta la pagina della documentazione Download di contenuti.
Formato
Nella sezione Formato, seleziona il formato file per i dati dei riquadri scaricati.
Puoi scaricare i dati dai riquadri della dashboard nei seguenti formati file:
- TXT (valori delimitati da tabulazioni)
- Foglio di lavoro di Excel (Excel 2007 o versioni successive)
- CSV
- JSON
- HTML
- Markdown
- PNG (immagine di visualizzazione)
Risultati
Nella sezione Risultati, seleziona il modo in cui il download visualizza i risultati dei dati. Seleziona Con opzioni di visualizzazione applicate per impostare il download in modo che includa le opzioni di configurazione applicate nella visualizzazione del riquadro, ad esempio la formattazione condizionale o le etichette personalizzate. Seleziona Come mostrati nella tabella dei dati per impostare il download in modo che i dati vengano visualizzati come appaiono nella tabella dei dati del riquadro.
Valori
Nella sezione Valori, scegli come vuoi formattare i valori dei dati scaricati.
Limite
Nella sezione Limite, specifica il numero di righe e colonne da includere nel download dei dati. Puoi scegliere fra le seguenti opzioni:
- Tabella dei risultati attuali: scarica solo i risultati visualizzati nel riquadro della dashboard.
- Tutti i risultati: scarica l'intero set di risultati della query. L'opzione Tutti i risultati è visibile solo agli utenti che hanno un ruolo che contiene l'autorizzazione
download_without_limit. - Personalizzato: specifica il numero predefinito di righe e colonne da includere nel download dei dati.
Layout rapido
In modalità di modifica, fai clic su Layout rapido in alto a sinistra nella barra degli strumenti blu per impostare tutti i riquadri sulla stessa dimensione. Le cinque opzioni per le dimensioni dei riquadri sono le seguenti:
- XS: sei riquadri in una riga della dashboard.
- S: quattro riquadri si adattano a una riga della dashboard.
- M: tre riquadri in una riga della dashboard.
- L: due riquadri si adattano a una riga della dashboard.
- XL: un riquadro occupa una riga della dashboard.
Le dimensioni dei riquadri cambiano in base alle dimensioni della dashboard. Il layout rapido influisce su tutti i riquadri non raggruppati, inclusi i riquadri di testo, i riquadri di visualizzazione, i riquadri Markdown e i pulsanti, ma non ridimensiona i gruppi di riquadri o i riquadri all'interno di un gruppo.
Applicazione di un tema alla dashboard
Un tema è un insieme di elementi visivi predefiniti, come il colore di sfondo, il colore del testo e la famiglia di caratteri, che puoi applicare alla tua dashboard.
Se l'amministratore di Looker ha abilitato la funzionalità in anteprima Temi delle dashboard interne, vedrai l'opzione Stile nella barra degli strumenti blu quando sei in modalità di modifica.
Fai clic su Stile per aprire il riquadro Stile e seleziona un tema dal campo Tema. Il tema verrà applicato alla dashboard. Se selezioni Nessuno e la tua istanza ha un tema predefinito, verrà applicato il tema predefinito.
Se sei un amministratore di Looker o disponi dell'autorizzazione manage_internal_themes, vedrai il pulsante Gestisci temi, che apre la pagina Amministratore > Temi, dove puoi creare e modificare i temi della dashboard.
Modifica dei dettagli della dashboard
In modalità di modifica, seleziona Mostra dettagli dashboard dal menu con tre puntini Azioni dashboard. Il campo Descrizione diventa quindi modificabile.
Al termine della modifica della descrizione, fai clic su Salva per salvare la modifica.
Eliminazione delle dashboard
Se hai il livello di accesso Manage Access, Edit (Gestione accesso, modifica) per una dashboard, puoi eliminarla in uno dei due modi seguenti:
- Puoi eliminare una o più dashboard alla volta dalle cartelle, come descritto nella pagina della documentazione Organizzazione e gestione dell'accesso ai contenuti.
- Puoi eliminare una singola dashboard selezionando Sposta nel cestino dal menu con tre puntini Azioni dashboard della dashboard.
Una volta eliminata una dashboard, solo un amministratore di Looker può recuperarla dal cestino.
Scorciatoie da tastiera quando le dashboard sono in modalità di modifica
Per visualizzare le scorciatoie da tastiera che puoi utilizzare durante la modifica delle dashboard, visita la pagina della documentazione Scorciatoie da tastiera in Looker.