Mit der Funktion Self-Service-Explores können Sie eine Datenquelle angeben und die Daten dann in einem Looker-Explore abfragen und visualisieren, ohne ein LookML-Modell konfigurieren oder die Git-Versionsverwaltung einrichten zu müssen. Die folgenden Datenquellen werden unterstützt:
Für Looker-Verbindungen zu BigQuery:
- Kommagetrennte Dateien (CSV)
- Excel-Dateien (XLS und XLSX)
- Google Sheets-Dateien
- BigQuery-Tabellen
Für Looker-Verbindungen zu Snowflake:
- Kommagetrennte Dateien (CSV)
- Excel-Dateien (XLS und XLSX)
Weitere Informationen zu den Anforderungen und Verfahren finden Sie in den Abschnitten Vorbereitung und Daten hochladen, um ein Self-Service-Explore zu erstellen.
Nachdem Sie die Datei hochgeladen haben, analysiert Looker die Daten: Für jedes Feld in der Datendatei erkennt Looker automatisch den Datentyp und wendet das entsprechende Format an. Looker wendet außerdem einen Namen und ein Label für jedes Feld an. Looker erstellt ein LookML-Modell der Daten und schreibt sie in die BigQuery- oder Snowflake-Datenbank, die von Ihrem Looker-Administrator angegeben wurde oder die Sie während des Uploadvorgangs angeben (wenn Ihr Looker-Administrator die erweiterte Verbindungsverwaltung aktiviert hat). Wenn das Modell bereit ist, wird in Looker die Seite Self-Service-Explore bearbeiten angezeigt.
Nachdem Sie Ihre Daten hochgeladen haben, können Sie Folgendes tun:
- Öffnen Sie das Explore, um Looker-Abfragen basierend auf Ihren hochgeladenen Daten zu erstellen.
- Fügen Sie Ihrem Explore Dimensionen und Measures hinzu.
- Verwalten Sie den Zugriff auf Ihr Explore, damit andere Nutzer Ihr Explore abfragen können.
- Zertifizieren Sie das Explore, damit andere Nutzer wissen, dass die Daten zuverlässig sind.
- Entfernen Sie die Daten, wenn Sie sie nicht mehr benötigen.
Hinweis
Wenn Sie Self-Service-Explores verwenden möchten, benötigen Sie Folgendes:
- Eine Looker-Instanz, die die folgenden Anforderungen erfüllt:
- Sie verwenden die Looker-Mindestversion:
- Wenn Sie Daten über eine BigQuery-Verbindung hochladen möchten, muss auf Ihrer Instanz Looker 25.20 oder höher ausgeführt werden.
- Wenn Sie Daten über eine Snowflake-Verbindung hochladen möchten, muss auf Ihrer Instanz Looker 26.8 oder höher ausgeführt werden.
- Von einem Looker-Administrator konfiguriert, um Self-Service-Explores zu aktivieren.
- Sie verwenden die Looker-Mindestversion:
- Ein Looker-Nutzerkonto mit der Berechtigung
upload_data, mit der ein Nutzer Datendateien in Ihre Instanz hochladen kann.
Daten hochladen, um ein Self-Service-Explore zu erstellen
In den folgenden Abschnitten finden Sie Informationen zum Erstellen von Self-Service-Explores aus verschiedenen Datenquellen:
- Datendateien von Ihrem Computer hochladen (CSV-, XLS- und XLSX-Dateien)
- Daten aus Google Sheets hochladen
- Daten aus einer BigQuery-Tabelle verwenden
Datendateien von Ihrem Computer hochladen (CSV-, XLS- und XLSX-Dateien)
Sie können ein Self-Service-Explore aus einer Datei auf Ihrem Computer erstellen, sofern die Datei die folgenden Anforderungen erfüllt:
- Die Datei darf maximal 100 MB groß sein.
- Die Datei muss eine CSV-Datei (Datei mit kommagetrennten Werten) oder eine Excel-Datei (XLS oder XLSX) sein.
- Bei CSV-Dateien muss die erste Datenzeile die Spaltennamen für die Datei enthalten.
So erstellen Sie ein Self-Service-Explore aus einer Datendatei auf Ihrem Computer:
- Klicken Sie im Looker-Hauptnavigationsmenü auf den Button Erstellen.
- Wählen Sie im Drop-down-Menü Datenquelle aus. Dadurch wird das Dialogfeld Datenquelle erstellen geöffnet.
- Wählen Sie im Dialogfeld Datenquelle erstellen den Tab Lokal hochladen aus.
- Wenn Ihr Looker-Administrator die erweiterte Verbindungsverwaltung aktiviert hat, wählen Sie im Drop-down-Menü Verbindung die Verbindung aus, die Sie für den Datenupload verwenden möchten. Ihnen werden nur die Verbindungen angezeigt, für die Sie die Berechtigung zum Hochladen von Daten haben. Klicken Sie nach Auswahl der Verbindung auf Weiter.
- Klicken Sie auf den Button Daten auswählen, um Ihre Datendatei zu suchen und auszuwählen. Alternativ können Sie eine Datei in das Dialogfeld Datenquelle erstellen ziehen.
- Wenn Sie eine Excel-Datei mit mehreren Arbeitsblättern ausgewählt haben, geben Sie im Drop-down-Menü Tabellenblatt in ausgewählter Excel-Datei an, welches Arbeitsblatt hochgeladen werden soll.
- Klicken Sie auf Hochladen.
Wenn das Modell bereit ist, wird in Looker die Seite Self-Service-Explore bearbeiten angezeigt.
Daten aus Google Sheets werden hochgeladen
Looker unterstützt das Erstellen eines Self-Service-Explores über einen Tab in Google Sheets. Zusätzlich zu den Anforderungen für Self-Service-Explores ist Folgendes erforderlich:
- Eine Looker-Instanz, die Ihr Looker-Administrator für Daten-Uploads und den Datenimport aus Google Sheets aktiviert hat (Informationen finden Sie unter Administratoreinstellungen – Self-Service-Explores).
- Eine BigQuery-Verbindung, die von Ihrem Looker-Administrator auf der Admin-Seite Self-Service-Explores aktiviert wurde.
- Die erforderlichen APIs, die von Ihrem Looker-Administrator aktiviert wurden.
- Ein Google Sheets-Dokument, für das Sie die Berechtigung zum Freigeben haben und in dem die erste Datenzeile im Google Sheets-Tab die Spaltennamen für die Daten enthält.
Beachten Sie die folgenden Einschränkungen beim Hochladen von Daten aus Google Sheets:
- Looker (Google Cloud Core)-Instanzen, die Private Service Connect verwenden, unterstützen den OAuth-Ablauf für Google Sheets-Uploads nicht. Diese Instanzen müssen den manuellen URL-Ablauf verwenden, um Daten aus Google Sheets hochzuladen.
- Instanzen von Looker (Google Cloud Core), die VPC Service Controls verwenden, unterstützen keine Google Sheets-Uploads.
- Wenn Ihre Daten in allen Spalten nur Stringwerte enthalten, werden die Kopfzeilen möglicherweise als Teil Ihrer Daten betrachtet und generische Namen für jede Spalte erstellt, z. B.
string_field_0undstring_field_1. In diesem Fall können Sie das Self-Service-Explore bearbeiten und die Datenfelder umbenennen.
In den folgenden Abschnitten werden die beiden Möglichkeiten zum Hochladen eines Google Sheets-Dokuments zum Erstellen eines Self-Service-Explores beschrieben:
- Google Sheets-Dokument über die Google Drive-Navigation auswählen: Wenn Ihr Looker-Administrator die Option Daten-Uploads und die Option Google Sheets-Datenimport aktiviert und OAuth für Ihre Instanz konfiguriert hat (wie im Abschnitt OAuth für Google Sheets-Uploads aktivieren beschrieben), können Sie über die Google Drive-Navigation einen Tab in Ihrem Google Sheets-Dokument auswählen, um ihn hochzuladen.
- URL für Ihr Google Sheets-Dokument manuell angeben: Wenn Ihr Looker-Administrator die Schalter Daten-Uploads und Google Sheets-Datenimport aktiviert, aber OAuth für Ihre Instanz nicht konfiguriert hat, können Sie die URL für Ihr Google Sheets-Dokument eingeben und das Google Sheets-Dokument dann manuell für das Looker-Dienstkonto freigeben, damit Looker die Daten hochladen kann.
Google Sheets-Daten über die Google Drive-Navigation angeben
So erstellen Sie ein Self-Service-Explore aus einer Google Sheets-Datei über die Google Drive-Navigation:
- Klicken Sie im Looker-Hauptnavigationsmenü auf den Button Erstellen.
- Wählen Sie im Drop-down-Menü Erstellen die Option Datenquelle aus. Dadurch wird das Dialogfeld Datenquelle erstellen geöffnet.
- Klicken Sie im Dialogfeld Datenquelle erstellen auf den Tab Aus Cloud importieren.
- Wenn Ihr Looker-Administrator die erweiterte Verbindungsverwaltung aktiviert hat, wählen Sie im Drop-down-Menü Verbindung die Verbindung aus, die Sie für den Datenupload verwenden möchten. Sie sehen nur BigQuery-Verbindungen, für die Sie die Berechtigung zum Hochladen von Daten haben. Klicken Sie nach Auswahl der Verbindung auf Weiter.
- Klicken Sie auf den Button In Google Drive suchen.
- Wählen Sie im Dialogfeld Über Google anmelden das Google-Konto aus, mit dem Sie zu Ihrem Google Sheets-Dokument gelangen möchten.
- Klicken Sie im Dialogfeld looker.com möchte auf Ihr Google-Konto zugreifen auf Weiter, um Looker den Zugriff auf Ihre Google Drive-Dateien zu erlauben.
Rufen Sie im Dialogfeld Datei auswählen das Google Sheets-Dokument auf, das Sie hochladen möchten, wählen Sie die Datei aus und klicken Sie dann auf Auswählen.
Wenn Ihr Google-Tabellen-Dokument mehrere Tabs enthält, wird im Dialogfeld Datenquelle erstellen das Drop-down-Menü Tabellenblatt angezeigt. Wählen Sie das Tabellenblatt aus, das Sie hochladen möchten, und klicken Sie dann auf Weiter.
Wenn das Modell bereit ist, wird in Looker die Seite Self-Service-Explore bearbeiten angezeigt.
Google Sheets-Daten über die Dokument-URL angeben
So erstellen Sie ein Self-Service-Explore aus einer Google Sheets-Datei mithilfe der Google Sheets-URL:
- Rufen Sie in einem Webbrowser das Google Sheets-Dokument auf, das Sie in Looker hochladen möchten.
- Wählen Sie im Google Sheets-Dokument den Tab für die Tabelle aus, die Sie hochladen möchten.
Prüfen Sie, ob die URL im Webbrowser die folgenden Elemente enthält:
- Die Tabellen-ID: Sie befindet sich in der URL zwischen
/d/und dem Suffix/editoder/view. - Die Tabellenblatt-ID: Dies ist der Parameter
gid, der die ID des Tabellenblatts angibt.
- Die Tabellen-ID: Sie befindet sich in der URL zwischen
Kopieren Sie die URL des Tabs in Google Sheets, den Sie hochladen möchten, und lassen Sie diesen Browsertab geöffnet.
Öffnen Sie Looker in einem anderen Browsertab und klicken Sie im Looker-Hauptnavigationsmenü auf den Button Erstellen.
Wählen Sie im Drop-down-Menü Erstellen die Option Datenquelle aus. Dadurch wird das Dialogfeld Datenquelle erstellen geöffnet.
Klicken Sie im Dialogfeld Datenquelle erstellen auf den Tab Aus Cloud importieren.
Wenn Ihr Looker-Administrator die erweiterte Verbindungsverwaltung aktiviert hat, wählen Sie im Drop-down-Menü Verbindung die Verbindung aus, die Sie für den Datenupload verwenden möchten. Sie sehen nur BigQuery-Verbindungen, für die Sie die Berechtigung zum Hochladen von Daten haben. Klicken Sie nach Auswahl der Verbindung auf Weiter.
Fügen Sie im Feld Google Sheets-URL die URL für den Tab in Google Sheets ein, den Sie hochladen möchten.
Klicken Sie im Dialogfeld Datenquelle erstellen im Abschnitt Google Sheets die Berechtigung für Looker erteilen auf Kopieren, um die E-Mail-Adresse des Looker-Dienstkontos in die Zwischenablage zu kopieren. Lassen Sie das Dialogfeld Datenquelle erstellen geöffnet.
Kehren Sie zum Browsertab mit Ihrer Google-Tabelle zurück. Klicken Sie in Google Sheets auf Teilen.
Führen Sie im Dialogfeld Freigeben die folgenden Schritte aus:
- Fügen Sie die E-Mail-Adresse des Looker-Dienstkontos in das Feld Personen, Gruppen, Chatbereiche und Kalendertermine hinzufügen ein.
- Wählen Sie im Drop-down-Menü neben dem Eingabefeld die Option Betrachter aus.
- Entfernen Sie das Häkchen aus dem Kästchen Personen benachrichtigen.
- Klicken Sie auf Freigeben.
Kehren Sie zum Dialogfeld Datenquelle erstellen zurück.
Klicken Sie auf Weiter.
Wenn das Modell bereit ist, wird in Looker die Seite Self-Service-Explore bearbeiten angezeigt.
Daten aus einer BigQuery-Tabelle verwenden
Looker unterstützt das Erstellen eines Self-Service-Explores aus einer Tabelle in einer BigQuery-Datenbank. Zusätzlich zu den Anforderungen für Self-Service-Explores ist Folgendes erforderlich:
- Eine Looker-Instanz mit Looker 26.10 oder höher.
- Eine BigQuery-Verbindung, die von Ihrem Looker-Administrator auf der Seite „Verwaltung“ Self-Service-Explores aktiviert wurde (Informationen finden Sie auf der Dokumentationsseite Admin-Einstellungen – Self-Service-Explores).
- Die BigQuery-Verbindung muss für die Authentifizierung mit OAuth konfiguriert sein.
- Ein Google-Konto mit den IAM-Rollen
bigquery.jobUserundbigquery.dataViewerfür die BigQuery-Tabelle, die Sie in Looker hochladen möchten.
So erstellen Sie ein Self-Service-Explore aus einer Tabelle in Ihrer BigQuery-Datenbank:
- Klicken Sie im Looker-Hauptnavigationsmenü auf den Button Erstellen.
- Wählen Sie im Drop-down-Menü Datenquelle aus. Dadurch wird das Dialogfeld Datenquelle erstellen geöffnet.
- Wählen Sie im Dialogfeld Datenquelle erstellen den Tab Mit Datenbank verbinden aus.
- Wählen Sie auf dem Tab Mit Datenbank verbinden im Drop-down-Menü BigQuery-Verbindung eine der BigQuery-Verbindungen aus, auf die Sie in der Looker-Instanz Zugriff haben.
- Wenn im Dialogfeld das Banner OAuth-Anmeldung erforderlich angezeigt wird, klicken Sie auf den Button Anmelden, um das Google-Konto auszuwählen, das Sie für die OAuth-Anmeldung verwenden möchten. Klicken Sie dann auf Zulassen, wenn Sie dazu aufgefordert werden.
- Wählen Sie auf dem Tab Mit Datenbank verbinden über die Drop-down-Menüs das BigQuery-Projekt und das Dataset aus, die die Tabelle enthalten, die Sie hochladen möchten. Wählen Sie dann die Tabelle aus, die Sie in Looker hochladen möchten.
- Klicken Sie auf Weiter, um die Tabelle hochzuladen.
Wenn das Modell bereit ist, wird in Looker die Seite Self-Service-Explore bearbeiten angezeigt.
Self-Service-Explore öffnen
Sie können jedes Self-Service-Explore öffnen, das Ihnen gehört oder das der Eigentümer für Sie freigegeben hat:
- Wenn Sie der Inhaber des Self-Service-Explores sind und sich auf der Seite Self-Service-Explore bearbeiten befinden, können Sie auf den Button Daten explorieren klicken, um das Explore zu öffnen.
- Andernfalls können Sie das Explore im Looker-Menü Explore im Abschnitt Self-Service-Explores auswählen.
Wenn Sie Looker-Administrator sind, können Sie außerdem jedes Self-Service-Explore in der Instanz öffnen, indem Sie die Links in der Tabelle Daten-Uploads auf der Admin-Seite Self-Service-Explores verwenden. Für Looker-Administratoren werden im Looker-Menü Explore im Abschnitt Self-Service-Explores nicht alle Self-Service-Explores der Instanz aufgeführt, sondern nur die, deren Inhaber Sie sind oder die der Inhaber ausdrücklich für Sie freigegeben hat.
Sie können ein Self-Service-Explore ähnlich wie jedes andere Looker-Explore verwenden, einschließlich der folgenden Aufgaben:
- Fragen Sie Ihre Daten im Explore-Bereich ab.
- Filtern und begrenzen Sie Ihre Ergebnisse auf die für Sie relevanten Daten.
- Ergebnisse aus verschiedenen Explores zusammenführen
- Tabellenkalkulationen verwenden, um Ad-hoc-Kennzahlen für ein Explore zu erstellen
- Benutzerdefinierte Felder verwenden, um Ad-hoc-Dimensionen und -Messwerte zu erstellen
- Visualisierungen erstellen
- Explore-Abfragen als Looks speichern
- Explore-Abfragen zu Dashboards hinzufügen
- Daten mit anderen Nutzern teilen
Außerdem können Sie Looker auffordern, die Daten zu aktualisieren, wenn sich die Informationen in Ihrer Datendatei seit dem ersten Upload geändert haben.
Self-Service-Explore bearbeiten
Nachdem Sie eine Datendatei hochgeladen haben, können Sie die Datenfelder des Explores bearbeiten und den Nutzerzugriff auf der Seite Self-Service-Explore bearbeiten verwalten.
Es gibt zwei Möglichkeiten, die Seite Self-Service-Explore bearbeiten aufzurufen:
- Wenn Sie zum ersten Mal eine Datendatei hochladen, wird in Looker automatisch die Seite Self-Service-Explore bearbeiten für Ihren Datenupload angezeigt.
Andernfalls wählen Sie im Looker-Menü Explore das Explore im Abschnitt Self-Service-Explores aus. Klicken Sie auf der Seite „Explore“ unten im Bereich Konfigurieren auf den Link Datenfelder bearbeiten, um die Seite Self-Service-Explore bearbeiten aufzurufen:
Wenn Sie die klassische Explore-Ansicht verwenden, wählen Sie im Zahnradmenü Explore-Aktionen die Option Datenfelder bearbeiten aus.
Auf der Seite Self-Service-Explore bearbeiten können Sie Folgendes tun:
- Explore umbenennen
- Datenfelder ändern
- Dimensionen und Measures hinzufügen
- Zugriff auf Self-Service-Explore verwalten
- Self-Service-Explore öffnen
- Datenupload aus Ihrer Instanz entfernen
Explore umbenennen
So benennen Sie ein Self-Service-Explore um:
Klicken Sie auf der Seite „Explore“ unten im Bereich Konfigurieren auf den Link Datenfelder bearbeiten.
Wenn Sie die klassische Explore-Ansicht verwenden, wählen Sie im Zahnradmenü Explore-Aktionen die Option Datenfelder bearbeiten aus.
Klicken Sie auf der Seite Self-Service-Explore bearbeiten auf den Namen des Datenuploads und geben Sie einen neuen Namen ein.
Drücken Sie die Eingabetaste, um den Namen zu speichern.
Der neue Name des Self-Service-Explores wird jetzt als Titel im Explore-Fenster verwendet, wenn Sie das Explore öffnen, und im Abschnitt Self-Service-Explores des Looker-Menüs Explore angezeigt. Möglicherweise müssen Sie Ihren Browser aktualisieren, um den aktualisierten Namen im Menü Explore zu sehen.
Datenfelder ändern
Auf der Seite Self-Service-Explore bearbeiten werden auf dem Tab Datenfelder die Felder aufgeführt, die Looker aus Ihrer Datendatei generiert hat.
Sie können ein generiertes Feld nicht löschen, sondern nur ausblenden. Wählen Sie dazu entweder im Zahnradmenü des Felds in der Tabelle Datenfelder die Option Ausblenden aus oder klicken Sie auf das Symbol Bearbeiten des Felds und setzen Sie ein Häkchen bei Dieses Feld in Explores und Visualisierungen ausblenden.
In den folgenden Abschnitten wird beschrieben, wie Sie Dimensionen und Measures bearbeiten:
Dimension bearbeiten
So bearbeiten Sie eine vorhandene Dimension:
- Klicken Sie auf der Seite Self-Service-Explore bearbeiten auf dem Tab Datenfelder in der Zeile der Dimension in der Tabelle Datenfelder auf das Symbol Bearbeiten, um das Dialogfeld Dimension bearbeiten zu öffnen.
- Aktualisieren Sie im Dialogfeld Dimension bearbeiten die folgenden Felder (das Feld Datentyp ist schreibgeschützt):
- Format: Wählen Sie im Drop-down-Menü eine Formatierungsoption aus.
- Name: Bearbeiten Sie den Namen, der zur Identifizierung der Dimension in LookML und Ausdrücken verwendet wird.
- Label: Bearbeiten Sie das Label, das in Explores und Visualisierungen angezeigt wird.
- + Beschreibung hinzufügen: Klicken Sie auf diese Option, um eine optionale Beschreibung für die Dimension einzugeben oder zu bearbeiten.
- Dieses Feld bei Analysen und Visualisierungen ausblenden: Aktivieren oder deaktivieren Sie dieses Kästchen, um die Dimension aus- oder einzublenden.
- Klicken Sie auf Speichern.
Messwert bearbeiten
So bearbeiten Sie eine vorhandene Messung:
- Klicken Sie auf der Seite Self-Service-Explore bearbeiten auf dem Tab Datenfelder in der Zeile des Messwerts in der Tabelle Datenfelder auf das Symbol Bearbeiten, um das Dialogfeld Messwert bearbeiten zu öffnen.
Aktualisieren Sie im Dialogfeld Messwert bearbeiten die folgenden Felder:
- Zu messendes Feld: Wählen Sie im Drop-down-Menü das Feld aus, das Sie aggregieren möchten.
- Messwerttyp: Wählen Sie im Drop-down-Menü den Aggregationstyp aus, z. B. Summe, Anzahl, Durchschnitt, Min oder Max.
- Label: Bearbeiten Sie das Label, das in Explores und Visualisierungen angezeigt wird.
- Tab „Filter“: Wählen Sie unter Ergebnisse eingrenzen im Drop-down-Menü Filtername ein Feld aus und geben Sie einen Filterwert an. Mit den Buttons + und - können Sie Filterbedingungen hinzufügen oder entfernen.
- Tab „Felddetails“: Wählen Sie im Drop-down-Menü Format eine Formatierungsoption aus und geben Sie optional eine Beschreibung (bis zu 255 Zeichen) ein.
- Dieses Feld bei Analysen und Visualisierungen ausblenden: Aktivieren oder deaktivieren Sie dieses Kästchen, um die Measure aus- oder einzublenden.
Klicken Sie auf Speichern.
Dimensionen und Measures hinzufügen
Sie können eigene Dimensionen und Messwerte für Ihr Self-Service-Explore erstellen. Sie werden anhand vorhandener Felder im Explore oder aus Looker-Ausdrücken definiert und bleiben für alle Nutzer Ihres Self-Service-Explores verfügbar.
In den folgenden Abschnitten wird beschrieben, wie Sie benutzerdefinierte Dimensionen und Messwerte erstellen:
Benutzerdefinierte Dimension erstellen
So erstellen Sie eine benutzerdefinierte Dimension mit einem Looker-Ausdruck:
- Klicken Sie auf der Seite Self-Service-Explore bearbeiten auf dem Tab Datenfelder auf die Schaltfläche Dimension hinzufügen, um das Dialogfeld Dimension erstellen zu öffnen.
- Geben Sie im Bearbeitungsfeld des Ausdruckseditors einen Looker-Ausdruck ein, der die Dimension definiert, oder klicken Sie auf Formuliere für mich einen Ausdruck mit Gemini, um einen Ausdruck zu generieren.
- Wählen Sie im Drop-down-Menü Format eine Formatierungsoption aus.
- Geben Sie Werte für Name und Label für die Dimension ein.
- Optional können Sie auf + Beschreibung hinzufügen klicken, um eine Beschreibung für die Dimension einzugeben oder zu bearbeiten.
- Optional können Sie das Kästchen Dieses Feld bei Analysen und Visualisierungen ausblenden anklicken, um die Dimension auszublenden.
- Klicken Sie auf Speichern.
Benutzerdefinierten Messwert erstellen
So erstellen Sie einen benutzerdefinierten Messwert:
- Klicken Sie auf der Seite Self-Service-Explore bearbeiten auf dem Tab Datenfelder auf den Button Messwert hinzufügen, um das Dialogfeld Messwert erstellen zu öffnen.
- Wählen Sie im Drop-down-Menü Zu messendes Feld das Feld aus, das Sie aggregieren möchten.
- Wählen Sie im Drop-down-Menü Messtyp den Typ der Aggregation aus, die Sie für das Feld Zu messendes Feld ausführen möchten.
- Geben Sie ein Label für die Messung ein.
- Konfigurieren Sie optionale Filterbedingungen oder Formatierungsdetails:
- Tab „Filter“: Wählen Sie unter Ergebnisse eingrenzen im Drop-down-Menü Filtername ein Feld aus und geben Sie einen Filterwert an. Mit den Buttons + und - können Sie Filterbedingungen hinzufügen oder entfernen.
- Tab „Felddetails“: Wählen Sie im Drop-down-Menü Format eine Formatierungsoption aus und geben Sie optional eine Beschreibung (bis zu 255 Zeichen) ein.
- Optional können Sie das Kästchen Dieses Feld bei Analysen und Visualisierungen ausblenden anklicken, um die Measure auszublenden.
- Klicken Sie auf Speichern.
Auf der Seite Self-Service-Explore bearbeiten werden die von Ihnen erstellten Felder unter den generierten Feldern in der Tabelle Datenfelder angezeigt.
Daten für ein Self-Service-Explore aktualisieren
Wenn Sie ein Self-Service-Explore erstellen, lädt Looker die Daten aus Ihrer Datei zum Zeitpunkt des Uploads hoch. Wenn sich die Daten in Ihrer Datei nach dem Erstellen des Self-Service-Explores ändern, können Sie die Daten mit den Schritten in diesem Abschnitt aktualisieren.
Beachten Sie Folgendes, wenn Sie die Daten für ein Self-Service-Explore aktualisieren:
- Sie können nur Daten für Self-Service-Explores aktualisieren, die Sie selbst erstellt haben.
- Wenn sich Felder seit der Erstellung des Self-Service-Explores geändert haben, löst Looker alle abwärtskompatiblen Änderungen automatisch auf.
- Wenn ein Feld aus der ursprünglich hochgeladenen Datei erheblich geändert wird, z. B. wenn die Spalte umbenannt oder der Datentyp geändert wird, zeigt Looker das Dialogfeld Änderungen überprüfen an, in dem die Unterschiede aufgeführt sind. Im Dialogfeld Änderungen prüfen wird der alte Name oder Datentyp als „Entfernt“ und der neue Name oder Datentyp als „Hinzugefügt“ aufgeführt. Im Dialogfeld können Sie die Änderungen übernehmen oder den Datenupload abbrechen. Wenn Sie die Änderungen bestätigen, werden die entfernten Felder dauerhaft aus Ihrem Self-Service-Explore gelöscht.
So aktualisieren Sie die Daten für ein Self-Service-Explore:
- Klicken Sie auf der Seite Self-Service-Explore bearbeiten auf den Button Daten aktualisieren.
Führen Sie im Dialogfeld Daten aktualisieren je nachdem, wie Sie das Self-Service-Explore ursprünglich erstellt haben, einen der folgenden Schritte aus:
- Wenn Sie das Self-Service-Explore ursprünglich durch Hochladen einer Datei von Ihrem Computer erstellt haben, klicken Sie auf Daten auswählen, um die Datei auf Ihrem Computer zu suchen.
- Wenn Sie das Self-Service-Explore ursprünglich durch Angabe eines Google Sheets-Dokuments erstellt haben, lädt Looker Daten aus demselben Tabellenblatt desselben Google Sheets-Dokuments hoch.
Klicken Sie auf Weiter. Wenn Sie das Self-Service-Explore ursprünglich aus einem Google Sheets-Dokument erstellt haben und Ihr Looker-Administrator OAuth für Google Sheets-Uploads konfiguriert hat, werden Sie von Looker aufgefordert, sich mit Ihrem Google-Konto anzumelden und den Zugriff auf Ihr Google Sheets-Dokument zu autorisieren.
Wenn Looker feststellt, dass sich Felder aus dem ursprünglichen Dateiupload in der neuen Datei erheblich geändert haben, wird das Dialogfeld Änderungen prüfen angezeigt:
- Wenn Sie die Daten aus dem ursprünglichen Dateiupload beibehalten möchten, klicken Sie auf Abbrechen, um die Datenaktualisierung abzubrechen.
- Klicken Sie andernfalls auf Bestätigen, um die Aktualisierungen zu akzeptieren. Looker löscht die entfernten und umbenannten Felder endgültig aus Ihrem Self-Service-Explore.
Wenn Ihre aktualisierte Datei keine wesentlichen Änderungen enthält oder Sie die Änderungen bestätigt haben, lädt Looker die Daten aus der angegebenen Datei in Ihr Self-Service-Explore hoch. Wenn das Modell bereit ist, wird in Looker die Seite Self-Service-Explore bearbeiten angezeigt.
Zugriff auf das Self-Service-Explore verwalten
So können Sie Ihr Self-Service-Explore für andere Looker-Nutzer und ‑Nutzergruppen freigeben:
- Klicken Sie auf der Seite Self-Service-Explore bearbeiten auf den Tab Nutzerzugriff und dann auf den Button Zugriff freigeben. (Sie können auch oben auf der Seite Self-Service-Explore bearbeiten auf das Dreipunkt-Menü klicken und Zugriff freigeben auswählen.)
- Klicken Sie im Dialogfeld Zugriff freigeben auf das Feld Nutzer oder Gruppe und wählen Sie entweder einen Eintrag aus dem Drop-down-Menü aus oder geben Sie einen Nutzernamen oder einen Gruppennamen ein, um das Menü zu filtern.
- Behalten Sie im Feld Zugriffsberechtigung den Wert Ansehen bei.
- Optional: Klicken Sie auf Hinzufügen, um einem anderen Nutzer oder einer anderen Gruppe Zugriff zu gewähren.
- Klicken Sie auf Freigeben.
Auf der Seite Self-Service-Explore bearbeiten wird auf dem Tab Nutzerzugriff der neue Nutzer oder die neue Gruppe angezeigt, dem bzw. der Sie Zugriff gewährt haben.
Wenn Sie den Zugriff eines Nutzers oder einer Gruppe auf Ihr Self-Service-Explore entfernen möchten, klicken Sie in der Tabelle Nutzerzugriff in der Zeile des Nutzers oder der Gruppe auf die Schaltfläche Nutzer löschen.
Self-Service-Explore zertifizieren
Self-Service-Explores basieren nicht auf einem LookML-Modell. Daher gelten ihre Daten als „nicht verwaltet“. Wenn Sie Daten hochladen, wird der Name des Self-Service-Explores mit einem gelben
-Badge „Nicht zertifiziert“ im Menü Explore und auf der Explore-Seite angezeigt. Dieses Badge gibt an, dass die Daten weder zertifiziert noch verwaltet sind.
Wenn Sie die Berechtigung certify_content haben, können Sie dem Explore eine Zertifizierung hinzufügen, damit andere Nutzer wissen, dass die Daten zuverlässig sind.
So fügen Sie dem Self-Service-Explore eine Zertifizierung hinzu:
- Wählen Sie im Looker-Menü Explore das gewünschte Explore im Bereich Self-Service-Explores aus.
- Klicken Sie auf das Zahnradmenü des Explores und wählen Sie Zertifizieren aus.
- Geben Sie im Dialogfeld Diesen Inhalt zertifizieren? Ihre Notizen zum Explore ein, z. B. die Herkunft der Daten und wie Sie wissen, dass es sich um gültige Daten handelt.
- Klicken Sie auf Zertifizieren.
Wenn Sie ein Self-Service-Explore zertifizieren, zeigt Looker im Menü Explore und auf der Explore-Seite neben dem Namen des Explores ein Zertifizierungslogo
an.
Weitere Informationen finden Sie auf der Dokumentationsseite Inhaltszertifizierung.
Self-Service-Explore entfernen
Sie können Ihren eigenen Datenupload und das zugehörige Self-Service-Explore mit den folgenden Schritten löschen:
Wählen Sie im Looker-Hauptmenü Explore das Explore im Bereich Self-Service-Explores aus.
Klicken Sie im Explore unten im Bereich Konfigurieren auf den Link Datenfelder bearbeiten:
Wenn Sie die klassische Explore-Ansicht verwenden, wählen Sie im Zahnradmenü Explore-Aktionen die Option Datenfelder bearbeiten aus.
Klicken Sie auf der Seite Self-Service-Explore bearbeiten auf das Dreipunkt-Menü.
Wählen Sie Daten entfernen aus.
Klicken Sie im Bestätigungsdialogfeld auf Kopieren.
Außerdem kann ein Looker-Administrator den Datenupload eines beliebigen Nutzers auf der Admin-Seite Self-Service-Explores löschen. Dazu sind die folgenden Schritte auszuführen:
- Wählen Sie im Looker-Menü Admin die Option Self-Service-Explores aus.
- Suchen Sie in der Tabelle Datenuploads auf der Seite Self-Service-Explores nach dem Datenupload und klicken Sie in der entsprechenden Zeile auf Löschen.
- Klicken Sie im Bestätigungsdialogfeld auf Kopieren.
Wichtige Punkte
Wenn für Ihre Looker-Instanz die erweiterte Verbindungsverwaltung aktiviert ist, beachten Sie die folgenden Einschränkungen:
- Wenn Sie ein Self-Service-Explore erstellen, können Sie aus einer Drop-down-Liste mit zulässigen Verbindungen auswählen. Looker filtert diese Liste, sodass Sie nur die Verbindungen sehen, die von den Modellen verwendet werden, für die Sie die Berechtigung
upload_datahaben. Sie können keine Daten in eine andere Verbindung hochladen. - Der fortlaufende Zugriff auf ein Self-Service-Explore hängt davon ab, ob Sie weiterhin Zugriff auf die zugrunde liegende Datenbankverbindung haben. Wenn Ihr Zugriff auf die Verbindung widerrufen wird, können Sie keine Self-Service-Explores mehr abfragen, bearbeiten oder freigeben, die diese Verbindung verwenden.
- Sie können ein Self-Service-Explore nur für Nutzer oder Gruppen freigeben, die die Berechtigung
access_datafür ein Modell haben, das die zugrunde liegende Datenbankverbindung für dieses Explore verwendet.