收集 AIDE(高级入侵检测环境)日志

解析器版本: 1.0

支持范围:

本文档介绍了如何使用 Bindplane 将 AIDE(高级入侵检测环境)日志注入到 Google Security Operations 中。AIDE 是一种文件完整性监控工具,可检测 Linux/Unix 系统上文件的更改。

准备工作

请确保满足以下前提条件:

  • Google SecOps 实例
  • 运行 AIDE 0.18 或更高版本(支持 JSON 格式)的 Linux 主机(使用 systemd)
  • 如果通过代理运行,请确保防火墙端口符合 Bindplane 代理要求
  • 对 AIDE 配置文件的特权访问权限

获取 Bindplane 代理的 Google SecOps 凭据

如需向 Google SecOps 验证 Bindplane 代理的身份,请选择以下方法之一:

  • 新部署:使用 Chronicle API(方法 1)。
  • 旧版部署:继续使用注入身份验证文件(方法 2),直到注入 API 于 2027 年 7 月 20 日停用为止。
  1. 登录 Google Cloud 控制台,然后选择与您的 Google SecOps 实例关联的 Google Cloud 项目。
  2. 依次前往 IAM 和管理 > 服务账号。
  3. 点击创建服务账号 。
  4. 提供以下配置详细信息:
    • 服务账号名称:输入账号的名称(例如 bindplane-ingest)。
    • 服务账号说明:输入说明(例如 Bindplane agent log ingestion)。
  5. 点击创建并继续 。
  6. 在向此服务帐号授予对项目的访问权限 部分,点击选择角色 ,然后选择 Chronicle Editor 。
  7. 点击继续 ,然后点击完成 。
  8. 点击您创建的服务帐号,然后前往密钥 标签页。
  9. 依次点击添加密钥 > 创建新密钥。
  10. 选择 JSON ,然后点击创建 。密钥文件会下载到您的计算机上。
  11. 将密钥文件另存为 Bindplane 收集器目录中的 ingestion-auth.json(在 Linux 上为 /opt/observiq-otel-collector/ingestion-auth.json,在 Windows 上为 C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json),或者更新 creds_file_path 在 config.yaml 中以与您保存该文件的路径匹配。
  12. 依次前往 IAM 和管理 > 设置 ,然后复制项目编号 。您需要此编号进行导出器配置。

方法 2:下载注入身份验证文件(旧版)

  1. 登录 Google SecOps 控制台。
  2. 依次前往 SIEM 设置 > 收集代理。
  3. 下载注入身份验证文件 。
  4. 将该文件安全地保存在将安装 Bindplane 代理的系统上。

获取 Google SecOps 客户 ID

  1. 登录 Google SecOps 控制台。
  2. 依次前往 SIEM 设置 > 个人资料。
  3. 从组织详细信息 部分复制并保存客户 ID 。

安装 Bindplane 代理

按照以下说明在 Linux 操作系统上安装 Bindplane 代理。

Linux 安装

  1. 打开具有根权限或 sudo 权限的终端。
  2. 运行以下命令:

    sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.sh
    

其他安装资源

如需了解其他安装选项,请参阅此安装指南。

配置 Bindplane 代理以注入 Syslog 并将其发送到 Google SecOps

  1. 访问配置文件:

    • 找到 config.yaml 文件。通常,该文件位于 Linux 上的 /opt/observiq-otel-collector/ 目录中。
    • 使用文本编辑器(例如 nano 或 vi)打开该文件。
  2. 按如下方式修改 config.yaml 文件:

    receivers:
      udplog:
        # Replace the port and IP address as required
        listen_address: "0.0.0.0:514"
    
    exporters:
      chronicle/chronicle_w_labels:
        protocol: https
        # Region of your instance, for example us, europe, asia-southeast1
        location: <LOCATION>
        # Project number of the Google Cloud project linked to the instance
        project: '<PROJECT_NUMBER>'
        compression: gzip
        # Adjust the path to the credentials file you downloaded in Step 1
        creds_file_path: '/path/to/ingestion-authentication-file.json'
        # Replace with your actual customer ID from Step 2
        customer_id: <CUSTOMER_ID>
        endpoint: chronicle.googleapis.com
        # Add optional ingestion labels for better organization
        log_type: 'AIDE'
        raw_log_field: body
        ingestion_labels:
    
    service:
      pipelines:
        logs/source0__chronicle_w_labels-0:
          receivers:
            - udplog
          exporters:
            - chronicle/chronicle_w_labels
    
    • 根据基础架构的需要替换端口和 IP 地址。
    • 将 <LOCATION> 替换为 Google SecOps 实例的区域(例如 us、europe 或 asia-southeast1)。导出器会使用此值为 chronicle.googleapis.com 添加前缀。
    • 将 <PROJECT_NUMBER> 替换为 IAM 和管理 > 设置 中的项目编号。
    • 将 <CUSTOMER_ID> 替换为实际的客户 ID。
    • 将 /path/to/ingestion-authentication-file.json 更新为在第 1 步中保存服务帐号密钥文件(方法 1)的文件路径。

旧版注入 API 导出器

  • 如果您使用方法 2 中的注入身份验证文件,请将 exporters 块替换为以下内容。将 creds_file_path 设置为注入身份验证文件的路径,并且如果您的实例位于美国境外,请将 malachiteingestion-pa.googleapis.com 替换为您的 区域端点(例如 europe-malachiteingestion-pa.googleapis.com)。

    exporters:
      chronicle/chronicle_w_labels:
        compression: gzip
        # Adjust the path to the credentials file you downloaded in Step 1
        creds_file_path: '/path/to/ingestion-authentication-file.json'
        # Replace with your actual customer ID from Step 2
        customer_id: <CUSTOMER_ID>
        endpoint: malachiteingestion-pa.googleapis.com
        # Add optional ingestion labels for better organization
        log_type: 'AIDE'
        raw_log_field: body
        ingestion_labels:
    

重启 Bindplane 代理以应用更改

  • 如需在 Linux 中重启 Bindplane 代理,请运行以下命令:

    sudo systemctl restart observiq-otel-collector
    

在 AIDE 上配置 Syslog 转发

  1. 打开 AIDE 配置文件:

    sudo vi /etc/aide/aide.conf
    
  2. 前往报告部分。

  3. 添加以下配置:

    • report_level:输入 list_entries。
    • report_format:输入 json(适用于 AIDE 0.18+)或 plain。
    • report_url:输入 syslog:authpriv。

    配置示例:

    ```ini
    report_level=list_entries
    report_format=json
    report_url=syslog:authpriv
    ```
    
  4. 保存配置。

  5. 配置 rsyslog 以将 AIDE 日志转发到 Bindplane 代理。打开 rsyslog 配置:

    sudo vi /etc/rsyslog.d/aide-forward.conf
    
  6. 添加以下配置,以将 authpriv 功能日志转发到 Bindplane 代理:

    authpriv.* @<BINDPLANE_AGENT_IP>:514
    
    • 将 <BINDPLANE_AGENT_IP> 替换为 Bindplane 代理主机的 IP 地址。
    • 对于 UDP 转发,请使用 @;对于 TCP 转发,请使用 @@。
  7. 重启 rsyslog:

    sudo systemctl restart rsyslog
    
  8. 如果这是全新安装,请初始化 AIDE 数据库:

    sudo aide --init
    sudo mv /var/lib/aide/aide.db.new /var/lib/aide/aide.db
    
  9. 测试配置:

    sudo aide --check
    
  10. 使用 Cron 作业设置自动检查:

    sudo crontab -e
    
  11. 添加以下行,以在每天凌晨 4:05 运行 AIDE:

    05 4 * * * root /usr/sbin/aide --check
    

UDM 映射表

日志字段 UDM 映射 逻辑
added_label principal.asset.attribute.labels 已合并
changed_label principal.asset.attribute.labels 已合并
old_acl_label principal.asset.attribute.labels 已合并
old_md5_label principal.asset.attribute.labels 已合并
old_perms_label principal.asset.attribute.labels 已合并
old_sha256_label principal.asset.attribute.labels 已合并
old_ts_label principal.asset.attribute.labels 已合并
removed_label principal.asset.attribute.labels 已合并
total_label principal.asset.attribute.labels 已合并
file_path principal.file.full_path 已直接映射
path principal.file.full_path 已直接映射
old_size principal.file.size 已直接映射
host principal.hostname 已直接映射
sr security_result 已合并
new_acl_label target.asset.attribute.labels 已合并
new_md5_label target.asset.attribute.labels 已合并
new_perms_label target.asset.attribute.labels 已合并
new_sha256_label target.asset.attribute.labels 已合并
new_ts_label target.asset.attribute.labels 已合并
path target.file.full_path 已直接映射
new_size target.file.size 已直接映射
不适用 metadata.event_type 常量:GENERIC_EVENT
不适用 metadata.product_name 常量:AIDE
不适用 metadata.vendor_name 常量:AIDE
不适用 principal.application 常量:aide
不适用 principal.file.size 常量:sizedata
不适用 target.file.size 常量:sizedata_target
total_files", "added_files", "removed_files", "changed_files", "old_timestamp", "old_perms", "old_sha256", "old_md5", and "old_acl principal.asset.attribute.labels 从变更日志映射
new_timestamp", "new_perms", "new_sha256", "new_md5", and "new_acl target.asset.attribute.labels 从变更日志映射

更新日志

查看此解析器的更新日志

需要更多帮助?获得社区成员和 Google SecOps 专业人士的解答。