收集 Cyber 2.0 IDS 日志
解析器版本: 2.0
本文档介绍了如何使用 Bindplane 代理将 Cyber 2.0 IDS 日志注入 Google Security Operations。
Cyber 2.0 IDS 提供企业级网络安全,并具有集成的入侵检测和防御功能。MX 设备使用 Snort 入侵检测引擎来监控网络流量中的恶意活动,并根据 Cisco Talos 的威胁情报生成 IDS 提醒。IDS 提醒以两种格式生成:旧版 ids-alerts 和当前 security_event 类型,优先级范围为 1(高)到 4(非常低),具体取决于 Snort 签名分类。
准备工作
请确保满足以下前提条件:
- Google SecOps 实例
- Windows Server 2016 或更高版本,或者具有
systemd的 Linux 主机 - Bindplane 代理与 Cyber 2.0 IDS 之间的网络连接
- 如果通过代理运行,请确保防火墙端口根据 Bindplane 代理要求处于开放状态
- 对 Cisco Meraki 控制面板的管理员访问权限
- Cyber 2.0 IDS,具有 Advanced Security Edition 许可(IDS/IPS 功能需要此许可)
- 从 Meraki MX 设备到 Bindplane 代理主机的网络连接(UDP 端口 514 或自定义端口)
获取 Google SecOps 注入身份验证文件
- 登录 Google SecOps 控制台。
- 依次前往 SIEM 设置 > 收集代理。
下载数据注入身份验证文件 。将该文件安全地保存在将安装 Bindplane 的 系统上。
获取 Google SecOps 客户 ID
- 登录 Google SecOps 控制台。
- 依次前往 SIEM 设置 > 个人资料。
从组织详细信息 部分复制并保存客户 ID 。
安装 Bindplane 代理
按照以下说明在 Windows 或 Linux 操作系统上安装 Bindplane 代理。
Windows 安装
- 以管理员身份打开命令提示符 或 PowerShell 。
运行以下命令:
msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quiet等待安装完成。
运行以下命令,验证安装是否成功:
sc query observiq-otel-collector服务状态应为 RUNNING 。
Linux 安装
- 使用 root 或 sudo 权限打开终端。
运行以下命令:
sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.sh等待安装完成。
运行以下命令,验证安装是否成功:
sudo systemctl status observiq-otel-collector服务状态应为 active (running) 。
其他安装资源
如需了解其他安装选项和问题排查信息,请参阅 Bindplane 代理安装指南。
配置 Bindplane 代理以注入 Syslog 并将日志发送到 Google SecOps
找到配置文件
Linux:
sudo nano /etc/bindplane-agent/config.yamlWindows:
notepad "C:\Program Files\observIQ OpenTelemetry Collector\config.yaml"
修改配置文件
将
config.yaml的全部内容替换为以下配置:receivers: udplog: listen_address: "0.0.0.0:514" exporters: chronicle/meraki_ids: compression: gzip creds_file_path: '<CREDS_FILE_PATH>' customer_id: '<CUSTOMER_ID>' endpoint: malachiteingestion-pa.googleapis.com log_type: CYBER_2_IDS raw_log_field: body ingestion_labels: vendor: cisco_meraki product: mx_security_appliance service: pipelines: logs/meraki_to_chronicle: receivers: - udplog exporters: - chronicle/meraki_ids替换以下占位符:
接收器配置:
- 接收器配置为在 UDP 端口
514(标准 Syslog 端口)上的所有接口 (0.0.0.0) 上侦听 - 如果端口 514 已在使用中,或者您需要在 Linux 上以非 root 身份运行,请将端口更改为
1514或其他可用端口
- 接收器配置为在 UDP 端口
导出器配置:
<CREDS_FILE_PATH>:注入身份验证文件的完整路径:- Linux:
/etc/bindplane-agent/ingestion-auth.json - Windows:
C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json
- Linux:
<CUSTOMER_ID>:在上一步中复制的客户 IDendpoint:区域端点网址(显示的默认网址是美国区域):- 美国:
malachiteingestion-pa.googleapis.com - 欧洲:
europe-malachiteingestion-pa.googleapis.com - 亚洲:
asia-southeast1-malachiteingestion-pa.googleapis.com - 如需查看完整列表,请参阅区域端点
- 美国:
log_type:对于 Cisco Meraki IDS 提醒,请设置为CYBER_2_IDS。ingestion_labels:用于在 Google SecOps 中对日志进行分类的可选标签。
配置示例
receivers: udplog: listen_address: "0.0.0.0:514" exporters: chronicle/meraki_ids: compression: gzip creds_file_path: '/etc/bindplane-agent/ingestion-auth.json' customer_id: 'a1b2c3d4-e5f6-g7h8-i9j0-k1l2m3n4o5p6' endpoint: malachiteingestion-pa.googleapis.com log_type: CYBER_2_IDS raw_log_field: body ingestion_labels: vendor: cisco_meraki product: mx_security_appliance environment: production service: pipelines: logs/meraki_to_chronicle: receivers: - udplog exporters: - chronicle/meraki_ids
保存配置文件
修改后,保存文件:
- Linux:按
Ctrl+O,然后按Enter,再按Ctrl+X - Windows:依次点击文件 > 保存
重启 Bindplane 代理以应用更改
如需在 Linux 中重启 Bindplane 代理,请执行以下操作:
运行以下命令:
sudo systemctl restart observiq-otel-collector验证服务是否正在运行:
sudo systemctl status observiq-otel-collector检查日志中的错误:
sudo journalctl -u observiq-otel-collector -f
如需在 Windows 中重启 Bindplane 代理,请执行以下操作:
请从下列选项中选择一项:
以管理员身份运行命令提示符或 PowerShell:
net stop observiq-otel-collector && net start observiq-otel-collector“服务”控制台:
- 按
Win+R,输入services.msc,然后按 Enter 键。 - 找到 observIQ OpenTelemetry Collector 。
- 右键点击并选择重启 。
- 按
验证服务是否正在运行:
sc query observiq-otel-collector检查日志中的错误:
type "C:\Program Files\observIQ OpenTelemetry Collector\log\collector.log"
配置 Cyber 2.0 IDS Syslog 转发
- 登录 Cisco Meraki 控制面板 ,网址为 https://dashboard.meraki.com。
- 从左上角的组织下拉菜单中选择您的组织。
- 从网络下拉菜单中选择包含 MX 安全设备的网络。
- 依次前往网络范围 > 配置 > 常规。
- 向下滚动至报告 部分。
- 在 Syslog 服务器 下,点击 添加 Syslog 服务器 。
- 使用以下设置配置 Syslog 服务器:
- 服务器 IP:输入 Bindplane 代理主机的 IP 地址(例如
192.168.1.100)。 - 端口:输入
514(如果不同,则输入在 Bindplane 代理中配置的自定义端口)。 - 角色:选择以下角色以转发 IDS 提醒:
- 选中 IDS 提醒 (适用于旧版
ids-alerts格式的事件) - 选中 Security events (适用于当前
security_event格式的事件,包括 IDS 提醒和 AMP 恶意软件检测)
- 选中 IDS 提醒 (适用于旧版
- 服务器 IP:输入 Bindplane 代理主机的 IP 地址(例如
- 点击页面底部的保存更改 。
- 验证 MX 安全设备上是否启用了 IDS/IPS:
- 依次前往安全和 SD-WAN > 配置 > 威胁防护。
- 确保模式 设置为检测 (IDS) 或防御 (IPS)。
- 根据您的安全要求,选择规则集:连接、平衡或安全。
- 点击保存更改 。
生成测试流量以验证日志转发:
- 依次前往安全和 SD-WAN > 监控 > 安全中心。
- 验证是否正在生成 IDS 提醒。
- 检查 Bindplane 代理日志,确认事件正在被接收并转发到 Google SecOps。
UDM 映射表
| 日志字段 | UDM 映射 | 逻辑 |
|---|---|---|
| time1, monthnum+day+time2, time | metadata.event_timestamp | 事件发生时的时间戳 |
| app_version | about.resource.attribute.labels | 资源属性的键值对列表 |
| prod_event_type | metadata.product_event_type | 特定于产品的事件类型 |
| Groups | principal.group.group_display_name | 群组的显示名称 |
| app_name, app_version, hostname, principal_ip, md5_value | about | 有关事件的信息 |
| inter_host | intermediary.hostname | 中介的主机名 |
| description | metadata.description | 事件的说明 |
| Protocol | network.ip_protocol | 网络连接中使用的 IP 协议 |
| Direction | network.direction | 网络流量的方向 |
| Source | principal.port | 主账号的端口号 |
| Destination | target.port | 目标的端口号 |
| SourceIP, principal_ip | principal.ip | 主账号的 IP 地址 |
| SourceIP, principal_ip | principal.asset.ip | 主账号资产的 IP 地址 |
| DestinationIP | target.ip | 目标的 IP 地址 |
| DestinationIP | target.asset.ip | 目标资产的 IP 地址 |
| HostName, hostname | principal.hostname | 主账号的主机名 |
| HostName, hostname | principal.asset.hostname | 主账号资产的主机名 |
| ApplicationName | target.application | 目标的应用名称 |
| UserName | principal.user.userid | 主账号的用户 ID |
| FullPath | target.file.full_path | 文件的完整路径 |
| Status | security_result.action | 安全系统采取的操作 |
| pid | principal.process.pid | 进程 ID |
| src_application | principal.application | 主账号的应用名称 |
| SubSeqNumber, FlowHandle, ClientZValue, MACAddress, State, IsXCast, FlowState, DLLMode | security_result.detection_fields | 安全结果中的检测字段 |
| severity | security_result.severity | 安全结果的严重程度 |
| DB, NewApps, UniqueApps, Computers, Duration | additional.fields | 其他字段 |
| metadata.event_type | 事件类型 | |
| metadata.product_name | 产品名称 | |
| metadata.vendor_name | 供应商名称 |