收集 Preempt Auth 日志
本文档介绍了如何使用 Bindplane 代理将 Preempt Auth 日志注入 Google Security Operations。
Preempt Auth 是一种身份验证事件监控解决方案,可为 Active Directory 环境生成详细的身份验证日志。它会捕获端点上的成功和失败登录事件、LDAP 搜索、服务访问和身份验证类型。
准备工作
请确保满足以下前提条件:
- Google SecOps 实例
- Windows Server 2016 或更高版本,或者具有
systemd的 Linux 主机 - Bindplane 代理与 Preempt 服务器之间的网络连接
- 如果通过代理运行,请确保防火墙端口根据 Bindplane 代理要求处于开放状态
- 对 Preempt Auth(CrowdStrike Identity Protection)的特权访问权限,且具有管理员权限
获取 Bindplane 代理的 Google SecOps 凭据
如需向 Google SecOps 验证 Bindplane 代理的身份,请选择以下方法之一:
- 新部署:使用 Chronicle API(方法 1)。
- 旧版部署:继续使用注入身份验证文件(方法 2),直到注入 API 于 2027 年 7 月 20 日停用为止。
方法 1:为 Chronicle API 创建服务帐号(推荐)
- 登录 Google Cloud 控制台,然后选择与您的 Google SecOps 实例关联的 Google Cloud 项目。
- 依次前往 IAM 和管理 > 服务账号。
- 点击创建服务账号 。
- 提供以下配置详细信息:
- 服务账号名称:输入账号的名称(例如
bindplane-ingest)。 - 服务账号说明:输入说明(例如
Bindplane agent log ingestion)。
- 服务账号名称:输入账号的名称(例如
- 点击创建并继续 。
- 在向此服务帐号授予对项目的访问权限 部分,点击选择角色 ,然后选择 Chronicle Editor 。
- 点击继续 ,然后点击完成 。
- 点击您创建的服务帐号,然后前往密钥 标签页。
- 依次点击添加密钥 > 创建新密钥。
- 选择 JSON ,然后点击创建 。密钥文件会下载到您的计算机上。
- 将密钥文件另存为 Bindplane 收集器目录中的
ingestion-auth.json(在 Linux 上为/opt/observiq-otel-collector/ingestion-auth.json,在 Windows 上为C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json),或者更新creds_file_path在config.yaml中以与您保存该文件的路径匹配。 - 依次前往 IAM 和管理 > 设置 ,然后复制项目编号 。您需要此编号进行导出器配置。
方法 2:下载注入身份验证文件(旧版)
- 登录 Google SecOps 控制台。
- 依次前往 SIEM 设置 > 收集代理。
- 下载注入身份验证文件 。
- 将该文件安全地保存在将安装 Bindplane 代理的系统上。
获取 Google SecOps 客户 ID
- 登录 Google SecOps 控制台。
- 依次前往 SIEM 设置 > 个人资料。
从组织详细信息 部分复制并保存客户 ID 。
安装 Bindplane 代理
按照以下说明在 Windows 或 Linux 操作系统上安装 Bindplane 代理。
Windows 安装
- 以管理员身份打开命令提示符 或 PowerShell 。
运行以下命令:
msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quiet等待安装完成。
运行以下命令,验证安装是否成功:
sc query observiq-otel-collector该服务应显示为正在运行 。
Linux 安装
- 打开具有根权限或 sudo 权限的终端。
运行以下命令:
sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.sh等待安装完成。
运行以下命令,验证安装是否成功:
sudo systemctl status observiq-otel-collector该服务应显示为活跃 (running) 。
其他安装资源
如需了解其他安装选项和问题排查信息,请参阅 Bindplane 代理安装指南。
配置 Bindplane 代理以注入 syslog 并将其发送到 Google SecOps
找到配置文件
Linux:
sudo nano /opt/observiq-otel-collector/config.yamlWindows:
notepad "C:\Program Files\observIQ OpenTelemetry Collector\config.yaml"
修改配置文件
将
config.yaml的全部内容替换为以下配置:receivers: tcplog: listen_address: "0.0.0.0:514" exporters: chronicle/preempt_auth: protocol: https # Region of your instance, for example us, europe, asia-southeast1 location: <LOCATION> # Project number of the Google Cloud project linked to the instance project: '<PROJECT_NUMBER>' compression: gzip creds_file_path: '<CREDS_FILE_PATH>' customer_id: '<CUSTOMER_ID>' endpoint: chronicle.googleapis.com log_type: PREEMPT_AUTH raw_log_field: body ingestion_labels: env: production service: pipelines: logs/preempt_auth_to_chronicle: receivers: - tcplog exporters: - chronicle/preempt_auth
配置参数
替换以下占位符:
接收器配置:
tcplog:通过 TCP 接收 syslog。如果您的 Preempt 部署通过 UDP 转发,请使用udplog。0.0.0.0:514:监听端口 514 上的所有接口。如果需要,请更改端口(例如,对于非根 Linux,为1514)。
导出器配置:
<CREDS_FILE_PATH>:服务帐号 JSON 密钥文件的完整路径(方法 1):- Linux:
/opt/observiq-otel-collector/ingestion-auth.json - Windows:
C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json
- Linux:
<CUSTOMER_ID>:获取 Google SecOps 客户 ID 步骤中的客户 ID。location:将<LOCATION>替换为 Google SecOps 实例的区域(例如,us、europe或asia-southeast1)。导出器会使用此值为chronicle.googleapis.com添加前缀。如需查看完整列表,请参阅区域级端点。project:将<PROJECT_NUMBER>替换为 IAM 和管理 > 设置 中的项目编号。endpoint:保持设置为chronicle.googleapis.com。
旧版注入 API 导出器
如果您使用方法 2 中的注入身份验证文件,请将
exporters块替换为以下内容。将creds_file_path设置为注入身份验证文件的路径,如果您的实例位于美国境外,请将malachiteingestion-pa.googleapis.com替换为您的 区域级端点(例如,europe-malachiteingestion-pa.googleapis.com)。exporters: chronicle/preempt_auth: compression: gzip creds_file_path: '<CREDS_FILE_PATH>' customer_id: '<CUSTOMER_ID>' endpoint: malachiteingestion-pa.googleapis.com log_type: PREEMPT_AUTH raw_log_field: body ingestion_labels: env: production
保存配置文件
- 修改后,保存文件:
- Linux:按
Ctrl+O,然后按Enter,再按Ctrl+X - Windows:依次点击文件 > 保存
- Linux:按
重启 Bindplane 代理以应用更改
如需在 Linux 中重启 Bindplane 代理,请运行以下命令:
sudo systemctl restart observiq-otel-collector验证服务是否正在运行:
sudo systemctl status observiq-otel-collector检查日志中的错误:
sudo journalctl -u observiq-otel-collector -f
如需在 Windows 中重启 Bindplane 代理,请选择以下选项之一:
以管理员身份运行命令提示符或 PowerShell:
net stop observiq-otel-collector && net start observiq-otel-collector“服务”控制台:
- 按
Win+R,输入services.msc,然后按 Enter 键。 - 找到 observIQ OpenTelemetry Collector 。
- 右键点击并选择重启 。
验证服务是否正在运行:
sc query observiq-otel-collector检查日志中的错误:
type "C:\Program Files\observIQ OpenTelemetry Collector\log\collector.log"
- 按
配置 Preempt Auth syslog 转发
- 登录 Preempt 管理控制台 。
- 依次前往设置 > SIEM 集成。
- 为身份验证事件启用 syslog 转发。
- 提供以下配置详细信息:
- 协议:选择 TCP (必须与 Bindplane 代理接收器配置匹配)。
- Syslog 服务器地址:输入 Bindplane 代理主机(例如
192.168.1.100)的 IP 地址。 - 端口:输入
514(必须与 Bindplane 代理接收器端口匹配)。
- 选择要转发的身份验证事件类型:
- 身份验证成功事件
- 身份验证失败事件
- LDAP 搜索
- 服务访问事件
- 点击保存 或应用 。
- 检查 Bindplane 代理日志,验证日志是否正在发送。
UDM 映射表
| 日志字段 | UDM 映射 | 逻辑 |
|---|---|---|
| authenticationType | extensions.auth.type | 如果 authenticationType 与 SSO_LOGIN 或 LDAP_AUTHENTICATION 匹配,则设置为“SSO”;如果与 DOMAIN_LOGIN 匹配,则设置为“MACHINE”;如果与 NTLM_AUTHENTICATION 匹配,则设置为“AUTHTYPE_UNSPECIFIED” |
| extensions.auth.mechanism | 设置为“MECHANISM_UNSPECIFIED” | |
| inter_ip | intermediary.hostname | 如果 inter_ip 不是有效的 IP 地址,则进行设置 |
| inter_ip | intermediary.ip | 如果 inter_ip 是有效的 IP 地址,则进行设置 |
| eventLabel | metadata.description | 直接复制值 |
| eventType | metadata.event_type | 如果 eventType 为 SUCCESSFUL_AUTHENTICATION 或 FAILED_AUTHENTICATION,则设置为“USER_LOGIN”;如果为 SERVICE_ACCESS 或 LDAP_SEARCH 且 principal_host_set 为 true,则设置为“SERVICE_UNSPECIFIED” |
| eventType | metadata.product_event_type | 直接复制值 |
| endpointDisplayName, ipAddress | principal.hostname | 如果 endpointDisplayName != ipAddress 且 endpointDisplayName != "",则进行设置 |
| ipAddress, inter_ip | principal.ip | 如果 ipAddress != inter_ip,则取自 ipAddress,否则取自 inter_ip |
| networkType | principal.resource.name | 直接复制值 |
| principal.resource.type | 设置为“网络类型” | |
| userDisplayName | principal.user.email_addresses | 如果 userDisplayName 与电子邮件正则表达式匹配,则进行设置 |
| userDisplayName | principal.user.user_display_name | 直接复制值 |
| userEntity.secondaryDisplayName, userDisplayName | principal.user.userid | 如果 userEntity.secondaryDisplayName 不为空,则取自 userEntity.secondaryDisplayName,否则如果 userEntity.secondaryDisplayName 为空,则取自 userDisplayName |
| eventType | security_result.action | 如果为 SUCCESSFUL_AUTHENTICATION,则设置为“ALLOW”;如果为 FAILED_AUTHENTICATION,则设置为“BLOCK” |
| eventSeverity | security_result.severity_details | 直接复制值 |
| authenticationType | security_result.summary | 直接复制值 |
| targetEntity.primaryDisplayName, targetServiceIdentifier, eventType, targetEntity.type | target.application | 如果 targetEntity.type == "CLOUD_SERVICE",则取自 targetEntity.primaryDisplayName;否则,如果 targetServiceIdentifier != "" 且之前未设置,则取自 targetServiceIdentifier;否则,如果 eventType == "LDAP_SEARCH" 且之前未设置,则取自“LDAP” |
| targetEntity.primaryDisplayName, targetEntity.type | target.hostname | 如果 targetEntity.type == "ENDPOINT",则进行设置 |
| targetServiceType | target.resource.name | 如果 targetServiceType != "" 且 != "UNKNOWN",则进行设置 |
| targetServiceType | target.resource.type | 如果 targetServiceType != "" 且 != "UNKNOWN",则设置为“服务类型” |
| targetEntity.primaryDisplayName, targetEntity.type | target.user.user_display_name | 如果 targetEntity.type == "USER",则进行设置 |
| targetEntity.secondaryDisplayName, targetEntity.type | target.user.userid | 如果 targetEntity.type == "USER",则进行设置 |
| metadata.product_name | 设置为“PREEMPT_AUTH” | |
| metadata.vendor_name | 设置为“Preempt” |