收集 NetApp ONTAP 日志

支持的平台:

本文档介绍了如何使用 Bindplane 代理将 NetApp ONTAP 日志注入到 Google Security Operations。

NetApp ONTAP 是一种存储操作系统,可针对身份验证事件、系统状态、网络活动和安全相关操作生成 syslog 消息。解析器使用正则表达式从 syslog 消息中提取字段,并将其映射到统一数据模型 (UDM)。

准备工作

请确保满足以下前提条件:

  • Google SecOps 实例
  • Windows Server 2016 或更高版本,或者具有 systemd 的 Linux 主机
  • Bindplane 代理与 NetApp ONTAP 集群之间的网络连接
  • 如果在代理后面运行,请确保防火墙端口已根据 Bindplane 代理要求打开
  • 通过 SSH 对 NetApp ONTAP 集群的管理员访问权限

获取 Google SecOps 注入身份验证文件

  1. 登录 Google SecOps 控制台。
  2. 依次前往 SIEM 设置 > 收集代理
  3. 下载数据注入身份验证文件
  4. 将文件安全地保存在将要安装 Bindplane 代理的系统上。

获取 Google SecOps 客户 ID

  1. 登录 Google SecOps 控制台。
  2. 依次前往 SIEM 设置 > 配置文件
  3. 复制并保存组织详细信息部分中的客户 ID

安装 Bindplane 代理

按照以下说明在 Windows 或 Linux 操作系统上安装 Bindplane 代理。

Windows 安装

  1. 以管理员身份打开命令提示符PowerShell
  2. 运行以下命令:

    msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quiet
    
  3. 等待安装完成。

  4. 运行以下命令,验证安装是否成功:

    sc query observiq-otel-collector
    

    该服务应显示为 正在运行

Linux 安装

  1. 打开具有 root 或 sudo 权限的终端。
  2. 运行以下命令:

    sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.sh
    
  3. 等待安装完成。

  4. 运行以下命令,验证安装是否成功:

    sudo systemctl status observiq-otel-collector
    

    该服务应显示为有效(正在运行)

其他安装资源

如需了解其他安装选项和问题排查信息,请参阅 Bindplane 代理安装指南

配置 Bindplane 代理以注入 syslog 并将其发送到 Google SecOps

找到配置文件

  • Linux

    sudo nano /opt/observiq-otel-collector/config.yaml
    
  • Windows

    notepad "C:\Program Files\observIQ OpenTelemetry Collector\config.yaml"
    

修改配置文件

  • config.yaml 的全部内容替换为以下配置:

    receivers:
        udplog:
            listen_address: "0.0.0.0:514"
    
    exporters:
        chronicle/netapp_ontap:
            compression: gzip
            creds_file_path: '/etc/bindplane-agent/ingestion-auth.json'
            customer_id: '<customer_id>'
            endpoint: malachiteingestion-pa.googleapis.com
            log_type: NETAPP_ONTAP
            raw_log_field: body
    
    service:
        pipelines:
            logs/netapp_ontap_to_chronicle:
                receivers:
                    - udplog
                exporters:
                    - chronicle/netapp_ontap
    

配置参数

替换以下占位符:

  • 接收器配置

    • listen_address:要监听的 IP 地址和端口:
      • 0.0.0.0 侦听所有接口(推荐)
      • 端口 514 是标准 syslog 端口(在 Linux 上需要 root 权限;对于非 root 用户,请使用 1514
  • 导出器配置

    • creds_file_path:提取身份验证文件的完整路径:
      • Linux/etc/bindplane-agent/ingestion-auth.json
      • WindowsC:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json
    • customer_id:从 Google SecOps 控制台复制的客户 ID
    • endpoint:区域端点网址:
      • 美国malachiteingestion-pa.googleapis.com
      • 欧洲europe-malachiteingestion-pa.googleapis.com
      • 亚洲asia-southeast1-malachiteingestion-pa.googleapis.com
      • 如需查看完整列表,请参阅区域级端点

保存配置文件

  • 修改后,保存文件:
    • Linux:依次按 Ctrl+OEnterCtrl+X
    • Windows:依次点击文件 > 保存

重启 Bindplane 代理以应用更改

  • 如需在 Linux 中重启 Bindplane 代理,请运行以下命令:

    sudo systemctl restart observiq-otel-collector
    
    1. 验证服务是否正在运行:

      sudo systemctl status observiq-otel-collector
      
    2. 检查日志是否存在错误:

      sudo journalctl -u observiq-otel-collector -f
      
  • 如需在 Windows 中重启 Bindplane 代理,请选择以下选项之一:

    • 以管理员身份运行命令提示符或 PowerShell:

      net stop observiq-otel-collector && net start observiq-otel-collector
      
    • 服务控制台:

      1. Win+R,输入 services.msc,然后按 Enter 键。
      2. 找到 observIQ OpenTelemetry 收集器
      3. 右键点击并选择重新启动
      4. 验证服务是否正在运行:

        sc query observiq-otel-collector
        
      5. 检查日志是否存在错误:

        type "C:\Program Files\observIQ OpenTelemetry Collector\log\collector.log"
        

在 ONTAP 中配置 syslog 目标

  1. 使用 SSH 访问 ONTAP 集群:

    ssh admin@<ontap-cluster-ip>
    
    • <ontap-cluster-ip> 替换为 ONTAP 集群的管理 IP。
  2. 检查现有事件过滤条件和通知:

    event filter show
    event notification show
    
  3. 创建 syslog 目标。将 <syslog-server-ip><syslog-server-port> 替换为您的 Bindplane 详细信息:

    event notification destination create -name syslog-ems -syslog <syslog-server-ip> -syslog-port <syslog-server-port> -syslog-transport udp-unencrypted
    

    -syslog-transport的其他选项:

    • udp-unencrypted(默认)
    • tcp-unencrypted
    • tcp-encrypted(适用于 TLS)
  4. 验证 syslog 目标位置:

    event notification destination show
    

配置现有活动过滤条件

  • 将默认过滤条件与 syslog 目标相关联:

    event notification create -filter-name no-info-debug-events -destinations syslog-ems
    event notification create -filter-name default-trap-events -destinations syslog-ems
    

可选:创建和配置自定义过滤条件

  1. 身份验证事件过滤条件(登录/退出):

    event filter create -filter-name auth_events
    event filter rule add -filter-name auth_events -type include -message-name *login* -severity info
    event filter rule add -filter-name auth_events -type include -message-name *logout* -severity info
    
  2. 安全检测字段过滤条件:

    event filter create -filter-name security_fields
    event filter rule add -filter-name security_fields -type include -message-name *nmsdk_language* -severity info
    
  3. 将每个过滤条件应用于 syslog 目的地:

    event notification create -filter-name auth_events -destinations syslog-ems
    event notification create -filter-name security_fields -destinations syslog-ems
    
  4. 验证通知:

    event notification show
    

UDM 映射表

日志字段 UDM 映射 逻辑
code 未映射
description metadata.description 使用 grok 模式从日志消息中提取。仅当说明为“正在退出”或“正在登录”时存在。
intermediary_host intermediary.hostname 使用 Grok 模式从日志消息中提取。
nmsdk_language security_result.detection_fields.value 使用 grok 模式从日志消息中提取。此值将作为“值”添加到“键”为“nmsdk_language”的 detection_fields 对象中。
nmsdk_platform security_result.detection_fields.value 使用 grok 模式从日志消息中提取。此值会作为“value”添加到“key”为“nmsdk_platform”的 detection_fields 对象中。
nmsdk_version security_result.detection_fields.value 使用 grok 模式从日志消息中提取。此值会作为“值”添加到“键”为“nmsdk_version”的 detection_fields 对象中。
netapp_version security_result.detection_fields.value 使用 grok 模式从日志消息中提取。此值会作为“值”添加到“键”为“netapp_version”的 detection_fields 对象中。
product_event_type metadata.product_event_type 使用 Grok 模式从日志消息中提取。
security_result.summary security_result.summary 使用 Grok 模式从日志消息中提取。
severity security_result.severity 如果严重程度为“info”(不区分大小写),则设置为“INFORMATIONAL”。
src_ip principal.ip 使用 Grok 模式从日志消息中提取。
src_port principal.port 使用 Grok 模式从日志消息中提取。
status security_result.summary 使用 Grok 模式从日志消息中提取。
ts metadata.event_timestamp.seconds 使用 Grok 模式从日志消息中提取并转换为时间戳。
url target.url 使用 Grok 模式从日志消息中提取。
user target.user.userid 使用 Grok 模式从日志消息中提取。
extensions.auth.type 如果说明为“正在退出”或“正在登录”,则设置为“AUTHTYPE_UNSPECIFIED”。
metadata.event_type 如果说明为“正在登录”,则设置为“USER_LOGIN”。
metadata.event_type 如果说明为“正在退出”,则设置为“USER_LOGOUT”。
metadata.event_type 如果说明不是“正在登录”或“正在退出”,则设置为“SCAN_UNCATEGORIZED”。
metadata.log_type 设置为“NETAPP_ONTAP”。
metadata.product_name 设置为“NETAPP_ONTAP”。
metadata.vendor_name 设置为“NETAPP_ONTAP”。
target.platform 如果 nmsdk_platform 包含“windows”(不区分大小写),则设置为“WINDOWS”。
accessLocation event.idm.read_only_udm.principal.ip 从变更日志映射
accessLocation event.idm.read_only_udm.principal.asset.ip 从变更日志映射
deviceId event.idm.read_only_udm.principal.asset_id 从变更日志映射
deviceId event.idm.read_only_udm.principal.asset.asset_id 从变更日志映射
deviceName event.idm.read_only_udm.principal.hostname 从变更日志映射
deviceName event.idm.read_only_udm.principal.asset.hostname 从变更日志映射
domain event.idm.read_only_udm.principal.administarative_domain 从变更日志映射
entityName event.idm.read_only_udm.target.file.names 从变更日志映射
entityPath event.idm.read_only_udm.target.file.full_path 从变更日志映射
entityType event.idm.read_only_udm.target.resource.attribute.labels 从变更日志映射
extension event.idm.read_only_udm.target.resource.attribute.labels 从变更日志映射
entityAccessedTime event.idm.read_only_udm.metadata.event_timestamp 从变更日志映射
alertTimestamp event.idm.read_only_udm.metadata.event_timestamp 从变更日志映射
id event.idm.read_only_udm.metadata.product_log_id 从变更日志映射
userDisplayName event.idm.read_only_udm.principal.user.user_display_name 从变更日志映射
userId event.idm.read_only_udm.principal.user.userid 从变更日志映射
volumeId event.idm.read_only_udm.additional.fields 从变更日志映射
volumeName event.idm.read_only_udm.additional.fields 从变更日志映射
alertType event.idm.read_only_udm.additional.fields 从变更日志映射
attributes.dataDestructionDetectedEntityCount event.idm.read_only_udm.additional.fields 从变更日志映射
attributes.changePercentage event.idm.read_only_udm.additional.fields 从变更日志映射
severity security_result.severity_details 从变更日志映射
file_extn security_result.detection_fields 从变更日志映射
uid metadata.product_log_id 从变更日志映射
product_name principal.hostname 从变更日志映射

更新日志

查看相应解析器的更改日志

需要更多帮助?获得社区成员和 Google SecOps 专业人士的解答。