收集 Digi Modems 日志
解析器版本:1.0
本文档介绍了如何使用 Bindplane 代理将 Digi Modems 日志注入 Google Security Operations。
Digi 调制解调器是工业蜂窝调制解调器,可为登录事件、身份验证尝试和网络连接生成 syslog 消息。解析器使用 grok 模式提取字段,并将其映射到统一数据模型 (UDM)。
准备工作
请确保满足以下前提条件:
- Google SecOps 实例
- Windows Server 2016 或更高版本,或者安装了
systemd的 Linux 主机 - Bindplane 代理与 Digi 调制解调器之间的网络连接
- 如果在代理后面运行,请确保按照 Bindplane 代理要求打开防火墙端口
- 对 Digi Remote Manager 或本地 Digi Modem Web 界面的特权访问权限
获取 Bindplane 代理的 Google SecOps 凭证
如需向 Google SecOps 验证 Bindplane 代理,请选择以下方法之一:
- 新部署:使用 Chronicle API(选项 1)。
- 旧版部署:继续使用数据注入身份验证文件(方法 2),直到 Ingestion API 于 2027 年 7 月 20 日停用。
方法 1:为 Chronicle API 创建服务账号(推荐)
- 登录 Google Cloud 控制台,然后选择与您的 Google SecOps 实例关联的 Google Cloud 项目。
- 依次前往 IAM 和管理 > 服务账号。
- 点击创建服务账号。
- 提供以下配置详细信息:
- 服务账号名称:输入账号的名称(例如
bindplane-ingest)。 - 服务账号说明:输入说明(例如
Bindplane agent log ingestion)。
- 服务账号名称:输入账号的名称(例如
- 点击创建并继续。
- 在向此服务账号授予对项目的访问权限部分,点击选择角色,然后选择 Chronicle Editor。
- 点击继续,然后点击完成。
- 点击您创建的服务账号,然后前往密钥标签页。
- 依次点击添加密钥 > 创建新密钥。
- 选择 JSON,然后点击创建。密钥文件会下载到您的计算机上。
- 将密钥文件另存为 Bindplane 收集器目录(Linux 上的
/opt/observiq-otel-collector/ingestion-auth.json或 Windows 上的C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json)中的ingestion-auth.json,或更新config.yaml中的creds_file_path以匹配您保存它的路径。 - 前往 IAM 和管理 > 设置,然后复制项目编号。您在配置导出器时需要用到该名称。
方法 2:下载数据注入身份验证文件(旧版)
- 登录 Google SecOps 控制台。
- 依次前往设置 > 数据管理 > 收集代理。如果您使用的是仅限 SIEM 的平台,请依次前往设置 > 收集代理。
- 下载数据注入身份验证文件。
- 将该文件安全地保存在将要安装 Bindplane 代理的系统上。
获取 Google SecOps 客户 ID
- 登录 Google SecOps 控制台。
- 依次前往设置 > 管理 > 个人资料。如果您使用的是仅限 SIEM 的平台,请依次前往设置 > 个人资料。
复制并保存组织详细信息部分中的客户 ID。
安装 Bindplane 代理
根据以下说明,在 Windows 或 Linux 操作系统上安装 Bindplane 代理。
Windows 安装
- 以管理员身份打开命令提示符或 PowerShell。
运行以下命令:
msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quiet等待安装完成。
运行以下命令,验证安装是否成功:
sc query observiq-otel-collector该服务应显示为正在运行。
Linux 安装
- 打开具有 root 或 sudo 权限的终端。
运行以下命令:
sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.sh等待安装完成。
运行以下命令,验证安装是否成功:
sudo systemctl status observiq-otel-collector该服务应显示为 active (running)。
其他安装资源
如需了解其他安装选项和问题排查,请参阅 Bindplane 代理安装指南。
配置 Bindplane 代理以注入 syslog 并发送到 Google SecOps
找到配置文件
Linux:
sudo nano /opt/observiq-otel-collector/config.yamlWindows:
notepad "C:\Program Files\observIQ OpenTelemetry Collector\config.yaml"
修改配置文件
将
config.yaml的全部内容替换为以下配置:receivers: udplog: listen_address: "0.0.0.0:514" exporters: chronicle/digi_modems: protocol: https # Region of your instance, for example us, europe, asia-southeast1 location: <LOCATION> # Project number of the Google Cloud project linked to the instance project: '<PROJECT_NUMBER>' compression: gzip creds_file_path: '/opt/observiq-otel-collector/ingestion-auth.json' customer_id: '<customer_id>' endpoint: chronicle.googleapis.com log_type: DIGI_MODEMS raw_log_field: body service: pipelines: logs/digi_modems_to_chronicle: receivers: - udplog exporters: - chronicle/digi_modems
配置参数
替换以下占位符:
接收器配置:
listen_address:要监听的 IP 地址和端口:0.0.0.0,以监听所有接口(推荐)- 端口
514是标准 syslog 端口(在 Linux 上需要 root 权限;对于非 root 用户,请使用1514)
导出器配置:
creds_file_path:服务账号 JSON 密钥文件的完整路径(选项 1):- Linux:
/opt/observiq-otel-collector/ingestion-auth.json - Windows:
C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json
- Linux:
customer_id:从 Google SecOps 控制台复制的客户 IDlocation:将<LOCATION>替换为 Google SecOps 实例所在的区域(例如us、europe或asia-southeast1)。导出工具会在此值前面加上chronicle.googleapis.com。如需查看完整列表,请参阅区域级端点。project:将<PROJECT_NUMBER>替换为 IAM 和管理 > 设置中的项目编号。endpoint:保持设置为chronicle.googleapis.com。
旧版提取 API 导出工具
如果您使用选项 2 中的数据注入身份验证文件,请将
exporters代码块替换为以下内容。将creds_file_path设置为数据注入身份验证文件的路径,如果您的实例位于美国境外,请将malachiteingestion-pa.googleapis.com替换为您的区域端点(例如europe-malachiteingestion-pa.googleapis.com)。exporters: chronicle/digi_modems: compression: gzip creds_file_path: '/opt/observiq-otel-collector/ingestion-auth.json' customer_id: '<customer_id>' endpoint: malachiteingestion-pa.googleapis.com log_type: DIGI_MODEMS raw_log_field: body
保存配置文件
- 修改后,保存文件:
- Linux:依次按
Ctrl+O、Enter和Ctrl+X - Windows:依次点击文件 > 保存
- Linux:依次按
重启 Bindplane 代理以应用更改
如需在 Linux 中重启 Bindplane 代理,请运行以下命令:
sudo systemctl restart observiq-otel-collector验证服务是否正在运行:
sudo systemctl status observiq-otel-collector检查日志中的错误:
sudo journalctl -u observiq-otel-collector -f
如需在 Windows 中重启 Bindplane 代理,请选择以下选项之一:
以管理员身份运行命令提示符或 PowerShell:
net stop observiq-otel-collector && net start observiq-otel-collector“服务”控制台:
- 按
Win+R,输入services.msc,然后按 Enter 键。 - 找到 observIQ OpenTelemetry 收集器。
- 右键点击并选择重启。
验证服务是否正在运行:
sc query observiq-otel-collector检查日志中的错误:
type "C:\Program Files\observIQ OpenTelemetry Collector\log\collector.log"
- 按
在 Digi 调制解调器上配置 syslog 服务器
- 登录 Digi Remote Manager 或本地 Digi Modem 网页界面。
- 使用 Remote Manager 访问设备配置:
- 找到要为其配置 syslog 的设备。
- 依次点击设备 ID > 设置 > 配置。
- 使用本地 Digi Modem Web 界面访问设备配置:
- 依次点击系统 > 配置 > 设备配置。
- 依次前往系统 > 日志。
- 点击以展开服务器列表。
- 点击添加服务器 +。
- 提供以下配置详细信息:
- 服务器:输入 Bindplane 代理 IP 地址。
- 选择要发送到服务器的事件类别(默认情况下,所有事件类别均处于启用状态)。
- Syslog 出站流量端口:输入 Bindplane 代理端口号(默认值为
514)。 - 协议:选择 UDP。
- 点击应用。
支持的 Digi 调制解调器示例日志
SYSLOG
{ "priority": 14, "timestamp": "Dec 28 17:27:45", "hostname": "host-device.router", "tag": "Eventlog", "message": "17:27:33, 28 Dec 2006,Login failure by Host: 10.0.0.25:23: CMD,Telnet" }SYSLOG
{ "priority": 14, "timestamp": "May 25 11:03:55", "hostname": "internal-srv-01", "tag": "Eventlog", "message": "11:03:55, 25 May 2023,Login failure by sanitized_user: WEB" }SYSLOG
{ "priority": 14, "timestamp": "Jun 11 23:58:26", "hostname": "internal-srv-01", "tag": "Eventlog", "message": "23:58:26, 11 Jun 2023,Login failure by GET /masked_path HTTP/1.0: CMD,Telnet" }SYSLOG
{ "priority": 14, "timestamp": "Jun 19 19:52:19", "hostname": "gateway-device-02", "tag": "Eventlog", "message": "19:52:18, 19 Jun 2023,WEB Login OK by internal_admin lvl 0" }
UDM 映射表
| 日志字段 | UDM 映射 | 逻辑 |
|---|---|---|
| 内容 | security_result.description | 在初始 grok 解析后直接从 content 字段映射。 |
| http_method | network.http.method | 使用 grok 模式从 content 字段中提取。 |
| http_version | network.application_protocol_version | 使用 grok 模式从 content 字段中提取。 |
| 主机名 | principal.hostname | 使用 grok 模式从日志消息中提取。 |
| ip | target.ip | 使用 grok 模式从 content 字段中提取。 |
| 端口 | target.port | 使用 grok 模式从 content 字段中提取并转换为整数。 |
| proto | network.application_protocol | 使用 grok 模式从 content 字段中提取。 |
| ts | metadata.event_timestamp | 使用 grok 模式从日志消息中提取并转换为时间戳。 |
| 类型 | login_type_label.value | 使用 grok 模式从 content 字段中提取。 |
| extensions.auth.type | 由解析器逻辑设置为 MACHINE。 |
|
| login_type_label.key | 由解析器逻辑设置为 Login type。 |
|
| metadata.event_type | 由是否存在特定字段(例如 ip 或 user)决定,并相应地设置为 NETWORK_CONNECTION 或 USER_LOGIN。 |
|
| metadata.log_type | 由解析器逻辑设置为 DIGI_MODEMS。 |
|
| metadata.product_event_type | 从日志消息中的 product_type 字段中提取。 |
|
| metadata.product_name | 由解析器逻辑设置为 DIGI_MODEMS。 |
|
| metadata.vendor_name | 由解析器逻辑设置为 DIGI_MODEMS。 |
|
| security_result.action | 由消息中是否存在 Login OK 或 Login failure 决定,并分别设置为 ALLOW 或 BLOCK。 |
|
| 用户 | target.user.userid | 使用 grok 模式从 content 字段中提取。 |