收集 HPE Nimble Storage OS 日志
本文档介绍了如何使用 Bindplane 将 HPE Nimble Storage OS 日志注入 Google Security Operations。
HPE Nimble Storage OS 是一种存储阵列操作系统,可生成系统、硬件和复制日志。该平台可监控存储操作,并为容量管理、阵列健康状况和数据保护活动提供详细的事件日志记录。HPE Nimble Storage 阵列支持将系统事件原生 syslog 转发到外部收集器。
准备工作
请确保满足以下前提条件:
- Google SecOps 实例
- Windows Server 2016 或更高版本,或具有
systemd的 Linux 主机 - Bindplane 代理与 HPE Nimble Storage 阵列之间的网络连接
- 如果通过代理运行,请确保防火墙端口根据 Bindplane 代理要求处于打开状态
- 对 HPE Nimble Storage 阵列具有管理员权限的特权访问权限
获取 Google SecOps 注入身份验证文件
- 登录 Google SecOps 控制台。
- 依次前往 SIEM 设置 > 收集代理。
下载数据注入身份验证文件 。将该文件安全地保存在将安装 Bindplane 的系统上。
获取 Google SecOps 客户 ID
- 登录 Google SecOps 控制台。
- 依次前往 SIEM 设置 > 个人资料。
从组织详细信息 部分复制并保存客户 ID 。
安装 Bindplane 代理
按照以下说明在 Windows 或 Linux 操作系统上安装 Bindplane 代理。
Windows 安装
- 以管理员身份打开命令提示符 或 PowerShell 。
运行以下命令:
msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quiet等待安装完成。
运行以下命令,验证安装是否成功:
sc query observiq-otel-collector
该服务应显示为正在运行 。
Linux 安装
- 使用 root 或 sudo 权限打开终端。
运行以下命令:
sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.sh等待安装完成。
运行以下命令,验证安装是否成功:
sudo systemctl status observiq-otel-collector
该服务应显示为活跃 (正在运行) 。
其他安装资源
如需了解其他安装选项和问题排查,请参阅 Bindplane 代理安装指南。
配置 Bindplane 代理以注入 syslog 并发送到 Google SecOps
找到配置文件
Linux :
sudo systemctl status observiq-otel-collectorWindows :
notepad "C:\Program Files\observIQ OpenTelemetry Collector\config.yaml"
修改配置文件
将
config.yaml的全部内容替换为以下配置:receivers: udplog: listen_address: "0.0.0.0:514" exporters: chronicle/nimble_os: compression: gzip creds_file_path: '/etc/bindplane-agent/ingestion-auth.json' customer_id: '<customer_id>' endpoint: malachiteingestion-pa.googleapis.com log_type: NIMBLE_OS raw_log_field: body ingestion_labels: env: production service: pipelines: logs/nimble_to_chronicle: receivers: - udplog exporters: - chronicle/nimble_os
配置参数
替换以下占位符:
接收器配置:
udplog:基于协议的接收器类型:- UDP syslog 的
udplog - TCP syslog 的
tcplog
- UDP syslog 的
0.0.0.0:要监听的 IP 地址:0.0.0.0以监听所有接口(推荐)- 要监听一个接口的特定 IP 地址
514:要监听的端口号(例如514、1514、6514)
导出器配置:
nimble_os:导出器的描述性名称creds_file_path:注入身份验证文件的完整路径:- Linux:
/etc/bindplane-agent/ingestion-auth.json - Windows:
C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json
- Linux:
<customer_id>:上一步中的客户 IDendpoint:区域级端点网址:- 美国:
malachiteingestion-pa.googleapis.com - 欧洲:
europe-malachiteingestion-pa.googleapis.com - 亚洲:
asia-southeast1-malachiteingestion-pa.googleapis.com - 如需查看完整列表,请参阅区域级端点
- 美国:
NIMBLE_OS:日志类型,与 Chronicle 中显示的内容完全一致ingestion_labels:YAML 格式的可选标签(例如env: production)
流水线配置:
nimble_to_chronicle:流水线的描述性名称
保存配置文件
- 修改后,保存文件:
- Linux:依次按
Ctrl+O、Enter和Ctrl+X - Windows:依次点击文件 > 保存
- Linux:依次按
重启 Bindplane 代理以应用更改
如需在 Linux 中重启 Bindplane 代理,请执行以下操作:
运行以下命令:
sudo systemctl restart observiq-otel-collector验证服务正在运行:
sudo systemctl status observiq-otel-collector检查日志中的错误:
sudo journalctl -u observiq-otel-collector -f
如需在 Windows 中重启 Bindplane 代理,请执行以下操作:
请从下列选项中选择一项:
- 以管理员身份运行命令提示符或 PowerShell:
net stop observiq-otel-collector && net start observiq-otel-collector- 服务控制台:
- 按
Win+R,输入services.msc,然后按 Enter 键。 - 找到 observIQ OpenTelemetry Collector 。
- 右键点击并选择重启 。
- 按
验证服务正在运行:
sc query observiq-otel-collector检查日志中的错误:
type "C:\Program Files\observIQ OpenTelemetry Collector\log\collector.log"
配置 HPE Nimble Storage OS syslog 转发
HPE Nimble Storage 阵列支持将系统、硬件和复制事件日志转发到外部 syslog 服务器。您可以使用 CLI 或管理 GUI 配置 syslog 转发。
使用 CLI 配置 syslog
使用管理员凭据通过 SSH 连接到 HPE Nimble Storage 阵列:
ssh admin@<nimble_array_ip>启用 syslog 并将 Bindplane 代理指定为 syslog 服务器:
group --edit --syslog_server <bindplane_agent_ip>(可选)指定自定义 syslog 端口(默认为
514):group --edit --syslog_port <port_number>验证 syslog 配置:
group --info | grep -i syslog输出应显示
Syslogd enabled: Yes,以及配置的服务器地址和端口。
使用管理 GUI 配置 syslog
- 登录 HPE Nimble Storage 管理界面。
- 依次前往管理 > Syslog。
- 点击启用 Syslog 服务器 。
- 在服务器 字段中,输入 Bindplane 代理主机的 IP 地址。
- 在端口 字段中,输入与 Bindplane 代理接收器配置(默认
514)匹配的端口。 - 点击保存 。
UDM 映射表
| 日志字段 | UDM 映射 | 逻辑 |
|---|---|---|
| extensions.auth.mechanism | 身份验证机制 | |
| extensions.auth.type | 身份验证类型 | |
| data_message | metadata.description | 事件说明 |
| type | metadata.event_type | 事件类型 |
| type | metadata.product_event_type | 产品事件类型 |
| id | metadata.product_log_id | 产品日志 ID |
| version | metadata.product_version | 产品版本 |
| group | principal.group.group_display_name | 群组显示名称 |
| logsource | principal.hostname | Principal 主机名 |
| client_ip | principal.ip | Principal IP 地址 |
| array | principal.resource.name | 资源名称 |
| principal.resource.resource_subtype | 资源子类型 | |
| principal.resource.resource_type | 资源类型 | |
| status | security_result.action | 安全操作 |
| error | security_result.description | 安全结果说明 |
| security_result.summary | 安全结果摘要 | |
| filename,target | target.file.full_path | 文件完整路径 |
| object_id | target.resource.id | 资源 ID |
| object,target,filename,partner,volname | target.resource.name | 资源名称 |
| target.resource.resource_subtype | 资源子类型 | |
| target.resource.resource_type | 资源类型 | |
| target.user.user_display_name | 用户显示名称 | |
| username | target.user.userid | 用户 ID |
| metadata.product_name | 产品名称 | |
| metadata.vendor_name | 供应商名称 |