收集 Symantec Messaging Gateway 日志

支持的环境:

本文档介绍了如何使用 Bindplane 将 Symantec Messaging Gateway 日志注入 Google Security Operations。

Symantec Messaging Gateway 是一种电子邮件安全网关,可为企业电子邮件提供反垃圾邮件、反恶意软件和内容过滤功能。它支持对电子邮件处理事件、政策执行和系统健康状况日志进行原生 syslog 转发。

准备工作

请确保满足以下前提条件:

  • Google SecOps 实例
  • Windows Server 2016 或更高版本,或者具有 systemd 的 Linux 主机
  • Bindplane 代理与 Symantec Messaging Gateway 设备之间的网络连接
  • 如果通过代理运行,请确保防火墙端口根据 Bindplane 代理要求处于开放状态
  • 对 Symantec Messaging Gateway 管理控制台的特权访问权限

获取 Google SecOps 注入身份验证文件

  1. 登录 Google SecOps 控制台。
  2. 前往 SIEM 设置 > 收集代理
  3. 下载数据注入身份验证文件 。将该文件安全地保存在将安装 Bindplane 的系统上。

获取 Google SecOps 客户 ID

  1. 登录 Google SecOps 控制台。
  2. 前往 SIEM 设置 > 个人资料
  3. 组织详细信息 部分复制并保存客户 ID

安装 Bindplane 代理

按照以下说明在 Windows 或 Linux 操作系统上安装 Bindplane 代理。

Windows 安装

  1. 以管理员身份打开命令提示符PowerShell
  2. 运行以下命令:

    msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quiet
    
  3. 等待安装完成。

  4. 运行以下命令,验证安装是否成功:

    sc query observiq-otel-collector
    

该服务应显示为正在运行

Linux 安装

  1. 使用 root 或 sudo 权限打开终端。
  2. 运行以下命令:

    sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.sh
    
  3. 等待安装完成。

  4. 运行以下命令,验证安装是否成功:

    sudo systemctl status observiq-otel-collector
    

该服务应显示为活跃 (正在运行)

其他安装资源

如需了解其他安装选项和问题排查方法,请参阅 Bindplane 代理安装指南

配置 Bindplane 代理以注入 syslog 并发送到 Google SecOps

找到配置文件

  • Linux

    sudo nano /etc/bindplane-agent/config.yaml
    
  • Windows

    notepad "C:\Program Files\observIQ OpenTelemetry Collector\config.yaml"
    

修改配置文件

  • config.yaml 的全部内容替换为以下配置:

    receivers:
        udplog:
            listen_address: "0.0.0.0:514"
    
    exporters:
        chronicle/symantec_mail:
            compression: gzip
            creds_file_path: '/etc/bindplane-agent/ingestion-auth.json'
            customer_id: '<customer_id>'
            endpoint: malachiteingestion-pa.googleapis.com
            log_type: SYMANTEC_MAIL
            raw_log_field: body
    
    service:
        pipelines:
            logs/symantec_mail_to_chronicle:
                receivers:
                    - udplog
                exporters:
                    - chronicle/symantec_mail
    

配置参数

替换以下占位符:

  • 接收器配置

    • listen_address:要监听的 IP 地址和端口:
      • 0.0.0.0 以监听所有接口(推荐)
      • 端口 514 是标准 syslog 端口(在 Linux 上需要 root;对于非 root 用户,请使用 1514
  • 导出器配置

    • creds_file_path:注入身份验证文件的完整路径:
      • Linux: /etc/bindplane-agent/ingestion-auth.json
      • Windows: C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json
    • customer_id:从 Google SecOps 控制台复制的客户 ID
    • endpoint:区域级端点网址:
      • 美国malachiteingestion-pa.googleapis.com
      • 欧洲: europe-malachiteingestion-pa.googleapis.com
      • 亚洲: asia-southeast1-malachiteingestion-pa.googleapis.com
      • 如需查看完整列表,请参阅区域级端点

保存配置文件

  • 修改后,保存文件:
    • Linux:依次按 Ctrl+OEnterCtrl+X
    • Windows:依次点击文件 > 保存

重启 Bindplane 代理以应用更改

如需在 Linux 中重启 Bindplane 代理,请执行以下操作:

  1. 运行以下命令:

    sudo systemctl restart observiq-otel-collector
    
  2. 验证服务是否正在运行:

    sudo systemctl status observiq-otel-collector
    
  3. 检查日志中是否存在错误:

    sudo journalctl -u observiq-otel-collector -f
    

如需在 Windows 中重启 Bindplane 代理,请执行以下操作:

  1. 请从下列选项中选择一项:

    • 以管理员身份运行命令提示符或 PowerShell:
    net stop observiq-otel-collector && net start observiq-otel-collector
    
    • 服务控制台:
      1. Win+R,输入 services.msc,然后按 Enter 键。
      2. 找到 observIQ OpenTelemetry Collector
      3. 右键点击并选择重启
  2. 验证服务是否正在运行:

    sc query observiq-otel-collector
    
  3. 检查日志中是否存在错误:

    type "C:\Program Files\observIQ OpenTelemetry Collector\log\collector.log"
    

配置 Symantec Messaging Gateway syslog 转发

  1. 登录 Symantec Messaging Gateway 管理控制台。
  2. 依次前往管理 > 设置 > 日志
  3. 点击远程 标签页。
  4. 启用 Syslog
  5. 配置远程 syslog 服务器:
    • 主机:输入 Bindplane 代理主机的 IP 地址。
    • 端口:输入 514
  6. 点击保存

UDM 映射表

日志字段 UDM 映射 逻辑
file.fileNameOrURL about.file.full_path 直接复制 FILE_INCLUDED 的值
file.md5 about.file.md5 直接复制 FILE_INCLUDED 的值
file.fileType about.file.mime_type 直接复制 FILE_INCLUDED 的值
file.sha256 about.file.sha256 直接复制 FILE_INCLUDED 的值
file.fileSize about.file.size 转换为 FILE_INCLUDED 的 uinteger
file.urlCategories、file.urlRiskScore about.labels 合并 LINK_INCLUDED 的标签
file.fileNameOrURL about.url 直接复制 LINK_INCLUDED 的值
emailInfo.longMsgRef, emailInfo.messageId, emailInfo.isOutbound, emailInfo.HELOString, emailInfo.authResults.raw_header, emailInfo.authResults.dkim, emailInfo.authResults.dkim_signing_domain, emailInfo.authResults.spf, emailInfo.authResults.dmarc, emailInfo.authResults.dmarc_policy, emailInfo.authResults.dmarc_override_action, emailInfo.tlsInfo.tlsAdvertised, emailInfo.tlsInfo.tlsUsed, emailInfo.tlsInfo.tlsKeyLength, emailInfo.tlsInfo.tlsFallbackReason, emailInfo.tlsInfo.tlsForwardSecrecy, emailInfo.tlsInfo.tlsNegotiationFailed, emailInfo.messageSize, emailInfo.avQuarantinePenId, emailInfo.rawHeaderFrom, emailInfo.headerReplyTo, emailInfo.newDomainAge, emailInfo.timeInCynicSandboxMs, incidents additional.fields 合并为标签
emailInfo.mailProcessingStartTime、@timestamp metadata.event_timestamp 如果存在,则从 mailProcessingStartTime 转换;否则从 @timestamp 转换
metadata.event_type 如果 email_from_present 和 email_to_present,则设置为“EMAIL_TRANSACTION”;否则,如果 has_principal 和 has_target,则设置为“NETWORK_CONNECTION”;否则,如果 has_user,则设置为“USER_UNCATEGORIZED”;否则,如果 has_principal,则设置为“STATUS_UPDATE”;否则设置为“GENERIC_EVENT”
emailInfo.xMsgRef metadata.product_log_id 直接复制值
emailInfo.headerFrom network.email.from 如果与电子邮件模式匹配,则直接复制值
emailInfo.subject network.email.subject 直接复制值
emailInfo.envTo、emailInfo.headerTo network.email.to 如果与电子邮件模式匹配,则从 envTo 和 headerTo 合并
emailInfo.tlsInfo.tlsCipher network.tls.cipher 直接复制值
emailInfo.senderMailserver network.tls.client.server_name 直接复制值
emailInfo.tlsInfo.tlsPolicy network.tls.version 直接复制值
emailInfo.tlsInfo.tlsProtocol network.tls.version_protocol 直接复制值
emailInfo.senderMailserver principal.hostname 直接复制值
emailInfo.senderIp principal.ip 直接复制值
emailInfo.country principal.location.country_or_region 直接复制值
emailInfo.envFrom principal.user.email_addresses 直接复制值
metadata.product_name 设置为“SYMANTEC_MAIL”
metadata.vendor_name 设置为“SYMANTEC_MAIL”
hostname event.idm.read_only_udm.principal.hostnameevent.idm.read_only_udm.principal.asset.hostname 从更新日志映射
process event.idm.read_only_udm.principal.process.file.names 从更新日志映射
pid event.idm.read_only_udm.principal.process.pid 从更新日志映射
tag event.idm.read_only_udm.metadata.product_event_type 从更新日志映射
loglevel event.idm.read_only_udm.security_result.severity 从更新日志映射
log_id event.idm.read_only_udm.metadata.product_log_id 从更新日志映射
internal_id event.idm.read_only_udm.additional.fields 从更新日志映射
ruleset event.idm.read_only_udm.additional.fields 从更新日志映射
ttl event.idm.read_only_udm.additional.fields 从更新日志映射
source event.idm.read_only_udm.additional.fields 从更新日志映射
allow_redirect event.idm.read_only_udm.additional.fields 从更新日志映射
transaction_id event.idm.read_only_udm.additional.fields 从更新日志映射
component event.idm.read_only_udm.additional.fields 从更新日志映射
msg_code event.idm.read_only_udm.additional.fields 从更新日志映射
url event.idm.read_only_udm.target.url 从更新日志映射
status event.idm.read_only_udm.network.http.response_code 从更新日志映射
description event.idm.read_only_udm.security_result.description 从更新日志映射
priority event.idm.read_only_udm.metadata.ingestion_labels 从更新日志映射
timestamp event.idm.read_only_udm.metadata.event_timestamp 从更新日志映射
emailInfo.longMsgRef", "emailInfo.messageId", "emailInfo.isOutbound", "emailInfo.HELOString", "emailInfo.authResults.raw_header", "emailInfo.authResults.dkim", "emailInfo.authResults.dkim_signing_domain", "emailInfo.authResults.spf", "emailInfo.authResults.dmarc", "emailInfo.authResults.dmarc_policy", "emailInfo.authResults.dmarc_override_action", "emailInfo.tlsInfo.tlsAdvertised", "emailInfo.tlsInfo.tlsUsed", "emailInfo.tlsInfo.tlsKeyLength", "emailInfo.tlsInfo.tlsFallbackReason", "emailInfo.tlsInfo.tlsForwardSecrecy", "emailInfo.tlsInfo.tlsNegotiationFailed", "emailInfo.messageSize", "emailInfo.avQuarantinePenId", "emailInfo.rawHeaderFrom", "emailInfo.headerReplyTo", "emailInfo.newDomainAge", "emailInfo.timeInCynicSandboxMs", and "incidents additional.fields 从更新日志映射

更新日志

查看此解析器的更新日志

需要更多帮助?获得社区成员和 Google SecOps 专业人士的解答。