收集 Cisco 无线局域网控制器 (WLC) 日志
解析器版本:12.0
本文档介绍了如何使用 Bindplane 代理将 Cisco 无线局域网控制器 (WLC) 日志注入到 Google Security Operations。
解析器使用 grok 模式从 Cisco WLC syslog 消息中提取字段,处理各种日志格式,包括 DHCP、身份验证和网络事件。它将提取的字段映射到统一数据模型 (UDM),并根据 mnemonic 和消息内容确定事件类型。
准备工作
请确保满足以下前提条件:
- Google SecOps 实例
- Windows Server 2016 或更高版本,或者具有
systemd的 Linux 主机 - Bindplane 代理与 Cisco WLC 之间的网络连接
- 如果在代理后面运行,请确保防火墙端口已根据 Bindplane 代理要求打开
- 对 Cisco WLC 的特权访问权限
获取 Google SecOps 注入身份验证文件
- 登录 Google SecOps 控制台。
- 依次前往 SIEM 设置 > 收集代理。
- 下载数据注入身份验证文件
将文件安全地保存在将要安装 Bindplane 代理的系统上。
获取 Google SecOps 客户 ID
- 登录 Google SecOps 控制台。
- 依次前往 SIEM 设置 > 配置文件。
复制并保存组织详细信息部分中的客户 ID。
安装 Bindplane 代理
按照以下说明在 Windows 或 Linux 操作系统上安装 Bindplane 代理。
Windows 安装
- 以管理员身份打开命令提示符或 PowerShell。
运行以下命令:
msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quiet等待安装完成。
运行以下命令,验证安装是否成功:
sc query observiq-otel-collector该服务应显示为 正在运行。
Linux 安装
- 打开具有 root 或 sudo 权限的终端。
运行以下命令:
sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.sh等待安装完成。
运行以下命令,验证安装是否成功:
sudo systemctl status observiq-otel-collector该服务应显示为有效(正在运行)。
其他安装资源
如需了解其他安装选项和问题排查信息,请参阅 Bindplane 代理安装指南。
配置 Bindplane 代理以注入 syslog 并将其发送到 Google SecOps
找到配置文件
Linux:
sudo nano /etc/bindplane-agent/config.yamlWindows:
notepad "C:\Program Files\observIQ OpenTelemetry Collector\config.yaml"
修改配置文件
将
config.yaml的全部内容替换为以下配置:receivers: udplog: listen_address: "0.0.0.0:514" exporters: chronicle/cisco_wireless: compression: gzip creds_file_path: '/etc/bindplane-agent/ingestion-auth.json' customer_id: '<customer_id>' endpoint: malachiteingestion-pa.googleapis.com log_type: CISCO_WIRELESS raw_log_field: body service: pipelines: logs/cisco_wireless_to_chronicle: receivers: - udplog exporters: - chronicle/cisco_wireless
配置参数
替换以下占位符:
接收器配置:
listen_address:要监听的 IP 地址和端口:0.0.0.0侦听所有接口(推荐)- 端口
514是标准 syslog 端口(在 Linux 上需要 root 权限;对于非 root 用户,请使用1514)
导出器配置:
creds_file_path:提取身份验证文件的完整路径:- Linux:
/etc/bindplane-agent/ingestion-auth.json - Windows:
C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json
- Linux:
customer_id:从 Google SecOps 控制台复制的客户 IDendpoint:区域端点网址:- 美国:
malachiteingestion-pa.googleapis.com - 欧洲:
europe-malachiteingestion-pa.googleapis.com - 亚洲:
asia-southeast1-malachiteingestion-pa.googleapis.com - 如需查看完整列表,请参阅区域级端点
- 美国:
保存配置文件
- 修改后,保存文件:
- Linux:依次按
Ctrl+O、Enter和Ctrl+X - Windows:依次点击文件 > 保存
- Linux:依次按
重启 Bindplane 代理以应用更改
如需在 Linux 中重启 Bindplane 代理,请运行以下命令:
sudo systemctl restart observiq-otel-collector验证服务是否正在运行:
sudo systemctl status observiq-otel-collector检查日志是否存在错误:
sudo journalctl -u observiq-otel-collector -f
如需在 Windows 中重启 Bindplane 代理,请选择以下选项之一:
以管理员身份运行命令提示符或 PowerShell:
net stop observiq-otel-collector && net start observiq-otel-collector服务控制台:
- 按
Win+R,输入services.msc,然后按 Enter 键。 - 找到 observIQ OpenTelemetry 收集器。
- 右键点击并选择重新启动。
验证服务是否正在运行:
sc query observiq-otel-collector检查日志是否存在错误:
type "C:\Program Files\observIQ OpenTelemetry Collector\log\collector.log"
- 按
在 Cisco WLC 上配置 syslog
- 登录 WLC 网页界面。
- 依次前往管理 > 日志 > 配置。
- 在 Syslog 服务器 IP 地址字段中输入 Bindplane 代理 IP 地址。
- 点击 Add(添加)。
- 提供以下配置详细信息:
- Syslog 严重程度:选择 Informational。
- Syslog Facility:选择 Local Use 0。
- 点击应用。
点击保存配置。
UDM 映射表
| 日志字段 | UDM 映射 | 逻辑 |
|---|---|---|
action_data |
read_only_udm.security_result.action_details |
直接从 action_data 字段映射。 |
data |
read_only_udm.metadata.description |
在经过一些处理(例如移除时间戳、多余字符)后,直接从 data 字段映射。从日志消息开头的时间戳中提取。解析器可处理各种格式。根据 cisco_wireless.include 文件中的复杂逻辑,基于 mnemonic 和 messageToProcess 字段确定。设置为“CISCO_WIRELESS”。facility、cisco_severity 和 mnemonic 字段的串联。如果可用,则从日志消息中提取。设置为“CISCO_WIRELESS”。如果可用,则从 version 字段中提取。设置为“CISCO”。如果事件与 DHCP 相关,则设置为“DHCP”。对于广播网络事件,请设置为“BROADCAST”。对于 UDP 网络事件,请设置为“UDP”。从说明中提取(如有)。从说明中提取(如有)。根据日志格式,从 wlc_controller 或 hostname 字段映射。从说明或 MessageSourceAddress 中提取(如有)。根据日志格式,从 wlc_controller 或 hostname 字段映射。从说明或 MessageSourceAddress 中提取(如有)。从说明中提取(如有)。从说明中提取(如有)。根据 SourceModuleName 和 SourceModuleType 字段创建(如果可用)。当用户 ID 看起来像电子邮件地址时,从 read_only_udm.principal.user.userid 映射。从说明中提取(如有)。从说明中提取(如有)。根据活动类型和说明确定。根据活动类型和说明确定。如果可用,则根据说明中的特定字段创建。从说明中提取(如有)。有时会合并多个字段中的信息。根据 cisco_severity 字段和事件类型确定。派生自 read_only_udm.security_result.severity 字段。根据说明和事件类型得出的安全结果的简明摘要。从说明中提取(如有)。从说明中提取(如有)。从说明中提取(如有)。从说明中提取(如有)。从说明中提取(如有)。从说明中提取(如有)。从说明中提取(如有)。对于设置修改事件,请设置为“SETTING”。从说明中提取(如有)。 |
event_data |
read_only_udm.metadata.product_event_type |
直接从 event_data 字段映射。 |
event_id |
read_only_udm.metadata.product_log_id |
直接从 event_id 字段映射。 |
event_ts |
read_only_udm.metadata.event_timestamp |
直接从 event_ts 字段映射。 |
facility |
read_only_udm.metadata.product_event_type |
直接从 facility 字段映射。 |
hostname |
read_only_udm.principal.hostname |
直接从 hostname 字段映射。 |
hostname |
read_only_udm.target.hostname |
直接从 hostname 字段映射。 |
inter_mac |
read_only_udm.intermediary.mac |
直接从 inter_mac 字段映射。 |
intermediary_hostname |
read_only_udm.intermediary.hostname |
直接从 intermediary_hostname 字段映射。 |
kv_data |
read_only_udm.principal.resource.attribute.labels |
解析为键值对,用于填充标签。 |
log_message |
read_only_udm.security_result.description |
直接从 log_message 字段映射。 |
MessageSourceAddress |
read_only_udm.principal.asset.ip |
直接从 MessageSourceAddress 字段映射。 |
MessageSourceAddress |
read_only_udm.principal.ip |
直接从 MessageSourceAddress 字段映射。 |
messageToProcess |
read_only_udm.metadata.description |
经过一些处理后直接从 messageToProcess 字段映射而来。 |
mnemonic |
read_only_udm.metadata.event_type |
与其他字段结合使用,以确定事件类型。 |
mnemonic |
read_only_udm.metadata.product_event_type |
直接从 mnemonic 字段映射。 |
severity_data |
read_only_udm.security_result.severity |
从 severity_data 字段映射而来,并已转换为枚举值。 |
SourceModuleName |
read_only_udm.principal.resource.attribute.labels |
直接从 SourceModuleName 字段映射。 |
SourceModuleType |
read_only_udm.principal.resource.attribute.labels |
直接从 SourceModuleType 字段映射。 |
timestamp |
read_only_udm.metadata.event_timestamp |
直接从 timestamp 字段映射。 |
version |
read_only_udm.metadata.product_version |
直接从 version 字段映射。 |
wlc_controller |
read_only_udm.principal.hostname |
直接从 wlc_controller 字段映射。 |
wlc_controller |
read_only_udm.target.hostname |
直接从 wlc_controller 字段映射。 |
mnemonic |
event.idm.read_only_udm.metadata.product_event_type |
从变更日志映射 |
urlHolder |
event.idm.read_only_udm.target.url |
从变更日志映射 |
syslog_sequence |
event.idm.read_only_udm.additional.fields |
从变更日志映射 |
userid |
event.idm.read_only_udm.principal.user.userid |
从变更日志映射 |
principal_mac |
event.idm.read_only_udm.principal.mac |
从变更日志映射 |
obs_host |
event.idm.read_only_udm.observer.hostname |
从变更日志映射 |
obs_desc |
event.idm.read_only_udm.observer.labels |
从变更日志映射 |
addr |
event.idm.read_only_udm.additional.fields |
从变更日志映射 |
component_status |
event.idm.read_only_udm.additional.fields |
从变更日志映射 |
ecc |
event.idm.read_only_udm.additional.fields |
从变更日志映射 |
multipleErrorsDetected |
event.idm.read_only_udm.additional.fields |
从变更日志映射 |
rep[0] |
event.idm.read_only_udm.additional.fields |
从变更日志映射 |
rep[1] |
event.idm.read_only_udm.additional.fields |
从变更日志映射 |
rep[2] |
event.idm.read_only_udm.additional.fields |
从变更日志映射 |
suppressed_times |
event.idm.read_only_udm.additional.fields |
从变更日志映射 |
valid |
event.idm.read_only_udm.additional.fields |
从变更日志映射 |
interface |
event.idm.read_only_udm.additional.fields |
从变更日志映射 |
event_id |
event.idm.read_only_udm.metadata.product_log_id |
从变更日志映射 |
principal_hostname |
event.idm.read_only_udm.principal.hostname和event.idm.read_only_udm.principal.asset.hostname之间 |
从变更日志映射 |
wlc_controller |
event.idm.read_only_udm.principal.hostname和event.idm.read_only_udm.principal.asset.hostname之间 |
从变更日志映射 |
src_ip_1 |
event.idm.read_only_udm.principal.ip |
从变更日志映射 |
src_ip_2 |
event.idm.read_only_udm.principal.ip |
从变更日志映射 |
mac1 |
event.idm.read_only_udm.principal.mac |
从变更日志映射 |
mac2 |
event.idm.read_only_udm.principal.mac |
从变更日志映射 |
slot |
event.idm.read_only_udm.security_result.detection_fields |
从变更日志映射 |
username |
event.idm.read_only_udm.principal.user.userid |
从变更日志映射 |
src_ip |
event.idm.read_only_udm.principal.ip和event.idm.read_only_udm.principal.asset.ip之间 |
从变更日志映射 |
ssid |
event.idm.read_only_udm.security_result.detection_fields |
从变更日志映射 |
SourceModuleName" and "SourceModuleType |
principal.resource.attribute.labels |
从变更日志映射 |
client_host", and "hostname |
principal.hostname |
从变更日志映射 |
client_ip |
principal.ip |
从变更日志映射 |
client_mac |
principal.mac |
从变更日志映射 |
ap_ip |
target.ip |
从变更日志映射 |
ap_mac |
target.mac |
从变更日志映射 |
messageToProcess" and "description |
metadata.description |
从变更日志映射 |
inter_url |
intermediary.url |
从变更日志映射 |
inter_ip |
intermediary.ip |
从变更日志映射 |
sec_desc |
security_result.description |
从变更日志映射 |
latest_version", "current_version", "certificate", "expiry_date", "clostest_sensor", "ssid", "client", "xid", "failure_reason", "auth_failure_reason", and "interface |
security_result.detection_fields |
从变更日志映射 |
action_data |
security_result.acion_details |
从变更日志映射 |
username |
principal.user.userid |
从变更日志映射 |
vendor", and "RSSI |
principal.resource.attribute.labels |
从变更日志映射 |
vendor", "security_setting", "channel", "protocol", and "RSSI |
target.resource.attribute.labels |
从变更日志映射 |
msg1 |
metadata.description |
从变更日志映射 |
wlc_controller |
event.idm.read_only_udm.principal.hostname |
从变更日志映射 |
event.idm.read_only_udm.metadata.event_type |
USER_RESOURCE_ACCESS |
从变更日志映射 |