收集 Preempt 日志

支持范围:

本文档介绍了如何使用 Bindplane 代理将 Preempt 日志注入到 Google Security Operations 中。

Preempt Security 是一种身份威胁检测和响应平台,可针对 Active Directory 威胁生成安全提醒,包括异常身份验证行为、提权和横向移动。它通过 syslog 以 CEF(通用事件格式)格式导出日志。

准备工作

请确保满足以下前提条件:

  • Google SecOps 实例
  • Windows Server 2016 或更高版本,或者具有 systemd 的 Linux 主机
  • Bindplane 代理与 Preempt 服务器之间的网络连接
  • 如果通过代理运行,请确保防火墙端口根据 Bindplane 代理要求处于打开状态
  • 对 Preempt 管理控制台的特权访问权限,并具有管理员权限

获取 Bindplane 代理的 Google SecOps 凭据

如需对 Bindplane 代理进行 Google SecOps 身份验证,请选择以下方法之一:

  • 新部署:使用 Chronicle API(方法 1)。
  • 旧版部署:继续使用注入身份验证文件(方法 2),直到注入 API 于 2027 年 7 月 20 日停用为止。
  1. 登录 Google Cloud 控制台,然后选择与您的 Google SecOps 实例关联的 Google Cloud 项目。
  2. 依次前往 IAM 和管理 > 服务账号。
  3. 点击创建服务账号 。
  4. 提供以下配置详细信息:
    • 服务账号名称:输入账号的名称(例如 bindplane-ingest)。
    • 服务账号说明:输入说明(例如 Bindplane agent log ingestion)。
  5. 点击创建并继续 。
  6. 在向此服务帐号授予对项目的访问权限 部分,点击选择角色 ,然后选择 Chronicle Editor 。
  7. 点击继续 ,然后点击完成 。
  8. 点击您创建的服务帐号,然后前往密钥 标签页。
  9. 依次点击添加密钥 > 创建新密钥。
  10. 选择 JSON ,然后点击创建 。密钥文件会下载到您的计算机上。
  11. 将密钥文件另存为 Bindplane 收集器目录中的 ingestion-auth.json(在 Linux 上为 /opt/observiq-otel-collector/ingestion-auth.json,在 Windows 上为 C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json),或者更新 creds_file_path 在 config.yaml 中以与您保存该文件的路径匹配。
  12. 依次前往 IAM 和管理 > 设置 ,然后复制项目编号 。您需要此编号进行导出器配置。

方法 2:下载注入身份验证文件(旧版)

  1. 登录 Google SecOps 控制台。
  2. 依次前往 SIEM 设置 > 收集代理。
  3. 下载注入身份验证文件 。
  4. 将该文件安全地保存在将安装 Bindplane 代理的系统上。

获取 Google SecOps 客户 ID

  1. 登录 Google SecOps 控制台。
  2. 依次前往 SIEM 设置 > 个人资料。
  3. 从组织详细信息 部分复制并保存客户 ID 。

安装 Bindplane 代理

按照以下说明在 Windows 或 Linux 操作系统上安装 Bindplane 代理。

Windows 安装

  1. 以管理员身份打开命令提示符 或 PowerShell 。
  2. 运行以下命令:

    msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quiet
    
  3. 等待安装完成。

  4. 运行以下命令,验证安装是否成功:

    sc query observiq-otel-collector
    

    该服务应显示为正在运行 。

Linux 安装

  1. 使用 root 或 sudo 权限打开终端。
  2. 运行以下命令:

    sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.sh
    
  3. 等待安装完成。

  4. 运行以下命令,验证安装是否成功:

    sudo systemctl status observiq-otel-collector
    

    该服务应显示为已激活(正在运行) 。

其他安装资源

如需了解其他安装选项和问题排查信息,请参阅 Bindplane 代理安装指南。

配置 Bindplane 代理以注入 syslog 并将其发送到 Google SecOps

找到配置文件

  • Linux :

    sudo nano /opt/observiq-otel-collector/config.yaml
    
  • Windows :

    notepad "C:\Program Files\observIQ OpenTelemetry Collector\config.yaml"
    

修改配置文件

  • 将 config.yaml 的全部内容替换为以下配置:

    receivers:
      tcplog:
        listen_address: "0.0.0.0:514"
    
    exporters:
      chronicle/preempt:
        protocol: https
        # Region of your instance, for example us, europe, asia-southeast1
        location: <LOCATION>
        # Project number of the Google Cloud project linked to the instance
        project: '<PROJECT_NUMBER>'
        compression: gzip
        creds_file_path: '<CREDS_FILE_PATH>'
        customer_id: '<CUSTOMER_ID>'
        endpoint: chronicle.googleapis.com
        log_type: PREEMPT
        raw_log_field: body
        ingestion_labels:
          env: production
    
    service:
      pipelines:
        logs/preempt_to_chronicle:
          receivers:
            - tcplog
          exporters:
            - chronicle/preempt
    

配置参数

替换以下占位符:

  • 接收器配置:

    • tcplog:通过 TCP 接收 syslog。如果您的 Preempt 部署通过 UDP 转发,请使用 udplog。
    • 0.0.0.0:514:监听端口 514 上的所有接口。如果需要,请更改端口(例如,对于非 root Linux,为 1514)。
  • 导出器配置:

    • <CREDS_FILE_PATH>:服务帐号 JSON 密钥文件的完整路径(方法 1):
      • Linux: /opt/observiq-otel-collector/ingestion-auth.json
      • Windows: C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json
    • <CUSTOMER_ID>:获取 Google SecOps 客户 ID 步骤中的客户 ID。
    • location:将 <LOCATION> 替换为 Google SecOps 实例的区域(例如 us、europe 或 asia-southeast1)。导出器会使用此值为 chronicle.googleapis.com 添加前缀。如需查看完整列表,请参阅区域级端点。
    • project:将 <PROJECT_NUMBER> 替换为 IAM 和管理 > 设置 中的项目编号。
    • endpoint:保持设置为 chronicle.googleapis.com。

旧版注入 API 导出器

  • 如果您使用方法 2 中的注入身份验证文件,请将 exporters 块替换为以下内容。将 creds_file_path 设置为注入身份验证文件的路径,如果您的实例位于美国境外,请将 malachiteingestion-pa.googleapis.com 替换为您的 区域级端点(例如 europe-malachiteingestion-pa.googleapis.com)。

    exporters:
      chronicle/preempt:
        compression: gzip
        creds_file_path: '<CREDS_FILE_PATH>'
        customer_id: '<CUSTOMER_ID>'
        endpoint: malachiteingestion-pa.googleapis.com
        log_type: PREEMPT
        raw_log_field: body
        ingestion_labels:
          env: production
    

保存配置文件

  • 修改后,保存文件:
    • Linux:按 Ctrl+O,然后按 Enter,再按 Ctrl+X
    • Windows:依次点击文件 > 保存

重启 Bindplane 代理以应用更改

  • 如需在 Linux 中重启 Bindplane 代理,请运行以下命令:

    sudo systemctl restart observiq-otel-collector
    
    1. 验证服务是否正在运行:

      sudo systemctl status observiq-otel-collector
      
    2. 检查日志中的错误:

      sudo journalctl -u observiq-otel-collector -f
      
  • 如需在 Windows 中重启 Bindplane 代理,请选择以下选项之一:

    • 以管理员身份运行命令提示符或 PowerShell:

      net stop observiq-otel-collector && net start observiq-otel-collector
      
    • 服务控制台:

      1. 按 Win+R,输入 services.msc,然后按 Enter 键。
      2. 找到 observIQ OpenTelemetry Collector 。
      3. 右键点击并选择重启 。
      4. 验证服务是否正在运行:

        sc query observiq-otel-collector
        
      5. 检查日志中的错误:

        type "C:\Program Files\observIQ OpenTelemetry Collector\log\collector.log"
        

配置 Preempt syslog 转发

  1. 登录 Preempt 管理控制台 。
  2. 依次前往设置 > SIEM 集成。
  3. 启用 syslog 转发。
  4. 提供以下配置详细信息:
    • 协议:选择 TCP (必须与 Bindplane 代理接收器配置匹配)。
    • 格式:选择 CEF。
    • Syslog 服务器地址:输入 Bindplane 代理主机(例如 192.168.1.100)的 IP 地址。
    • 端口:输入 514(必须与 Bindplane 代理接收器端口匹配)。
  5. 选择要转发的事件类型:
    • 提醒
    • 违反政策
    • 异常身份验证事件
  6. 点击保存 或应用 。
  7. 通过检查 Bindplane 代理日志,验证日志是否正在发送。

UDM 映射表

日志字段 UDM 映射 逻辑
event_id, _target metadata.event_type 如果 _target 不为空且 event_id == "SUSPICIOUS_DOMAIN_ACTIVITY",则设置为“SCAN_NETWORK”;如果 _target 不为空且 event_id 在 ["UNUSUAL_ENDPOINT_ACCESS", "UNUSUAL_ACTIVITY", "UNUSUAL_ENDPOINT_USE"] 中,则设置为“USER_UNCATEGORIZED”;如果 event_id == "APPLIANCE_CONNECTIVITY_FAILURE",则设置为“NETWORK_UNCATEGORIZED”;否则设置为“GENERIC_EVENT”
event_id metadata.product_event_type 直接复制值
version metadata.product_version 直接复制值
cs1 metadata.url_back_to_product 如果 cs1Label == "incidentLink",则使用 cs1 中的值
network.ip_protocol 如果 event_id == "APPLIANCE_CONNECTIVITY_FAILURE",则设置为“TCP”
dhost, host principal.hostname 如果 dhost 不为空且不是 IP,则使用 dhost 中的值;否则,如果 host 不为空且不是 IP,则使用 host 中的值
dhost, host principal.ip 如果 dhost 是 IP,则使用 dhost 中的值;否则,如果 host 是 IP,则使用 host 中的值
description, event_name, act, cs5, cs2, externalId, cn2 security_result.description 如果 description 不为空,则使用 description 中的值;否则,如果 cs5Label == "status" 或 cs2Label == "status",则使用 event_name、act、cs5 中的状态或 cs2 中的状态进行串联;使用 externalId 中的 IncidentID;使用 cn2 中的 CompromisedEntities
cs1 security_result.rule_name 如果 cs1Label == "ruleName",则使用 cs1 中的值
severity security_result.severity 从整数转换:如果 > 7,则为 HIGH;如果 > 4,则为 MEDIUM;如果 > 2,则为 LOW;如果 > 0,则为 INFORMATIONAL;否则为 UNKNOWN_SEVERITY;或者,如果 cat == "Policy Log" 且 severity == "INFO",则设置为 LOW
severity security_result.severity_details 直接复制值
act, event_name security_result.summary 如果 act 不为空,则使用 act 中的值;否则使用 event_name 中的值
destinationServiceName target.application 如果 event_id == "APPLIANCE_CONNECTIVITY_FAILURE",则使用 destinationServiceName 中的值
shost target.hostname 直接复制值
src, dst target.ip 如果 event_id == "APPLIANCE_CONNECTIVITY_FAILURE",则使用 src 或 dst 中的值
suser target.user.userid 直接复制值
vendor metadata.vendor_name 如果 vendor 不为空,则使用 vendor 中的值;否则设置为“PreemptSecurity”
product metadata.product_name 如果 product 不为空,则使用 product 中的值;否则设置为“PBF”

更新日志

查看此解析器的更新日志

需要更多帮助?获得社区成员和 Google SecOps 专业人士的解答。