收集 Stealthbits StealthDEFEND 日志

支持范围:

本文档介绍了如何使用 Bindplane 代理将 Stealthbits StealthDEFEND 日志注入到 Google Security Operations。

Stealthbits(现为 Netwrix)StealthDEFEND 是一个实时威胁检测平台,可识别并响应针对 Active Directory 和文件系统的攻击。它会生成 LEEF 格式的提醒,涵盖身份验证异常、提权和 AD 对象修改。解析器会从 StealthDEFEND 日志条目中提取字段,并将其映射到统一数据模型 (UDM),从而捕获主体和目标标识符、安全结果以及漏洞扫描详细信息。

准备工作

请确保满足以下前提条件:

  • Google SecOps 实例
  • Windows Server 2016 或更高版本,或者安装了 systemd 的 Linux 主机
  • Bindplane 代理与 StealthDEFEND 服务器之间的网络连接
  • 如果在代理后面运行,请确保按照 Bindplane 代理要求打开防火墙端口
  • 拥有 StealthDEFEND 控制台的特权访问权限和管理员权限

获取 Bindplane 代理的 Google SecOps 凭证

如需向 Google SecOps 验证 Bindplane 代理,请选择以下方法之一:

  • 新部署:使用 Chronicle API(选项 1)。
  • 旧版部署:继续使用数据注入身份验证文件(方法 2),直到 Ingestion API 于 2027 年 7 月 20 日停用。
  1. 登录 Google Cloud 控制台,然后选择与您的 Google SecOps 实例关联的 Google Cloud 项目。
  2. 依次前往 IAM 和管理 > 服务账号。
  3. 点击创建服务账号。
  4. 提供以下配置详细信息:
    • 服务账号名称:输入账号的名称(例如 bindplane-ingest)。
    • 服务账号说明:输入说明(例如 Bindplane agent log ingestion)。
  5. 点击创建并继续。
  6. 在向此服务账号授予对项目的访问权限部分,点击选择角色,然后选择 Chronicle Editor。
  7. 点击继续,然后点击完成。
  8. 点击您创建的服务账号,然后前往密钥标签页。
  9. 依次点击添加密钥 > 创建新密钥。
  10. 选择 JSON,然后点击创建。密钥文件会下载到您的计算机上。
  11. 将密钥文件另存为 Bindplane 收集器目录(Linux 上的 /opt/observiq-otel-collector/ingestion-auth.json 或 Windows 上的 C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json)中的 ingestion-auth.json,或更新 config.yaml 中的 creds_file_path 以匹配您保存它的路径。
  12. 前往 IAM 和管理 > 设置,然后复制项目编号。您在配置导出器时需要用到该名称。

方法 2:下载数据注入身份验证文件(旧版)

  1. 登录 Google SecOps 控制台。
  2. 依次前往设置 > 数据管理 > 收集代理。如果您使用的是仅限 SIEM 的平台,请依次前往设置 > 收集代理。
  3. 下载数据注入身份验证文件。
  4. 将该文件安全地保存在将要安装 Bindplane 代理的系统上。

获取 Google SecOps 客户 ID

  1. 登录 Google SecOps 控制台。
  2. 依次前往设置 > 管理 > 个人资料。如果您使用的是仅限 SIEM 的平台,请依次前往设置 > 个人资料。
  3. 复制并保存组织详细信息部分中的客户 ID。

安装 Bindplane 代理

根据以下说明,在 Windows 或 Linux 操作系统上安装 Bindplane 代理。

Windows 安装

  1. 以管理员身份打开命令提示符或 PowerShell。
  2. 运行以下命令:

    msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quiet
    
  3. 等待安装完成。

  4. 运行以下命令,验证安装是否成功:

    sc query observiq-otel-collector
    

    该服务应显示为正在运行。

Linux 安装

  1. 打开具有 root 或 sudo 权限的终端。
  2. 运行以下命令:

    sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.sh
    
  3. 等待安装完成。

  4. 运行以下命令,验证安装是否成功:

    sudo systemctl status observiq-otel-collector
    

    该服务应显示为 active (running)。

其他安装资源

如需了解其他安装选项和问题排查,请参阅 Bindplane 代理安装指南。

配置 Bindplane 代理以注入 syslog 并发送到 Google SecOps

找到配置文件

  • Linux:

    sudo nano /opt/observiq-otel-collector/config.yaml
    
  • Windows:

    notepad "C:\Program Files\observIQ OpenTelemetry Collector\config.yaml"
    

修改配置文件

  • 将 config.yaml 的全部内容替换为以下配置:

    receivers:
      tcplog:
        listen_address: "0.0.0.0:514"
    
    exporters:
      chronicle/stealthbits_defend:
        protocol: https
        # Region of your instance, for example us, europe, asia-southeast1
        location: <LOCATION>
        # Project number of the Google Cloud project linked to the instance
        project: '<PROJECT_NUMBER>'
        compression: gzip
        creds_file_path: '/opt/observiq-otel-collector/ingestion-auth.json'
        customer_id: '<customer_id>'
        endpoint: chronicle.googleapis.com
        log_type: STEALTHBITS_DEFEND
        raw_log_field: body
    
    service:
      pipelines:
        logs/stealthbits_defend:
          receivers:
            - tcplog
          exporters:
            - chronicle/stealthbits_defend
    

配置参数

替换以下占位符:

  • 接收器配置:

    • tcplog:基于协议的接收器类型:
      • udplog(适用于 UDP syslog)
      • tcplog(适用于 TCP syslog)
      • syslog(适用于 RFC 3164/5424 系统日志)
    • 0.0.0.0:要监听的 IP 地址:
      • 0.0.0.0,以监听所有接口(推荐)
      • 要在一个接口上监听的特定 IP 地址
    • 514:要监听的端口号(例如 514、1514、6514)
  • 导出器配置:

    • <customer_id>:上一步中的客户 ID
    • location:将 <LOCATION> 替换为 Google SecOps 实例所在的区域(例如 us、europe 或 asia-southeast1)。导出工具会在此值前面加上 chronicle.googleapis.com。如需查看完整列表,请参阅区域级端点。
    • project:将 <PROJECT_NUMBER> 替换为 IAM 和管理 > 设置中的项目编号。
    • endpoint:保持设置为 chronicle.googleapis.com。
    • 根据平台,将 creds_file_path 调整为服务账号 JSON 密钥文件的路径(选项 1):
      • Linux:/opt/observiq-otel-collector/ingestion-auth.json
      • Windows:C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json

旧版提取 API 导出工具

  • 如果您使用选项 2 中的数据注入身份验证文件,请将 exporters 代码块替换为以下内容。将 creds_file_path 设置为数据注入身份验证文件的路径,如果您的实例位于美国境外,请将 malachiteingestion-pa.googleapis.com 替换为您的区域端点(例如 europe-malachiteingestion-pa.googleapis.com)。

    exporters:
      chronicle/stealthbits_defend:
        compression: gzip
        creds_file_path: '/opt/observiq-otel-collector/ingestion-auth.json'
        customer_id: '<customer_id>'
        endpoint: malachiteingestion-pa.googleapis.com
        log_type: STEALTHBITS_DEFEND
        raw_log_field: body
    

保存配置文件

  • 修改后,保存文件:
    • Linux:依次按 Ctrl+O、Enter 和 Ctrl+X
    • Windows:依次点击文件 > 保存

重启 Bindplane 代理以应用更改

  • 如需在 Linux 中重启 Bindplane 代理,请运行以下命令:

    sudo systemctl restart observiq-otel-collector
    
    1. 验证服务是否正在运行:

      sudo systemctl status observiq-otel-collector
      
    2. 检查日志中的错误:

      sudo journalctl -u observiq-otel-collector -f
      
  • 如需在 Windows 中重启 Bindplane 代理,请选择以下选项之一:

    • 以管理员身份运行命令提示符或 PowerShell:

      net stop observiq-otel-collector && net start observiq-otel-collector
      
    • “服务”控制台:

      1. 按 Win+R,输入 services.msc,然后按 Enter 键。
      2. 找到 observIQ OpenTelemetry 收集器。
      3. 右键点击并选择重启。
      4. 验证服务是否正在运行:

        sc query observiq-otel-collector
        
      5. 检查日志中的错误:

        type "C:\Program Files\observIQ OpenTelemetry Collector\log\collector.log"
        

配置 StealthDEFEND syslog 转发

StealthDEFEND 支持通过 LEEF 格式的 syslog 进行 SIEM 集成。配置 syslog 导出,以将提醒和事件转发到 Bindplane 代理。

  1. 登录 StealthDEFEND 管理控制台。
  2. 前往配置 > SIEM。
  3. 点击添加以创建新的 SIEM 集成。
  4. 提供以下配置详细信息:
    • 类型:选择 Syslog。
    • 格式:选择 LEEF。
    • 主机:输入 Bindplane 代理主机的 IP 地址(例如 192.168.1.100)。
    • 端口:输入 514(必须与 Bindplane 接收器端口匹配)。
    • 协议:选择 TCP(必须与 Bindplane 接收器类型匹配)。
  5. 选择要转发的事件类别(例如威胁提醒、AD 更改、身份验证事件)。
  6. 点击保存。

UDM 映射表

日志字段 UDM 映射 逻辑
attack_host about.hostname 与额外实体关联的主机名
extensions.auth.type 使用的身份验证类型
已结束 extensions.vulns.vulnerabilities.scan_end_time 漏洞扫描的结束时间
已开始 extensions.vulns.vulnerabilities.scan_start_time 漏洞扫描的开始时间
intermediary_hostname intermediary.hostname 中间设备的主机名
SettingName metadata.description 事件的说明
event_type metadata.event_type 事件类型
product_event metadata.product_event_type 特定产品的事件类型
device_version metadata.product_version 产品版本
网域 principal.administrative_domain 主体的管理网域
source_domain principal.domain.name 主账号的域名
src、shost、AttackingHost、breached_from_host principal.hostname 主账号的主机名
src、shost、AttackingHostIp principal.ip 主体的 IP 地址
DistinguishedName principal.user.group_identifiers 主用户的群组标识符
AffectedObject principal.user.user_display_name 主用户的显示名称
suser, usrName principal.user.userid 主账号的用户 ID
protocol_label security_result.about.labels “关于”部分的安全结果标签
sec_result_action security_result.action 安防系统采取的操作
类别 security_result.category_details 安全结果的详细类别
AlertText, operation security_result.description 安全结果的说明
policy_name security_result.rule_name 触发结果的规则的名称
严重级别 security_result.severity 安全结果的严重程度
Reason, att_name security_result.summary 安全结果摘要
OrigServer, AttackedHost target.hostname 目标的主机名
dst, AttackedHostIp target.ip 目标的 IP 地址
duser, UserName target.user.userid 目标的用户 ID
UserSID target.user.windows_sid 目标用户的 Windows SID
device_product metadata.product_name 商品名称
device_vendor metadata.vendor_name 供应商名称

更新日志

查看此解析器的更新日志

需要更多帮助?获得社区成员和 Google SecOps 专业人士的解答。