收集 Trellix EPO 日志
支持的平台:
Google SecOps
SIEM
本文档介绍了如何使用 Bindplane 代理将 Trellix ePO 日志注入到 Google Security Operations。
Trellix ePO(以前称为 McAfee ePolicy Orchestrator)是一个集中式安全管理平台,可在端点安全产品中提供统一的政策强制执行、实时可视性和自动化合规性。借助该产品,管理员可以通过一个基于 Web 的控制台管理安全政策、部署代理、监控威胁和生成报告。
准备工作
请确保满足以下前提条件:
- Google SecOps 实例
- 搭载
systemd的 Windows 2016 或更高版本或 Linux 主机 - 如果通过代理运行,请确保防火墙端口已根据 Bindplane 代理要求打开
- 对 Trellix ePO 控制台的特权访问权限(具有管理员权限)
获取 Google SecOps 注入身份验证文件
- 登录 Google SecOps 控制台。
- 依次前往 SIEM 设置 > 收集代理。
- 下载注入身份验证文件。
- 将文件安全地保存在将要安装 Bindplane 的系统上。
获取 Google SecOps 客户 ID
- 登录 Google SecOps 控制台。
- 依次前往 SIEM 设置 > 配置文件。
- 复制并保存组织详细信息部分中的客户 ID。
安装 Bindplane 代理
按照以下说明在 Windows 或 Linux 操作系统上安装 Bindplane 代理。
Windows 安装
- 以管理员身份打开命令提示符或 PowerShell。
运行以下命令:
msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quiet
Linux 安装
- 打开具有 root 或 sudo 权限的终端。
运行以下命令:
sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.sh
其他安装资源
如需了解其他安装选项,请参阅此安装指南。
配置 Bindplane 代理以注入 Syslog 并将其发送到 Google SecOps
访问配置文件:
- 找到
config.yaml文件。通常,它位于 Linux 上的/etc/bindplane-agent/目录中,或位于 Windows 上的安装目录中。 - 使用文本编辑器(例如
nano、vi或记事本)打开该文件。
- 找到
按如下方式修改
config.yaml文件:receivers: tcplog: # Replace the port and IP address as required listen_address: "0.0.0.0:514" exporters: chronicle/chronicle_w_labels: compression: gzip # Adjust the path to the credentials file you downloaded in Step 1 creds_file_path: '/path/to/ingestion-authentication-file.json' # Replace with your actual customer ID from Step 2 customer_id: YOUR_CUSTOMER_ID_HERE endpoint: malachiteingestion-pa.googleapis.com # Add optional ingestion labels for better organization log_type: 'MCAFEE_EPO' raw_log_field: body ingestion_labels: service: pipelines: logs/source0__chronicle_w_labels-0: receivers: - tcplog exporters: - chronicle/chronicle_w_labels- 根据基础架构的需要替换端口和 IP 地址。
- 将
YOUR_CUSTOMER_ID_HERE替换为实际的客户 ID。 - 将
/path/to/ingestion-authentication-file.json更新为在第 1 步中保存身份验证文件的文件路径。 - 更新
endpoint值,使其与您租户的区域一致。
重启 Bindplane 代理以应用更改
如需在 Linux 中重启 Bindplane 代理,请运行以下命令:
sudo systemctl restart observiq-otel-collector如需在 Windows 中重启 Bindplane 代理,您可以使用服务控制台,也可以输入以下命令:
net stop observiq-otel-collector && net start observiq-otel-collector
配置 Trellix ePO syslog 转发
- 使用管理员凭据登录 Trellix ePO 控制台。
- 依次前往菜单 > 配置 > 已注册的服务器。
- 点击 New Server。
- 在服务器类型下拉列表中,选择 Syslog。
- 在名称字段中,输入一个描述性名称(例如
Chronicle-Bindplane)。 - 点击下一步。
- 在 Syslog 服务器字段中,输入 Bindplane 代理主机(例如
192.168.1.100)的 IP 地址。 - 在端口字段中,输入
514(或在 Bindplane 中配置的端口)。 - 在协议下拉列表中,选择 TCP。
- 在事件格式下拉列表中,选择 Common Event Format (CEF)。
- 点击测试连接,验证与 Bindplane 代理的连接。
- 点击保存。
- 依次前往菜单 > Automation > 自动回复。
- 点击新建回答以创建新的自动回答规则。
- 在名称字段中,输入一个描述性名称(例如
Syslog-Chronicle)。 - 在事件组下拉列表中,选择要转发的事件组:
- ePO 通知事件
- 威胁事件
- 客户活动
- 点击下一步。
- 在过滤条件标签页中,根据需要配置任何事件过滤条件(或保留默认设置以转发所有事件)。
- 点击下一步。
- 在操作部分,选择发送 Syslog。
- 在 Syslog 服务器下拉列表中,选择已注册的 syslog 服务器 (
Chronicle-Bindplane)。 - 点击下一步。
检查配置,然后点击保存。
UDM 映射表
| 日志字段 | UDM 映射 | 逻辑 |
|---|---|---|
about_token |
about |
已合并 |
additional_token |
additional |
已重命名/已映射 |
ActionID_label |
additional.fields |
已合并 |
BadLinkRatingID_label |
additional.fields |
已合并 |
ContentID_label |
additional.fields |
已合并 |
DownloadRatingID_label |
additional.fields |
已合并 |
Error_label |
additional.fields |
已合并 |
ExploitRatingID_label |
additional.fields |
已合并 |
InitiatorID_label |
additional.fields |
已合并 |
InitiatorType_label |
additional.fields |
已合并 |
ListID_label |
additional.fields |
已合并 |
Locale_label |
additional.fields |
已合并 |
PhishingRatingID_label |
additional.fields |
已合并 |
PopupRatingID_label |
additional.fields |
已合并 |
ProductID_label |
additional.fields |
已合并 |
RatingID_label |
additional.fields |
已合并 |
ReasonID_label |
additional.fields |
已合并 |
SiteName_label |
additional.fields |
已合并 |
SourceProcessSigned_label |
additional.fields |
已合并 |
SourceProcessSigner_label |
additional.fields |
已合并 |
SpamRatingID_label |
additional.fields |
已合并 |
TargetDriveType_label |
additional.fields |
已合并 |
_field |
additional.fields |
已合并 |
analyzer_engine_version_label |
additional.fields |
已合并 |
analyzer_ipv4_label |
additional.fields |
已合并 |
analyzer_label |
additional.fields |
已合并 |
analyzer_name_label |
additional.fields |
已合并 |
analyzerengineversion_label |
additional.fields |
已合并 |
bps_id_label |
additional.fields |
已合并 |
client_labels_ |
additional.fields |
已合并 |
description_value_label |
additional.fields |
已合并 |
detected_utc_label |
additional.fields |
已合并 |
eventType_label |
additional.fields |
已合并 |
event_version_label |
additional.fields |
已合并 |
extradatnames_label |
additional.fields |
已合并 |
machine_agent_version_label |
additional.fields |
已合并 |
opg_data_label |
additional.fields |
已合并 |
product_family_label |
additional.fields |
已合并 |
product_name_label |
additional.fields |
已合并 |
server_list_labels |
additional.fields |
已合并 |
source_ipv4_label |
additional.fields |
已合并 |
sphotfix_label |
additional.fields |
已合并 |
target_protocol_label |
additional.fields |
已合并 |
targetprotocol_label |
additional.fields |
已合并 |
tenant_guid_label |
additional.fields |
已合并 |
tenant_id_label |
additional.fields |
已合并 |
tenant_node_path_label |
additional.fields |
已合并 |
threat_action_taken_label |
additional.fields |
已合并 |
time_s_zone_label |
additional.fields |
已合并 |
timezone_bias_label |
additional.fields |
已合并 |
type_label |
additional.fields |
已合并 |
user_info_label |
additional.fields |
已合并 |
verbuild_label |
additional.fields |
已合并 |
vermin_label |
additional.fields |
已合并 |
vermjr_label |
additional.fields |
已合并 |
verrev_label |
additional.fields |
已合并 |
workflowid_label |
additional.fields |
已合并 |
intermediary |
intermediary |
已合并 |
intermediary1 |
intermediary |
已合并 |
Analyzer |
intermediary.application |
直接映射 |
analyzer |
intermediary.application |
直接映射 |
AnalyzerHostName |
intermediary.asset.hostname |
直接映射 |
AnalyzerMAC |
intermediary.asset.mac |
已合并 |
AnalyzerHostName |
intermediary.hostname |
直接映射 |
analyzerhostname |
intermediary.hostname |
直接映射 |
analyzeripv4 |
intermediary.ip |
已合并 |
AnalyzerMAC |
intermediary.mac |
已合并 |
analyzermac |
intermediary.mac |
已合并 |
Name |
metadata.description |
直接映射 |
event_description |
metadata.description |
直接映射 |
eventname |
metadata.description |
直接映射 |
scantype |
metadata.description |
直接映射 |
tvdeventid |
metadata.description |
直接映射 |
event_type |
metadata.event_type |
直接映射 |
TenantId |
metadata.product_deployment_id |
直接映射 |
EventID |
metadata.product_event_type |
直接映射 |
Type |
metadata.product_event_type |
直接映射 |
eventType |
metadata.product_event_type |
直接映射 |
prod_event_type |
metadata.product_event_type |
直接映射 |
product_event_type |
metadata.product_event_type |
已重命名/已映射 |
tvdeventid |
metadata.product_event_type |
直接映射 |
AutoID |
metadata.product_log_id |
直接映射 |
AutoId |
metadata.product_log_id |
直接映射 |
alertId |
metadata.product_log_id |
直接映射 |
autoid |
metadata.product_log_id |
直接映射 |
product_log_id |
metadata.product_log_id |
已重命名/已映射 |
analyzername |
metadata.product_name |
直接映射 |
product_name |
metadata.product_name |
直接映射 |
AnalyzerVersion |
metadata.product_version |
直接映射 |
analyzerversion |
metadata.product_version |
直接映射 |
product_version |
metadata.product_version |
直接映射 |
productversion |
metadata.product_version |
直接映射 |
app_protocol |
network.application_protocol |
直接映射 |
target_protocol |
network.ip_protocol |
直接映射 |
sys_ip |
observer.ip |
已合并 |
analyzer_name |
observer.namespace |
直接映射 |
principal_token |
principal |
已重命名/已映射 |
source_user_domain |
principal.administrative_domain |
直接映射 |
application_name |
principal.application |
直接映射 |
host |
principal.application |
直接映射 |
process_name |
principal.application |
直接映射 |
source_process_name |
principal.application |
直接映射 |
agentguid |
principal.asset.asset_id |
直接映射 |
token_new |
principal.asset.attribute.labels |
已合并 |
SiteName |
principal.asset.hostname |
直接映射 |
SourceHostName |
principal.asset.hostname |
直接映射 |
host |
principal.asset.hostname |
直接映射 |
principal_hostname |
principal.asset.hostname |
直接映射 |
source |
principal.asset.hostname |
直接映射 |
machine_ip_address |
principal.asset.ip |
已合并 |
sourceIP |
principal.asset.ip |
已合并 |
src_ip |
principal.asset.ip |
已合并 |
SourceMAC |
principal.asset.mac |
已合并 |
machine_raw_mac_address |
principal.asset.mac |
已合并 |
AutoGUID |
principal.asset.product_object_id |
直接映射 |
autoguid |
principal.asset.product_object_id |
直接映射 |
SiteName |
principal.hostname |
直接映射 |
SourceHostName |
principal.hostname |
直接映射 |
TargetHostName |
principal.hostname |
直接映射 |
analyzer_host_name |
principal.hostname |
直接映射 |
host |
principal.hostname |
直接映射 |
machine_name |
principal.hostname |
直接映射 |
prin_host |
principal.hostname |
直接映射 |
principal_asset_hostname |
principal.hostname |
直接映射 |
principal_machine_name |
principal.hostname |
直接映射 |
source_host_name |
principal.hostname |
直接映射 |
sourcehostname |
principal.hostname |
直接映射 |
machine_ip_address |
principal.ip |
已合并 |
normalized_ip_address |
principal.ip |
已合并 |
prin_ip |
principal.ip |
已合并 |
sourceIP |
principal.ip |
已合并 |
source_ip |
principal.ip |
已合并 |
sourceipv4 |
principal.ip |
已合并 |
src_ip |
principal.ip |
已合并 |
srcip |
principal.ip |
已合并 |
SourceMAC |
principal.mac |
已合并 |
machine_raw_mac_address |
principal.mac |
已合并 |
normalized_mac_address |
principal.mac |
已合并 |
sourcemac |
principal.mac |
已合并 |
source_port |
principal.port |
直接映射 |
cmd_line |
principal.process.command_line |
直接映射 |
eventCommandLine |
principal.process.command_line |
直接映射 |
source_process_cmd |
principal.process.command_line |
直接映射 |
SourceFilePath |
principal.process.file.full_path |
直接映射 |
SourceProcessName |
principal.process.file.full_path |
直接映射 |
eventProgramName |
principal.process.file.full_path |
直接映射 |
process_name |
principal.process.file.full_path |
直接映射 |
prog_name |
principal.process.file.full_path |
直接映射 |
sourceprocessname |
principal.process.file.full_path |
直接映射 |
SourceProcessHash |
principal.process.file.md5 |
直接映射 |
Source_FileSize |
principal.process.file.size |
直接映射 |
parent_process_name |
principal.process.parent_process.file.full_path |
直接映射 |
source_parent_process_id |
principal.process.parent_process.pid |
直接映射 |
process_id |
principal.process.pid |
直接映射 |
source_process_id |
principal.process.pid |
直接映射 |
source_device_sn |
principal.resource.id |
直接映射 |
source_product_name |
principal.resource.name |
直接映射 |
SourceURL |
principal.url |
直接映射 |
sourceurl |
principal.url |
直接映射 |
subject |
principal.user.group_identifiers |
已合并 |
machine_user_name |
principal.user.user_display_name |
直接映射 |
source_user_name |
principal.user.user_display_name |
直接映射 |
username |
principal.user.user_display_name |
直接映射 |
SourceUserName |
principal.user.userid |
直接映射 |
clientId |
principal.user.userid |
直接映射 |
eventProgramUser |
principal.user.userid |
直接映射 |
sourceusername |
principal.user.userid |
直接映射 |
sec_res |
security_result |
已合并 |
security_result |
security_result |
已合并 |
security_result_token |
security_result |
已合并 |
virus_type_label |
security_result.about.resource.attribute.labels |
已合并 |
action |
security_result.action |
已合并 |
security_action |
security_result.action |
已合并 |
action_taken |
security_result.action_details |
直接映射 |
security_action_details |
security_result.action_details |
直接映射 |
threat_action_taken |
security_result.action_details |
直接映射 |
category |
security_result.category |
已合并 |
security_category |
security_result.category |
已合并 |
ThreatCategory |
security_result.category_details |
已合并 |
category_details |
security_result.category_details |
已合并 |
security_category_details |
security_result.category_details |
已合并 |
threatcategory |
security_result.category_details |
已合并 |
Data |
security_result.description |
直接映射 |
natural_lang_description |
security_result.description |
直接映射 |
security_description |
security_result.description |
直接映射 |
Access_Requested_label |
security_result.detection_fields |
已合并 |
Analyzer_ContentVersion_label |
security_result.detection_fields |
已合并 |
_field |
security_result.detection_fields |
已合并 |
analyzer_dat_version_label |
security_result.detection_fields |
已合并 |
analyzer_detection_method_label |
security_result.detection_fields |
已合并 |
analyzerdatversion_label |
security_result.detection_fields |
已合并 |
analyzerdetectionmethod_label |
security_result.detection_fields |
已合并 |
command_executed_label |
security_result.detection_fields |
已合并 |
label_agent_guid |
security_result.detection_fields |
已合并 |
label_task_name |
security_result.detection_fields |
已合并 |
labels0 |
security_result.detection_fields |
已合并 |
return_code_label |
security_result.detection_fields |
已合并 |
seq_no_label |
security_result.detection_fields |
已合并 |
server_id_label |
security_result.detection_fields |
已合并 |
task_id_label |
security_result.detection_fields |
已合并 |
task_name_label |
security_result.detection_fields |
已合并 |
threat_event_id_label |
security_result.detection_fields |
已合并 |
threat_handled_label |
security_result.detection_fields |
已合并 |
threat_type_label |
security_result.detection_fields |
已合并 |
threateventid_label |
security_result.detection_fields |
已合并 |
threathandled_label |
security_result.detection_fields |
已合并 |
threattype_label |
security_result.detection_fields |
已合并 |
total_chunks_label |
security_result.detection_fields |
已合并 |
transaction_id_label |
security_result.detection_fields |
已合并 |
TVDEventID |
security_result.rule_id |
直接映射 |
event_id |
security_result.rule_id |
直接映射 |
policy_name |
security_result.rule_name |
直接映射 |
rule_name |
security_result.rule_name |
直接映射 |
TVDSeverity |
security_result.severity_details |
直接映射 |
ThreatSeverity |
security_result.severity_details |
直接映射 |
threat_severity |
security_result.severity_details |
直接映射 |
threatseverity |
security_result.severity_details |
直接映射 |
ThreatActionTaken |
security_result.summary |
直接映射 |
ThreatType |
security_result.summary |
直接映射 |
detection_message |
security_result.summary |
直接映射 |
security_result.severity |
security_result.summary |
直接映射 |
security_summary |
security_result.summary |
直接映射 |
threat_type |
security_result.threat_id |
直接映射 |
ThreatName |
security_result.threat_name |
直接映射 |
threat_name |
security_result.threat_name |
直接映射 |
threatname |
security_result.threat_name |
直接映射 |
src_token |
src |
已重命名/已映射 |
src_domain |
src.administrative_domain |
直接映射 |
source_ip |
src.ip |
已合并 |
source_port |
src.port |
直接映射 |
src_user |
src.user.userid |
直接映射 |
target_token |
target |
已重命名/已映射 |
ProductCode |
target.application |
直接映射 |
tar_app |
target.application |
直接映射 |
serverid |
target.asset.asset_id |
直接映射 |
token_new |
target.asset.attribute.labels |
已合并 |
HostName |
target.asset.hostname |
直接映射 |
TargetHostName |
target.asset.hostname |
直接映射 |
target_hostname |
target.asset.hostname |
直接映射 |
targetIP |
target.asset.ip |
已合并 |
TargetMAC |
target.asset.mac |
已合并 |
AgentGUID |
target.asset_id |
直接映射 |
TargetFileName |
target.file.full_path |
直接映射 |
target_file_name |
target.file.full_path |
直接映射 |
targetfilename |
target.file.full_path |
直接映射 |
target_file_size |
target.file.size |
已重命名/已映射 |
HostName |
target.hostname |
直接映射 |
TargetHostName |
target.hostname |
直接映射 |
machine_name |
target.hostname |
直接映射 |
target_asset_hostname |
target.hostname |
直接映射 |
target_host_name |
target.hostname |
直接映射 |
targethostname |
target.hostname |
直接映射 |
dstip |
target.ip |
已合并 |
normalized_ip_address |
target.ip |
已合并 |
targetIP |
target.ip |
已合并 |
target_ip |
target.ip |
已合并 |
target_ipv4 |
target.ip |
直接映射 |
targetipv4_val |
target.ip |
已合并 |
TargetMAC |
target.mac |
已合并 |
normalized_mac_address |
target.mac |
已合并 |
targetmac |
target.mac |
已合并 |
TenantId |
target.namespace |
直接映射 |
tenantid |
target.namespace |
直接映射 |
TargetPort |
target.port |
直接映射 |
target_port |
target.port |
直接映射 |
targetport |
target.port |
直接映射 |
TargetProcessName |
target.process.file.full_path |
直接映射 |
eventObject |
target.process.file.full_path |
直接映射 |
file_name |
target.process.file.full_path |
直接映射 |
process_name |
target.process.file.full_path |
直接映射 |
target_file_name |
target.process.file.full_path |
直接映射 |
target_name |
target.process.file.full_path |
直接映射 |
targetprocessname |
target.process.file.full_path |
直接映射 |
value_data |
target.process.file.full_path |
直接映射 |
hash |
target.process.file.md5 |
直接映射 |
md5 |
target.process.file.md5 |
直接映射 |
target_hash |
target.process.file.md5 |
直接映射 |
sha1 |
target.process.file.sha1 |
直接映射 |
target_sha |
target.process.file.sha1 |
直接映射 |
sha256 |
target.process.file.sha256 |
直接映射 |
file_size |
target.process.file.size |
直接映射 |
target_parent_file_name |
target.process.parent_process.file.full_path |
直接映射 |
LogonSessionID |
target.process.pid |
直接映射 |
tar_pid |
target.process.pid |
直接映射 |
key_name |
target.registry.registry_key |
直接映射 |
ThreatName |
target.resource.name |
直接映射 |
source_url |
target.url |
直接映射 |
nodeid_label |
target.user.attribute.labels |
已合并 |
version_label |
target.user.attribute.labels |
已合并 |
targetuseremail |
target.user.email_addresses |
已合并 |
machine_user_name |
target.user.user_display_name |
直接映射 |
target_user_name |
target.user.user_display_name |
直接映射 |
value |
target.user.user_display_name |
直接映射 |
TargetUserName |
target.user.userid |
直接映射 |
UserName |
target.user.userid |
直接映射 |
UserSID |
target.user.windows_sid |
直接映射 |
| 不适用 | about |
常量:about_token |
| 不适用 | additional.fields |
常量:eventType_label |
| 不适用 | intermediary |
常量:intermediary1 |
| 不适用 | intermediary.asset.mac |
常量:AnalyzerMAC |
| 不适用 | intermediary.ip |
常量:analyzeripv4 |
| 不适用 | intermediary.mac |
常量:AnalyzerMAC |
| 不适用 | metadata.description |
常量:No raw event available |
| 不适用 | metadata.event_type |
常量:GENERIC_EVENT |
| 不适用 | metadata.product_name |
常量:McAfee EPO |
| 不适用 | metadata.vendor_name |
常量:McAfee |
| 不适用 | observer.ip |
常量:sys_ip |
| 不适用 | principal.asset.attribute.labels |
常量:token_new |
| 不适用 | principal.asset.ip |
常量:src_ip |
| 不适用 | principal.asset.mac |
常量:SourceMAC |
| 不适用 | principal.ip |
常量:src_ip |
| 不适用 | principal.mac |
常量:SourceMAC |
| 不适用 | principal.platform |
常量:WINDOWS |
| 不适用 | principal.process.file.size |
常量:uinteger |
| 不适用 | principal.user.group_identifiers |
常量:subject |
| 不适用 | security_result |
常量:sec_res |
| 不适用 | security_result.about.resource.attribute.labels |
常量:virus_type_label |
| 不适用 | security_result.action |
常量:action |
| 不适用 | security_result.category |
常量:category |
| 不适用 | security_result.category_details |
常量:ThreatCategory |
| 不适用 | security_result.detection_fields |
常量:threat_event_id_label |
| 不适用 | security_result.severity |
常量:HIGH |
| 不适用 | src.ip |
常量:source_ip |
| 不适用 | target.asset.attribute.labels |
常量:token_new |
| 不适用 | target.asset.ip |
常量:targetIP |
| 不适用 | target.asset.mac |
常量:TargetMAC |
| 不适用 | target.ip |
常量:targetIP |
| 不适用 | target.mac |
常量:TargetMAC |
| 不适用 | target.process.file.size |
常量:uinteger |
| 不适用 | target.user.attribute.labels |
常量:version_label |
| 不适用 | target.user.email_addresses |
常量:targetuseremail |