收集 Xcitium Endpoint Security 日志
解析器版本: 2.0
本文档介绍了如何使用 Bindplane 代理将 Xcitium Endpoint Security(以前称为 Comodo)日志注入到 Google Security Operations 中。
Xcitium Endpoint Security 是一个端点保护平台,它结合了防病毒、防火墙、入侵防御和隔离技术,可保护端点免受已知和未知威胁的侵害。它采用默认拒绝方法,并使用自动隔离功能来隔离无法识别的文件和进程,以防止它们在分析时造成损害。
准备工作
请确保满足以下前提条件:
- Google SecOps 实例
- Windows Server 2016 或更高版本,或者具有
systemd的 Linux 主机 - Bindplane 代理与 Xcitium 管理的端点之间的网络连接
- 如果通过代理运行,请确保防火墙端口根据 Bindplane 代理要求打开
- 对 Xcitium Endpoint Manager 控制台(以前称为 Comodo ITSM / ITarian)的特权访问权限
- 在 Xcitium Endpoint Manager 中具有管理员角色,可修改配置文件和门户设置
获取 Google SecOps 数据注入身份验证文件
- 登录 Google SecOps 控制台。
- 依次前往 SIEM 设置 > 收集代理。
- 下载数据注入身份验证文件。
- 将该文件安全地保存在将安装 Bindplane 代理的系统上。
获取 Google SecOps 客户 ID
- 登录 Google SecOps 控制台。
- 依次前往 SIEM 设置 > 个人资料 。
- 从组织详细信息 部分复制并保存客户 ID 。
安装 Bindplane 代理
按照以下说明在 Windows 或 Linux 操作系统上安装 Bindplane 代理。
Windows 安装
- 以管理员身份打开命令提示符 或 PowerShell 。
运行以下命令:
msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quiet等待安装完成。
运行以下命令,验证安装是否成功:
sc query observiq-otel-collector该服务应显示为正在运行 。
Linux 安装
- 使用 root 或 sudo 权限打开终端。
运行以下命令:
sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.sh等待安装完成。
运行以下命令,验证安装是否成功:
sudo systemctl status observiq-otel-collector该服务应显示为活跃 (正在运行) 。
其他安装资源
如需了解其他安装选项和问题排查信息,请参阅 Bindplane 代理安装指南。
配置 Bindplane 代理以注入 syslog 并发送到 Google SecOps
找到配置文件
Linux:
sudo nano /etc/bindplane-agent/config.yamlWindows:
notepad "C:\Program Files\observIQ OpenTelemetry Collector\config.yaml"
修改配置文件
将
config.yaml的全部内容替换为以下配置:receivers: udplog: listen_address: "0.0.0.0:514" exporters: chronicle/comodo_av: compression: gzip creds_file_path: '/path/to/ingestion-authentication-file.json' customer_id: 'your-customer-id' endpoint: malachiteingestion-pa.googleapis.com log_type: COMODO_AV raw_log_field: body ingestion_labels: service: pipelines: logs/comodo_to_chronicle: receivers: - udplog exporters: - chronicle/comodo_av
配置参数
替换以下占位符:
接收器配置:
listen_address:要监听的 IP 地址和端口。使用0.0.0.0监听所有接口。默认 syslog 端口为514。
导出器配置:
creds_file_path:注入身份验证文件的完整路径。- Linux:
/etc/bindplane-agent/ingestion-auth.json - Windows:
C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json
- Linux:
customer_id:Google SecOps 控制台中的客户 ID。endpoint:区域级端点网址:- 美国:
malachiteingestion-pa.googleapis.com - 欧洲:
europe-malachiteingestion-pa.googleapis.com - 亚洲:
asia-southeast1-malachiteingestion-pa.googleapis.com - 如需查看完整列表,请参阅区域级端点。
- 美国:
保存配置文件
修改后,保存文件:
- Linux:依次按
Ctrl+O、Enter和Ctrl+X。 - Windows:依次点击文件 > 保存。
- Linux:依次按
重启 Bindplane 代理以应用更改
如需在 Linux 中重启 Bindplane 代理,请运行以下命令:
sudo systemctl restart observiq-otel-collector验证服务正在运行:
sudo systemctl status observiq-otel-collector检查日志中的错误:
sudo journalctl -u observiq-otel-collector -f
如需在 Windows 中重启 Bindplane 代理,请选择以下选项之一:
以管理员身份运行命令提示符或 PowerShell:
net stop observiq-otel-collector && net start observiq-otel-collector服务控制台:
- 按
Win+R,输入services.msc,然后按 Enter 键。 - 找到 observIQ OpenTelemetry Collector 。
- 右键点击并选择重启 。
验证服务正在运行:
sc query observiq-otel-collector检查日志中的错误:
type "C:\Program Files\observIQ OpenTelemetry Collector\log\collector.log"
- 按
配置 Xcitium Endpoint Security syslog 转发
Xcitium Endpoint Manager 提供两个级别的 syslog 转发。请同时配置这两个级别,以确保全面覆盖日志。
配置端点级 syslog 转发(Xcitium 客户端 - 安全日志)
- 登录 Xcitium Endpoint Manager 控制台。
- 依次前往配置模板 > 配置文件。
- 点击要修改的 Windows 配置文件,或创建新配置文件。
- 依次点击添加配置文件部分 > 日志记录设置。
- 在 Xcitium 客户端 - 安全 部分,启用写入 Syslog 服务器 。
- 提供以下配置详细信息:
- 主机:输入 Bindplane 代理主机的主机名或 IP 地址。
- 端口:输入在 Bindplane 代理中配置的端口号(例如
514)。
- (可选)启用写入日志文件(CEF 格式) ,以保留通用事件格式的日志本地副本。
- 在通信客户端 部分,启用写入 Syslog 服务器 。
- 提供以下配置详细信息:
- 主机:输入 Bindplane 代理主机的主机名或 IP 地址。
- 端口:输入在 Bindplane 代理中配置的端口号(例如
514)。
- 选择要收集日志的事件类型:
- 监控日志
- 脚本日志
- 操作系统补丁日志
- 第三方应用更新日志
- 应用安装日志
- 卸载日志
- 事件检测和响应 (EDR) 代理通信日志
- Xcitium 客户端 - 安全 (XCS) 通信日志
- 远程控制通信日志
- 运维日志
- 点击保存 。
配置门户级 syslog 转发(审核日志)
- 登录 Xcitium Endpoint Manager 控制台。
- 依次前往设置 > 门户设置 > 日志记录设置。
- 点击修改 。
- 启用写入 syslog 服务器 。
- 提供以下配置详细信息:
- 主机:输入 Bindplane 代理主机的主机名或 IP 地址。
- 端口:输入在 Bindplane 代理中配置的端口号(例如
514)。
点击保存 。
如需了解详情,请参阅 Xcitium Endpoint Manager 日志记录设置文档 和 配置审核日志设置。
UDM 映射表
| 日志字段 | UDM 映射 | 逻辑 |
|---|---|---|
event_type |
metadata.event_type |
已重命名/映射 |
data5 |
principal.application |
已直接映射 |
data3 |
principal.asset.platform_software.platform_version |
已直接映射 |
dvchost |
principal.hostname |
已直接映射 |
dvc |
principal.ip |
已合并 |
data4 |
principal.user.product_object_id |
已直接映射 |
filePath |
target.file.full_path |
已直接映射 |
fname |
target.process.parent_process.file.full_path |
已直接映射 |
suser |
target.user.userid |
已直接映射 |
| 不适用 | metadata.product_name |
常量:COMODO_AV |
| 不适用 | metadata.vendor_name |
常量:COMODO |
| 不适用 | principal.ip |
常量:dvc |