收集 Airlock Digital 应用许可名单日志

解析器版本:1.0

支持的平台:

本文档介绍了如何使用 Bindplane 代理将 Airlock Digital 应用许可名单日志注入到 Google Security Operations。

Airlock Digital 是一款应用许可名单和执行控制平台,可在端点上强制实施默认拒绝的安全模型,确保只有可信的应用、脚本和进程才能执行。该平台可在文件、路径、发布者和父进程级别提供精细的政策控制,同时提供全面的审核轨迹,以实现合规性和威胁管理。Airlock Digital 会生成执行事件、被阻止的执行、政策变更和管理操作的日志,这些日志可以使用 syslog、CEF、JSON 或 HTTP(S) 转发到 SIEM 解决方案。

准备工作

请确保满足以下前提条件:

  • Google SecOps 实例
  • Windows Server 2016 或更高版本,或者具有 systemd 的 Linux 主机
  • Bindplane 代理与 Airlock Digital 服务器之间的网络连接
  • 如果在代理后面运行,请确保防火墙端口已根据 Bindplane 代理要求打开
  • 具有管理员访问权限的 Airlock Digital 服务器(本地或云端)
  • Airlock Digital v4.7 或更高版本(用于支持 syslog 外部日志记录)

获取 Google SecOps 注入身份验证文件

  1. 登录 Google SecOps 控制台。
  2. 依次前往 SIEM 设置 > 收集代理
  3. 下载数据注入身份验证文件
  4. 将文件安全地保存在将要安装 Bindplane 的系统上。

获取 Google SecOps 客户 ID

  1. 登录 Google SecOps 控制台。
  2. 依次前往 SIEM 设置 > 配置文件
  3. 复制并保存组织详细信息部分中的客户 ID

安装 Bindplane 代理

按照以下说明在 Windows 或 Linux 操作系统上安装 Bindplane 代理。

Windows 安装

  1. 以管理员身份打开命令提示符PowerShell
  2. 运行以下命令:

    msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quiet
    
  3. 等待安装完成。

  4. 运行以下命令,验证安装是否成功:

    sc query observiq-otel-collector
    

    该服务应显示为 正在运行

Linux 安装

  1. 打开具有 root 或 sudo 权限的终端。
  2. 运行以下命令:

    sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.sh
    
  3. 等待安装完成。

  4. 运行以下命令,验证安装是否成功:

    sudo systemctl status observiq-otel-collector
    

    该服务应显示为有效(正在运行)

其他安装资源

如需了解其他安装选项和问题排查信息,请参阅 Bindplane 代理安装指南

配置 Bindplane 代理以注入 syslog 并将其发送到 Google SecOps

找到配置文件

  • Linux

    sudo nano /opt/observiq-otel-collector/config.yaml
    
  • Windows

    notepad "C:\Program Files\observIQ OpenTelemetry Collector\config.yaml"
    

修改配置文件

  • config.yaml 的全部内容替换为以下配置:

    receivers:
        tcplog:
            listen_address: "0.0.0.0:514"
    
    exporters:
        chronicle/airlock_digital:
            compression: gzip
            creds_file_path: '/etc/bindplane-agent/ingestion-auth.json'
            customer_id: '<customer_id>'
            endpoint: malachiteingestion-pa.googleapis.com
            log_type: AIRLOCK_DIGITAL
            raw_log_field: body
    
    service:
        pipelines:
            logs/airlock_digital:
                receivers:
                    - tcplog
                exporters:
                    - chronicle/airlock_digital
    

配置参数

替换以下占位符:

  • 接收器配置

    • tcplog:基于协议的接收器类型:
      • udplog(适用于 UDP syslog)
      • tcplog(适用于 TCP syslog)
      • syslog 适用于 RFC 3164/5424 syslog
    • 0.0.0.0:要监听的 IP 地址:
      • 0.0.0.0 侦听所有接口(推荐)
      • 在某个接口上监听的特定 IP 地址
    • 514:要监听的端口号(例如 51415146514
  • 导出器配置

    • <customer_id>:上一步中的客户 ID
    • malachiteingestion-pa.googleapis.com:区域端点网址:
      • 美国malachiteingestion-pa.googleapis.com
      • 欧洲europe-malachiteingestion-pa.googleapis.com
      • 亚洲asia-southeast1-malachiteingestion-pa.googleapis.com
      • 如需查看完整列表,请参阅区域级端点
    • 根据平台调整 creds_file_path
      • Linux/etc/bindplane-agent/ingestion-auth.json
      • WindowsC:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json

保存配置文件

  • 修改后,保存文件:
    • Linux:依次按 Ctrl+OEnterCtrl+X
    • Windows:依次点击文件 > 保存

重启 Bindplane 代理以应用更改

  • 如需在 Linux 中重启 Bindplane 代理,请运行以下命令:

    sudo systemctl restart observiq-otel-collector
    
    1. 验证服务是否正在运行:

      sudo systemctl status observiq-otel-collector
      
    2. 检查日志是否存在错误:

      sudo journalctl -u observiq-otel-collector -f
      
  • 如需在 Windows 中重启 Bindplane 代理,请选择以下选项之一:

    • 以管理员身份运行命令提示符或 PowerShell:

      net stop observiq-otel-collector && net start observiq-otel-collector
      
    • 服务控制台:

      1. Win+R,输入 services.msc,然后按 Enter 键。
      2. 找到 observIQ OpenTelemetry 收集器
      3. 右键点击并选择重新启动
      4. 验证服务是否正在运行:

        sc query observiq-otel-collector
        
      5. 检查日志是否存在错误:

        type "C:\Program Files\observIQ OpenTelemetry Collector\log\collector.log"
        

配置 Airlock Digital 外部日志记录

将 Airlock Digital Server 配置为使用 syslog 将日志转发到 Bindplane 代理。Airlock Digital 支持多种外部日志记录格式,包括通用 Syslog、CEF、JSON、HTTP(S) 和 GELF。

  1. 使用管理员账号登录 Airlock Digital Server Console
  2. 依次前往系统 > 外部日志记录
  3. 点击添加以创建新的外部日志记录配置。
  4. 日志记录类型下拉菜单中,选择通用 Syslog

  5. 提供以下配置详细信息:

    • 服务器地址:输入 Bindplane 代理主机(例如 192.168.1.100)的 IP 地址或主机名
    • 端口:输入 514(或在 Bindplane 代理中配置的端口)
    • 协议:选择 TCP
  6. 日志类别部分中,选择要转发的事件类型:

    • 执行事件(已屏蔽和允许的执行)
    • 政策变更
    • 管理操作
    • 代理事件
    • 服务器活动
  7. 点击保存以应用外部日志记录配置。

  8. 通过检查 Bindplane 代理日志或查看 Airlock Digital Server 控制台中的外部日志记录状态,验证日志是否正在转发。

如需详细了解 Airlock Digital SIEM 集成,请参阅 Airlock Digital SIEM 集成页面

UDM 映射表

日志字段 UDM 映射 逻辑
event_type extensions.auth.type 已映射:ServerActivityMessageSSO
product_event_type extensions.auth.type 已映射:(?i)LoginSSO
task extensions.auth.type 已映射:LoginAUTHTYPE_UNSPECIFIEDLogoutAUTHTYPE_UNSPECIFIED
intermediary_hostname intermediary.hostname 直接映射
description metadata.description 直接映射
metadata_description metadata.description 直接映射
event_timestamp metadata.event_timestamp 解析为 yyyy-MM-dd HH:mm:ss.SSS
ingestion_time metadata.event_timestamp 解析为 RFC 3339
event_type metadata.event_type 已映射:FileActivityMessageSTATUS_UPDATEServerActivityMessageUSER_LOGIN、`Se...
has_principal metadata.event_type 已映射:trueFILE_UNCATEGORIZED
product_event_type metadata.event_type 已映射:(?i)LoginUSER_LOGIN
task metadata.event_type 已映射:LoginUSER_LOGINLogoutUSER_LOGOUT
event_type metadata.product_event_type 直接映射
product_event_type metadata.product_event_type 直接映射
checkpoint metadata.product_log_id 直接映射
browser network.http.user_agent 直接映射
netdomain principal.administrative_domain 直接映射
asset_category principal.asset.category 直接映射
hostname principal.asset.hostname 直接映射
srcip principal.asset.ip 已合并
software principal.asset.software 已合并
hostname principal.hostname 直接映射
principal_hostname principal.hostname 直接映射
srcip principal.ip 已合并
process_file_path principal.process.file.full_path 直接映射
file_md5 principal.process.file.md5 直接映射
process_file_name principal.process.file.names 已合并
file_sha256 principal.process.file.sha256 直接映射
parent_process_file principal.process.parent_process.file.full_path 直接映射
principal_user_userid principal.user.userid 直接映射
description security_result.action 已映射:Invalid login attemptsecurity_result_action
metadata_description security_result.action 已映射:logged in successsecurity_result_action
security_result_action security_result.action 已合并
file_sha128_label security_result.detection_fields 已合并
policyname_label security_result.detection_fields 已合并
policyver_label security_result.detection_fields 已合并
ppolicy_label security_result.detection_fields 已合并
sha128_label security_result.detection_fields 已合并
sha384_label security_result.detection_fields 已合并
sha512_label security_result.detection_fields 已合并
type_label security_result.detection_fields 已合并
source_file src.file.full_path 直接映射
source_file_name src.file.full_path 直接映射
filename target.file.full_path 直接映射
sha256 target.file.sha256 直接映射
commandline target.process.command_line 直接映射
filename target.process.file.full_path 直接映射
InstanceURL target.url 直接映射
principal_user_userid target.user.userid 直接映射
user target.user.userid 直接映射
不适用 extensions.auth.type 常量:AUTHTYPE_UNSPECIFIED
不适用 metadata.event_type 常量:USER_LOGIN
不适用 metadata.product_name 常量:Airlock Digital
不适用 metadata.vendor_name 常量:Airlock Digital

更新日志

查看相应解析器的更改日志

需要更多帮助?获得社区成员和 Google SecOps 专业人士的解答。