收集 Quest 文件访问审核日志
本文档介绍了如何使用 Bindplane 代理将 Quest 文件访问审核日志注入到 Google Security Operations。
Quest Change Auditor(以前称为 Quest File Access Audit)是一个文件服务器和 Active Directory 审核平台,可监控和报告 Windows 环境中的文件访问活动、权限更改和管理操作。Change Auditor 提供内置的 SIEM 集成功能,包括通过事件订阅转发 syslog。
准备工作
请确保满足以下前提条件:
- Google SecOps 实例
- Windows Server 2016 或更高版本,或者具有
systemd的 Linux 主机 - Bindplane 代理与 Quest Change Auditor 协调器服务器之间的网络连接
- 如果在代理后面运行,请确保防火墙端口已根据 Bindplane 代理要求打开
- 对 Quest Change Auditor 客户端或协调器服务器的特权访问权限
获取 Google SecOps 注入身份验证文件
- 登录 Google SecOps 控制台。
- 依次前往 SIEM 设置 > 收集代理。
- 下载数据注入身份验证文件。
将文件安全地保存在将要安装 Bindplane 的系统上。
获取 Google SecOps 客户 ID
- 登录 Google SecOps 控制台。
- 依次前往 SIEM 设置 > 配置文件。
复制并保存组织详细信息部分中的客户 ID。
安装 Bindplane 代理
按照以下说明在 Windows 或 Linux 操作系统上安装 Bindplane 代理。
Windows 安装
- 以管理员身份打开命令提示符或 PowerShell。
运行以下命令:
msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quiet等待安装完成。
运行以下命令,验证安装是否成功:
sc query observiq-otel-collector该服务应显示为 正在运行。
Linux 安装
- 打开具有 root 或 sudo 权限的终端。
运行以下命令:
sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.sh等待安装完成。
运行以下命令,验证安装是否成功:
sudo systemctl status observiq-otel-collector该服务应显示为有效(正在运行)。
其他安装资源
如需了解其他安装选项和问题排查信息,请参阅 Bindplane 代理安装指南。
配置 Bindplane 代理以注入 syslog 并将其发送到 Google SecOps
找到配置文件
Linux:
sudo nano /opt/observiq-otel-collector/config.yamlWindows:
notepad "C:\Program Files\observIQ OpenTelemetry Collector\config.yaml"
修改配置文件
将
config.yaml的全部内容替换为以下配置:receivers: udplog: listen_address: "0.0.0.0:514" exporters: chronicle/quest_file_audit: compression: gzip creds_file_path: '/etc/bindplane-agent/ingestion-auth.json' customer_id: '<customer_id>' endpoint: malachiteingestion-pa.googleapis.com log_type: QUEST_FILE_AUDIT raw_log_field: body service: pipelines: logs/quest_file_audit_to_chronicle: receivers: - udplog exporters: - chronicle/quest_file_audit
配置参数
替换以下占位符:
接收器配置:
listen_address:要监听的 IP 地址和端口:0.0.0.0侦听所有接口(推荐)- 端口
514是标准 syslog 端口(在 Linux 上需要 root 权限;对于非 root 用户,请使用1514)
导出器配置:
creds_file_path:提取身份验证文件的完整路径:- Linux:
/etc/bindplane-agent/ingestion-auth.json - Windows:
C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json
- Linux:
customer_id:从 Google SecOps 控制台复制的客户 IDendpoint:区域端点网址:- 美国:
malachiteingestion-pa.googleapis.com - 欧洲:
europe-malachiteingestion-pa.googleapis.com - 亚洲:
asia-southeast1-malachiteingestion-pa.googleapis.com - 如需查看完整列表,请参阅区域级端点
- 美国:
保存配置文件
- 修改后,保存文件:
- Linux:依次按
Ctrl+O、Enter和Ctrl+X - Windows:依次点击文件 > 保存
- Linux:依次按
重启 Bindplane 代理以应用更改
如需在 Linux 中重启 Bindplane 代理,请运行以下命令:
sudo systemctl restart observiq-otel-collector验证服务是否正在运行:
sudo systemctl status observiq-otel-collector检查日志是否存在错误:
sudo journalctl -u observiq-otel-collector -f
如需在 Windows 中重启 Bindplane 代理,请选择以下选项之一:
以管理员身份运行命令提示符或 PowerShell:
net stop observiq-otel-collector && net start observiq-otel-collector服务控制台:
- 按
Win+R,输入services.msc,然后按 Enter 键。 - 找到 observIQ OpenTelemetry 收集器。
- 右键点击并选择重新启动。
验证服务是否正在运行:
sc query observiq-otel-collector检查日志是否存在错误:
type "C:\Program Files\observIQ OpenTelemetry Collector\log\collector.log"
- 按
配置 Quest Change Auditor syslog 转发
选项 1:使用 Change Auditor 客户端配置 syslog 转发
- 打开 Change Auditor 客户端应用。
- 依次前往管理 > 事件订阅。
- 点击新建,然后选择 Syslog 作为订阅类型。
- 在 Syslog 事件订阅向导中,配置以下内容:
- Host:输入 Bindplane 代理主机 IP 地址。
- 端口:输入
514。 - 消息格式:选择 CEF(通用事件格式)或 LEEF(日志事件扩展格式)。
- 子系统:选择要转发的事件子系统(例如文件系统)。
- 点击完成以创建订阅。
方法 2:使用 PowerShell 配置 syslog 转发
- 在 Change Auditor 协调器服务器上打开 PowerShell,然后导入 Change Auditor 模块。
创建 syslog 事件订阅:
$subsystems = Get-CAEventExportSubsystems | Where-Object { $_.Name -like "*File*" } New-CASyslogEventSubscription -Host "<BINDPLANE_AGENT_IP>" -Port 514 -SyslogFormat "CEF" -Subsystems $subsystems验证订阅是否已创建:
Get-CASyslogEventSubscriptions
UDM 映射表
| 日志字段 | UDM 映射 | 逻辑 |
|---|---|---|
| 关键字、EventType、任务、ThreadID、渠道、操作码 | additional.fields | 有关活动的其他信息 |
| EventTime | metadata.event_timestamp | 事件发生时的时间戳 |
| event_type | metadata.event_type | 事件的类型 |
| EventReceivedTime | metadata.ingested_timestamp | 事件被提取时的时间戳 |
| EventID | metadata.product_event_type | 产品定义的事件类型 |
| RecordNumber | metadata.product_log_id | 产品分配的日志 ID |
| metadata.product_name | 生成相应事件的产品的名称 | |
| metadata.vendor_name | 生成相应事件的供应商的名称 | |
| SourceModuleType | observer.application | 观测者使用的应用 |
| SourceModuleName | observer.resource.attribute.labels | 与观测者资源关联的标签 |
| 网域 | principal.administrative_domain | 主账号的管理网域 |
| SourceName | principal.application | 主账号使用的应用 |
| 主机名 | principal.asset.hostname | 与正文相关联的资产的主机名 |
| ip_address | principal.asset.ip | 与正文相关联的资产的 IP 地址 |
| 主机名 | principal.hostname | 主账号的主机名 |
| ip_address | principal.ip | 主账号的 IP 地址 |
| ProcessID | principal.process.pid | 进程 ID |
| logonID | principal.user.attribute.labels | 与用户关联的标签 |
| AccountType | principal.user.attribute.roles | 与用户关联的角色 |
| AccountName | principal.user.userid | 用户 ID |
| UserID | principal.user.windows_sid | 用户的 Windows SID |
| 说明 | security_result.description | 安全结果的说明 |
| SeverityValue | security_result.severity | 安全结果的严重程度 |
| 严重级别 | security_result.severity_details | 严重程度详情 |
| 类别 | security_result.summary | 安全性结果摘要 |
| file_path | target.file.full_path | 目标文件的完整路径 |
| file_path | target.process.file.full_path | 与目标进程关联的文件的完整路径 |