收集 ION Spectrum 日志
本文档介绍了如何使用 Bindplane 代理将 ION Spectrum 日志注入 Google Security Operations。
ION Spectrum 是 ION Group 的金融交易和处理平台,用于外汇和多资产前台/中台/后台自动化。它会生成交易活动、系统事件和用户操作的审核日志。
准备工作
请确保满足以下前提条件:
- Google SecOps 实例
- Windows Server 2016 或更高版本,或者具有
systemd的 Linux 主机 - Bindplane 代理与 ION Spectrum 服务器之间的网络连接
- 如果通过代理运行,请确保防火墙端口根据 Bindplane 代理要求处于开放状态
- 对 ION Spectrum 服务器具有管理员权限的特权访问权限
获取 Google SecOps 注入身份验证文件
- 登录 Google SecOps 控制台。
- 前往 SIEM 设置 > 收集代理。
- 下载数据注入身份验证文件。
将文件安全地保存在将安装 Bindplane 的系统上。
获取 Google SecOps 客户 ID
- 登录 Google SecOps 控制台。
- 前往 SIEM 设置 > 个人资料。
从组织详细信息 部分复制并保存客户 ID 。
安装 Bindplane 代理
按照以下说明在 Windows 或 Linux 操作系统上安装 Bindplane 代理。
Windows 安装
- 以管理员身份打开命令提示符 或 PowerShell 。
运行以下命令:
msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quiet等待安装完成。
运行以下命令,验证安装是否成功:
sc query observiq-otel-collector该服务应显示为正在运行 。
Linux 安装
- 打开具有根权限或 sudo 权限的终端。
运行以下命令:
sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.sh等待安装完成。
运行以下命令,验证安装是否成功:
sudo systemctl status observiq-otel-collector该服务应显示为活跃 (正在运行) 。
其他安装资源
如需了解其他安装选项和问题排查信息,请参阅 Bindplane 代理安装指南。
配置 Bindplane 代理以注入日志并发送到 Google SecOps
找到配置文件
Linux :
sudo nano /opt/observiq-otel-collector/config.yamlWindows :
notepad "C:\Program Files\observIQ OpenTelemetry Collector\config.yaml"
修改配置文件
将
config.yaml的全部内容替换为以下配置:receivers: filelog: include: - /opt/ion/spectrum/logs/*.csv - /opt/ion/spectrum/logs/*.log start_at: beginning poll_interval: 5s exporters: chronicle/ion_spectrum: compression: gzip creds_file_path: '/etc/bindplane-agent/ingestion-auth.json' customer_id: '<customer_id>' endpoint: malachiteingestion-pa.googleapis.com log_type: ION_SPECTRUM raw_log_field: body ingestion_labels: env: production service: pipelines: logs/ion_spectrum_to_chronicle: receivers: - filelog exporters: - chronicle/ion_spectrum
配置参数
替换以下占位符:
接收器配置:
include:ION Spectrum 日志文件的路径:- Windows:
C:\ION\Spectrum\logs\*.csv和C:\ION\Spectrum\logs\*.log - Linux:
/opt/ion/spectrum/logs/*.csv和/opt/ion/spectrum/logs/*.log
- Windows:
start_at:设置为beginning以读取现有日志,或设置为end以仅读取新条目poll_interval:检查新日志数据的频率(默认值:5s)
导出器配置:
ion_spectrum:导出器的描述性名称creds_file_path:注入身份验证文件的完整路径:- Linux:
/etc/bindplane-agent/ingestion-auth.json - Windows:
C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json
- Linux:
<customer_id>:上一步中的客户 IDendpoint:区域级端点网址:- 美国:
malachiteingestion-pa.googleapis.com - 欧洲:
europe-malachiteingestion-pa.googleapis.com - 亚洲:
asia-southeast1-malachiteingestion-pa.googleapis.com - 如需查看完整列表,请参阅区域级端点
- 美国:
ION_SPECTRUM:日志类型,与 Chronicle 中显示的内容完全一致ingestion_labels:YAML 格式的可选标签(例如,env: production)
流水线配置:
ion_spectrum_to_chronicle:流水线的描述性名称
保存配置文件
- 修改后,保存文件:
- Linux:按
Ctrl+O,然后按Enter,再按Ctrl+X - Windows:依次点击文件 > 保存
- Linux:按
重启 Bindplane 代理以应用更改
如需在 Linux 中重启 Bindplane 代理,请运行以下命令:
sudo systemctl restart observiq-otel-collector验证服务正在运行:
sudo systemctl status observiq-otel-collector检查日志中的错误:
sudo journalctl -u observiq-otel-collector -f
如需在 Windows 中重启 Bindplane 代理,请选择以下选项之一:
以管理员身份运行命令提示符或 PowerShell:
net stop observiq-otel-collector && net start observiq-otel-collector服务控制台:
- 按
Win+R,输入services.msc,然后按 Enter 键。 - 找到 observIQ OpenTelemetry Collector 。
- 右键点击并选择重启 。
验证服务正在运行:
sc query observiq-otel-collector检查日志中的错误:
type "C:\Program Files\observIQ OpenTelemetry Collector\log\collector.log"
- 按
配置 ION Spectrum 日志收集
- 以管理员权限登录 ION Spectrum 服务器。
- 进入 ION Spectrum 日志目录。常见的默认路径包括:
- Windows:
C:\ION\Spectrum\logs\ - Linux:
/opt/ion/spectrum/logs/
- Windows:
- 验证是否正在生成以下日志类型:
- 审核日志:用户活动、登录/退出事件和配置更改(CSV 格式)。
- 交易日志:交易执行、订单管理和结算事件。
- 系统日志:应用错误、警告和性能事件。
- 确保 Bindplane 代理对日志目录和文件具有读取权限。
如果 Bindplane 代理在与 ION Spectrum 不同的主机上运行,请配置网络文件共享 (NFS 或 SMB),以使 Bindplane 代理主机可以访问日志目录。
UDM 映射表
| 日志字段 | UDM 映射 | 逻辑 |
|---|---|---|
| column5 | metadata.event_timestamp | 事件发生时的时间戳 |
| has_principal、has_target_user、column6 | metadata.event_type | 事件类型(例如,USER_LOGIN、NETWORK_CONNECTION) |
| column6 | metadata.product_event_type | 产品定义的事件类型 |
| column1 | principal.asset.hostname | 与正文相关联的资产的主机名 |
| column1 | principal.asset.ip | 与正文相关联的资产的 IP 地址 |
| column1 | principal.hostname | 与正文相关联的主机名 |
| column1 | principal.ip | 与正文相关联的 IP 地址 |
| column7 | security_result.action | 因安全评估而采取的操作 |
| column7 | security_result.action_details | 有关安全结果操作的详细信息 |
| column4 | target.user.group_identifiers | 目标用户所属群组的标识符 |
| column3 | target.user.user_display_name | 目标用户的显示名称 |
| column2 | target.user.userid | 目标用户的用户 ID |
| metadata.product_name | 生成事件的产品的名称 | |
| metadata.vendor_name | 生成事件的供应商的名称 | |
ION_SPECTRUM |
metadata.product_name |
从更新日志映射 |