收集 Appian Cloud 日志

解析器版本:4.0

支持:

本文档介绍了如何使用 Bindplane 代理将 Appian Cloud 日志注入 Google Security Operations。

Appian Cloud 是一个低代码自动化平台,可让组织构建企业应用和工作流。日志流式传输功能可通过 IPsec VPN 连接提供 Appian Cloud 环境中的审核和安全性事件日志。

准备工作

请确保满足以下前提条件:

  • Google SecOps 实例
  • Windows Server 2016 或更高版本,或者具有 systemd 的 Linux 主机
  • 如果在代理后面运行,请确保按照 Bindplane 代理要求打开防火墙端口
  • Appian Cloud 的专业版或签名版许可
  • Appian 环境网址记录
  • Appian Cloud 与将部署 Bindplane 代理的环境之间的 IPsec VPN

获取 Bindplane 代理的 Google SecOps 凭证

如需向 Google SecOps 验证 Bindplane 代理,请选择以下方法之一:

  • 新部署:使用 Chronicle API(选项 1)。
  • 旧版部署:继续使用数据注入身份验证文件(方法 2),直到 Ingestion API 于 2027 年 7 月 20 日停用。
  1. 登录 Google Cloud 控制台,然后选择与您的 Google SecOps 实例关联的 Google Cloud 项目。
  2. 前往 IAM 和管理 > 服务账号。
  3. 点击创建服务账号。
  4. 提供以下配置详细信息:
    • 服务账号名称:输入账号的名称(例如 bindplane-ingest)。
    • 服务账号说明:输入说明(例如 Bindplane agent log ingestion)。
  5. 点击创建并继续。
  6. 在向此服务账号授予对项目的访问权限部分,点击选择角色,然后选择 Chronicle Editor。
  7. 点击继续,然后点击完成。
  8. 点击您创建的服务账号,然后前往密钥标签页。
  9. 依次点击添加密钥> 创建新密钥。
  10. 选择 JSON,然后点击创建。密钥文件会下载到您的计算机上。
  11. 将密钥文件另存为 Bindplane 收集器目录(Linux 上的 /opt/observiq-otel-collector/ingestion-auth.json 或 Windows 上的 C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json)中的 ingestion-auth.json,或更新 config.yaml 中的 creds_file_path 以匹配您保存该文件的路径。
  12. 前往 IAM 和管理 > 设置,然后复制项目编号。您在配置导出器时需要用到该名称。

方法 2:下载数据注入身份验证文件(旧版)

  1. 登录 Google SecOps 控制台。
  2. 前往 SIEM 设置> 收集代理。
  3. 下载数据注入身份验证文件。
  4. 将文件安全地保存在将安装 Bindplane 代理的系统上。

获取 Google SecOps 客户 ID

  1. 登录 Google SecOps 控制台。
  2. 前往 SIEM 设置 > 个人资料。
  3. 从组织详细信息部分复制并保存客户 ID。

安装 Bindplane 代理

根据以下说明,在 Windows 或 Linux 操作系统上安装 Bindplane 代理。

Windows 安装

  1. 以管理员身份打开命令提示符或 PowerShell。
  2. 运行以下命令:

    msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quiet
    
  3. 等待安装完成。

  4. 运行以下命令,验证安装是否成功:

    sc query observiq-otel-collector
    

    该服务应显示为 RUNNING。

Linux 安装

  1. 打开具有 root 或 sudo 权限的终端。
  2. 运行以下命令:

    sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.sh
    
  3. 等待安装完成。

  4. 运行以下命令,验证安装是否成功:

    sudo systemctl status observiq-otel-collector
    

    该服务应显示为有效(正在运行)。

其他安装资源

如需了解其他安装选项和问题排查信息,请参阅 Bindplane 代理安装指南。

配置 Bindplane 代理以注入 syslog 并发送到 Google SecOps

找到配置文件

  • Linux:

    sudo nano /opt/observiq-otel-collector/config.yaml
    
  • Windows:

    notepad "C:\Program Files\observIQ OpenTelemetry Collector\config.yaml"
    

修改配置文件

  • 将 config.yaml 的全部内容替换为以下配置:

    receivers:
      tcplog:
        listen_address: "0.0.0.0:6514"
    
    exporters:
      chronicle/appian_cloud:
        protocol: https
        # Region of your instance, for example us, europe, asia-southeast1
        location: <LOCATION>
        # Project number of the Google Cloud project linked to the instance
        project: '<PROJECT_NUMBER>'
        compression: gzip
        creds_file_path: '/opt/observiq-otel-collector/ingestion-auth.json'
        customer_id: '<customer_id>'
        endpoint: chronicle.googleapis.com
        log_type: APPIAN_CLOUD
        raw_log_field: body
    
    service:
      pipelines:
        logs/appian_to_chronicle:
          receivers:
            - tcplog
          exporters:
            - chronicle/appian_cloud
    

配置参数

替换以下占位符:

  • 接收器配置:

    • listen_address:要监听的 IP 地址和端口:
      • 0.0.0.0 在所有接口上监听(推荐)
      • 建议将端口 6514 用于 Appian Cloud 日志流式传输
  • 导出器配置:

    • creds_file_path:服务账号 JSON 密钥文件的完整路径(选项 1):
      • Linux:/opt/observiq-otel-collector/ingestion-auth.json
      • Windows:C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json
    • customer_id:从 Google SecOps 控制台复制的客户 ID
    • location:将 <LOCATION> 替换为 Google SecOps 实例所在的区域(例如 us、europe 或 asia-southeast1)。导出工具会在此值前面加上 chronicle.googleapis.com。如需查看完整列表,请参阅区域级端点。
    • project:将 <PROJECT_NUMBER> 替换为“IAM 和管理”>“设置”中的项目编号。
    • endpoint:保持设置为 chronicle.googleapis.com。

旧版提取 API 导出工具

  • 如果您使用选项 2 中的数据注入身份验证文件,请将 exporters 代码块替换为以下内容。将 creds_file_path 设置为数据注入身份验证文件的路径,如果您的实例位于美国境外,请将 malachiteingestion-pa.googleapis.com 替换为您的区域端点(例如 europe-malachiteingestion-pa.googleapis.com)。

    exporters:
      chronicle/appian_cloud:
        compression: gzip
        creds_file_path: '/opt/observiq-otel-collector/ingestion-auth.json'
        customer_id: '<customer_id>'
        endpoint: malachiteingestion-pa.googleapis.com
        log_type: APPIAN_CLOUD
        raw_log_field: body
    

保存配置文件

  • 修改后,保存文件:
    • Linux:依次按 Ctrl+O、Enter 和 Ctrl+X
    • Windows:依次点击文件 > 保存

重启 Bindplane 代理以应用更改

  • 如需在 Linux 中重启 Bindplane 代理,请运行以下命令:

    sudo systemctl restart observiq-otel-collector
    
    1. 验证服务是否正在运行:

      sudo systemctl status observiq-otel-collector
      
    2. 检查日志中的错误:

      sudo journalctl -u observiq-otel-collector -f
      
  • 如需在 Windows 中重启 Bindplane 代理,请选择以下选项之一:

    • 以管理员身份运行命令提示符或 PowerShell:

      net stop observiq-otel-collector && net start observiq-otel-collector
      
    • “服务”控制台:

      1. 按 Win+R,输入 services.msc,然后按 Enter 键。
      2. 找到 observIQ OpenTelemetry 收集器。
      3. 右键点击,然后选择重新启动。
      4. 验证服务是否正在运行:

        sc query observiq-otel-collector
        
      5. 检查日志中的错误:

        type "C:\Program Files\observIQ OpenTelemetry Collector\log\collector.log"
        

为 Appian Cloud 启用日志流式传输

  1. 向 Appian 提交支持请求,主题为启用日志流式传输,并包含以下详细信息:
    • 环境网址
    • 所需网络路径,例如 IPsec VPN
    • Bindplane 代理 IP 地址
    • Bindplane 代理 TCP 端口号(例如 6514)
  2. Appian 支持团队会安排维护窗口并部署配置。

UDM 映射表

日志字段 UDM 映射 逻辑
available_heap_space_label additional.fields 已合并
cpu_core_count_label additional.fields 已合并
daemon_thread_count_label additional.fields 已合并
data_store_label additional.fields 已合并
devicetimestamp_label additional.fields 已合并
entity_label additional.fields 已合并
execute_time_label additional.fields 已合并
load_average_label additional.fields 已合并
operation_name_label additional.fields 已合并
operation_type_label additional.fields 已合并
permanent_generation_available_label additional.fields 已合并
permanent_generation_used_label additional.fields 已合并
prepare_time_label additional.fields 已合并
retcode_label additional.fields 已合并
session_count_label additional.fields 已合并
tenured_collection_count_label additional.fields 已合并
tenured_collection_time_label additional.fields 已合并
tenured_generation_available_label additional.fields 已合并
tenured_generation_usage_after_collection_label additional.fields 已合并
tenured_generation_used_label additional.fields 已合并
thread_label additional.fields 已合并
total_swap_space_label additional.fields 已合并
total_system_memory_label additional.fields 已合并
total_thread_count_label additional.fields 已合并
transform_time_label additional.fields 已合并
used_heap_space_label additional.fields 已合并
used_swap_space_label additional.fields 已合并
used_system_memory_label additional.fields 已合并
young_cllection_time_label additional.fields 已合并
young_collection_count_label additional.fields 已合并
has_principal_user extensions.auth.type 已映射:true → AUTHTYPE_UNSPECIFIED
src_host intermediary.hostname 直接映射
src_ip intermediary.ip 已合并
time metadata.event_timestamp 已解析为 yyyy-MM-dd HH:mm:ss
event_type metadata.event_type 直接映射
device metadata.product_event_type 直接映射
product_type metadata.product_event_type 直接映射
http_method network.http.method 直接映射
useragent network.http.parsed_user_agent 已重命名/映射
useragent network.http.user_agent 直接映射
connectionid network.session_id 直接映射
sessionID network.session_id 直接映射
session_id network.session_id 直接映射
domain principal.administrative_domain 直接映射
application principal.application 直接映射
host principal.asset.hostname 直接映射
hostname principal.asset.hostname 直接映射
IpAddress principal.asset.ip 已合并
host principal.hostname 直接映射
hostname principal.hostname 直接映射
IpAddress principal.ip 已合并
src_port principal.port 直接映射
process_id principal.process.pid 直接映射
url principal.url 直接映射
roles principal.user.attribute.roles 已合并
companyname principal.user.company_name 直接映射
email principal.user.email_addresses 已合并
user_id principal.user.email_addresses 已映射:N/A → user_id
modified_by_uuid principal.user.product_object_id 直接映射
user principal.user.product_object_id 直接映射
modified_by_username principal.user.userid 直接映射
userId principal.user.userid 直接映射
user_id principal.user.userid 直接映射
username2 principal.user.userid 直接映射
versionDetails security_result.about.platform_version 直接映射
outcome_result security_result.action 已合并
security_result_action security_result.action 已合并
act security_result.action_details 直接映射
status security_result.action_details 直接映射
sec_result_category security_result.category 已合并
category security_result.category_details 已合并
desc security_result.description 直接映射
details security_result.description 直接映射
details_label security_result.detection_fields 已合并
endpoint_label security_result.detection_fields 已合并
execution_count_label security_result.detection_fields 已合并
maximum_execution_time_label security_result.detection_fields 已合并
maximum_response_size_label security_result.detection_fields 已合并
maximum_response_time_label security_result.detection_fields 已合并
mean_execution_time_label security_result.detection_fields 已合并
mean_response_size_label security_result.detection_fields 已合并
minimum_execution_time_label security_result.detection_fields 已合并
minimum_response_size_label security_result.detection_fields 已合并
model_label security_result.detection_fields 已合并
rolesAllow_label security_result.detection_fields 已合并
sqlcmd_label security_result.detection_fields 已合并
status_code_1xx_count_label security_result.detection_fields 已合并
status_code_2xx_count_label security_result.detection_fields 已合并
status_code_3xx_count_label security_result.detection_fields 已合并
status_code_4xx_count_label security_result.detection_fields 已合并
status_code_5xx_count_label security_result.detection_fields 已合并
type_label security_result.detection_fields 已合并
uuid_label security_result.detection_fields 已合并
severity security_result.severity Mapped: "INFORMATIONAL","INFORMATION","INFO" → INFORMATIONAL, "WARNING", "MEDIUM" → `M…
detail security_result.severity_details 直接映射
action1 security_result.summary 直接映射
msg security_result.summary 直接映射
object security_result.summary 直接映射
operation_detail security_result.summary 直接映射
reason security_result.summary 直接映射
summary security_result.summary 直接映射
server_host target.asset.hostname 直接映射
tar_host target.asset.hostname 直接映射
src_ip1 target.asset.ip 已合并
hash target.file.md5 直接映射
document_name target.file.names 已合并
server_host target.hostname 直接映射
tar_host target.hostname 直接映射
src_ip1 target.ip 已合并
commandline target.process.command_line 直接映射
action_label target.resource.attribute.labels 已合并
environment_label target.resource.attribute.labels 已合并
filters_label target.resource.attribute.labels 已合并
new_value_label target.resource.attribute.labels 已合并
original_value_label target.resource.attribute.labels 已合并
page_group_invoved_label target.resource.attribute.labels 已合并
page_involved_label target.resource.attribute.labels 已合并
record_identifier_label target.resource.attribute.labels 已合并
record_type_name_label target.resource.attribute.labels 已合并
record_type_url_stub_label target.resource.attribute.labels 已合并
setting_new_value_label target.resource.attribute.labels 已合并
setting_old_value_label target.resource.attribute.labels 已合并
site_involved_label target.resource.attribute.labels 已合并
site_url_stub_label target.resource.attribute.labels 已合并
view_label target.resource.attribute.labels 已合并
database target.resource.name 直接映射
property target.resource.name 直接映射
record_type_name target.resource.name 直接映射
resourcename target.resource.name 直接映射
site_involved target.resource.name 直接映射
id target.resource.product_object_id 直接映射
oid target.resource.product_object_id 直接映射
queryid target.resource.product_object_id 直接映射
sessionID target.resource.product_object_id 直接映射
transactionId target.resource.product_object_id 直接映射
action target.resource.resource_subtype 直接映射
name target.resource.resource_subtype 直接映射
user_uuid target.user.product_object_id 直接映射
username1 target.user.userid 直接映射
不适用 extensions.auth.type 常量:AUTHTYPE_UNSPECIFIED
不适用 metadata.event_type 常量:GENERIC_EVENT
不适用 metadata.log_type 常量:APPIAN_CLOUD
不适用 metadata.product_name 常量:Cloud Platform
不适用 metadata.vendor_name 常量:Appian
不适用 security_result.severity 常量:INFORMATIONAL
sessionID event.idm.read_only_udm.network.session_id 从更新日志映射
transactionId event.idm.read_only_udm.target.resource.product_object_id 从更新日志映射
versionDetails event.idm.read_only_udm.security_result.about.platform_version 从更新日志映射
application event.idm.read_only_udm.principal.application 从更新日志映射
IpAddress event.idm.read_only_udm.principal.ip 从更新日志映射
IpAddress event.idm.read_only_udm.principal.asset.ip 从更新日志映射
userId event.idm.read_only_udm.principal.user.userid 从更新日志映射
rolesAllow event.idm.read_only_udm.additional.fields 从更新日志映射
userRole event.idm.read_only_udm.additional.fields 从更新日志映射
status event.idm.read_only_udm.section_result.action_details 从更新日志映射
resourcename event.idm.read_only_udm.target.resource.name 从更新日志映射
commandline event.idm.read_only_udm.target.process.command_line 从更新日志映射
devicetimestamp event.idm.read_only_udm.additional.fields 从更新日志映射
email event.idm.read_only_udm.principal.user.email_addresses 从更新日志映射
document_name target.files.names 从更新日志映射
msg" and "reason security_result.summary 从更新日志映射
original_value", "setting_new_value", "setting_old_value", and "new_value target.resource.attribute.labels 从更新日志映射
page_involved", "site_involved", and "page_group_involved target.resource.attribute.labels 从更新日志映射
total_thread_count", "daemon_thread_count", used_heap_space", "available_heap_space", "tenured_generation_usage_after_collection", "tenured_generation_used", "tenured_generation_available", "permanent_generation_used", and "permanent_generation_available additional.fields 从更新日志映射
young_collection_count", "young_cllection_time", "tenured_collection_count", "tenured_collection_time", "cpu_core_count", "total_system_memory", "used_system_memory", "total_swap_space", "used_swap_space", "load_average", and "session_count additional.fields 从更新日志映射
record_identifier", "record_type_url_stub", "view", "filters", "environment", and "site_url_stub target.resource.attribute.labels 从更新日志映射
data_store", "entity", and "operation_type additional.fields 从更新日志映射
operation_name", "prepare_time", "transform_time", and "execute_time additional.fields 从更新日志映射
connectionid network.session.id 从更新日志映射
minimum_execution_time", "execution_count", "status_code_1xx_count", "status_code_2xx_count", "status_code_3xx_count", "status_code_4xx_count", "status_code_5xx_count", "minimum_response_size", "maximum_response_time", "maximum_response_size", "mean_execution_time", and "maximum_response_size security_result.detection_fields 从更新日志映射

更新日志

查看相应解析器的更新日志

需要更多帮助?获得社区成员和 Google SecOps 专业人士的解答。