收集 Oracle Unified Directory 日志
本文档介绍了如何使用 Bindplane 将 Oracle Unified Directory 日志注入到 Google Security Operations。
Oracle Unified Directory 是一种企业 LDAP 目录服务,用于身份管理。它提供了一个可伸缩的、基于标准的目录,用于存储和管理身份数据,支持身份验证、授权和目录代理功能。解析器会从 Oracle Unified Directory 日志条目中提取字段,并将它们映射到统一数据模型 (UDM)。
准备工作
请确保满足以下前提条件:
- Google SecOps 实例
- Windows Server 2016 或更高版本,或者具有
systemd的 Linux 主机 - Bindplane 代理与 Oracle Unified Directory 服务器之间的网络连接
- 如果通过代理运行,请确保防火墙端口根据 Bindplane 代理要求处于开放状态
- 对 Oracle Unified Directory 服务器的特权访问权限,且具有管理员权限
获取 Google SecOps 注入身份验证文件
- 登录 Google SecOps 控制台。
- 前往 SIEM 设置 > 收集代理。
下载数据注入身份验证文件 。将该文件安全地保存在将安装 Bindplane 的系统上。
获取 Google SecOps 客户 ID
- 登录 Google SecOps 控制台。
- 前往 SIEM 设置 > 个人资料。
从组织详细信息 部分复制并保存客户 ID 。
安装 Bindplane 代理
按照以下说明在 Windows 或 Linux 操作系统上安装 Bindplane 代理。
Windows 安装
- 以管理员身份打开命令提示符 或 PowerShell 。
运行以下命令:
msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quiet等待安装完成。
运行以下命令,验证安装是否成功:
sc query observiq-otel-collector
该服务应显示为 RUNNING 。
Linux 安装
- 使用 root 或 sudo 权限打开终端。
运行以下命令:
sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.sh等待安装完成。
运行以下命令,验证安装是否成功:
sudo systemctl status observiq-otel-collector
该服务应显示为 active (running) 。
其他安装资源
如需了解其他安装选项和问题排查信息,请参阅 Bindplane 代理安装指南。
将 Bindplane 代理配置为注入 syslog 并发送到 Google SecOps
找到配置文件
Linux :
sudo systemctl status observiq-otel-collectorWindows :
notepad "C:\Program Files\observIQ OpenTelemetry Collector\config.yaml"
修改配置文件
将
config.yaml的全部内容替换为以下配置:receivers: tcplog: listen_address: "0.0.0.0:514" exporters: chronicle/oracle_oud: compression: gzip creds_file_path: '/etc/bindplane-agent/ingestion-auth.json' customer_id: '<customer_id>' endpoint: malachiteingestion-pa.googleapis.com log_type: ORACLE_OUD raw_log_field: body service: pipelines: logs/oracle_oud: receivers: - tcplog exporters: - chronicle/oracle_oud
配置参数
替换以下占位符:
接收器配置:
tcplog:基于协议的接收器类型:- UDP syslog 的
udplog - TCP syslog 的
tcplog - RFC 3164/5424 syslog 的
syslog
- UDP syslog 的
0.0.0.0:要监听的 IP 地址:0.0.0.0以监听所有接口(推荐)- 特定 IP 地址以监听一个接口
514:要监听的端口号(例如514、1514、6514)
导出器配置:
<customer_id>:上一步中的客户 IDmalachiteingestion-pa.googleapis.com:区域端点网址:- 美国:
malachiteingestion-pa.googleapis.com - 欧洲:
europe-malachiteingestion-pa.googleapis.com - 亚洲:
asia-southeast1-malachiteingestion-pa.googleapis.com - 如需完整列表,请参阅区域端点
- 美国:
- 根据平台调整
creds_file_path:- Linux:
/etc/bindplane-agent/ingestion-auth.json - Windows:
C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json
- Linux:
保存配置文件
- 修改后,保存文件:
- Linux:按
Ctrl+O,然后按Enter,再按Ctrl+X - Windows:依次点击文件 > 保存
- Linux:按
重启 Bindplane 代理以应用更改
如需在 Linux 中重启 Bindplane 代理,请执行以下操作:
运行以下命令:
sudo systemctl restart observiq-otel-collector验证服务是否正在运行:
sudo systemctl status observiq-otel-collector检查日志中的错误:
sudo journalctl -u observiq-otel-collector -f
如需在 Windows 中重启 Bindplane 代理,请执行以下操作:
请从下列选项中选择一项:
- 以管理员身份运行命令提示符或 PowerShell:
net stop observiq-otel-collector && net start observiq-otel-collector- “服务”控制台:
- 按
Win+R,输入services.msc,然后按 Enter 键。 - 找到 observIQ OpenTelemetry Collector 。
- 右键点击并选择重启 。
- 按
验证服务是否正在运行:
sc query observiq-otel-collector检查日志中的错误:
type "C:\Program Files\observIQ OpenTelemetry Collector\log\collector.log"
配置 Oracle Unified Directory syslog 转发
Oracle Unified Directory 会将日志存储在服务器文件系统的本地,通常位于 OUD_INSTANCE/logs/ 目录中。使用系统 syslog 守护程序配置 syslog 转发,以将这些日志发送到 Bindplane 代理。
确定 Oracle Unified Directory 日志目录。常见的日志文件包括
access、errors、replication和audit。配置系统 syslog 守护程序(例如
rsyslog)以监控和转发 OUD 日志文件。创建新的 rsyslog 配置文件:sudo nano /etc/rsyslog.d/oud-forward.conf添加以下内容:
module(load="imfile") input(type="imfile" File="/path/to/oud-instance/logs/access" Tag="oracle-oud" Severity="info" Facility="local0") input(type="imfile" File="/path/to/oud-instance/logs/errors" Tag="oracle-oud" Severity="error" Facility="local0") local0.* @@BINDPLANE_AGENT_IP:514重启 rsyslog 服务:
sudo systemctl restart rsyslog
UDM 映射表
| 日志字段 | UDM 映射 | 逻辑 |
|---|---|---|
| conn,op,msgID,oid,result,etime,filter,attrs,ou,version,type,authFailureID,authFailureReason,name,o | additional.fields | 其他 UDM 字段未涵盖的其他元数据 |
| metadata.event_type | 事件类型(例如 USER_LOGIN、NETWORK_CONNECTION) | |
| operation,operation1 | metadata.product_event_type | 特定于产品的事件类型 |
| protocol | network.application_protocol | 网络连接中使用的应用协议 |
| hostname | principal.hostname | 正文资产的主机名 |
| srcaddr | principal.ip | 正文的 IP 地址 |
| srcport | principal.port | 正文使用的端口号 |
| uid | principal.user.userid | 正文用户的用户 ID |
| operation | security_result.action_details | 安全产品采取的操作的详细信息 |
| reason | security_result.description | 安全结果的说明 |
| msg_data | security_result.summary | 安全结果的摘要 |
| destaddr | target.ip | 目标的 IP 地址 |
| destport | target.port | 目标使用的端口号 |
| metadata.product_name | 生成事件的产品的名称 | |
| metadata.vendor_name | 产品供应商的名称 | |
authFailureID", "filter", "attrs", "changetype", "replace" and "authFailureReason |
additional.fields |
从更改日志映射 |
from |
principal.ip |
从更改日志映射 |