收集 ESET AV 日志

解析器版本:6.0

支持的平台:

本文档介绍了如何使用 Bindplane 代理将 ESET 防病毒日志注入到 Google Security Operations。

ESET 是一种终端威胁防护解决方案,可针对威胁检测、防火墙事件、HIPS 提醒和审核操作生成 syslog 消息。解析器会从 JSON 格式的 syslog 中提取键值对,并将其映射到统一数据模型 (UDM)。

准备工作

  • 请确保满足以下前提条件:

  • Google SecOps 实例

  • Windows Server 2016 或更高版本,或者具有 systemd 的 Linux 主机

  • Bindplane 代理与 ESET PROTECT 服务器之间的网络连接

  • 如果在代理后面运行,请确保防火墙端口已根据 Bindplane 代理要求打开

  • 对 ESET PROTECT 控制台(本地或云端)的特权访问权限

获取 Google SecOps 注入身份验证文件

  1. 登录 Google SecOps 控制台。
  2. 依次前往 SIEM 设置 > 收集代理
  3. 下载数据注入身份验证文件
  4. 将文件安全地保存在将要安装 Bindplane 代理的系统上。

获取 Google SecOps 客户 ID

  1. 登录 Google SecOps 控制台。
  2. 依次前往 SIEM 设置 > 配置文件
  3. 复制并保存组织详细信息部分中的客户 ID

安装 Bindplane 代理

按照以下说明在 Windows 或 Linux 操作系统上安装 Bindplane 代理。

Windows 安装

  1. 以管理员身份打开命令提示符PowerShell
  2. 运行以下命令:

    msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quiet
    
  3. 等待安装完成。

  4. 运行以下命令,验证安装是否成功:

    sc query observiq-otel-collector
    

    该服务应显示为 正在运行

Linux 安装

  1. 打开具有 root 或 sudo 权限的终端。
  2. 运行以下命令:

    sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.sh
    
  3. 等待安装完成。

  4. 运行以下命令,验证安装是否成功:

    sudo systemctl status observiq-otel-collector
    

    该服务应显示为有效(正在运行)

其他安装资源

如需了解其他安装选项和问题排查信息,请参阅 Bindplane 代理安装指南

配置 Bindplane 代理以注入 syslog 并将其发送到 Google SecOps

找到配置文件

  • Linux

    sudo nano /etc/bindplane-agent/config.yaml
    
  • Windows

    notepad "C:\Program Files\observIQ OpenTelemetry Collector\config.yaml"
    

修改配置文件

  • config.yaml 的全部内容替换为以下配置:

    receivers:
        udplog:
            listen_address: "0.0.0.0:514"
    
    exporters:
        chronicle/eset_av:
            compression: gzip
            creds_file_path: '/etc/bindplane-agent/ingestion-auth.json'
            customer_id: '<customer_id>'
            endpoint: malachiteingestion-pa.googleapis.com
            log_type: ESET_AV
            raw_log_field: body
    
    service:
        pipelines:
            logs/eset_av_to_chronicle:
                receivers:
                    - udplog
                exporters:
                    - chronicle/eset_av
    

配置参数

替换以下占位符:

  • 接收器配置

    • listen_address:要监听的 IP 地址和端口:
      • 0.0.0.0 侦听所有接口(推荐)
      • 端口 514 是标准 syslog 端口(在 Linux 上需要 root 权限;对于非 root 用户,请使用 1514
  • 导出器配置

    • creds_file_path:提取身份验证文件的完整路径:
      • Linux/etc/bindplane-agent/ingestion-auth.json
      • WindowsC:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json
    • customer_id:从 Google SecOps 控制台复制的客户 ID
    • endpoint:区域端点网址:
      • 美国malachiteingestion-pa.googleapis.com
      • 欧洲europe-malachiteingestion-pa.googleapis.com
      • 亚洲asia-southeast1-malachiteingestion-pa.googleapis.com
      • 如需查看完整列表,请参阅区域级端点

保存配置文件

  • 修改后,保存文件:
    • Linux:依次按 Ctrl+OEnterCtrl+X
    • Windows:依次点击文件 > 保存

重启 Bindplane 代理以应用更改

  • 如需在 Linux 中重启 Bindplane 代理,请运行以下命令:

    sudo systemctl restart observiq-otel-collector
    
    1. 验证服务是否正在运行:

      sudo systemctl status observiq-otel-collector
      
    2. 检查日志是否存在错误:

      sudo journalctl -u observiq-otel-collector -f
      
  • 如需在 Windows 中重启 Bindplane 代理,请选择以下选项之一:

    • 以管理员身份运行命令提示符或 PowerShell:

      net stop observiq-otel-collector && net start observiq-otel-collector
      
    • 服务控制台:

      1. Win+R,输入 services.msc,然后按 Enter 键。
      2. 找到 observIQ OpenTelemetry 收集器
      3. 右键点击并选择重新启动
      4. 验证服务是否正在运行:

        sc query observiq-otel-collector
        
      5. 检查日志是否存在错误:

        type "C:\Program Files\observIQ OpenTelemetry Collector\log\collector.log"
        

在 ESET PROTECT 本地版中配置 Syslog

  1. 登录 ESET PROTECT Web 控制台。
  2. 依次点击更多 > 设置 > 高级设置 > Syslog 服务器
  3. 切换启用 Syslog 开关以启用 Syslog。
  4. 提供以下配置详细信息:
    • 主机:输入 Bindplane 代理 IP 地址。
    • 端口:输入 514
    • 格式:选择 Syslog
    • 传输:选择 UDP
    • 轨迹日志详细程度:选择信息
    • 将日志导出到 Syslog:设置为启用
    • 导出的日志格式:选择 JSON
  5. 点击保存

在 ESET PROTECT Cloud 上配置 syslog

  1. 登录 ESET PROTECT Cloud 控制台。
  2. 依次点击更多 > 设置 > Syslog 服务器
  3. 切换启用 Syslog 开关以启用 Syslog。
  4. 提供以下配置详细信息:
    • 载荷格式:选择 JSON
    • 信封格式:选择 Syslog
    • 最低日志级别:选择信息
    • 要记录的事件类型:选择全部(或根据需要选择特定类型)。
    • 目标 IP:输入 Bindplane 代理 IP 地址。
    • 端口:输入 514
  5. 点击保存

UDM 映射表

日志字段 UDM 映射 逻辑
账号 principal.administrative_domain 使用 grok 模式 %{DATA:admin_domain}\\\\%{WORD:user_id}account 字段中提取。
账号 principal.user.userid 使用 grok 模式 %{DATA:admin_domain}\\\\%{WORD:user_id}account 字段中提取。
操作 security_result.action 如果 actionBlock(不区分大小写),则设置为 BLOCK。如果 actionStart(不区分大小写),则设置为 ALLOW
action_taken security_result.action_details 直接从 action_taken 字段映射。
computer_severity_score security_result.detection_fields 系统会创建一个键值对,其中包含键 computer_severity_scorecomputer_severity_score 字段中的值。此键值对会附加到 security_result.detection_fields 数组。
detail security_result.description 直接从 detail 字段映射。
域名 principal.domain.name 直接从 domain 字段映射。
eialarmid security_result.detection_fields 系统会创建一个键值对,其中包含键 eialarmideialarmid 字段中的值。此键值对会附加到 security_result.detection_fields 数组。
eiconsolelink principal.url 直接从 eiconsolelink 字段映射。
事件 metadata.description 已将 event 重命名为 event_desc,并映射到 metadata.description
event_type metadata.product_event_type 直接从 event_type 字段映射。
group_name principal.group.group_display_name 直接从 group_name 字段映射。
hash principal.file.sha1 转换为小写。如果小写值与 SHA-1 正则表达式匹配,则映射到 principal.file.sha1
hash principal.resource.attribute.labels 系统会创建一个键值对,其中包含键 hashhash 字段中的值。此键值对会附加到 principal.resource.attribute.labels 数组。
主机名 principal.asset.hostname 直接从 hostname 字段映射。
主机名 principal.hostname 直接从 hostname 字段映射。
入站 network.direction 如果为 true,则设置为 INBOUND。如果为 false,则设置为 OUTBOUND
ipv4 target.asset.ip 如果 target_address 为空,则直接从 ipv4 字段映射。
ipv4 target.ip 如果 target_address 为空,则直接从 ipv4 字段映射。
json_data 解析为 JSON 以提取各种字段。
消息 使用 grok 进行解析,以提取时间戳、主机和 json_data。
need_restart additional.fields 系统会创建一个键值对,其中键为 need_restart,值为 need_restart 字段中的值(转换为字符串)。此键值对会附加到 additional.fields 数组。
os_name principal.platform 如果包含 Windowwindow(不区分大小写),则设为 WINDOWS。如果包含 Linuxlinux(不区分大小写),则设为 LINUX。如果包含 Macmac(不区分大小写),则设置为 MAC
os_name principal.platform_version 直接从 os_name 字段映射。
process_name principal.process.file.full_path 直接从 process_name 字段映射。如果为空,则取值为 processname
processname principal.process.file.full_path 如果 process_name 为空,则映射到 process_name
协议 network.ip_protocol 转换为大写。如果大写值与已知协议(TCP、UDP、ICMP 等)匹配,则映射到 network.ip_protocol
结果 security_result.summary 直接从 result 字段映射。
rulename security_result.rule_name 直接从 rulename 字段映射。
scan_id security_result.detection_fields 系统会创建一个键值对,其中包含键 scan_idscan_id 字段中的值。此键值对会附加到 security_result.detection_fields 数组。
scanner_id security_result.detection_fields 系统会创建一个键值对,其中包含键 scanner_idscanner_id 字段中的值。此键值对会附加到 security_result.detection_fields 数组。
和程度上减少 security_result.severity 如果包含 Warnwarn(不区分大小写),则设为 HIGH。如果包含 Infoinfo(不区分大小写),则设置为 LOW
severity_score security_result.detection_fields 系统会创建一个键值对,其中包含键 severity_scoreseverity_score 字段中的值。此键值对会附加到 security_result.detection_fields 数组。
source_address principal.asset.ip 直接从 source_address 字段映射。
source_address principal.ip 直接从 source_address 字段映射。
source_port principal.port 转换为字符串,然后再转换为整数。映射到 principal.port
source_uuid metadata.product_log_id 直接从 source_uuid 字段映射。
目标 已重命名为 target1
target_address target.asset.ip 直接从 target_address 字段映射。
target_address target.ip 直接从 target_address 字段映射。
target_port target.port 转换为字符串,然后再转换为整数。映射到 target.port
threat_handled security_result.detection_fields 系统会创建一个键值对,其中键为 threat_handled,值为 threat_handled 字段中的值(转换为字符串)。此键值对会附加到 security_result.detection_fields 数组。
threat_name security_result.threat_name 直接从 threat_name 字段映射。
threat_type security_result.threat_id 直接从 threat_type 字段映射。
时间 metadata.event_timestamp 用于填充 metadata.event_timestamp
用户名 principal.user.userid 如果 user_iduser 为空,则直接从 username 字段映射。
用户 principal.user.userid 如果 user_id 为空,则直接从 user 字段映射。
metadata.event_type 如果 source_addresstarget_address 不为空,则设置为 NETWORK_CONNECTION。否则,如果 has_user 为 true,则设置为 USER_UNCATEGORIZED。否则,如果 has_principal 为 true,则设置为 STATUS_UPDATE。否则,请将其设置为 GENERIC_EVENT
metadata.log_type 设置为 ESET_AV
metadata.product_name 设置为 ESET_AV
metadata.vendor_name 设置为 ESET_AV
intermediary.hostname 此字段的值取自从日志消息中提取的 host 字段。
principal.user.userid 如果字段 account 不为空,解析器会使用 Grok 模式从 account 字段中提取用户 ID。否则,它会检查字段 user 是否不为空,如果不为空,则取其值。如果 accountuser 均为空,则检查字段 username 是否不为空,如果不为空,则取其值。
timestamp event.idm.read_only_udm.metadata.collected_timestamp 从变更日志映射
event_id event.idm.read_only_udm.metadata.product_log_id 从变更日志映射
process_pid event.idm.read_only_udm.principal.process.pid 从变更日志映射
desc event.idm.read_only_udm.additional.fields 从变更日志映射
occurred event.idm.read_only_udm.metadata.event_timestamp 从变更日志映射
threatHandled event.idm.read_only_udm.security_result.detection_fields 从变更日志映射
actionTaken event.idm.read_only_udm.security_result.action_details 从变更日志映射
threatName event.idm.read_only_udm.security_result.threat_name 从变更日志映射
threatType event.idm.read_only_udm.security_result.summary 从变更日志映射
target target.resource.attribute.labels 从变更日志映射
object_uri target.url 从变更日志映射
severity security_result.severity_details 从变更日志映射
threat_flags security_result.detection_fields 从变更日志映射
category security_result.category_details 从变更日志映射
object_type" and "engine_version principal.resource.attribute.labels 从变更日志映射
circumstances security_result.description 从变更日志映射
security_result_action BLOCK 从变更日志映射
security_result_action ALLOW 从变更日志映射
scan_id", "scanner_id", and "threat_handled security_result.detection_fields 从变更日志映射
group_name principal.group_display_name 从变更日志映射

更新日志

查看相应解析器的更改日志

需要更多帮助?获得社区成员和 Google SecOps 专业人士的解答。