收集 Veeam 日志
本文档介绍了如何使用 Bindplane 代理将 Veeam 日志注入到 Google Security Operations。
Veeam Backup & Replication 是一种数据保护平台,可为备份作业、复制任务、恢复操作和系统事件生成 syslog 消息。解析器使用 Grok 模式从 syslog 消息中提取字段,并将其映射到统一数据模型 (UDM)。
准备工作
请确保满足以下前提条件:
- Google SecOps 实例
- Windows Server 2016 或更高版本,或者具有
systemd的 Linux 主机 - Bindplane 代理与 Veeam Backup & Replication 服务器之间的网络连接
- 如果在代理后面运行,请确保防火墙端口已根据 Bindplane 代理要求打开
- Veeam 的特权访问权限
获取 Google SecOps 注入身份验证文件
- 登录 Google SecOps 控制台。
- 依次前往 SIEM 设置 > 收集代理。
- 下载数据注入身份验证文件。
将文件安全地保存在将要安装 Bindplane 的系统上。
获取 Google SecOps 客户 ID
- 登录 Google SecOps 控制台。
- 依次前往 SIEM 设置 > 配置文件。
复制并保存组织详细信息部分中的客户 ID。
安装 Bindplane 代理
按照以下说明在 Windows 或 Linux 操作系统上安装 Bindplane 代理。
Windows 安装
- 以管理员身份打开命令提示符或 PowerShell。
运行以下命令:
msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quiet等待安装完成。
运行以下命令,验证安装是否成功:
sc query observiq-otel-collector该服务应显示为 正在运行。
Linux 安装
- 打开具有 root 或 sudo 权限的终端。
运行以下命令:
sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.sh等待安装完成。
运行以下命令,验证安装是否成功:
sudo systemctl status observiq-otel-collector该服务应显示为有效(正在运行)。
其他安装资源
如需了解其他安装选项和问题排查信息,请参阅 Bindplane 代理安装指南。
配置 Bindplane 代理以注入 syslog 并将其发送到 Google SecOps
找到配置文件
Linux:
sudo nano /opt/observiq-otel-collector/config.yamlWindows:
notepad "C:\Program Files\observIQ OpenTelemetry Collector\config.yaml"
修改配置文件
将
config.yaml的全部内容替换为以下配置:receivers: udplog: listen_address: "0.0.0.0:514" exporters: chronicle/veeam: compression: gzip creds_file_path: '/etc/bindplane-agent/ingestion-auth.json' customer_id: '<customer_id>' endpoint: malachiteingestion-pa.googleapis.com log_type: VEEAM raw_log_field: body service: pipelines: logs/veeam_to_chronicle: receivers: - udplog exporters: - chronicle/veeam
配置参数
替换以下占位符:
接收器配置:
listen_address:要监听的 IP 地址和端口:0.0.0.0侦听所有接口(推荐)- 端口
514是标准 syslog 端口(在 Linux 上需要 root 权限;对于非 root 用户,请使用1514)
导出器配置:
creds_file_path:提取身份验证文件的完整路径:- Linux:
/etc/bindplane-agent/ingestion-auth.json - Windows:
C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json
- Linux:
customer_id:从 Google SecOps 控制台复制的客户 IDendpoint:区域端点网址:- 美国:
malachiteingestion-pa.googleapis.com - 欧洲:
europe-malachiteingestion-pa.googleapis.com - 亚洲:
asia-southeast1-malachiteingestion-pa.googleapis.com - 如需查看完整列表,请参阅区域级端点
- 美国:
保存配置文件
- 修改后,保存文件:
- Linux:依次按
Ctrl+O、Enter和Ctrl+X - Windows:依次点击文件 > 保存
- Linux:依次按
重启 Bindplane 代理以应用更改
如需在 Linux 中重启 Bindplane 代理,请运行以下命令:
sudo systemctl restart observiq-otel-collector验证服务是否正在运行:
sudo systemctl status observiq-otel-collector检查日志是否存在错误:
sudo journalctl -u observiq-otel-collector -f
如需在 Windows 中重启 Bindplane 代理,请选择以下选项之一:
以管理员身份运行命令提示符或 PowerShell:
net stop observiq-otel-collector && net start observiq-otel-collector服务控制台:
- 按
Win+R,输入services.msc,然后按 Enter 键。 - 找到 observIQ OpenTelemetry 收集器。
- 右键点击并选择重新启动。
验证服务是否正在运行:
sc query observiq-otel-collector检查日志是否存在错误:
type "C:\Program Files\observIQ OpenTelemetry Collector\log\collector.log"
- 按
为 Veeam 配置 syslog
- 登录 Veeam Backup & Replication 控制台。
- 依次前往菜单 > 选项 > SIEM 集成。
- 在 Syslog 服务器部分,点击添加。
- 提供以下配置详细信息:
- 名称:输入 Bindplane 代理 IP 地址和端口号(例如
192.168.1.1:514)。 - 传输:根据 Bindplane 代理配置,选择 UDP 或 TCP。
- 名称:输入 Bindplane 代理 IP 地址和端口号(例如
- 点击确定进行保存。
UDM 映射表
| 日志字段 | UDM 映射 | 逻辑 |
|---|---|---|
application |
principal.application |
直接从 grok 模式提取的 application 字段映射。 |
CredentialId |
principal.resource.attribute.labels.[] |
直接从 kv 过滤器提取的 CredentialId 字段映射。创建了键为“CredentialId”的标签。 |
date_2、time_2、year |
metadata.event_timestamp |
系统会使用 date 过滤条件将 date_2、time_2 和 year 字段串联并解析,以创建 metadata.event_timestamp。 |
date_2,time_2 |
metadata.event_timestamp |
系统会连接 date_2 和 time_2 字段,并使用 date 过滤条件进行解析,以创建 metadata.event_timestamp。 |
deviceId |
principal.resource.product_object_id |
直接从 kv 过滤器提取的 deviceId 字段映射。 |
description |
security_result.description |
直接从 grok 模式提取的 description 字段映射。 |
error_code |
security_result.detection_fields.[] |
直接从 grok 模式提取的 error_code 字段映射。创建了键为“error_code”的标签。 |
executing_feature |
principal.hostname,principal.asset.hostname |
直接从 grok 模式提取的 executing_feature 字段映射。 |
host |
principal.hostname,principal.asset.hostname |
直接从 grok 模式提取的 host 字段映射。 |
ManagementIP |
principal.ip,principal.asset.ip |
直接从 kv 过滤器提取的 ManagementIP 字段映射。 |
pid |
principal.process.pid |
直接从 grok 模式提取的 pid 字段映射。 |
previousSeverity |
security_result.severity_details |
直接从 grok 模式提取的 previousSeverity 字段映射。 |
prod_event_type |
metadata.product_event_type |
直接从 grok 模式提取的 prod_event_type 字段映射。 |
query |
security_result.detection_fields.[] |
直接从 grok 模式提取的 query 字段映射。创建了键为“query”的标签。 |
reportingAddress |
principal.ip,principal.asset.ip |
直接从 grok 模式提取的 reportingAddress 字段映射。 |
severity |
security_result.severity |
从 severity 字段映射。该值由基于 severity 字段的条件逻辑确定(ERROR、MAJOR/WARN、INFO 会映射到特定的 UDM 严重程度值)。 |
src_ip |
principal.ip,principal.asset.ip |
直接从 grok 模式提取的 src_ip 字段映射。 |
summary |
security_result.summary |
直接从 grok 模式提取的 summary 字段映射。 |
target_ip |
target.ip,target.asset.ip |
直接从 grok 模式提取的 target_ip 字段映射。 |
thread_id |
security_result.detection_fields.[] |
直接从 grok 模式提取的 thread_id 字段映射。创建了键为“thread_id”的标签。 |
| (不适用) | event_type |
由解析器中的逻辑确定。如果 principal 和 target 都包含 MID 数据,则为 NETWORK_UNCATEGORIZED。如果只有 principal 具有 MID 数据,则为 STATUS_UPDATE。否则为 GENERIC_EVENT。 |
| (不适用) | metadata.event_type |
从内部生成的 event_type 字段复制。 |
| (不适用) | metadata.vendor_name |
硬编码为“VEEAM”。 |
| (不适用) | metadata.product_name |
硬编码为“Veeam”。 |
| (不适用) | event.timestamp |
事件时间戳取自日志条目的 collection_time 字段。 |
enterpriseId |
additional.fields |
从变更日志映射 |
recipient_emailid |
additional.fields |
从变更日志映射 |
description |
metadata.description |
从变更日志映射 |
version |
additional.fields |
从变更日志映射 |
categoryId |
additional.fields |
从变更日志映射 |
instanceId |
additional.fields |
从变更日志映射 |
VbrVersion |
metadata.product_version |
从变更日志映射 |