收集 SentinelOne 活动日志
本文档介绍了如何使用 Google Cloud Storage V2 将 SentinelOne 活动日志注入到 Google Security Operations。
SentinelOne Singularity 是一款自主式端点保护平台,可在端点、云工作负载和 IoT 设备中提供实时预防、检测和响应功能。活动日志会捕获 SentinelOne 环境中的管理和运营事件,包括用户登录、政策变更、威胁管理操作、代理安装和系统配置变更。这些活动日志可以通过 SentinelOne REST API 导出,并写入 GCS 存储桶以供 Google SecOps 提取。
准备工作
请确保满足以下前提条件:
- Google SecOps 实例
- 已启用 Cloud Storage API 的 GCP 项目
- 创建和管理 GCS 存储分区的权限
- 创建 Cloud Run 服务、Pub/Sub 主题和 Cloud Scheduler 作业的权限
- 具有 API 访问权限的 SentinelOne Singularity 管理控制台
- 具有 Viewer 角色或更高权限的 SentinelOne 服务用户账号
生成 SentinelOne API 令牌
- 登录 SentinelOne 管理控制台 (
https://<your-management-url>.sentinelone.net)。 - 依次前往设置 > 用户 > 服务用户。
- 依次点击操作 > 创建新的服务用户。
- 提供以下配置详细信息:
- 名称:输入一个描述性名称(例如
SIEM Activity Log Integration) - 失效日期:设置失效日期或保留默认设置
- 范围级别:选择适当的范围(账号或网站)
- 角色:选择 Viewer(读取活动日志所需的最低角色)
- 名称:输入一个描述性名称(例如
- 点击 Create User(创建用户)。
- 系统会显示一个对话框,其中包含 API 令牌。
- 复制并妥善保存 API 令牌。
验证 API 访问权限
在继续进行集成之前,请先测试您的凭据:
S1_BASE_URL="https://your-management-url.sentinelone.net" S1_API_TOKEN="your-api-token" curl -s -X GET "${S1_BASE_URL}/web/api/v2.1/activities?limit=2" \ -H "Authorization: ApiToken ${S1_API_TOKEN}" \ | python3 -m json.tool如果响应成功,则会返回一个 JSON 对象,其中包含一个
data数组(包含活动记录)和一个pagination对象:{ "data": [ { "id": "123456789", "activityType": 27, "activityUuid": "a2c8037c-e6df-436d-b92b-bc09a418717e", "createdAt": "2026-03-29T10:30:00.000000Z", "primaryDescription": "User logged in", "accountId": "123456", "accountName": "My Account", "siteId": "789012", "data": {} } ], "pagination": { "nextCursor": "eyJpZCI6...", "totalItems": 1500 } }
如果您看到以下错误,请执行相应操作:
- HTTP 401(未授权):验证 API 令牌是否正确且未过期。
- HTTP 403(禁止):验证服务用户是否具有适当的范围和角色。
创建 Google Cloud Storage 存储桶
- 前往 Google Cloud 控制台。
- 选择您的项目或创建新项目。
- 在导航菜单中,依次前往 Cloud Storage > 存储分区。
- 点击创建存储分区。
提供以下配置详细信息:
设置 值 为存储桶命名 输入一个全局唯一的名称(例如 sentinelone-activity-logs)位置类型 根据您的需求进行选择(区域级、双区域、多区域) 位置 选择营业地点(例如 us-central1)存储类别 标准(建议用于经常访问的日志) 访问权限控制 均匀(推荐) 保护工具 可选:启用对象版本控制或保留政策 点击创建。
为 Cloud Run 函数创建服务账号
Cloud Run 函数需要一个服务账号,该账号具有写入 GCS 存储桶的权限,并且可以由 Pub/Sub 调用。
创建服务账号
- 在 GCP 控制台中,依次前往 IAM 和管理 > 服务账号。
- 点击创建服务账号。
- 提供以下配置详细信息:
- 服务账号名称:输入
s1-activity-collector-sa - 服务账号说明:输入
Service account for Cloud Run function to collect SentinelOne Activity logs
- 服务账号名称:输入
- 点击创建并继续。
- 在向此服务账号授予对项目的访问权限部分中,添加以下角色:
- 点击选择角色。
- 搜索并选择 Storage Object Admin。
- 点击 + 添加其他角色。
- 搜索并选择 Cloud Run Invoker。
- 点击 + 添加其他角色。
- 搜索并选择 Cloud Functions Invoker。
- 点击继续。
- 点击完成。
必须拥有这些角色,才能:
- Storage Object Admin:将日志写入 GCS 存储桶并管理状态文件
- Cloud Run Invoker:允许 Pub/Sub 调用函数
- Cloud Functions Invoker:允许调用函数
授予对 GCS 存储桶的 IAM 权限
向服务账号授予对 GCS 存储桶的写入权限:
- 前往 Cloud Storage > 存储分区。
- 点击您的存储桶名称。
- 前往权限标签页。
- 点击授予访问权限。
- 提供以下配置详细信息:
- 添加主账号:输入服务账号电子邮件地址(例如
s1-activity-collector-sa@PROJECT_ID.iam.gserviceaccount.com) - 分配角色:选择 Storage Object Admin
- 添加主账号:输入服务账号电子邮件地址(例如
- 点击保存。
创建 Pub/Sub 主题
创建一个 Pub/Sub 主题,Cloud Scheduler 将向该主题发布消息,而 Cloud Run 函数将订阅该主题。
- 在 GCP 控制台中,前往 Pub/Sub > 主题。
- 点击创建主题。
- 提供以下配置详细信息:
- 主题 ID:输入
s1-activity-trigger - 将其他设置保留为默认值
- 主题 ID:输入
- 点击创建。
创建 Cloud Run 函数以收集日志
Cloud Run 函数将由来自 Cloud Scheduler 的 Pub/Sub 消息触发,以从 SentinelOne REST API 中提取活动日志并将其写入 GCS。
- 在 GCP 控制台中,前往 Cloud Run。
- 点击创建服务。
- 选择函数(使用内嵌编辑器创建函数)。
在配置部分中,提供以下配置详细信息:
设置 值 Service 名称 s1-activity-collector区域 选择与您的 GCS 存储桶匹配的区域(例如 us-central1)运行时 选择 Python 3.12 或更高版本 在触发器(可选)部分中:
- 点击 + 添加触发器。
- 选择 Cloud Pub/Sub。
- 在选择 Cloud Pub/Sub 主题部分,选择主题
s1-activity-trigger。 - 点击保存。
在身份验证部分中:
- 选择需要进行身份验证。
- 检查 Identity and Access Management (IAM)。
向下滚动并展开容器、网络、安全性。
前往安全性标签页:
- 服务账号:选择服务账号
s1-activity-collector-sa
- 服务账号:选择服务账号
前往容器标签页:
- 点击变量和密钥。
- 为每个环境变量点击+ 添加变量:
变量名称 示例值 说明 GCS_BUCKETsentinelone-activity-logsGCS 存储桶名称 GCS_PREFIXsentinelone-activities日志文件的前缀 STATE_KEYsentinelone-activities/state.json状态文件路径 S1_BASE_URLhttps://your-mgmt-url.sentinelone.netSentinelOne 管理控制台网址 S1_API_TOKENyour-api-tokenSentinelOne API 令牌 PAGE_SIZE1000每个 API 页面的记录数(最多 1000 条) MAX_RECORDS50000每次运行的记录数上限 LOOKBACK_HOURS2初始回溯期 在变量和 Secret 部分中,向下滚动到请求:
- 请求超时:输入
540秒(9 分钟)
- 请求超时:输入
前往设置标签页:
- 在资源部分中:
- 内存:选择 512 MiB 或更高值
- CPU:选择 1
- 在资源部分中:
在修订版本伸缩部分中:
- 实例数下限:输入
0 - 实例数上限:输入
100(或根据预期负载进行调整)
- 实例数下限:输入
点击创建。
等待服务创建完成(1-2 分钟)。
创建服务后,系统会自动打开内嵌代码编辑器。
添加函数代码
- 在入口点字段中输入 main。
在内嵌代码编辑器中,创建两个文件:
第一个文件 - main.py::
import functions_framework from google.cloud import storage import json import os import urllib3 from datetime import datetime, timezone, timedelta import time # Initialize HTTP client with timeouts http = urllib3.PoolManager( timeout=urllib3.Timeout(connect=5.0, read=60.0), retries=False, ) # Initialize Storage client storage_client = storage.Client() # Environment variables GCS_BUCKET = os.environ.get('GCS_BUCKET') GCS_PREFIX = os.environ.get('GCS_PREFIX', 'sentinelone-activities').strip('/') STATE_KEY = os.environ.get('STATE_KEY') or f"{GCS_PREFIX}/state.json" S1_BASE_URL = os.environ.get('S1_BASE_URL', '').rstrip('/') S1_API_TOKEN = os.environ.get('S1_API_TOKEN') PAGE_SIZE = int(os.environ.get('PAGE_SIZE', '1000')) MAX_RECORDS = int(os.environ.get('MAX_RECORDS', '50000')) LOOKBACK_HOURS = int(os.environ.get('LOOKBACK_HOURS', '2')) ACTIVITIES_ENDPOINT = '/web/api/v2.1/activities' def parse_datetime(value): """Parse ISO datetime string to datetime object.""" if not value: return None if value.endswith("Z"): value = value[:-1] + "+00:00" try: return datetime.fromisoformat(value) except Exception: try: return datetime.strptime(value, '%Y-%m-%dT%H:%M:%S.%f') except Exception: return None @functions_framework.cloud_event def main(cloud_event): """ Cloud Run function triggered by Pub/Sub to fetch SentinelOne Activity records and write to GCS. Args: cloud_event: CloudEvent object containing Pub/Sub message """ if not all([GCS_BUCKET, S1_BASE_URL, S1_API_TOKEN]): print('Error: Missing required environment variables') return try: bucket = storage_client.bucket(GCS_BUCKET) # Load state state = load_state(bucket, STATE_KEY) # Determine time window now = datetime.now(timezone.utc) last_time = None if isinstance(state, dict) and state.get("last_event_time"): try: last_time = parse_datetime(state["last_event_time"]) # Overlap by 2 minutes to catch delayed events if last_time: last_time = last_time - timedelta(minutes=2) except Exception as e: print(f"Warning: Could not parse last_event_time: {e}") if last_time is None: last_time = now - timedelta(hours=LOOKBACK_HOURS) print( f"Fetching activity logs from " f"{last_time.isoformat()} to {now.isoformat()}" ) # Fetch activity logs records, newest_event_time = fetch_activity_logs( start_time=last_time, end_time=now, ) if not records: print("No new activity records found.") save_state(bucket, STATE_KEY, now.isoformat()) return # Write to GCS as NDJSON timestamp = now.strftime('%Y%m%d_%H%M%S') object_key = f"{GCS_PREFIX}/logs_{timestamp}.ndjson" blob = bucket.blob(object_key) ndjson = '\n'.join( [json.dumps(record, ensure_ascii=False) for record in records] ) + '\n' blob.upload_from_string( ndjson, content_type='application/x-ndjson' ) print( f"Wrote {len(records)} records to " f"gs://{GCS_BUCKET}/{object_key}" ) # Update state if newest_event_time: save_state(bucket, STATE_KEY, newest_event_time) else: save_state(bucket, STATE_KEY, now.isoformat()) print(f"Successfully processed {len(records)} records") except Exception as e: print(f'Error processing activity logs: {str(e)}') raise def load_state(bucket, key): """Load state from GCS.""" try: blob = bucket.blob(key) if blob.exists(): state_data = blob.download_as_text() return json.loads(state_data) except Exception as e: print(f"Warning: Could not load state: {e}") return {} def save_state(bucket, key, last_event_time_iso): """Save the last event timestamp to GCS state file.""" try: state = {'last_event_time': last_event_time_iso} blob = bucket.blob(key) blob.upload_from_string( json.dumps(state, indent=2), content_type='application/json' ) print(f"Saved state: last_event_time={last_event_time_iso}") except Exception as e: print(f"Warning: Could not save state: {e}") def fetch_activity_logs(start_time, end_time): """ Fetch activity logs from SentinelOne REST API with cursor-based pagination. Args: start_time: Start time for log query end_time: End time for log query Returns: Tuple of (records list, newest_event_time ISO string) """ url = f"{S1_BASE_URL}{ACTIVITIES_ENDPOINT}" headers = { 'Authorization': f'ApiToken {S1_API_TOKEN}', 'Content-Type': 'application/json', } # Format timestamps for SentinelOne API start_str = start_time.strftime('%Y-%m-%dT%H:%M:%S.000000Z') records = [] newest_time = None cursor = None backoff = 1.0 while True: if len(records) >= MAX_RECORDS: print(f"Reached max_records limit ({MAX_RECORDS})") break params = { 'createdAt__gt': start_str, 'limit': str(PAGE_SIZE), 'sortBy': 'createdAt', 'sortOrder': 'asc', } if cursor: params['cursor'] = cursor try: response = http.request( 'GET', url, fields=params, headers=headers ) # Handle rate limiting with exponential backoff if response.status == 429: retry_after = int( response.headers.get( 'Retry-After', str(int(backoff)) ) ) print( f"Rate limited (429). " f"Retrying after {retry_after}s..." ) time.sleep(retry_after) backoff = min(backoff * 2, 30.0) continue # Handle token expiry if response.status == 401: print( "API token is invalid or expired. " "Generate a new token in SentinelOne console." ) return records, newest_time backoff = 1.0 if response.status != 200: print(f"HTTP Error: {response.status}") response_text = response.data.decode('utf-8') print(f"Response body: {response_text}") return records, newest_time data = json.loads(response.data.decode('utf-8')) result = data.get('data', []) pagination = data.get('pagination', {}) total_items = pagination.get('totalItems', 0) next_cursor = pagination.get('nextCursor') if not result: print("No more results (empty page)") break print( f"Retrieved {len(result)} events " f"(total: {total_items})" ) records.extend(result) # Track newest event time for event in result: try: event_time = event.get('createdAt') if event_time: if newest_time is None: newest_time = event_time else: current_dt = parse_datetime(event_time) newest_dt = parse_datetime(newest_time) if ( current_dt and newest_dt and current_dt > newest_dt ): newest_time = event_time except Exception as e: print( f"Warning: Could not parse " f"event time: {e}" ) # Check pagination if not next_cursor: print("Reached last page") break cursor = next_cursor except Exception as e: print(f"Error fetching activity logs: {e}") return records, newest_time print(f"Retrieved {len(records)} total activity records") return records, newest_time第二个文件 - requirements.txt::
functions-framework==3.* google-cloud-storage==2.* urllib3>=2.0.0
点击部署以保存并部署该函数。
等待部署完成(2-3 分钟)。
创建 Cloud Scheduler 作业
Cloud Scheduler 会定期向 Pub/Sub 主题发布消息,从而触发 Cloud Run 函数。
- 在 GCP Console 中,前往 Cloud Scheduler。
- 点击创建作业。
提供以下配置详细信息:
设置 值 名称 s1-activity-collector-hourly区域 选择与 Cloud Run 函数相同的区域 频率 0 * * * *(每小时一次,整点时)时区 选择时区(建议选择世界协调时间 [UTC]) 目标类型 Pub/Sub 主题 选择主题 s1-activity-trigger消息正文 {}(空 JSON 对象)点击创建。
时间表频率选项
根据日志量和延迟时间要求选择频次:
| 频率 | Cron 表达式 | 使用场景 |
|---|---|---|
| 每隔 10 分钟 | */10 * * * * |
高成交量,近乎实时 |
| 每小时 | 0 * * * * |
标准(推荐) |
| 每 2 小时 | 0 */2 * * * |
调低音量 |
测试集成
- 在 Cloud Scheduler 控制台中,找到您的作业。
- 点击强制运行以手动触发作业。
- 等待几秒钟。
- 前往 Cloud Run > 服务。
- 点击函数名称
s1-activity-collector。 - 点击日志标签页。
验证函数是否已成功执行。查找:
Fetching activity logs from YYYY-MM-DDTHH:MM:SS+00:00 to YYYY-MM-DDTHH:MM:SS+00:00 Retrieved X events (total: Y) Wrote X records to gs://sentinelone-activity-logs/sentinelone-activities/logs_YYYYMMDD_HHMMSS.ndjson Successfully processed X records前往 Cloud Storage > 存储分区。
点击您的存储桶名称。
前往前缀文件夹
sentinelone-activities/。验证是否已创建具有当前时间戳的新
.ndjson文件。
如果您在日志中看到错误,请执行以下操作:
- HTTP 400:检查 SentinelOne 管理控制台网址是否没有尾部斜杠。验证查询参数是否正确。
- HTTP 401:API 令牌无效或已过期。在 SentinelOne 控制台中,依次点击设置 > 用户 > 服务用户,生成新令牌。
- HTTP 403:服务用户没有足够的权限。验证角色和范围级别。
- HTTP 429:速率限制 - 函数将自动重试,并采用指数退避算法。
- 缺少环境变量:检查是否已在 Cloud Run 函数配置中设置所有必需的变量。
在 Google SecOps 中配置 Feed 以注入 SentinelOne 活动日志
- 依次前往 SIEM 设置 > Feed。
- 点击添加新 Feed。
- 点击配置单个 Feed。
- 在 Feed 名称字段中,输入 Feed 的名称(例如
SentinelOne Activity Logs)。 - 选择 Google Cloud Storage V2 作为来源类型。
- 选择 Sentinelone 活动作为日志类型。
点击获取服务账号。系统会显示一个唯一的服务账号电子邮件地址,例如:
chronicle-12345678@chronicle-gcp-prod.iam.gserviceaccount.com复制此电子邮件地址,以便在下一步中使用。
点击下一步。
为以下输入参数指定值:
存储桶网址:输入带有前缀路径的 GCS 存储桶 URI:
gs://sentinelone-activity-logs/sentinelone-activities/- 替换:
sentinelone-activity-logs:您的 GCS 存储桶名称。sentinelone-activities:存储日志的可选前缀/文件夹路径(留空表示根目录)。
- 替换:
来源删除选项:根据您的偏好选择删除选项:
- 永不:转移后永不删除任何文件(建议用于测试)。
- 删除已转移的文件:在成功转移后删除文件。
- 删除已转移的文件和空目录:成功转移后删除文件和空目录。
文件存在时间上限:包含在过去指定天数内修改的文件(默认值为 180 天)
资产命名空间:资产命名空间
注入标签:要应用于此 Feed 中事件的标签
点击下一步。
在最终确定界面中查看新的 Feed 配置,然后点击提交。
向 Google SecOps 服务账号授予 IAM 权限
Google SecOps 服务账号需要您的 GCS 存储桶的 Storage Object Viewer 角色。
- 前往 Cloud Storage > 存储分区。
- 点击您的存储桶名称。
- 前往权限标签页。
- 点击授予访问权限。
- 提供以下配置详细信息:
- 添加主账号:粘贴 Google SecOps 服务账号电子邮件地址
- 分配角色:选择 Storage Object Viewer
点击保存。
UDM 映射表
| 日志字段 | UDM 映射 | 逻辑 |
|---|---|---|
deviceNtDomain |
about.administrative_domain |
已重命名/已映射 |
deviceExternalId |
about.asset.asset_id |
直接映射 |
device_product |
about.asset.asset_id |
直接映射 |
device_vendor |
about.asset.asset_id |
直接映射 |
fileHash |
about.file.full_path |
直接映射 |
filePath |
about.file.full_path |
已重命名/已映射 |
_hash |
about.file.sha256 |
已重命名/已映射 |
fileHash |
about.file.sha256 |
已重命名/已映射 |
fsize |
about.file.size |
已重命名/已映射 |
dvchost |
about.hostname |
已重命名/已映射 |
ips |
about.ip |
已合并 |
dvc_mac |
about.mac |
已映射:slot → mac_address |
dvcmac |
about.mac |
已合并 |
mac_address |
about.mac |
已合并 |
deviceTranslatedAddress |
about.nat_ip |
已合并 |
Emne |
about.process.command_line |
直接映射 |
Path |
about.process.command_line |
直接映射 |
Subject |
about.process.command_line |
直接映射 |
deviceProcessName |
about.process.command_line |
已重命名/已映射 |
dvcpid |
about.process.pid |
已重命名/已映射 |
permissions |
about.resource.attribute.permissions |
已合并 |
additional_cfp1 |
additional.fields |
已合并 |
additional_cfp2 |
additional.fields |
已合并 |
additional_cfp3 |
additional.fields |
已合并 |
additional_cfp4 |
additional.fields |
已合并 |
additional_cn1 |
additional.fields |
已合并 |
additional_cn2 |
additional.fields |
已合并 |
additional_cn3 |
additional.fields |
已合并 |
additional_cs1 |
additional.fields |
已合并 |
additional_cs2 |
additional.fields |
已合并 |
additional_cs3 |
additional.fields |
已合并 |
additional_cs4 |
additional.fields |
已合并 |
additional_cs5 |
additional.fields |
已合并 |
additional_cs6 |
additional.fields |
已合并 |
additional_cs7 |
additional.fields |
已合并 |
additional_devicePayloadId |
additional.fields |
已合并 |
additional_eventId |
additional.fields |
已合并 |
additional_flexString1 |
additional.fields |
已合并 |
additional_fname |
additional.fields |
已合并 |
cs2 |
additional.fields |
已映射:arc_test → additional_cs2 |
cs5_label |
additional.fields |
已合并 |
source_type_label |
additional.fields |
已合并 |
has_user |
extensions.auth.type |
已映射:true → AUTHTYPE_UNSPECIFIED |
event_name |
metadata.description |
直接映射 |
msg |
metadata.description |
已重命名/已映射 |
primaryDescription |
metadata.description |
直接映射 |
Generated |
metadata.event_timestamp |
解析为 yyyy-MM-ddTHH:mm:ss |
Received |
metadata.event_timestamp |
解析为 yyyy-MM-ddTHH:mm:ss |
createdAt |
metadata.event_timestamp |
解析为 ISO8601 |
rt |
metadata.event_timestamp |
解析为 (EEE,ddMMMyyyy,HH:mm:ss) |
updatedAt |
metadata.event_timestamp |
解析为 ISO8601 |
event_name |
metadata.event_type |
已映射:"LogSpyware","LogPredictiveMachineLearning" → SCAN_UNCATEGORIZED |
has_principal |
metadata.event_type |
已映射:true → NETWORK_CONNECTION、true → STATUS_UPDATE |
has_user |
metadata.event_type |
已映射:true → USER_LOGIN |
activityType |
metadata.product_event_type |
直接映射 |
device_event_class_id |
metadata.product_event_type |
直接映射 |
event_name |
metadata.product_event_type |
直接映射 |
activityID |
metadata.product_log_id |
直接映射 |
activityUuid |
metadata.product_log_id |
直接映射 |
externalId |
metadata.product_log_id |
直接映射 |
device_product |
metadata.product_name |
直接映射 |
device_version |
metadata.product_version |
直接映射 |
device_vendor |
metadata.vendor_name |
已重命名/已映射 |
app_protocol_output |
network.application_protocol |
直接映射 |
deviceDirection |
network.direction |
映射:0 → INBOUND,1 → OUTBOUND |
requestMethod |
network.http.method |
已重命名/已映射 |
requestClientApplication |
network.http.user_agent |
已重命名/已映射 |
ip_protocol_out |
network.ip_protocol |
直接映射 |
in |
network.received_bytes |
已重命名/已映射 |
out |
network.sent_bytes |
已重命名/已映射 |
sntdom |
principal.administrative_domain |
已重命名/已映射 |
sourceServiceName |
principal.application |
已重命名/已映射 |
data.ipAddress |
principal.asset.ip |
已合并 |
Group_name |
principal.group.group_display_name |
直接映射 |
Gruppenavn |
principal.group.group_display_name |
直接映射 |
Device_name |
principal.hostname |
直接映射 |
Enhetsnavn |
principal.hostname |
直接映射 |
shost |
principal.hostname |
已重命名/已映射 |
data.ipAddress |
principal.ip |
已合并 |
principal_ip |
principal.ip |
已合并 |
shost |
principal.ip |
已合并 |
mac |
principal.mac |
已合并 |
sourceTranslatedAddress |
principal.nat_ip |
已合并 |
sourceTranslatedPort |
principal.nat_port |
已重命名/已映射 |
spt |
principal.port |
已重命名/已映射 |
data.sourceprocesscommandline |
principal.process.command_line |
直接映射 |
sproc |
principal.process.command_line |
已重命名/已映射 |
data.sourceprocessname |
principal.process.file.names |
已合并 |
spid |
principal.process.pid |
已重命名/已映射 |
principal_role |
principal.user.attribute.roles |
已合并 |
suser |
principal.user.user_display_name |
直接映射 |
suid |
principal.user.userid |
已重命名/已映射 |
sec_result |
security_result |
已合并 |
_action |
security_result.action |
已合并 |
act |
security_result.action |
映射:accept → _action,deny → _action |
Action_Taken |
security_result.action_details |
直接映射 |
act |
security_result.action_details |
直接映射 |
cat |
security_result.category_details |
已合并 |
Scan_Type |
security_result.description |
直接映射 |
Type |
security_result.description |
直接映射 |
msg_data_2 |
security_result.description |
直接映射 |
infection_channel_label |
security_result.detection_fields |
已合并 |
operasjon_label |
security_result.detection_fields |
已合并 |
operation_label |
security_result.detection_fields |
已合并 |
permission_label |
security_result.detection_fields |
已合并 |
spyware_Grayware_Type_label |
security_result.detection_fields |
已合并 |
threat_probability_label |
security_result.detection_fields |
已合并 |
tillatelse_label |
security_result.detection_fields |
已合并 |
mwProfile |
security_result.rule_name |
直接映射 |
severity |
security_result.severity |
映射:"0", "1", "2", "3", "LOW" → LOW,`"4", "5", "6", "MEDIUM", "SUBSTANTIAL", "INFO"... |
Result |
security_result.summary |
直接映射 |
appcategory |
security_result.summary |
直接映射 |
reason |
security_result.summary |
已重命名/已映射 |
Spyware |
security_result.threat_name |
直接映射 |
Unknown_Threat |
security_result.threat_name |
直接映射 |
Virus_Malware_Name |
security_result.threat_name |
直接映射 |
oldFilePath |
src.file.full_path |
已重命名/已映射 |
oldFileSize |
src.file.size |
已重命名/已映射 |
old_permissions |
src.resource.attribute.permissions |
已合并 |
dntdom |
target.administrative_domain |
已重命名/已映射 |
destinationServiceName |
target.application |
已重命名/已映射 |
agentId |
target.asset.asset_id |
直接映射 |
data.computerName |
target.asset.hostname |
直接映射 |
data.newGroupName |
target.group.group_display_name |
直接映射 |
data.newGroupId |
target.group.product_object_id |
直接映射 |
data.computerName |
target.hostname |
直接映射 |
temp_dhost |
target.hostname |
直接映射 |
IPv6_Address |
target.ip |
已合并 |
dst_ip |
target.ip |
已合并 |
ipv6 |
target.ip |
已映射:- → IPv6_Address |
data.siteName |
target.location.name |
直接映射 |
siteName |
target.location.name |
直接映射 |
mac_address |
target.mac |
已合并 |
accountName |
target.namespace |
直接映射 |
destination_translated_address |
target.nat_ip |
已合并 |
destinationTranslatedPort |
target.nat_port |
已重命名/已映射 |
dpt |
target.port |
已重命名/已映射 |
dproc |
target.process.command_line |
已重命名/已映射 |
File_name |
target.process.file.full_path |
直接映射 |
Infected_Resource |
target.process.file.full_path |
直接映射 |
Object |
target.process.file.full_path |
直接映射 |
Objekt |
target.process.file.full_path |
直接映射 |
dpid |
target.process.pid |
已重命名/已映射 |
full_scope_details_label |
target.resource.attribute.labels |
已合并 |
notification_scope_label |
target.resource.attribute.labels |
已合并 |
resource_Type_label |
target.resource.attribute.labels |
已合并 |
scope_level_label |
target.resource.attribute.labels |
已合并 |
site_id_label |
target.resource.attribute.labels |
已合并 |
vendor_activity_id_label |
target.resource.attribute.labels |
已合并 |
request |
target.url |
直接映射 |
target_role |
target.user.attribute.roles |
已合并 |
CustomerName |
target.user.user_display_name |
直接映射 |
data.accountName |
target.user.user_display_name |
直接映射 |
temp_duser |
target.user.user_display_name |
直接映射 |
Bruker |
target.user.userid |
直接映射 |
User_value |
target.user.userid |
直接映射 |
accountId |
target.user.userid |
直接映射 |
temp_duid |
target.user.userid |
直接映射 |
| 不适用 | extensions.auth.type |
常量:AUTHTYPE_UNSPECIFIED |
| 不适用 | metadata.event_type |
常量:PROCESS_UNCATEGORIZED |
| 不适用 | metadata.vendor_name |
常量:SentinelOne |
| 不适用 | network.direction |
常量:INBOUND |
| 不适用 | security_result.severity |
常量:LOW |
createdAt |
event.idm.read_only_udm.metadata.event_timestamp |
从变更日志映射 |
updatedAt |
event.idm.read_only_udm.security_result.last_updated_time |
从变更日志映射 |
activityUuid |
event.idm.read_only_udm.metadata.product_log_id |
从变更日志映射 |
activityID |
event.idm.read_only_udm.metadata.product_log_id |
从变更日志映射 |
primaryDescription |
event.idm.read_only_udm.metadata.description |
从变更日志映射 |
rt |
event.idm.read_only_udm.metadata.event_timestamp |
从变更日志映射 |
activityType |
event.idm.read_only_udm.metadata.product_event_type |
从变更日志映射 |
device_product |
event.idm.read_only_udm.metadata.product_name |
从变更日志映射 |
data.ipAddress |
event.idm.read_only_udm.principal.ip |
从变更日志映射 |
data.ipAddress |
event.idm.read_only_udm.principal.asset.ip |
从变更日志映射 |
data.sourceprocesscommandline |
event.idm.read_only_udm.principal.process.command_line |
从变更日志映射 |
data.sourceprocessname |
event.idm.read_only_udm.principal.process.file.names |
从变更日志映射 |
agentId |
event.idm.read_only_udm.target.asset.asset_id |
从变更日志映射 |
data.computerName |
event.idm.read_only_udm.target.hostname |
从变更日志映射 |
data.computerName |
event.idm.read_only_udm.target.asset.hostname |
从变更日志映射 |
accountName |
event.idm.read_only_udm.target.namespace |
从变更日志映射 |
siteName, |
event.idm.read_only_udm.target.location.name |
从变更日志映射 |
accountId |
event.idm.read_only_udm.target.user.userid |
从变更日志映射 |
data.accountName |
event.idm.read_only_udm.target.user.user_display_name |
从变更日志映射 |
data.newGroupId |
event.idm.read_only_udm.target.group.product_object_id |
从变更日志映射 |
data.newGroupName |
event.idm.read_only_udm.target.group.group_display_name |
从变更日志映射 |
data.sourceType |
event.idm.read_only_udm.additional.fields |
从变更日志映射 |
data.alertid |
event.idm.read_only_udm.security_result.rule_id |
从变更日志映射 |
data.ruledescription |
event.idm.read_only_udm.security_result.detection_fields |
从变更日志映射 |
data.oldGroupName |
event.idm.read_only_udm.security_result.detection_fields |
从变更日志映射 |
data.oldGroupId |
event.idm.read_only_udm.security_result.detection_fields |
从变更日志映射 |
data.newGroupId |
event.idm.read_only_udm.security_result.detection_fields |
从变更日志映射 |
data.newGroupName |
event.idm.read_only_udm.security_result.detection_fields |
从变更日志映射 |
data.fullScopeDetails |
event.idm.read_only_udm.security_result.description |
从变更日志映射 |