收集 Cloudian HyperStore 日志
解析器版本: 2.0
本文档介绍了如何使用 Bindplane 代理将 Cloudian HyperStore 日志注入 Google Security Operations。
解析器使用 grok 模式从 Cloudian HyperStore syslog 消息中提取字段,包括时间戳、IP 地址、用户名和说明。它会将提取的字段映射到统一数据模型 (UDM),并根据识别的活动设置相应的事件类型。
准备工作
请确保满足以下前提条件:
- Google SecOps 实例
- Windows Server 2016 或更高版本,或者具有
systemd的 Linux 主机 - Bindplane 代理与 Cloudian HyperStore 系统之间的网络连接
- 如果通过代理运行,请确保防火墙端口根据 Bindplane 代理要求处于开放状态
- 对 Cloudian HyperStore 的特权访问权限
获取 Google SecOps 注入身份验证文件
- 登录 Google SecOps 控制台。
- 前往 SIEM 设置 > 收集代理。
- 下载数据注入身份验证文件。
将该文件安全地保存在将安装 Bindplane 代理的系统上。
获取 Google SecOps 客户 ID
- 登录 Google SecOps 控制台。
- 前往 SIEM 设置 > 个人资料。
从组织详细信息 部分复制并保存客户 ID 。
安装 Bindplane 代理
按照以下说明在 Windows 或 Linux 操作系统上安装 Bindplane 代理。
Windows 安装
- 以管理员身份打开命令提示符 或 PowerShell 。
运行以下命令:
msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quiet等待安装完成。
运行以下命令,验证安装是否成功:
sc query observiq-otel-collector该服务应显示为正在运行 。
Linux 安装
- 使用 root 或 sudo 权限打开终端。
运行以下命令:
sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.sh等待安装完成。
运行以下命令,验证安装是否成功:
sudo systemctl status observiq-otel-collector该服务应显示为活跃 (正在运行) 。
其他安装资源
如需了解其他安装选项和问题排查方法,请参阅 Bindplane 代理安装指南。
配置 Bindplane 代理以注入 syslog 并发送到 Google SecOps
找到配置文件
Linux:
sudo nano /etc/bindplane-agent/config.yamlWindows:
notepad "C:\Program Files\observIQ OpenTelemetry Collector\config.yaml"
修改配置文件
将
config.yaml的全部内容替换为以下配置:receivers: udplog: listen_address: "0.0.0.0:514" exporters: chronicle/cloudian_hyperstore: compression: gzip creds_file_path: '/etc/bindplane-agent/ingestion-auth.json' customer_id: '<customer_id>' endpoint: malachiteingestion-pa.googleapis.com log_type: CLOUDIAN_HYPERSTORE raw_log_field: body service: pipelines: logs/cloudian_hyperstore_to_chronicle: receivers: - udplog exporters: - chronicle/cloudian_hyperstore
配置参数
替换以下占位符:
接收器配置:
listen_address:要监听的 IP 地址和端口:0.0.0.0以监听所有接口(推荐)- 端口
514是标准 syslog 端口(在 Linux 上需要 root;对于非 root 用户,请使用1514)
导出器配置:
creds_file_path:注入身份验证文件的完整路径:- Linux:
/etc/bindplane-agent/ingestion-auth.json - Windows:
C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json
- Linux:
customer_id:从 Google SecOps 控制台复制的客户 IDendpoint:区域级端点网址:- 美国:
malachiteingestion-pa.googleapis.com - 欧洲:
europe-malachiteingestion-pa.googleapis.com - 亚洲:
asia-southeast1-malachiteingestion-pa.googleapis.com - 如需查看完整列表,请参阅区域级端点
- 美国:
保存配置文件
- 修改后,保存文件:
- Linux:按
Ctrl+O,然后按Enter,再按Ctrl+X - Windows:依次点击文件 > 保存
- Linux:按
重启 Bindplane 代理以应用更改
如需在 Linux 中重启 Bindplane 代理,请运行以下命令:
sudo systemctl restart observiq-otel-collector验证服务正在运行:
sudo systemctl status observiq-otel-collector检查日志中是否存在错误:
sudo journalctl -u observiq-otel-collector -f
如需在 Windows 中重启 Bindplane 代理,请选择以下选项之一:
以管理员身份运行命令提示符或 PowerShell:
net stop observiq-otel-collector && net start observiq-otel-collector服务控制台:
- 按
Win+R,输入services.msc,然后按 Enter 键。 - 找到 observIQ OpenTelemetry Collector 。
- 右键点击并选择重启 。
验证服务正在运行:
sc query observiq-otel-collector检查日志中是否存在错误:
type "C:\Program Files\observIQ OpenTelemetry Collector\log\collector.log"
- 按
配置 Cloudian HyperStore syslog
- 使用 CLI 登录 HyperStore Config Controller 节点。
运行以下
hsctl命令:hsctl config set logging.syslog.remote.enabled=true hsctl config set logging.syslog.remote.host=<BINDPLANE_IP> hsctl config set logging.syslog.remote.protocol=<UDP_OR_TCP> hsctl config set logging.syslog.remote.port=<BINDPLANE_PORT> hsctl config apply ALL hsctl service restart s3 iam hyperstore firewall --nodes=ALL hsctl config set monitoring.agent.logging.level=INFO hsctl config apply monitoring- 将
<BINDPLANE_IP>替换为 Bindplane 代理 IP 地址。 - 将
<UDP_OR_TCP>替换为在 Bindplane 代理中配置的协议。 - 将
<BINDPLANE_PORT>替换为 Bindplane 代理端口号。
- 将
UDM 映射表
| 日志字段 | UDM 映射 | 逻辑 |
|---|---|---|
description |
metadata.description |
直接映射 |
datetime |
metadata.event_timestamp |
解析为 RFC 3339 |
method |
network.http.method |
已重命名/映射 |
url |
network.http.referral_url |
直接映射 |
status_code |
network.http.response_code |
已重命名/映射 |
session_id |
network.session_id |
直接映射 |
application |
principal.application |
直接映射 |
hostname |
principal.hostname |
直接映射 |
source_ip |
principal.ip |
已合并 |
request_id |
principal.process.pid |
直接映射 |
target_ip |
target.ip |
已合并 |
port |
target.port |
已重命名/映射 |
file_path |
target.process.file.full_path |
直接映射 |
user |
target.user.user_display_name |
直接映射 |
| 不适用 | extensions.auth.type |
常量:AUTHTYPE_UNSPECIFIED |
| 不适用 | metadata.event_type |
常量:NETWORK_CONNECTION |
| 不适用 | metadata.product_name |
常量:Cloudian Hyperstore |
| 不适用 | metadata.vendor_name |
常量:Cloudian |