收集 Trend Micro Email Security 日志
本文档介绍了如何使用 Bindplane 将 Trend Micro Email Security 日志注入到 Google Security Operations。Trend Micro Email Security 是一种基于云的电子邮件网关,可保护组织免受垃圾邮件、恶意软件、钓鱼式攻击、勒索软件和高级定向攻击,在这些威胁到达用户邮箱之前将其拦截。它为入站和出站电子邮件流量提供网址过滤、附件沙盒和数据泄露防护功能。
准备工作
请确保满足以下前提条件:
- Google SecOps 实例。
- Windows 2016 或更高版本,或者具有 systemd 的 Linux 主机。
- 如果在代理后面运行,请确保根据 Bindplane 代理要求打开防火墙端口。
- 对 Trend Micro Email Security 管理控制台的特权访问权限。
获取 Bindplane 代理的 Google SecOps 凭证
如需向 Google SecOps 验证 Bindplane 代理,请选择以下方法之一:
- 新部署:使用 Chronicle API(选项 1)。
- 旧版部署:继续使用数据注入身份验证文件(方法 2),直到 Ingestion API 于 2027 年 7 月 20 日停用。
方法 1:为 Chronicle API 创建服务账号(推荐)
- 登录 Google Cloud 控制台,然后选择与您的 Google SecOps 实例关联的 Google Cloud 项目。
- 依次前往 IAM 和管理 > 服务账号。
- 点击创建服务账号。
- 提供以下配置详细信息:
- 服务账号名称:输入账号的名称(例如
bindplane-ingest)。 - 服务账号说明:输入说明(例如
Bindplane agent log ingestion)。
- 服务账号名称:输入账号的名称(例如
- 点击创建并继续。
- 在向此服务账号授予对项目的访问权限部分,点击选择角色,然后选择 Chronicle Editor。
- 点击继续,然后点击完成。
- 点击您创建的服务账号,然后前往密钥标签页。
- 依次点击添加密钥 > 创建新密钥。
- 选择 JSON,然后点击创建。密钥文件会下载到您的计算机上。
- 将密钥文件另存为 Bindplane 收集器目录(Linux 上的
/opt/observiq-otel-collector/ingestion-auth.json或 Windows 上的C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json)中的ingestion-auth.json,或更新config.yaml中的creds_file_path以匹配您保存它的路径。 - 前往 IAM 和管理 > 设置,然后复制项目编号。您在配置导出器时需要用到该名称。
方法 2:下载数据注入身份验证文件(旧版)
- 登录 Google SecOps 控制台。
- 依次前往设置 > 数据管理 > 收集代理。如果您使用的是仅限 SIEM 的平台,请依次前往设置 > 收集代理。
- 下载数据注入身份验证文件。
- 将该文件安全地保存在将要安装 Bindplane 代理的系统上。
获取 Google SecOps 客户 ID
- 登录 Google SecOps 控制台。
- 依次前往设置 > 管理 > 个人资料。如果您使用的是仅限 SIEM 的平台,请依次前往设置 > 个人资料。
- 复制并保存组织详细信息部分中的客户 ID。
安装 Bindplane 代理
根据以下说明,在 Windows 或 Linux 操作系统上安装 Bindplane 代理。
Windows 安装
- 以管理员身份打开命令提示符或 PowerShell。
运行以下命令:
msiexec /i "[https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi](https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi)" /quiet
Linux 安装
- 打开具有 root 或 sudo 权限的终端。
运行以下命令:
sudo sh -c "$(curl -fsSlL [https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh](https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh))" install_unix.sh
其他安装资源
如需了解其他安装选项,请参阅此安装指南。
配置 Bindplane 代理以注入 syslog 并发送到 Google SecOps
访问配置文件:
- 找到
config.yaml文件。通常,它位于 Linux 上的/opt/observiq-otel-collector/目录中,或 Windows 上的安装目录中。 - 使用文本编辑器(例如
nano、vi或记事本)打开该文件。
- 找到
按如下方式修改
config.yaml文件:receivers: tcplog: # Replace the port and IP address as required listen_address: "0.0.0.0:514" exporters: chronicle/chronicle_w_labels: protocol: https # Region of your instance, for example us, europe, asia-southeast1 location: <LOCATION> # Project number of the Google Cloud project linked to the instance project: '<PROJECT_NUMBER>' compression: gzip # Adjust the path to the credentials file you downloaded in Step 1 creds_file_path: '/path/to/ingestion-authentication-file.json' # Replace with your actual customer ID from Step 2 customer_id: YOUR_CUSTOMER_ID endpoint: chronicle.googleapis.com # Add optional ingestion labels for better organization log_type: 'TRENDMICRO_EMAIL_SECURITY' raw_log_field: body ingestion_labels: service: pipelines: logs/source0__chronicle_w_labels-0: receivers: - tcplog exporters: - chronicle/chronicle_w_labels
- 根据基础架构的要求替换端口和 IP 地址。
- 将
<LOCATION>替换为 Google SecOps 实例所在的区域(例如us、europe或asia-southeast1)。导出工具会在此值前面加上chronicle.googleapis.com。 - 将
<PROJECT_NUMBER>替换为 IAM 和管理 > 设置中的项目编号。 - 将
YOUR_CUSTOMER_ID替换为实际客户 ID。 - 将
/path/to/ingestion-authentication-file.json更新为第 1 步中保存服务账号密钥文件(选项 1)的文件路径。
旧版提取 API 导出工具
如果您使用选项 2 中的数据注入身份验证文件,请将
exporters代码块替换为以下内容。将creds_file_path设置为数据注入身份验证文件的路径,如果您的实例位于美国境外,请将malachiteingestion-pa.googleapis.com替换为您的区域端点(例如europe-malachiteingestion-pa.googleapis.com)。exporters: chronicle/chronicle_w_labels: compression: gzip # Adjust the path to the credentials file you downloaded in Step 1 creds_file_path: '/path/to/ingestion-authentication-file.json' # Replace with your actual customer ID from Step 2 customer_id: YOUR_CUSTOMER_ID endpoint: malachiteingestion-pa.googleapis.com # Add optional ingestion labels for better organization log_type: 'TRENDMICRO_EMAIL_SECURITY' raw_log_field: body ingestion_labels:
重启 Bindplane 代理以应用更改
如需在 Linux 中重启 Bindplane 代理,请运行以下命令:
sudo systemctl restart observiq-otel-collector如需在 Windows 中重启 Bindplane 代理,您可以使用服务控制台,也可以输入以下命令:
net stop observiq-otel-collector && net start observiq-otel-collector
配置 Trend Micro Email Security syslog 转发
如需将 Trend Micro Email Security 配置为通过 syslog 将日志转发到 Bindplane 代理,请按以下步骤操作:
- 登录趋势科技电子邮件安全管理控制台。
- 依次前往管理 > Syslog 设置。
点击 Add(添加)以创建新的 syslog 服务器配置文件。
提供以下配置详细信息:
- 服务器地址:输入 Bindplane 代理主机的 IP 地址(例如
192.168.1.100)。 - 端口:输入
514(或在 Bindplane 代理中配置的端口)。 - 协议:选择 TCP。
- 格式:选择 CEF(通用事件格式)。
- 服务器地址:输入 Bindplane 代理主机的 IP 地址(例如
在日志类型部分,选择要转发的日志类别:
- 政策事件 - 电子邮件过滤政策操作。
- 垃圾信息检测 - 垃圾邮件和灰色邮件事件。
- 恶意软件检测 - 病毒和恶意软件检测事件。
- 勒索软件检测 - 勒索软件检测事件。
- 网址分析 - 网址点击和点击时保护事件。
- 高级威胁防范 - 沙盒分析事件。
- 数据泄露防护 - DLP 违规事件。
- 内容过滤 - 内容过滤规则事件。
点击保存。
点击测试连接,验证日志是否已发送到 Bindplane 代理。
通过检查 Bindplane 代理日志来验证日志是否已到达。
如需了解详情,请参阅趋势科技电子邮件安全文档。
UDM 映射表
| 日志字段 | UDM 映射 | 逻辑 |
|---|---|---|
additional_cn1 |
additional.fields |
已合并 |
additional_cs1 |
additional.fields |
已合并 |
additional_cs2 |
additional.fields |
已合并 |
additional_cs3 |
additional.fields |
已合并 |
additional_cs4 |
additional.fields |
已合并 |
additional_cs5 |
additional.fields |
已合并 |
additional_cs6 |
additional.fields |
已合并 |
message |
extensions.auth.type |
已映射:login → AUTHTYPE_UNSPECIFIED |
msg |
metadata.description |
直接映射 |
rt |
metadata.event_timestamp |
已解析为 ISO8601 |
cs1 |
metadata.event_type |
已映射:phishing → SCAN_UNCATEGORIZED |
message |
metadata.event_type |
已映射:CEF:0 → GENERIC_EVENT,login → USER_LOGIN |
cs1 |
metadata.product_event_type |
直接映射 |
network_direction |
network.direction |
已映射:INCOMING → INBOUND,OUTGOING → OUTBOUND |
cs2 |
principal.hostname |
直接映射 |
principal_ip |
principal.hostname |
直接映射 |
principal_ip |
principal.ip |
已合并 |
message |
principal.user.userid |
已映射:login → target.user.userid |
suser |
principal.user.userid |
直接映射 |
act |
security_result.action |
映射:ALLOW → act、DENY → security_result_action、QUARANTINE → act |
security_result_action |
security_result.action |
已合并 |
act |
security_result.action_details |
直接映射 |
cs5 |
security_result.rule_name |
直接映射 |
severity |
security_result.severity |
Mapped: "0", "1", "2", "3", "LOW" → LOW, `"4", "5", "6", "MEDIUM", "SUBSTANTIAL", "INFO"… |
cs6 |
target.url |
直接映射 |
duser |
target.user.email_addresses |
已映射:; → emailId |
emailId |
target.user.email_addresses |
已合并 |
duser |
target.user.userid |
直接映射 |
principal.user.userid |
target.user.userid |
已重命名/映射 |
| 不适用 | extensions.auth.type |
常量:AUTHTYPE_UNSPECIFIED |
| 不适用 | metadata.event_type |
常量:GENERIC_EVENT |
| 不适用 | network.direction |
常量:INBOUND |
| 不适用 | principal.user.userid |
常量:target.user.userid |
| 不适用 | security_result.severity |
常量:LOW |